Jump to content

Archived

This topic is now archived and is closed to further replies.

Carpe_Diem

[Résolu] Après essai Ubuntu 10.04, install 10.10

Recommended Posts

A part trifouiller la résolution, je vois pas trop... pour ça que je suis resté silencieux.

Share this post


Link to post
Share on other sites

j'ai eu un problème de ce genre avec ion ; la résolution setté était correcte, mais à l'affichage, une partie du bureau sortait de l'écran.

xrandr -s 800x600 # une autre résolution quelconque

xrandr -s 1900x1200 # ta résolution initiale

sinon, sur un écran LCD et plus récents, tu as normalement (dans les menus de l'OSD) une fonction auto-ajust.

des améliorations ?

Share this post


Link to post
Share on other sites

Bonjour carpe-diem, j'ai lu tout vos posts et j'ai remarqué que tu disais avoir installé ubuntu en démarrant de windows, ce qui veut dire qu'en fait tu l'as installée à la sauvage avec "WUBI" comme un programme, pour installer proprement un linux, il faut un démarrer sur le live-cd, essayer un peu le système, puis si la chose te plaît et que ton matos est reconnu, il y a une icone sur le bureau "installer ubuntu" ou "installer linux mint", je ne sais pas comment tu as installé ta 10.10, mais si tu as refait l'install à partir de windows ça :craint: craint.

je te conseille Linux Mint en lieu et place d'Ubuntu, d'abord Linux Mint est basée sur Ubuntu, mais elle n'a pas les défauts de cette dernière, prend la version gnome Linux Mint 9 32 bits version LTS ou la 64Bits Linux Mint 9 64 bits version LTS, cette distribution est deuxième ou troisième dans le classement de DistroWatch et est un cran au dessus pour la reconnaissance du matos et le user-friendly :yes:

Lorsque tu lance l'install à partir du live-cd il te suffit de suivre et de répondre aux questions, pour le partitionnement je te conseille de choisir manuel, oh et fait attention de choisir ton disque de 74 Go(la taille du disque est un menu qui permet de choisir le disque à partitionner lorsqu'il y en a plusieurs), et de mettre trois partitions, une partition système de 10 Go à 20 Go, en EXT3 ou EXT4, selon tes besoins, si tu compte installer des jeux ou autres fait là en 20 Go son label est "/" (un bête slash, je sais...), ensuite une partition swap de 1 Go elle n'a pas de label celle là, et enfin créer la partition "/home" en EXT4 pour tes données en dernier donc à laquelle tu laisses le reste de la place donc environ 48 Go si tu as mis 20 Go pour la partition système "/", pour le reste de l'installation il va te demander de choisir où mettre grub, en général cette étape suit celle du partitionnement, tu dois choisir ton HDD de 74 Go pour ça, car sinon il va installer grub sur le MBR de ton disque windows et foutre le bordel (pour un débutant en tout cas) voilà, j'espère que j'ai rien oublié. :yes:

bon, un petit edit pour dire que j'ai pas vu la deuxième page de message, donc désolé, tiens pas compte de ce post.

Share this post


Link to post
Share on other sites

Merci à cid_Dileezer_geek, Mephisto et Uzak et à tous leurs prédécesseurs.

Uzak : je pense aussi à un problème de résolution mais comme je ne vois pas les icônes ça va être dur.

Méphisto : : je vois pas trop ce que tu veux dire. Passer en mode console ? Quel user / sudo ?

cid_Dileezer_geek : pas de souci, j'ai bien installé à partir du CD hors Win7 donc juste après le démarrage du Bios et j'ai bien choisi mon HDD 74Go mais le partitonnement manuel ne marchait pas (choix grisé que ce soit sur la racine ou en sous-racine). Donc, j'ai choisit "utiliser le disque entier" et mon HDD dédié. Il m'a mis le double boot... par défaut... si j'ai compris ce qui s'est passé. Mais ça marche bien, pas de souci. Donc, pour moi l'install est bonne.

Reste le réglage de la résolution je pense. Installer les Catalyst ATI sur le HDD dédié ? Lesquels ? Sans danger pour ceux sur Win7 ?

Nb : avez vous noté que je passe par un ampli HC en HDMI à partir d'une HD4890 pour envoyer le tout sur un écran TV ? (cf. ma conf en signature). Sous Win7, no soucy.

Share this post


Link to post
Share on other sites

Nan, mais dans la bubnut 10.10, y a une version beta des catalyst 10.10, exprès rien que pour canonical, alors qu'ils devraient sortir que dans quelques temps (pour linux). Pas besoin de télécharger quoi que ce soit, il faut chercher dans le gestionaire de package. Chercher fglrx.

Share this post


Link to post
Share on other sites

Essaye en console

sudo aptitude search fglrx

Share this post


Link to post
Share on other sites

Bon, c'est OK avec une mise en résolution inférieure en 1360*768 (16:9ème). Je trouve maintenant les menus et le bureau au complet.

Sans anti-virus et pare-feu annexes... waoo, enfin un écran qui va plus vite que mon tappage sur le clavier... lol...;

Reste à résoudre : je veux du 1900*1200.....mais il y a du mieux.

Je crois avoir trouvé la source du problème : mon écran TV est reconnu en 37 pouces alors que c'est un 46 pouces. Développeurs svp......à l'aide.

NB : je vous écrit depuis Ubuntu à ce moment. C'est bo (relatif à chacun), c'est propre et clair.

Share this post


Link to post
Share on other sites
Méphisto : : je vois pas trop ce que tu veux dire. Passer en mode console ? Quel user / sudo ?

A l'instinct, j'aurais fait ca en sudo

en console, il te faut des arguments supplementaires pour indiquer le serverlayout concerne (qui, pour les process dependants de la session X, sont set en variables de session)

fait-le dans un terminal de ta session X, pour pas te prendre la tete :)

mais, ca revient a changer la resolution, comme tu l'as fait

et manifestement, ca a resolu ton probleme des menus.

pour ton histoire de 1900x1200, que renvoit un 'xrandr' (en user, cette fois) ?

Share this post


Link to post
Share on other sites

tu as bien installé le pilote proprio d'ATI/AMD ?

si non, tu peux le faire en console : sudo aptitude install fglrx

une fois ce truc installer, tu dois avoir un gestionnaire d'affichage (dans system->administration->???) qui devrait te permettre d'avoir la pleine résolution.

Bizarre que ça n'ait pas marché du premier coup.

Share this post


Link to post
Share on other sites

Bravo pour votre suivi du sujet, et merci.

Donc, Méphisto : après avoir trouvé le menu "Terminal", j'ai lancé direct la commande xrandr. J'obtiens ceci :

Screen 0: minimum 320 x 200, current 1360 x 768, maximum 8192 x 8192

DVI-0 disconnected (normal left inverted right x axis y axis)

VGA-0 disconnected (normal left inverted right x axis y axis)

HDMI-0 connected 1360x768+0+0 (normal left inverted right x axis y axis) 820mm x 460mm

1920x1080 50.0 + 60.0

1600x1200 60.0

1400x1050 60.0

1280x1024 60.0

1360x768 60.0*

1024x768 75.1 70.1 60.0

800x600 72.2 75.0 60.3 56.2

640x480 72.8 75.0 60.0

720x400 70.1

DisplayPort-0 disconnected (normal left inverted right x axis y axis)

Il détecte donc bien la connexion HDMI, annonce un max de 8192*8192 mais ne propose pas le 1920*1200.

Mon écran est reconnu comme un 37" alors que c'est un 46".

Lorinc, je n'ai pas installé les pilotes ATI (comme un âne, j'ai téléchargé à partir de Win7....lol; sur un HDD non monté sur Ubuntu donc) et puis je joue sous Win7.

Dans Sys / admin, je n'ai rien concernant l'écran. J'ai par contre la gestion de l'écran dans Sys / Pref / Ecrans.

Dans sys / admin, j'ai le gestionnaire de mise à jour et celui d'install de pilotes supplémentaires. Ce dernier me propose bien l'activation des pilotes ATI pour CG de type FGLRX. Je ne l'ai pas lancé en attendant votre approbation.

J'ai en effet lu qu'il y avait qq problèmes avec les 10.9 ATI et la 10.10 Ubuntu (histoire dans le kernel , de mémoire).

Share this post


Link to post
Share on other sites

pour fglrx, etant un inconditionnel nvidia, je m'abstiendrai de repondre

je me rapelle juste d'un chip integre sur un vieux laptop, a une epoque ou les pilotes ati marchottaient, j'avais un scintillement sur l'ecran...

bref, si tu arrives a utiliser leurs pilotes, tant mieux. sinon, les alternatives libres sont moins "efficaces", mais fonctionnent parfaitement.

autrement, au sujet de resolutions non detectes, jette un oeil la-dessus :

https://wiki.ubuntu.com/X/Config/Resolution#Adding%20undetected%20resolutions

Share this post


Link to post
Share on other sites

Merci Mephisto,

un peu compliqué pour moi les modifs du xorg (je parle en termes de risques : erreur de clavier, retour arrière,...).

Mes excuses, mon écran est en 1920*1080 et non pas en 1920*1200...oups ! donc en 16/9 et non pas en 16/10, meiux pour un écran TV...lol.

J'ai donc essayé 1920*1080 et les bords sont mangés : je perds notamment en haut le menu (essentiel) "Applications - Raccourcis - Système.

La bonne résolution est donc proposée mais rend mal car, et j'en reste presque persuadé, il y a erreur sur la reconnaissance de la taille de l'écran 46" et non 37".

Alors, il est possible que les pilotes ATI m'aident sur ce sujet mais je vais attendre votre GO avant de lancer l'install des Catalyst, voire attendre ceux d'octobre qui devraient arriver vers le 20/10.

Share this post


Link to post
Share on other sites

Bon, ben, tout est Ok avec l'install des Catalyst 8.78.30 (je suppose les 10.9). La résol, la taille écran, la visibilité.

On peut clore le sujet.

Grand merci à tous :smack:

Et bravo pour ton T-shirt Lorinc

Share this post


Link to post
Share on other sites

×
×
  • Create New...