Jump to content

Archived

This topic is now archived and is closed to further replies.

Carpe_Diem

[Résolu] Après essai Ubuntu 10.04, install 10.10

Recommended Posts

oula du bluetooh out of the box avec linux .... :transpi:

tu as pas une souris/clavier usb ou ps/2 ????

Ben non, sinon, il y a longtemps que j'aurais essayé et sûrement réussi.

Share this post


Link to post
Share on other sites

oula du bluetooh out of the box avec linux .... :transpi:

tu as pas une souris/clavier usb ou ps/2 ????

Ben non, sinon, il y a longtemps que j'aurais essayé et sûrement réussi.

Sinon un autre ordinateur en réseau ? pour se connecter à distance en ssh?

Peut être une option dans le bios du pc pour le bluetooth.

Sinon une fois que tu arrives sur l'écran d'accueil, essaye de désactiver et de réactiver le bluetooth

Share this post


Link to post
Share on other sites

Merci de ton aide Dark,

- je n'ai qu'un seul ordi à la maison

- j'ai essayé avec les boutons de reconnexion du clavier, de la souris, de la clef USB BT. J'ai aussi essayé en enlevant la clé de la prise USB et en la remettant. C'est les seuls essais que je peux faire , je ne peux pas intervenir logiciellement sous Linux puisque je n'ai pas la main.

- reste le Bios, faut que je fouine, mais je n'ai pas mémoire d'option pour le BT dans ce Bios (qui est à jour à la verion 1702 de juin, la suivante de septembre ne servant qu'au suppport de nouveaux CPU).

Je vais encore traquer la solution sur le Net.....

Share this post


Link to post
Share on other sites

Vite fait, pour le démarrage, si tu changes d'option de démarrage avec les flèches, sans valider, le compte à rebours s'arrête normalement.

Ce que je trouve étrange, c'est que le démarrage sur le live CD a bien reconnu ton clavier et ta souris...

Si tu as de la config à faire, tu pourras toujours passer par là pour accéder à ta partition système.

Share this post


Link to post
Share on other sites

Vite fait, pour le démarrage, si tu changes d'option de démarrage avec les flèches, sans valider, le compte à rebours s'arrête normalement.

Ce que je trouve étrange, c'est que le démarrage sur le live CD a bien reconnu ton clavier et ta souris...

Si tu as de la config à faire, tu pourras toujours passer par là pour accéder à ta partition système.

Bon,

j'ai fouiner sur le net et notamment sur le site forum.ubuntu-fr.org et des problèmes pleuvent y compris avec la 10.04. Toutes les soluces passent par des scripts ou des modifs de fichiers...grrr...j'ai l'impression d'être revenu en 1990 avec mes "cours" demadant un travail sous Dos et la création de tableau avec les "alt 100 et autres".

Alors, mon idée est de modifier les fichiers Ubuntu que j'ai sur mon HDD dédié via une session Windows.

Qu'en pensez-vous ? Faut-il être sous Linux pour en modifier des fichiers système avec succès ?

Et la question reste : quelles modifs pour faire reconnaitre et démarrer mon clavier et souris MX5500/1000 Logitech Bluethooth à l'ouverture de session (compte et mdp) sous Ubuntu 10.04.1 (Lucid je crois) ?

NB : je n'ai pas utiliser le liveCD pour essayer (cf. + haut dans les discussions initiales). J'ai démarré sous Windows, puis choisit "Installation avec Windows" au lancement du CD gravé avec un .iso et installé Ubuntu sur un disque dédié tout juste formaté NTFS.

Share this post


Link to post
Share on other sites
Bon, j'ai fouiner sur le net et notamment sur le site forum.ubuntu-fr.org et des problèmes pleuvent y compris avec la 10.04. Toutes les soluces passent par des scripts ou des modifs de fichiers...grrr...j'ai l'impression d'être revenu en 1990 avec mes "cours" demadant un travail sous Dos et la création de tableau avec les "alt 100 et autres".
C'est la config qui est dans des fichiers textes, c'est tout. Sous win t'as la config dans la base de registre, sous linux, c'est dans plein de petits fichiers...
Alors, mon idée est de modifier les fichiers Ubuntu que j'ai sur mon HDD dédié via une session Windows. Qu'en pensez-vous ? Faut-il être sous Linux pour en modifier des fichiers système avec succès ?
Non, il n'y a aucune implémentation correcte des pilotes pour le ext4 (système de fichier) sous windows. Tu vas plus galérer qu'autre chose. Utilise le liveCD plutôt.
Et la question reste : quelles modifs pour faire reconnaitre et démarrer mon clavier et souris MX5500/1000 Logitech Bluethooth à l'ouverture de session (compte et mdp) sous Ubuntu 10.04.1 (Lucid je crois)?
Ben là, suspense... Faudrait voir d'où vient le problème exactement. T'as bien le clavier et la souris sous liveCD ?

Tu peux chercher dans /var/log/message pour voir si ton noyau détecte les périph dans un premier temps, puis voir dans les logs du serveur X (je sais plus où exactement, ptet /var/log/X/blabla.log) pour voir si il prend bien ton clavier/souris (c'est lui qui en a la gestion)

Share this post


Link to post
Share on other sites

Je viens juste d'éditer mon précédent post en "NB" : je n'ai rien testé avec un LiveCD, direct install.

Quand je dis "modifier des fichiers système via une session Windows", ce sont des modifs manuelles en edit du fichier texte pas une installation de pilote. C'est ce que j'ai compris des solutions dans le forum Ubuntu.

D'où vient le problème est bien la question et je :pleure:

Je crois avoir une piste : je n'ai aucun /var, /home sous mon HDD dédié àUbuntu.

Je n'ai que l'arborescence Ubuntu / disque / boot / grub et la sous-arborescence boot / install / winboot... y'a pas un blem là ???

J'ai essayé de désinstaller Ubuntu puis de débrancher mon HDD Windows et de relancer une install Ubuntu sur le HDD dédié après modif du Bios et CD dans le lecteur .... mauvaise désinstalltion d'Ubuntu puisqu'il voulait redémarrer et perte du HDD système Windows :cartonrouge: . Il a fallu que je réinstalle le Bios et que je repositionne le HDD Windows en 1ère position pour arriver à le faire reconnaitre et à redémarrer sous Windows. Et me revoici donc sur le forum.

Quelles conclusions non-hâtives à en tirer ?

Share this post


Link to post
Share on other sites

Ubuntu ne peut pas s'installer sur du NTFS. La partition racine sera sur un système de fichier ext3 ou ext4 (ou autre mais pas NTFS ou FAT, car ces systèmes de fichiers ne peuvent pas gérer les droits comme le requière le noyau).

Je comprends pas trop la manip décrite après...

Ça donne quoi si tu bootes sur le liveCD ? Il reconnait ton clavier et ta souris ?

Share this post


Link to post
Share on other sites

Ubuntu ne peut pas s'installer sur du NTFS. La partition racine sera sur un système de fichier ext3 ou ext4 (ou autre mais pas NTFS ou FAT, car ces systèmes de fichiers ne peuvent pas gérer les droits comme le requière le noyau).

Je comprends pas trop la manip décrite après...

Ça donne quoi si tu bootes sur le liveCD ? Il reconnait ton clavier et ta souris ?

je me disais bien aussi que le formatage ntfs n'allait pas être apprécié par Ubuntu, mais il n'a pas râlé lors de l'install.

J'ai fait ma manip et j'ai juste perdu mon HDD windows du Bios. Après multiples manip dans le Bios, je l'ai retrouvé, mais j'ai perdu un autre HDD. Sur les 3 dont je dispose, le Bios n'en reconnait plus que 2 même après mise à jour vers la Bios 1805.

J'essaye d'installer direct, le LiveCD, pas essayer.

Bref, pour l'instant, c'est de la m_____e, ou de la d___e... c'est quoi un OS qui ne reconnait pas une connexion BT pour un clavier ?

Il faut que j'installe sous Windows un logiciel de formatage ext ???? ou je rêve là ?

Décision est prise : ce sera un CD à la poubelle... basta

Share this post


Link to post
Share on other sites

c'est bien les CD-RW . :D

bon sinon, j'ai rien compris , à part que ton matos était pas reconnu.

( et le liveCD en live ( au démarrage ) toujours pas testé ? )

Et c'est quoi cette histoire du Bios qui voit 2 ou 3 disques durs ?

Share this post


Link to post
Share on other sites

Salut Ouragan,

je dois avouer avoir été quelque énervé lors de mon dernier post.

A la base, mon problème est que mon clavier MX5500 et ma souris MX1000 (BT sans fil) ne se connectent pas lorsque je lance l'installation du CD (ou ne sont pas reconnus par l'install Ubuntu). Je parle ici du lancement après avoir mis le lecteur CD en première position dans le démarrage du Bios et je choisis un HDD dédié sur lequel on n'a que la corbeille et le "system volume information" de Windows.

Quand j'installe Ubuntu dans une session Windows, il ne me pose que l'arborescence Ubuntu / disque / boot / grub et la sous-arborescence boot / install / winboot.

Donc, dans le premier cas, je ne peux pas installer parce que je ne peux pas choisir la langue (premier écran de l'install) faute de clavier ou souris,

et dans le second cas, les /home, /var et autres / ne s'installent pas car le HDD n'est pas formaté ext et lors de l'install du CD il ne me demande rien.

J'ai essayé plusieurs fois les 2 possibilités et j'ai manipé la clef BT, les connexions claviers et souris... sans succès.

J'ai testé via ces 2 entrées possibles :

- lancement du CD dans une session Windows. Ce qui donne les 2 choix : "Démo et install" avec le conseil "rebooter avec le CD dans le lecteur..."

- et le second choix "Intstaller dans Windows".

Pour le second, cf. ci-dessus avec les seuls 2 arbo montées

Pour le premier : si je ne mets pas le Cd en premier dans le démarrage du Bios, je retourne sur une session Windows au redémarrage de manière très classique. Si je mets le CD en premier, alors, tout va bien jusqu'au premier écran d'install Ubuntu, et là, pas de souris ni clavier.

Quant au Bios, je n'y comprends rien non plus. j'ai 3 HDD et il n'y en plus que 2 reconnus dans le Bios alors même qu'ils sont là dans le gestionnaire de fichier Windows et dans le gestionnaire de disques.

NB : Bios et pilote Logitech à jour.

Pour le CD, oui c'est un RW, je devrais pouvoir le réutiliser.

Pour le LiceCD, si ce n'est pas le CD que j'ai gravé avec le .iso, alors c'est quoi ?

Share this post


Link to post
Share on other sites

Pour débuter Linux Mint (basée sur Ubuntu) n'est pas mal non plus. Par rapport à sa grande soeur Ubuntu, elle inclut de base tout les paquets nécessaire au multimédia (flash, mp3, dvd et Cie). La version standard est basée sur Gnome dont j'apprécie grandement le menu. Et il y a une version "Community' KDE en 32 et 64 bits.

Dernière raison de l'utiliser : elle est développée par un Français : Clément Lefebvre.

Share this post


Link to post
Share on other sites

L'installateur se charge tout seul du formatage du disque, pas besoin de formater quoi que ce soit avant.

Si ton clavier souris n'est pas reconnu dans l'installation avec le Cd (donc l'installation sous le noyau linux, pas sous windows), laisse tomber, c'est mort (ou trop compliqué).

Ce qu'il se passe quand tu fais l'install depuis windows, à mon avis, c'est que le programme créé une partition de boot pour booter sur le programme d'installation. C'est pour ça que tu n'as rien dedans, à part boot grub et companie, et sûrement le programme d'installation.

La reconnaissance du matos est un problème plutôt récurrent pour linux, bien que beaucoup de progrès aient été faits. C'est pour ça qu'on avait tous insisté lourdement sur l'essai en liveCD ;)

Share this post


Link to post
Share on other sites

D'abord, merci de votre aide et j'ai une piste sérieuse : la 10.10 Beta !

Chargée en .iso, gravée et vérifée. Tout est Ok sur le CD.

Mise du CD en premier démarrage dans le Bios.

Lancement et arrivée sur un message subliminal "iso Linux 4.01 Debian....." après j'ai pas eu le temps de lire le reste de la ligne.

Logo Ubuntu

Fond d'écran Ubuntu

Mire d'install et miracle, le clavier et la souris fonctionnent : choix "Français" et choix "Try"... tout OK, et j'arrive sur l'écran d'essai d'Ubuntu (le LiveCd si j'ai compris).... simplissime avec 2 icônes de dossier. Quelques clics et OpenOffice se charge pour ouvrir un fichier.. yep... mais j'ai pas trouvé de quoi aller surfer (noooob into Linux, yes I'm).

Reboot et choix "Intallation" cette fois-ci. Clavier et souris toujours OK...ouf

Préparation de l'install avec les 2 cases cochées "MP3........" et "Download last updates".

Ecran de choix : install côte à côte, effacer complètement le disque ou définir les partitions manuellement.

Choix 3 pour une install sur mon HDD dédié.

Arrivée sur l'écran des disques et des partitions.

.... tout roule jusqu'ici....

Je choisis précautionneusement mon HDD dédié /dev/sdc pour 74Go (le bon vieux Raptor).

Choix de créer une nouvelle table de partitions (et pas ajouter ou modifier).

Je crée mes partitions sur le Raptor une à une avec :

le / pour 10Go formatage ext4 en primaire

le reste est installé en "logique" et en ext4 avec

/boot : 4Go

/home : 42Go

le swap (pas a la même place...grrr) : 2Go

/tmp : 2Go

/usr : 2Go

/var : 2Go

/srv : 2Go

/opt : 2Go

/usr/load : 4Go

Il reste 2.3 Go selon l'écran.

Choix du chargeur d'amorçage (boot loader) : je choisis mon HDD Système Windows en espérant avoir le double boot.

.... chargements divers, renseignements divers dont login de session et mot de passe et à la fin : message d'erreur comme quoi il n'y a pas assez de place sur le HDD......

Alors, est-ce que j'ai mal paramétré les volumétries ? Ou 74 Go c'est pas assez ? Je penche pour la 1ère. Nb : Windows accorde 69Go à mon bon vieux Raptor.

Donc, les questions :

avez-vous le bon paramétrage des volumétries pour les FS ? (pas de côté à côte automatisé sur mon HDD Windows)

est-ce que choisir le chargeur d'amorçage (boot loader)sur mon HDD Windows est la bonne solution ou vaut-il mieux choisir le Raptor dédié ?

mais où est donc passé le fureteur ...lol ?

Merci humblement.

Share this post


Link to post
Share on other sites

Je pense que tu t'es compliqué la vie sur les partitions : il suffit de spécifier uniquement le /home, le /swap, et la racine /

Ainsi, tout ce qui est urs, srv, opt, etc. se retrouvera sur la même partition que le /.

Share this post


Link to post
Share on other sites

j'ai encore fouiné sur le net et je pense que tu as raison.

J'ai monté toutes les partitions proposées avec cette 10.10.

Je vais essayer avec :

/ pour 20Go (à l'aise pour les MàJ)

/home pour 30Go (y'aura bien quelques trucs à y poser)

/tmp pour 3Go (j'aime le vider de temps à autres)

/var pour 3Go (mes réminisences Unix - Solaris)

swap pour 4Go (j'ai 4 de RAM)

Maintenant, je vous écris depuis Ubuntu 10.10 Beta dont les 3/4 sont en anglais, version Beta oblige.

Bref, ça marche, mais il va falloir régler la résolution, le correcteur d'orthographe et touti quanti.

Je ne vais pas me prononcer maintenant.

NB : j'ai choisit d'installer le mbr Linux sur le HDD dédié.. pas de pollution comme ça.

Share this post


Link to post
Share on other sites

Bien joué pour le boot sur le disque dédié. Ça aurait surement foutu la merde dans le boot de windows sinon.

Bienvenue chez les pingouins :linux:

Share this post


Link to post
Share on other sites

Merci de tes encouragements Uzak.

je vais poursuivre les mises au point quand la finale de 10.10 sera là. Totale réinstall en vue histoire de partir du bon pied.

Share this post


Link to post
Share on other sites

oui, ton erreur de boot avec espace disque insuffisant, c'était typiquement parce que tu avais mis /boot sur un volume étendu. :D

bon pour le reste bravo ^^ . Moi, perso, j'aurais couru au supermarché acheter un clavier+ souris USB. à 12 ¤ . :D

Share this post


Link to post
Share on other sites

oui, ton erreur de boot avec espace disque insuffisant, c'était typiquement parce que tu avais mis /boot sur un volume étendu. :D

bon pour le reste bravo ^^ . Moi, perso, j'aurais couru au supermarché acheter un clavier+ souris USB. à 12 € . :D

J'ai failli aller en acheter un filaire PS2 ou USB pour 20€ (FNAC). Mais en y réfléchissant, je joue du clavier depuis mon canapé à 3m de l'écran. Donc, j'auris mis 20€ et je n'étais plus sur mon canapé....pas question. J'ai considéré cela comme 20€ de perte.

Un point à ne pas oublier donc.

Mais, je peux vous dire merci pour la volumétrie de FS et merci aussi à la 10.10 Béta, je crois.

La 10.10 finale sort quand ?

Share this post


Link to post
Share on other sites

Merci de ta réponse.

J'ai, encore , cette question à propos des FS en btrfs :

je crois que la gestion correcte des SSD est dans le noyau de la 10.10 mais qu'il faut aussi formater en btrfs et avoir un /boot séparé (ext4 ou btrfs ?).

Je n'ai retrouvé que cela mais pas ma source d'hier... grrr... mais il y a un patch officieux ici.

Quelqu'un sait ?

Share this post


Link to post
Share on other sites

Une ou deux pitites remarques :

- me semble que quand on formatte en btrfs, le boot doit être séparé parce que le btrfs est illisible au moment du boot (manque de pilotes tout ça), donc ça répond à ta question.

- Le btrfs n'est pas encore beaucoup plus conseillé que l'ext4, principalement parce qu'il n'est pas encore stable/finalisé/à utiliser en production

- pour le /tmp, j'ai fais le choix de le monter en RAM, comme c'est souvent conseillé. Ça limite encore un peu les IO sur le SSD, ça accélère pas mal de choses. Faut juste avoir un peu de RAM en rab (si tu viens de Windows ça devrait être le cas). Par contre bien sûr dès que t'éteints ton PC tu perds le contenu ...

Edit : si c'est la config que tu as en signature, alors oui je confirme tu as de la RAM en rab :D

Share this post


Link to post
Share on other sites

Bien, je crois que je vais poser la 10.10 finale en ext4 pour éviter les problèmes (débutant, je rappelle).

Pour le SSD, je vais suivre cette méthode d'optimisation qui reprend en effet le coup du /tmp (à porter sur un HDD en l'occurence).

Bref, je verrais en 2011 quand j'aurais 2 SSD (1 Linux et 1 Windows, on ne mélange pas les torchons et les serviettes).

Pour le moment ce sera Linux sur HDD et Windows sur SSD. Cela me paraît plus sage ainsi pour débuter.

Je reviens vous voir après install de la 10.10 finale.

Share this post


Link to post
Share on other sites

Bien,

la 10.10 finale a été téléchargée, gravée et installée.

Pas de gros problème de clavier. Par contre :

- impossible de créer les FS comme j'en aurais eu envie (les choix sont grisés après la première création d'un FS).

- donc installé " de force" en mode "Utiliser le HDD entier" avec choix sur mon HDD dédié. Ubuntu s'est bien installé sur le F mais j'ai le double boot comme par défaut dira t'on. Car impossible de booter sur le F (curseur clignotant en haut à gauche en continu après 20 minutes d'attente, y compris après un simple reset et après un reboot hard);

- résolution d'écran qui ne me permet pas de voir les menus. Je clique droit / gauche à l'aveuglette

Donc, j'ai un double boot et je ne peux pas voir les menus sous Ubuntu.

Le double boot, pas grave (vérif faite sous Win7, Ubuntu s'est bien installé sur le F prévu en dédié Linux), mais ne pas voir les menus... grrrr.....

Pour info : carte ATI HD4890 inside et je n'ai pas monté les drivers dont on a rien à faire, je pense (je joue sous Win7).

La résolution reconnue par défaut est 1900*1200 ce qui est correct....

Pourquoi je ne vois pas les menus (idem d'ailleurs avec la 10.04 essayée initialement)?

Merci, je ne voudrais pas être désabusé au premier essai.

NB : j'ai coché la case "mettre à jour" lors de l'install et il en a chargé le petit Ubuntu (10-15 minutes).

Share this post


Link to post
Share on other sites

×
×
  • Create New...