Jump to content

[résolu] administration d'un serveur Linux


Recommended Posts

Bonjour!

C'est au moins le dixième forum que je visite et je n'ai eu aucune réponse... :transpi: Certains ont peut etre déja lu ce message sur d'autres forums :yes:

voila, j'aimerais savoir comment, sous Webmin, est il possible que soit désactivé un utilisateur d'un système de fichiers, inactif depuis 2 minutes par exemple, svp?

C'est à dire qu'après 2 minutes d'inactivité, l'utilisateur devra retaper son login et mot de passe pour pouvoir re-accéder à son répertoire personnel sur le serveur

J'èspère avoir fourni toutes les précisions nécessaires.

Je vous remercie énormément d'avance

Link to comment
Share on other sites

merci beaucoup pour ton aide

bon par contre, il me faudrait toute la journée pour lire man bash :chinois:

je vais essayer de me débrouiller avec mon ami google!

Ça va faire 10 jours que je me suis mis à linux, je commence à m'y habituer...

Edit: si en fait, je crois qu'il faut éditer le fichier /etc/profile et rajouter une nouvelle ligne du genre :

export TMOUT=temps en secondes.

Je testerais lundi, maintenant c'est weekend ^^

++

Link to comment
Share on other sites

Moi je met plutôt ça dans mon .bashrc

http://publib.boulder.ibm.com/infocenter/p...ity_threats.htm

"You can force a terminal to log out after a period of inactivity by setting the TMOUT and TIMEOUT parameters in the /etc/profile file. The TMOUT parameter works in the ksh (Korn) shell, and the TIMEOUT parameter works in the bsh (Bourne) shell"

Ben, je sais pas, si vous avez d'autres idées ou précisions, j suis ouvert... :yes:

Merci beaucoup

Link to comment
Share on other sites

mon fichier /etc/bashrc ressemble a ca:

# /etc/bashrc

# System wide functions and aliases

# Environment stuff goes in /etc/profile

# by default, we want this to get set.

# Even for non-interactive, non-login shells.

if [ "`id -gn`" = "`id -un`" -a `id -u` -gt 99 ]; then

umask 002

else

umask 022

fi

# are we an interactive shell?

if [ "$PS1" ]; then

case $TERM in

xterm*)

PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'

;;

*)

;;

esac

[ "$PS1" = "\\s-\\v\\\$ " ] && PS1="[\u@\h \W]\\$ "

if [ -z "$loginsh" ]; then # We're not a login shell

for i in /etc/profile.d/*.sh; do

if [ -x $i ]; then

. $i

fi

done

fi

fi

unset loginsh

merci beaucoup d'avance

Link to comment
Share on other sites

Ok merci beaucoup a vous deux, gauret et theocrite.

je vais essayer de suite, je vous tiens au courant.

P.S : j'aime bien ton avatar, theocrite... :francais:

edit : rien à faire, ça ne marche pas, que ce soit avec le bashrc ou le profile

j'avais configuré le timout à 120 secondes..........

Link to comment
Share on other sites

Le terminal me renvoie 0.

J'ai redémarrer le pc (on ne sait jamais) et quand j'ai reouvert le terminal (Konsole), il m'affiche ça :

bash: TMOUT: readonly variable.

J'ai esssayé de calquer les autres variables de mon fichier /etc/profile comme HISTSIZE qui est configurée de cette manière:

HISTSIZE=1000

...

export ... HISTSIZE

Les variables TMOUT et HISTSIZE avaient donc la même synthaxe ( TMOUT=120.............................export TMOUT).

Une nouvelle commande 'echo $TMOUT' me renvoie 0 tandis que 'echo $HISTSIZE' me renvoie 1000.

J'ai même essayé de laisser le TMOUT dans .profile ET .bashrc, mais toujours une réponse à 0.

Tiens, je te montre aussi le .profile sans le TMOUT, si jamais tu avais une autre idée...

Merci beaucoup

# /etc/profile -*- Mode: shell-script -*-

# © MandrakeSoft, Chmouel Boudjnah <chmouel@mandrakesoft.com>

loginsh=1

# Users generally won't see annoyng core files

[ "$UID" = "0" ] && ulimit -S -c 1000000 > /dev/null 2>&1

if ! echo ${PATH} |grep -q /usr/X11R6/bin ; then

PATH="$PATH:/usr/X11R6/bin"

fi

if [ "$UID" -ge 500 ] && ! echo ${PATH} |grep -q /usr/games ; then

PATH=$PATH:/usr/games

fi

umask 022

USER=`id -un`

LOGNAME=$USER

MAIL="/var/spool/mail/$USER"

HISTCONTROL=ignoredups

HOSTNAME=`/bin/hostname`

HISTSIZE=1000

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then

INPUTRC=/etc/inputrc

fi

# some old programs still use it (eg: "man"), and it is also

# required for level1 compliance for LI18NUX2000

NLSPATH=/usr/share/locale/%l/%N

export PATH PS1 USER LOGNAME MAIL HOSTNAME INPUTRC NLSPATH

export HISTCONTROL HISTSIZE

for i in /etc/profile.d/*.sh ; do

if [ -x $i ]; then

. $i

fi

done

unset i

Link to comment
Share on other sites

J'ai vu sur un forum qu'il fallait regarder dans /etc/profile.d/* pour y trouver un truc du genre

readonly TMOUT

ou bien

typeset -r TMOUT

J'ai bien trouvé typeset -r TMOUT dans /etc/profile.d/msec.sh mais ça ne m'avance pas .

J'ai essayé de mettre un $ devant la commande, ça ne marche toujours pas :craint:

bon week end ^^

++

Link to comment
Share on other sites

Une question tu as rechargé ton shell après les modifications que tu as faites ? Ça se fait soit en tapant "bash" (ou le nom de ton interpréteur de shell) ou en quittant ta session puis en te reloguant.

Par ailleurs pas la peine de faire :

 TMOUT=50
export TMOUT
HISTFILE=1000
export HISTFILE

Tu peux faire directement

export TMOUT=50
export HISTFILE=1000

ce qui évite d'éventuels oublis.

Pour info, voici un extrait de mon .bashrc :

export PATH=$PATH:/sbin:/usr/sbin:/usr/local/sbin
export HISTCONTROL=ignoredups

TMOUT=600

Tiens d'ailleurs j'ai même pas d'export, j'ai mis ça à l'arrache et ça fonctionne quand même.

Sinon pour tester tente de faire

export TMOUT=2

et attends trois secondes et voit ce qui se passe.

Link to comment
Share on other sites

Salut!

J'ai suivit tes conseils pour recharger le shell ( je ne savais pas qu'il fallait le faire) masis ça n'a rien changé.

Que j'utlise l'export ou non, meme avec un TMOUT=2, il n'y a pas de déconnexion de l'utilisateur à moins de fermer la session et d'en ouvrir une autre mais ce n'est pas la solution recherchée :heben:

La commande echo $TMOUT me renvoie 0.

J'ai aussi essayé de le mettre dans le .profile et le .bashrc ou soit l'un soit l'autre :transpi:

Tout ce que je constate, quand je rajoute TMOUT=2 dans le .bashrc et que j'ouvre mon Terminal (Konsole), j'ai ça à l'écran :

bash: TMOUT: readonly variable

Quand je supprime le TMOUT du bashrc, il n'y est plus.

Je me demande si en fait la variable TMOUT n'a pas été configurée comme une variable en lecture seule sans possibilité de la modifier.

Comme la commande echo me renvoie 0, cela expliquerais pourquoi il est impossible de reconfigurer le TMOUT et pourquoi il n'y a pas déconnection apres le temps d'expiration du TMOUT.

IL suffirait peut etre alors de modifier les parametres du TMOUT pour qu'on puisse le modifier??

C'est la seule idée que j'ai pour le moment...

merci du temps que tu consacres a m'aider ^^

++

Link to comment
Share on other sites

Désolé pour ne pas te l'avoir dit plus tôt :up:;)

Bon par contre je ne sais pas quoi faire avec :ouioui::mad2:

[root@servccf ~]# grep -rh TMOUT /etc/profile.d
if ( ${?TMOUT} ) then									( provient de .msec.csh)
set autologout=`expr $TMOUT / 120`								  
[ -n "$TMOUT" ] && typeset -r TMOUT					( provient de .msec.sh)
...
[root@servccf ~]#

Est ce que tu pourrais m'aider a trouver ce que je dois modifier parce que je n'y comprends rien...

Je sais que je me répète mais merci beaucoup parce que tu est la seule personne à me répondre parmis la centaine de personne à lire ce topic.

P;S: j'ai essayé de m'appliquer cette fois-ci pour la mise en page!

Link to comment
Share on other sites

Désolé pour ne pas te l'avoir dit plus tôt :zarb::non:
No soucis :-D
[ -n "$TMOUT" ] && typeset -r TMOUT ( provient de .msec.sh)
Tu mets un # au début de la ligne puis tu relance un bash.

Au passage ce fichier msec.sh m'intrigue s'il est pas trop long, ça m'intéresserait que tu le poste.

Je sais que je me répète mais merci beaucoup parce que tu est la seule personne à me répondre parmis la centaine de personne à lire ce topic.
C'est normal les autres c'est des nuls (surtout lorinc et poulp en fait)
P;S: j'ai essayé de m'appliquer cette fois-ci pour la mise en page!
Niquel ;)
Link to comment
Share on other sites

voila le .msec.sh :

#---------------------------------------------------------------
# Project		 : Mandrakelinux
# Module		  : msec
# File			: msec.sh
# Version		 : $Id: msec.sh,v 1.12 2004/07/29 23:28:46 flepied Exp $
# Author		  : Yoann Vandoorselaere
# Created On	  : Wed Feb 13 18:35:58 2002
# Purpose		 : settings according to security level
#---------------------------------------------------------------

if [ -r /etc/sysconfig/msec ]; then
. /etc/sysconfig/msec
fi

if [ `id -u` -ge 500 ]; then
if [ -n "$UMASK_USER" ]; then
umask $UMASK_USER
else
umask 022
fi
else
if [ -n "$UMASK_ROOT" ]; then
umask $UMASK_ROOT
else
umask 002
fi
fi

if [ -n "$SECURE_LEVEL" ]; then
if [ "$SECURE_LEVEL" -le 1 ] && ! echo ${PATH} | fgrep -q :.; then
export PATH=$PATH:.
fi
fi

export SECURE_LEVEL

[ -n "$TMOUT" ] && typeset -r TMOUT

# msec.sh ends here

Au fait, est ce que tu sais si la déconnection intervient après x secondes d'inactivité de la station de travail (le temps d'aller se prendre un café par exemple :oops: ) ou x secondes d'inactivité sur le favoris réseaux (l'utilisateur est occupé à jouer à CS offline par exemple)?

Link to comment
Share on other sites

Essaye.

Ouvre trois consoles et à la main lance un export TMOUT=20

Et attends 20s.

En gros tu as un timer par shell ouvert (ctrl+alt+F[1-6], bash, sh, ksh..., xterm; eterm, aterm...), ça comptera TMOUT secondes à partir du dernier signal intercepté en provenance du clavier (une lettre, flèche haut, esc etc...).

Donc si tu ouvre deux consoles et que tu écris dans une, l'autre peut très bien quitter.

Au passage, c'est bien utile surtout pour ne pas rester logué en root. (enfin c'est ce que je fais perso).

Sinon les terms qui se ferment ça devient vite stressant.

Link to comment
Share on other sites

Est-ce que c'est résolu ?

Sinon, je te dirais de commencer par enlever tous les TMOUT que tu aurais ajouté, redémarrer le PC et lancer un echo $TMOUT pour voir le résultat...

Si tu obtiens un résultat c'est que cette variable existe déjà et est configuré ailleurs (et en mode readonly d'après les infos).

À ce moment il faudra trouver où ? Puis changer son contenu !!!

Si après avoir effacé tes TMOUT ajoutés manuellement qu'il n'y a plus rien à propos de cette variable, essai de l'ajouter... mais à un seul endroit et je crois que le meilleur endroit est dans le fichier .profile de l'usager.

Link to comment
Share on other sites

Bonjour à tous,

Effectivement, je ne me logue plus en root pour le moment.

J'ai ouvert deux console en meme temps, apres avoir mis dans le .bashrc:

export TMOUT=25

J'ai écrit nimporte quoi dans la deuxieme, le temps d'attendre les 25 secondes du TMOUT.

Au bout de 25 secondes, la premiere console s'est bien fermée mais la deuxieme aussi alors que j'étais en train d'écrire dedans!!

Donc, j'ai bien déconnection de la console après le temps du TMOUT...

Maintenant, je me suis connecté depuis un poste client XP sur le serveur pour avoir accès à un répertoire personnel bidon (répertoire partagé) par le favoris réseaux mais il n'y a pas de déconnection : après que le TMOUT soit dépassé, il est toujours possible d'accéder à un répertoire personnel d'un utilisateur qui aurait oublié de fermer la session (toujours depuis le poste client)... :byebye:

Une idée??? :byebye:

MERCI BEAUCOUP

Link to comment
Share on other sites

désolé, mais il n'y a pas de connexion sécurisée de type SSH, Telnet,... ( ou alors je ne connais pas) :transpi::craint:

C'est juste une connexion par le voisinage réseau d'un poste client à son serveur (dans une meme groupe de travail), distant de quelques metres... ( je n'y connais pas grand chose :smack: )

Est ce vraiment nécessaire une connexion SSH pour pouvoir utliser un timeout? :craint:

Bon ,alors comme tu me l'as conseillé, j'ai installé PiTTY sur un poste client et quand j'essaye de me connecter par SSH, port 21,en entrant l'ip du client, j'ai un message d'erreur du genre "connexion refusée" et ça m'etonnerais que ce soit à cause de la table de routage du routeur...

Lol, j'y comprends plus rien, j'ai l'impression d'etre encore plus paumé que lors du début du topic!! :byebye:

bon allez bon weekend quand meme^^

++

merci aux personnes patientes!

Link to comment
Share on other sites

Donc tu te "connectes" via un partage de fichiers, ... Samba !

En réalité tu ne te "connectes" (ouvrir un session) pas en passant de cette façon mais tu accèdes à une ressource réseau qui est disponible grâce à Samba (serveur Linux pour les partage de fichiers Windows). Il n'y a pas de moyen via le TMOUT de contrôler le temps d'accès à la ressources partagée je crois.

S'il y a une gestion du temps c'est peut-être depuis la config de Samba.

Link to comment
Share on other sites

connexion sécurisée de type SSH, Telnet
Arg...

telnet n'est pas et n'a jamais été sécurisé... À banir ! Comme rlogin, rsh, ftp et cie

Est ce vraiment nécessaire une connexion SSH pour pouvoir utliser un timeout? :D
Oui, tant que tu ne démarres pas un bash, TMOUT n'est pas utile. TMOUT est une variable de bash (et probablement d'autres interpréteurs comme zsh etc).
Bon ,alors comme tu me l'as conseillé, j'ai installé PiTTY sur un poste client et quand j'essaye de me connecter par SSH, port 21
Déjà c'est putty et ensuite c'est le port 22 (par défaut).

21, c'est le ftp.

De toutes façons putty ne permet pas le transfert de fichiers à ma connaissance, utilise plutôt winscp. Ou alors met un OS correct qui supporte les bons protocles.

ça m'etonnerais que ce soit à cause de la table de routage du routeur...
M'étonnerais aussi, mettre le bon port devrait aider.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...