Jump to content

[debian] installation Kernel Panic


Recommended Posts

Hello,

Comme j'expliquais dans le topic sur les jeux, ça me démangeais sérieusement de revenir sous linux pour mon seul pc sous windows (celui de jeux). Comme je joue de moins en moins, il va me servir à d'autres activités.

De ce fait, j'ai choisi d'installer une debian, testing.

J'ai 2 disques raptors que je voualis mettre en RAID0 avec un LVM dessus (pas forcément pour les perfs j'y crois pas trop, mais pour m'amuser ...)

Lorsque j'instal ma debian, impossible de modifier le secteur de boot, bref j'ai du merdé la conf' quelque part.

Alors je décide de faire un bête partitionnement :

disque1: /

disque2: /home + swap 1Go

La grub ne fais pas d'histoire à l'instal' (non mais quand même ! :)).

Par contre, au reboot je prends un kernel panic :

segmentation fault

pivot_root: No such file or directory

/sbin/init: 432: cannot open /dev/console: No such file

<0>Kernel Panic: Attempt to kill init!

Je me dis que le parametre "root" et "root=" du système que je veux selectionner n'est pas bon (il arrive pas à passer la racine de la ram a la partition système, si j'ai bien compris).

Par défaut j'ai :

root (hd0,0)

kernel /boot/vmlinux-2.6.8-2-386 root=/dev/sda1 ro acpi=off

Je trouve la ligne kernel suspecte par le "/dev/sda1", je remplace illico par /dev/sda, car a l'install mes disques étaient notés /dev/sda et sdb...

Pas mieux ! :-(

Je peux lancer le système avec le mode recovery en choissant de monté la partition root /dev/discs/disc0/part1 (bah oui le premier disque, partition une, est la partition à monter en / !). J'ai essayé de mettre root=/dev/discs/disc0/part dans le boot kernel, mais pas mieux (mais je ne pense pas que ça doit marcher comme ça, si ?)

Bref, je suis un peu perdu ! Quelqu'un a-t-il une idée pour me dépatouiller ? :transpi:

Link to comment
Share on other sites

J'ai le noyau du la current daily build de la debian testing.

Pour le kernel-image, faut je télécharge un nouveau noyau à partir du shell de secours (en installant apt, ifocnfig et tout ça à partir du CD avant) pour le recompiler et avoir une chance que ça marche ?

Link to comment
Share on other sites

Faut que je passe en mode rescue pour compiler un nouveau noyau ?

Pourquoi ca a marché sur la même bécane avec une Ubuntu :francais:

Faut donc que je trouve a compiler avec le suport d'ICH5 ?

:cartonjaune: Merci tuXXX je vais essayer (je trouve ça dingue quand même !)

là le problème c'est qu'il y a une erreur dans l'initrd

Link to comment
Share on other sites

si je fais une install en mode expert, il me dit à un moment:

"modules à charger", et dans la liste je coche bien "ata_piix (Intel Corporation 82801 ER (ICH5R) SATA Controler)"

J'ai essayé avec les 2 noyaux (2.6 et enfin 2.4 (je n'y arrivais pas avant ...).

Tu me dis qu'il y a un problème dans le initrd.

Ca veut dire que pour mon matos l'installation de noyaux ne peut pas se faire hormis en les compilant ? ou seulement pour cette version ?

Passer en mode rescue, attraper un shell et créer un nouveau initrd c'est pas possible ?

:cartonjaune: J'étais un peu perdu, je le suis complètement :francais:

Link to comment
Share on other sites

L'initrd (un ramdisk contenant des modules et un petit script de démarrage permettant de passer du bootloader à l'init linux) utilisé (/boot/initrd.img-2.6.8-2-386) a un problème (un programme plante) donc automatiquement c'est tout de suite plus dur de booter.

Après, pour savoir pourquoi ça plante c'est plus dur à dire...

Il faut :

- soit ne pas utiliser d'initrd (qui de toute façon ne te sert à rien), mais puisque les noyaux debian en ont tous besoin (plein de modules pour pouvoir s'adapter à plein de machines différentes) il faut que tu utilise un noyau perso.

- soit utiliser un autre initrd qui marche (donc à priori installer une autre version du package "kernel-image" sous debian)

Link to comment
Share on other sites

:transpi: pour l'explication. C'est très clair merci !

- soit ne pas utiliser d'initrd (qui de toute façon ne te sert à rien), mais puisque les noyaux debian en ont tous besoin (plein de modules pour pouvoir s'adapter à plein de machines différentes) il faut que tu utilise un noyau perso.

- soit utiliser un autre initrd qui marche (donc à priori installer une autre version du package "kernel-image" sous debian)

- ne pas utiliser initrd: on a vu que ca ne marchait pas

- utiliser un autre initrd :

J'i d/l le dernier stable 2.6.13 et compilé en prenant garde de bien mettre le driver ich5r, et de mettre dans le fichier de config : CONFIG_SCSI_SATA=y.

Je l'ai bien dans la séletion au boot et meme sentence :

VFS: cannot open root device "sda1" or unknown block(0,0)

please append a correct "root=" boot option

Kernel panic - not syning: VFS: Unable to mount root fs on unknown-block(0,0)

:-(

Edit: ps: par contre, on compilant le nouveau noyau, j'ai pas d'initrd (malgré que j'ai fais un mkinitrd ...)

Link to comment
Share on other sites

Bein alors un petit up pour savoir si quelqu'un comprends ce qui m'arrive.

J'ai continué de jouer. J'ai essayé l'install à partir du CD 1 testng plutôt qu'une net install (j'ai eu un souci du même acabit en aprallèle au boulot).

Que dalle.

J'ai essayé de passé en mode rescue, puis de faire un

ls -l /dev/sda1

, car "/" est dans ce device à en croire mon fstab. Avec, j'ai récupérer les unméros majeur et mineur de la partition (8 et 2), et j'ai donc fait un "root=0802" plutot que "root=/dev/sda1".

Pas plus de succes.

Je me suis rappelé que sur cette machine j'avais déjà installé une Ubuntu Hoary. Je d/l donc la Preview de la 5.10 (j'aime le risque). Strictement le même problème ! (ça commence à devenir agaçant).

Ensuite, je réinstalle à partir du CD KUbuntu Hoary que j'avais essayé en son époque: et la miracle ça marche direct.

Que ça merdoie avec la debian j'arrive à le concevoir (quoique), mais que ca marche avec KUbuntu Hoary et plus avec Ubuntu 5.10 ça me dépasse ....

Link to comment
Share on other sites

lorinc: regarde 2 post plus haut

J'i d/l le dernier stable 2.6.13 et compilé en prenant garde de bien mettre le driver ich5r, et de mettre dans le fichier de config : CONFIG_SCSI_SATA=y.

A moins que ce ne soit pas ça que tu voulais me dire ;)

En plus c'est carrément bizzarre que le support y soit dans ubuntu 5.04 et pas dans 5.10 (!)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...