Jump to content

Archived

This topic is now archived and is closed to further replies.

Morneithan

Me revoilà !

Recommended Posts

@Duke: ca apparait --- . Mais bon, c'est trop tard j'ai compilé le noyau (je veux bien le refaire mais bon...)

@Warrior: j'utilisais presque aucune distrib (ca fais deux mois que je suis sur Linux :D).

Oui je sais c'est pas une distrib pour débutant mais bon, vu que ca m'interresse et que je suis prêt à galérer (c'est le cas d'ailleur ^^), à mettre les mains dans le camboui et bien j'ai pris Gentoo.

Puis de toute façon c'est trop tard je suis plus trop loin de la fin :zarb: !

Share this post


Link to post
Share on other sites

Bon, je suis confronté à un problème avec Grub lors du boot.

J'arrive sans problème à booter sur Windows (c'est d'ailleur depuis ce dernier que j'écris ces lignes) mais quand je veux booter sous Gentoo, voici l'erreur qui s'affiche:

"root (hd0,5)

File system is ext2fs, partition type Ox83.

kernel /kernel-2.6.12-gentoo-r6 root=/dev/hda9

Error 13: Invalid or unsoportable executable format"

J'ai cherché sur google, sur le forum Gentoo ainsi que survolé le topic sur les Bootloader s sans résultat.

Je vous appelle donc à l'aide, sachant que j'ai fait mon grub.conf tel que décrit dans le handbook en changeant juste les numéros des partitions.

Leur "root (hd0,0)" devient donc "root (hd0,5), ma partition /boot étant hda6, et leur "root=/dev/hda3" définissant la partition racine devient pour moi "root=/dev/hda9" vu que c'est sur cette partition que se trouve / .

Je n'arrive pas bien à trouver mon erreur, donc un aperçu exterieur venant de vous pourrait surement m'aider.

Merci d'avance à tous pour vos réponse.

Bonne nuitée :roll: !

EDIT: Juste pour préciser que je n'ai pas mis image splash dans grub.conf, vu qu'apparement ce n'est que si on à pa de carte graphique...

Share this post


Link to post
Share on other sites

Tu as mis le support de système de fichier ext2 et ext3 en dur dans le noyau? => <*>

car si tu l'as compilé en module, ça ne marche pas (grub ne charge pas de module). => <M>

Share this post


Link to post
Share on other sites

Oui oui j'ai bien fais attention à ne selcetionner aucun paramètre concernant les systemes de fichier en Modules, il sont bien en dur (comme expliqué dans le handbook).

En tout cas c'est bien génant d'avoir installé un système pendant 3 jours pour rester bloquer au boot :nvidia::byebye: !

Share this post


Link to post
Share on other sites

utilise genkernel pour compiler ton premier noyau

=>au moins t'est sur que celui là marchera et donc tu devrait booter sur ta gentoo.

De toute facon tu aura le temps de compiler un noyau a toi , t'inquiete pas pour ca .

Soit juste un peu patient . :byebye:

Share this post


Link to post
Share on other sites

Ca veut dire qu'il faut que je me refasse un noyau ??? Rooooh, malheur !!!!!

Ca signife que je dois refaire bien deux étapes...

Je vais encore y passer une aprèm' :byebye: !

Bon ben si ya pas d'autre solution c'est partit ^^ !

EDIT: J'attend de voir si quelqu'un à une autre solution à me proposer, sinon je refais le noyau... Mais je suis certains d'avoir séléctionné en dur les systemes de fichier, et non en modules...

Share this post


Link to post
Share on other sites

regarde dans le handbook :ouioui:

(tu montes les partitions qui vont bien)
chroot /mnt/gentoo /bin/bash
env-update && source /etc/profile

si je me souviens bien

Share this post


Link to post
Share on other sites

Ben justement, je veux monter proc avec la commande du handbook (mount -t proc none /mnt/gentoo/proc) et il me sort " mount point /mnt/gentoo/proc does not exist ".

Et si fais la commande chroot "chroot /mnt/gentoo /bin/bash" il me sort " /bin/bash no such file or directory"

Alors bon... je commence à m'inquièter un chouïa là ...

Share this post


Link to post
Share on other sites

essaie de commencer par:

mount -t ext3 /dev/hda9 /mnt/gentoo
mount /dev/hda7 /mnt/gentoo/boot

puis les commandes que je t'ai données. En effet, si ton /dev/hda9 (donc ton systeme) n'est pas monté sur /mnt/gentoo, il ne peut pas chrooter sur /mnt/gentoo, vu que ce repertoire est vide.

(pour le /dev/hda7, j'ai mis ce que je me souvenais de ton install, si je me suis gourré tu corriges bien sur)

edit: ah et ces deux la elles faisaient aussi partie des "partitions qui vont bien" en question dans mon premier message, y'avait pas que /proc :ouioui:

Share this post


Link to post
Share on other sites

J'ai fais ce que t'as dis,à chaque fois il me sort un message de plusieurs ligne puis quand je met les commande pour chrooter, ben il me fais pareil que tout à l'heure...

Je le sens mal :ouioui: ...

Share this post


Link to post
Share on other sites

bah sois plus précis sur le message d'erreur, y'a pas de raison que ca merde...

au pire on attend tuXXX hein :ouioui:

Share this post


Link to post
Share on other sites

Nan en fait ca venais de moi. j'ai réessayé et c'est bon les partitions sont montées et je suis en chroot !

(j'ai fais les commandes que tu m'as donnés à la lettre près :yes: , donc j'ai pas fais mount -t proc non /mnt/gentoo/proc ... j'espère que ca ira)

Morneithan: Elu Boulet Du Jour !

"Merci merci, c'est un grand honneur :ouioui:"

Bon ben c'est partit pour refaire toutes les étapes à partir du noyau ^^ !

Share this post


Link to post
Share on other sites

Morneithan, je vais pas te rejouer mon couplet sur gentoo...

mais je me fais du soucis pour toi, je crais vraiment que tu ais voulu attaquer gentoo un peu tot. Tu ne vas pas prendre de plaisir à l'utilisation tellement tu vas gallérer...

et c'est bien domage :transpi:

Share this post


Link to post
Share on other sites

Ben perso, malgrès que je galère, je m'amuse bien ^^ !

Oui bon c'est vrai ca fais 4-5 fois que je compile le noyau parce que j'ai mal fais un truc, ca fais également 4 jours que je suis sur cette install, mais bon, j'ai appris moult truc et puis pour l'instant je suis pas dégouté du tout, j'ai juste envie de finir cette install parce que c'est vrai que ca commence à faire vriament long (mais c'est presque fini heureusment) :transpi: .

Après bien entendu j'ai bien pris conscience que Gentoo n'est pas une distrib pour débutant, mais comme je l'avais déjà dis lors de mes débuts sur cette section du forum, je ne risque pas vraiment d'avoir le temps par la suite de m'y mettre vraiment... C'est pour ca que j'ai choisi Gentoo.

Ensuite il est vrai que je pose parfois (souvent même) des questions très très connes sur le forum, mais c'est parce que je n'ai pas encore appris les reflexes que sous google:linux , les How To, etc... et surout la feignantise de lire de long tutos en anglais. Mais ca va venir.

Donc de toute façon je vois surout le côté positif de cette (très) longue install : Je comprend mieux comment marche un systeme linux, j'arrive à éditer un fichier, à me rendre dans un répertoire, etc...

Bon après vous allez me dire que j'aurais très bien pû faire ca sur une Debian, beaucoup plus rapide à mettre en place, mais j'avais juste envie d'essayer gentoo, ce que je ne regrette pas.

Enfin bref voilà quoi (je dois certainement me repeter par rapport à d'autre post mais bon).

J'essayerais en tout cas de mieux réfléchir avant de poser mes questions, car je comprend que tu te fasses du soucis: j'ai moi même honte des questions que je pose quand je les relits avec plus de recul, je me dis que c'etait vraiment tout con...

Voilà voilà :eeek2: !

(Houla le pavé ^^ )

EDIT: Oui bon c'est vrai que je regrette un chouïa de ne pas avoir pris de Debian car c'est enervant de tomber sur une tuile à chaque ligne lancée, mais bon, chui presque à la fin... je risque de encore plus me prendre la tête à changer de distrib maintenant :byebye: !

Share this post


Link to post
Share on other sites

Doublon (scusez moué):

I)Question: J'ai refais mon Noyau avec genkernel. Problème est que quand je fais

ls /boot/kernel* /boot/initrd*

j'ai bien la version du noyau mais pour initrd j'ai "No such file or directory". Et vu que apparement j'en ai bien besoin pour le fichier de config de grub, je sais pas trop quoi faire...

II) Dans l'éventualité ou la question ci-dessus n'ai pas de réponse qui me permette de booter sous Gentoo (Oui après 4 jours et bon nombre de messages de rappel sur la difficulté de la distrib, je commence à me résigner, bien malheureusement :iloveyou: ), quel version de Debian vaut mieux t-il prendre ? (Ca yé j'ai posé la question qui va causer ma perte ---> je commence à avouer ma défaite face à Gentoo :iloveyou: )

Merci d'avance pour vos réponses (j'espère surout que la première aura une réponse qui me permette de booter ^^ ).

ATTENTION: Je précise que même si je viens éventuellement à laisser Gentoo de côté pour le moment, ca veut pas dire qu'elle m'a dégoutée !!! Car c'est juste que malgrès tout ce qu'elle m'apporte niveau connaissance, je commence à vraiment avoir envie de passer définitivement sous Linux, et c'est pas en restant au niveau "Installation" que je vais en profiter.

PS: J'imagine déjà le sourire victorieux de certains ("ca yé il à abbandonné !!! niark niark niark !!! :iloveyou:")

:transpi: sans rancune.

Share this post


Link to post
Share on other sites

Pour compiler le noyau avec genkernel, tu peux configurer avec le menuconfig (mais je te conseille de rien enlever, et de rajouter des trucs seulement en module...)...

Ensuite, il faut choisir "all" comme action (pas "bzImage", ou "kernel")

donc tu peux faire "genkernel --menuconfig all", et en théorie, il te construit bien l'initrd (je l'ai jamais vu ne pas le faire)

Share this post


Link to post
Share on other sites

Ben j'ai bien fais "genkernel --menuconfig all" (j'ai même fais "genkernel all") et j'ai eu cette erreur...

EDIT: En tout cas le sort s'acharne sur moi ^^ : première install d'un OS que je tiens absolument à faire de façon sérieuse (c'est bien la première fois que je m'amuse à installer un système pendant 4 jours :yes:) , et première fois que ca marche pas ^^ ! Je m'en doutais un peu cela dis :yes: !

Share this post


Link to post
Share on other sites

Salut,

+ 1 Duke98

Morneithan, faut pas avoir honte de dire que tu utilise une Mandrake ou Fedora tout le monde est passé par la, mais si c'est pour épater tes pote en les disant que tu a réussi a installer une Gentoo ça ne sert a rien, puisque tu va perdre ton temps a résoudre des probleme au lieu d'optimisé ou testé a 100% cette distribution .

Share this post


Link to post
Share on other sites

Mes potes, pour le plupart, il aiment pas Linux ou ils s'en foutent complètement ... je risque pas d'aller les impressionner. (ce qui les impressionne c'est d'avoir fais XXX frags en une seule partie de UT2k4 :transpi: ).

Et puis je suis bien conscient que c'est pas une honte d'avoir une mandriva, mais pour le peu que j'ai testé j'avais pas accroché du tout.

Bon sinon j'en suis toujours au même point avec cte connerie d'initrd ...

Si personne peut m'aider concernant ce point, ben je pense que je vais devoir downloader le CD de Debian (d'ailleur c'est quoi le nouveau nom de la version testing ?), je prendrais pas 4 jours à l'installer celle là ^^ !

Share this post


Link to post
Share on other sites
Ben perso, malgrès que je galère, je m'amuse bien ^^ !

....

Oui mais si je te met en garde, c'est parce que l'install de base, c'est plutot très facile....

J'ai aussi voulu commencer par gentoo, et je peux te dire que c'est pas à l'install que j'ai morflé. Par contre dans les trois mois qui ont suivi ca a vraiment été gallère et des tutos en anglais, j'en ai avalé une paillassé (enfin comme tout utilisateur de gentoo... rien d'exceptionnel ;) )

C'est clair que tu auras appris beaucoup pendant l'install, mais je trouve que c'est un peu domage si tu peux pas bien profiter de l'utilisation après.

Enfin, c'est juste pour que tu te prépare mentalement pour la suite :craint:

Share this post


Link to post
Share on other sites

Morneithan,

Meme si tu est un utilisateur éxperimenté dans le monde de Linux il te faudra au moins 2 a 3 jour pour avoir un Bureaux fonctionelle ;)

Si personne peut m'aider concernant ce point, ben je pense que je vais devoir downloader le CD de Debian (d'ailleur c'est quoi le nouveau nom de la version testing ?), je prendrais pas 4 jours à l'installer celle là ^^ !

Oui en prenant une Debian pour commencer c'est une éxelente idée et tu apprendra beaucoup :eeek2:

Va sur le site Oficielle pour prend L'iso, le CD 1 est suffisant pour installer une Debian et ça ma prit environ 10 a 15 min .

c'est simple il suffit d'un :

1- apt-get install x-windows-system

2- apt-get install kdebase ou gnome-desktop-environment ou xfce4

3- Startx

Et la lumiere fut :craint:

Bonne Journée

Share this post


Link to post
Share on other sites

Ok, mais il ya a une chose que je comprend pas trop: Ce CC d'install en question c'est celui de la Sarge ?

J'ai fais un tour sur le site Debian et sur le topic du forum consacrée à cette distrib et j'ai vu que Sarge est la version Stable. Elle n'est donc pas un peu "obsolète" pour un PC d'utilisation courante (jeu, multimedia,etc..) ?

J'ai vu par contre que la Etch était le meilleur compromis pour l'utilisation que je pourrais en faire, ce n'est donc pas mieux de prendre celle-ci ?

Share this post


Link to post
Share on other sites

Sarge a été "releasé" il y a un peu plus d'un mois: elle n'est donc pas obsolète/

Mais, apr exemple, il n'y a pas x.org, qui vient d'apparaître en unstable (sid).

D'ici quelques jours, x.orgfera partie de testing (etch).

Personnelement, j'attendrai une version de x.org modulaire avant d'y passer.

Enfin, tu peux choisir une etch, car les logiciels de la sarge n'évolueront plus.

Share this post


Link to post
Share on other sites

"version de x.org modulaire" : T'entend quoi par là ?

Bon, si j'ai bien compris soit j'attend une semaine environ que Etch ai X.org et je me lance, soit je prend de suite une Sarge, c'est ca ?

Share this post


Link to post
Share on other sites

×
×
  • Create New...