Jump to content

Archived

This topic is now archived and is closed to further replies.

David_L

[Article] Installer WoW sous Linux !

Recommended Posts

Pour améliorer la lisibilité, je suggère de mettre toutes les parties "terminal" dans une autre police (ou dans une balise genre quote ou code comme sur le forum)

Share this post


Link to post
Share on other sites

Elles sont déjà dans une autre police :) On a pas de balise spécifique pour le code encore mais on y penses avec le nombre d'articles linux publiés

Share this post


Link to post
Share on other sites
Elles sont déjà dans une autre police :) On a pas de balise spécifique pour le code encore mais on y penses avec le nombre d'articles linux publiés

regarde comment j'ai fait pour l'article fedora...

un simple tableau à une case ca marche très bien

Share this post


Link to post
Share on other sites
regarde comment j'ai fait pour l'article fedora...

un simple tableau à une case ca marche très bien

Tu veux le lien pour éditer ? :-D

Share this post


Link to post
Share on other sites

Je n'ai eu aucun probleme avec les 71.69 au contraire j'avais plus de perf en terme de fps qu'avec les 71.74 avec lesquelles je tourne actuellement.

Share this post


Link to post
Share on other sites
Je n'ai eu aucun probleme avec les 71.69 au contraire j'avais plus de perf en terme de fps qu'avec les 71.74 avec lesquelles je tourne actuellement.

Les deux ne sont pas incompatibles... tu peux avoir des bonnes perfs mais que ça plante tout le temps...

(cf ATI au début ... bouuuuuu le troll)

Share this post


Link to post
Share on other sites

Quand je dis que je n'avais aucun probleme c'est que j'avais aucun probleme (plantage ramage etc) :keskidit:

Tandis que les 71.74 j'ai un doute sur leur fiabilitée ...

Pis j'utilise pas une Drake ou une RH/FC donc ca peut varier d'une distri a une autre.

Et je vois pas ou y a un troll pour ATI sur Nux :mdr:

J'avais une ATI avant ;)

Share this post


Link to post
Share on other sites

moi c'est l'inverse sur les 71.69 j'avais des ramance sur des exterieur sur ut2004 que j'avais jamais eu, alors que tous est redevenu fluide avec les 71.74.

Le plus dommage est que wow tourne maintenant nikel avec wine et le patch dx9 (qui devrait etre dans le prochain wine), et de faire la présentation de wow sur cedega qui est pas libre ni gratuit :)

Premier version de wine qui faisait tourner wow

http://www.linux-gamers.net/modules/news/a...php?storyid=726

Pareil pour steam et HL²

http://www.linux-gamers.net/modules/news/a...php?storyid=728

Le patch dx9 pour wine

http://www.linux-gamers.net/modules/news/a...php?storyid=749

Share this post


Link to post
Share on other sites

J'attends justement le prochain Wine pour arreter mon Abo a Transgaming :keskidit:

Je vous pondrais surement un autre guide ;)

Share this post


Link to post
Share on other sites
Le plus dommage est que wow tourne maintenant nikel avec wine et le patch dx9 (qui devrait etre dans le prochain wine), et de faire la présentation de wow sur cedega qui est pas libre ni gratuit :)

Et pourquoi vouloir a tout pris le faire tourner en Dx (cedega ou wine+patch) alors qu'il tourne parfaitement bien en opengl??

Share this post


Link to post
Share on other sites

Justement le patch Dx9 te permet de le faire tourner en Dx au lieu d'opengl....

Perso je trouve ca completement inutile mais bon...

Share this post


Link to post
Share on other sites

En fait la derniere version de WoW a vu le mode OpenGL avoir de grand probleme (tant sous windows que sous linux)

Share this post


Link to post
Share on other sites
En fait la derniere version de WoW a vu le mode OpenGL avoir de grand probleme (tant sous windows que sous linux)

cool, un nouveau linuxien sur ce forum :incline:

au fait, pour le guide, si jamais je le lis, je mets la pérénité de mon couple en jeu, donc tant pis...

:incline:

:D

Share this post


Link to post
Share on other sites

ben disons que tu n'as pas beaucoup posté depuis tout ce temps... :fumer: et que j'espérais une présence plus active ;)

Share this post


Link to post
Share on other sites

Generalement je parcours et reponds que dans les forums dans lesquels j'ai un "interet" on va dire :fumer:

Share this post


Link to post
Share on other sites
En fait la derniere version de WoW a vu le mode OpenGL avoir de grand probleme (tant sous windows que sous linux)

Pour moi, personellement ca a été un faux problème, ca ma empecher de jouer une journée (le tps de trouver le patch et de recompiler), et je joue tt les jours quasiment 10h par jour (vi c'est pas louable je sais :non:), en OpenGL et sa marche très très bien avec ma vieillissante Ti4200 (qui elle ne supporte pas Dx9). Alors dire qu'il y a de gros problème avec l'OpenGL.....mouais je demande à voir.

Pour ma part je n'ai eu aucun pb avec ce jeu, avec wine, de l'install au lancement tout a été comme une fleur (hormis l'update 1.30 qui a obligé le patch de wine)...

Share this post


Link to post
Share on other sites

petit problème, je suis sous mdk 10.1 et voila ce que j'ai comme erreur :

--------- Error log - file /root/.WineCVS/sources/cvscedega/ErrorLog : ---------

ts_xlib.c:1175: warning: return type defaults to `int'

ts_xlib.c: In function `TSXOpenIM':

ts_xlib.c:1176: error: `XIM' undeclared (first use in this function)

ts_xlib.c:1176: error: syntax error before "r"

ts_xlib.c:1178: error: `r' undeclared (first use in this function)

ts_xlib.c:1178: warning: implicit declaration of function `XOpenIM'

ts_xlib.c:1178: error: `a0' undeclared (first use in this function)

ts_xlib.c:1178: error: `a1' undeclared (first use in this function)

ts_xlib.c:1178: error: `a2' undeclared (first use in this function)

ts_xlib.c:1178: error: `a3' undeclared (first use in this function)

ts_xlib.c: At top level:

ts_xlib.c:1183: error: syntax error before "TSXCheckIfEvent"

ts_xlib.c:1183: error: syntax error before '*' token

ts_xlib.c:1183: warning: type defaults to `int' in declaration of `TSXCheckIfEvent'

ts_xlib.c:1183: error: `TSXCheckIfEvent' declared as function returning a function

ts_xlib.c:1183: warning: type defaults to `int' in declaration of `XPointer'

ts_xlib.c:1183: error: syntax error before "a3"

ts_xlib.c:1186: warning: type defaults to `int' in declaration of `wine_tsx11_lock'

ts_xlib.c:1186: error: 'wine_tsx11_lock' redeclared as different kind of symbol

../include/ts_xlib.h:19: error: previous declaration of 'wine_tsx11_lock' was here

ts_xlib.c:1186: error: 'wine_tsx11_lock' redeclared as different kind of symbol

../include/ts_xlib.h:19: error: previous declaration of 'wine_tsx11_lock' was here

ts_xlib.c:1186: warning: data definition has no type or storage class

ts_xlib.c:1187: warning: type defaults to `int' in declaration of `r'

ts_xlib.c:1187: warning: implicit declaration of function `XCheckIfEvent'

ts_xlib.c:1187: error: `a0' undeclared here (not in a function)

ts_xlib.c:1187: error: `a1' undeclared here (not in a function)

ts_xlib.c:1187: error: `a2' undeclared here (not in a function)

ts_xlib.c:1187: error: `a3' undeclared here (not in a function)

ts_xlib.c:1187: error: initializer element is not constant

ts_xlib.c:1187: warning: data definition has no type or storage class

ts_xlib.c:1188: warning: type defaults to `int' in declaration of `wine_tsx11_unlock'

ts_xlib.c:1188: error: 'wine_tsx11_unlock' redeclared as different kind of symbol

../include/ts_xlib.h:20: error: previous declaration of 'wine_tsx11_unlock' was here

ts_xlib.c:1188: error: 'wine_tsx11_unlock' redeclared as different kind of symbol

../include/ts_xlib.h:20: error: previous declaration of 'wine_tsx11_unlock' was here

ts_xlib.c:1188: warning: data definition has no type or storage class

ts_xlib.c:1189: error: syntax error before "return"

ts_xlib.c:1192: error: syntax error before '*' token

ts_xlib.c:1192: error: syntax error before '*' token

ts_xlib.c: In function `TSXSynchronize':

ts_xlib.c:1194: error: syntax error before '*' token

ts_xlib.c:1196: warning: implicit declaration of function `XSynchronize'

ts_xlib.c:1196: warning: assignment makes pointer from integer without a cast

ts_xlib.c: At top level:

ts_xlib.c:1201: error: syntax error before '*' token

ts_xlib.c:1203: error: syntax error before '*' token

make[1]: *** [ts_xlib.o] Erreur 1

make[1]: Leaving directory `/root/.WineCVS/sources/cvscedega/winex/tsx11'

make: *** [tsx11/libwine_tsx11.so] Erreur 2

Error in Make

Try fixing the error based on the output above, and

run the script again, without paramaters (Eg: WineCVS.sh)

pouvez vous m'aider ?

Share this post


Link to post
Share on other sites

J'ai installé cvscedega en suivant le guide.

Quasiment pas de problèmes sauf quand je rentre dans un lieu clos, genre une caverne ou une salle fermée, le jeu freeze et cedega me sort du programme.

Aurais je manqué qq chose dans la configuration ?

J'ai changé plusieurs paramètres pour faire des tests, avec tous les détails graphiques au minimum, ca bug quand même.

Si qq'un à une idée lumineuse, je le remercie.

Prosper

Share this post


Link to post
Share on other sites
ts_xlib.c: At top level:

ts_xlib.c:1201: error: syntax error before '*' token

ts_xlib.c:1203: error: syntax error before '*' token

make[1]: *** [ts_xlib.o] Erreur 1

make[1]: Leaving directory `/root/.WineCVS/sources/cvscedega/winex/tsx11'

make: *** [tsx11/libwine_tsx11.so] Erreur 2pouvez vous m'aider ?

Ca sent la librairie de dev manquante.

Je parie pour xlib et un urpmi libxorg-x11-devel devrait faire l'affaire.

Prosper

Share this post


Link to post
Share on other sites

bien le bonjour par chez vous !

tout d'abord, merci pour avoir mis ce tutorial en ligne, j'imagine qu'il va faire le plus grand des plaisirs à tous.

ensuite : afin de peut etre l'améliorer, il faudrait juste dire qu'il faut les paquetages bison et flex en tout cas sous suse 9.2... (je suis pas le seul à ne pas les avoir au début de l'install)...

ensuite ... hum... ca marche po :mdr: .

voici mon erreur lors de l'installation de CVScedega:

--------- Error log - file /root/.WineCVS/sources/cvscedega/ErrorLog : ---------
ts_xlib.c: In function `TSXOpenIM':
ts_xlib.c:1176: error: `XIM' undeclared (first use in this function)
ts_xlib.c:1176: error: parse error before "r"
ts_xlib.c:1178: error: `r' undeclared (first use in this function)
ts_xlib.c:1178: warning: implicit declaration of function `XOpenIM'
ts_xlib.c:1178: error: `a0' undeclared (first use in this function)
ts_xlib.c:1178: error: `a1' undeclared (first use in this function)
ts_xlib.c:1178: error: `a2' undeclared (first use in this function)
ts_xlib.c:1178: error: `a3' undeclared (first use in this function)
ts_xlib.c: At top level:
ts_xlib.c:1183: error: parse error before "TSXCheckIfEvent"
ts_xlib.c:1183: error: parse error before '*' token
ts_xlib.c:1183: warning: type defaults to `int' in declaration of `TSXCheckIfEvent'
ts_xlib.c:1183: error: `TSXCheckIfEvent' declared as function returning a function
ts_xlib.c:1183: warning: type defaults to `int' in declaration of `XPointer'
ts_xlib.c:1183: error: parse error before "a3"
ts_xlib.c:1186: warning: type defaults to `int' in declaration of `wine_tsx11_lock'
ts_xlib.c:1186: error: `wine_tsx11_lock' redeclared as different kind of symbol
../include/ts_xlib.h:19: error: previous declaration of `wine_tsx11_lock'
ts_xlib.c:1186: warning: data definition has no type or storage class
ts_xlib.c:1187: warning: type defaults to `int' in declaration of `r'
ts_xlib.c:1187: error: `r' used prior to declaration
ts_xlib.c:1187: warning: implicit declaration of function `XCheckIfEvent'
ts_xlib.c:1187: error: `a0' undeclared here (not in a function)
ts_xlib.c:1187: error: `a1' undeclared here (not in a function)
ts_xlib.c:1187: error: `a2' undeclared here (not in a function)
ts_xlib.c:1187: error: `a3' undeclared here (not in a function)
ts_xlib.c:1187: error: initializer element is not constant
ts_xlib.c:1187: warning: data definition has no type or storage class
ts_xlib.c:1188: warning: type defaults to `int' in declaration of `wine_tsx11_unlock'
ts_xlib.c:1188: error: `wine_tsx11_unlock' redeclared as different kind of symbol
../include/ts_xlib.h:20: error: previous declaration of `wine_tsx11_unlock'
ts_xlib.c:1188: warning: data definition has no type or storage class
ts_xlib.c:1189: error: parse error before "return"
ts_xlib.c:1192: error: parse error before '*' token
ts_xlib.c:1192: error: parse error before '*' token
ts_xlib.c: In function `TSXSynchronize':
ts_xlib.c:1194: error: parse error before '*' token
ts_xlib.c:1196: warning: implicit declaration of function `XSynchronize'
ts_xlib.c:1196: error: `a0' undeclared (first use in this function)
ts_xlib.c:1196: error: `a1' undeclared (first use in this function)
ts_xlib.c:1196: warning: assignment makes pointer from integer without a cast
ts_xlib.c: At top level:
ts_xlib.c:1201: error: parse error before '*' token
ts_xlib.c:1203: error: parse error before '*' token
ts_xlib.c: In function `TS_XInitImageFuncPtrs':
ts_xlib.c:1206: error: `a0' undeclared (first use in this function)
make[1]: *** [ts_xlib.o] Erreur 1
make[1]: Leaving directory `/root/.WineCVS/sources/cvscedega/winex/tsx11'
make: *** [tsx11/libwine_tsx11.so] Erreur 2


Error in Make

Try fixing the error based on the output above, and
run the script again, without paramaters (Eg: WineCVS.sh)


linux:~ #  

je ne sais pas trop où demander de l'aide .. alors je me tourne vers vous, pourrez-vous m'aider ??

Share this post


Link to post
Share on other sites

bon et bien autant pour moi ... j'ai trouvé l'erreur en lisant les posts au dessus ...

ce n'était pas "libxorg-x11-devel", mais plutot "xorg-x11-devel" trouvé dans yast...

merci !!! (l'install continue, on verra où ca me mène :mdr: )

Share this post


Link to post
Share on other sites

×
×
  • Create New...