Jump to content

Archived

This topic is now archived and is closed to further replies.

bibisousnours

Knoopix bootable

Recommended Posts

(t'as de la chance, tout est deja marqué sur les tutos, mais je ne suis pas trop pressé de rejoindre mon lit, n'empeche, que la, je file :francais:)

merci d'avoir pris du temps. J'ai compris grace au coup des "racourcis".

Share this post


Link to post
Share on other sites
Je suis retourné sur Xp parceque quand la ram est pleine... une knoopix ca ram :francais:

J'ai essayé de monter /dev/hda1 dans /home/knoppix/tmp avec :

mount -t captive-ntfs /dev/hda1 /home/knoppix/tmp

apres qu'il ait trouvé les drivers XP pour les partitions NTFS; mais il écrit un truc du genre:

captive-NTFS version 1.5.5 check new version at www.********

et la partition n'a pas l'air d'avoir été monté où que ce soit :D

Quand je double clique sur l'icone de la partition sur le bureau, ca la monte automatiquement et ca l'ouvre. Une fois que c'est fait il y a une petite fleche verte en bas de l'icone à droite. Apres je fais bouton droit dessus, changer les droits d'écriture. Ca me demande si je veux vraiment autoriser l'écriture sur la partition NTFS, je clique sur oui, puis il me dit qu'il n'a pas pu le faire, peut etre parcequ'un fichier est utilisé dessus (ce qui n'est pas le cas apriori) :byebye:

je suis un peu perdu là.

Sinon, non, pas de trace de /dev/hda1 ... :transpi:

Nononon :sms:

Justement j'ai dis de desactiver le readonly SEULEMENT si la fleche verte n'est pas la.

Ensuite, un

su => pour passer en mode root

mount -t captive-nfs /dev/hda1 /home/knoppix/tmp

(Si /dev/hda1 n'existe pas, tu peux dire ou tu te trouves en cliquant sur le disque du bureau ? Ca ouvre Konqueror avec file:/mnt/xxxxxx. Peux tu dire ce que xxxxx vaut ?

Ensuite, pendant que la fleche verte est activée, tu vas en mode console, tu tapes

su

cat /etc/mtab

et la tu copies colle le resultat.

(je ne vais pas tarder a rejoindre les bras de morphée :love:)

Share this post


Link to post
Share on other sites

quand je clique sur l'icone de la partition, ca écrit /mnt/hda1.

Par contre, quand je vais dans /dev/ il n'y a pas hda1, même si au final, avec un mount en ligne de commande c'est bien là qu'il va chercher la partition :francais:

Je reboot sous knoppix pour tester ce que tu viens de me dire.

N'hésite pas à aller te coucher, ce n'est pas urgent, je reprendrai ca demain :transpi:

Merci beaucoup :D

Share this post


Link to post
Share on other sites

J'ai essayé de monter /dev/hda1 dans /home/knoppix/tmp avec :

mount -t captive-ntfs /dev/hda1  /home/knoppix/tmp

apres qu'il ait trouvé les drivers XP pour les partitions NTFS; mais il écrit un truc du genre:

captive-NTFS version 1.5.5 check new version at www.********

s'il t'as rendu la main sans donner de message d'erreur, c'est qu'il l'a bien montée. tu peux le voir en tapant mount.

ensuite, tu prends konqueror et tu va dans le répertoire /home/knoppix/tmp et tu devrais y trouver le contenu de ton disque :francais:

enfin faudra peut-être rajouter un -o rw

edit : voilà un lien INterressant :

http://mjules.free.fr/NTFS_et_GNU_linux.htm

Share this post


Link to post
Share on other sites

J'ai fais ce que tu m'as dit 16ar, mais au moment de taper "mount -t captive-ntfs /dev/hda1 /home/knoppix/tmp"

il ne me redonne pas la main par la suite et dans /home/knoppix/tmp, je n'ai rien de plus (la fleche verte n'est pas sur l'icone et j'ai décoché avant la case "readonly")

si je clique sur l'icone du bureau, je me retrouve dans /mnt/hda1. en tapant : cat /etc/mtab dans le shell, j'ai :

/dev/root / ext2 rw 0 0

/dev/scd0 /cdrom iso9660 ro 0 0

/dev/cloop /KNOPPIX iso9660 ro 0 0

/ramdisk /ramdisk tmpfs rw,size=405064k 0 0

/proc/bus/usb /proc/bus/usb usbdevfs rw,devmode=0666 0 0

automount(pid539) /mnt/auto autofs rw,fd=4,pgrp=539,minproto=2,maxproto=4 0 0

/dev/hda1 /mnt/hda1 ntfs ro,nosuid,nodev,umask=000,uid=1000,gid=1000 0 0

Je pense que ce qui cloche c'est captive-ntfs qui ne trouve pas les bon drivers (ou je ne sais pas lui dire quoi faire avec) bien qu'il les télécharge sur le site de microsoft

Share this post


Link to post
Share on other sites

alors, si tu regarde la dernier ligne donner par le mtab :

/dev/hda1 /mnt/hda1 ntfs ro,nosuid,nodev,umask=000,uid=1000,gid=1000 0 0

on voit que le périphérique /dev/hda1 est monté à l'endroit /mnt/hda1 avec l'interpretation NTFS du systeme de fichier (c'est le nom du driver au passage, donc il n'utilise pas captive-ntfs :D ) et avec les options ro (read only), nsuid (pas de bit set user id pour les fichiers), nodev (là :francais: ), umask=000 ( droit rwx par défaut pour tous les fichiers), uid=1000, gid=1000 ( le proprio possede 1000 en id et appartient au groupe 1000)

donc ça veut dire que tu dois pouvoir le monter à la main en faisant

# mount /dev/hda1 /mnt/hda1 -t captive-ntfs -o rw,nosuid,umask=000,uid=1000,gid=1000

tu peux essayer

Share this post


Link to post
Share on other sites

en essayant

# mount /dev/hda1 /mnt/hda1 -t captive-ntfs -o rw,nosuid,umask=000,uid=1000,gid=1000

avec:

La partition déjà montée j'ai :

root@ttyp2[/]# mount /dev/hda1 /mnt/hda1 -t captive-ntfs -o rw,nosuid,umask=000,uid=1000,gid=1000

Captive NTFS v1.1.5. Check a new version at: http://www.jankratochvil.net/

mount.captive-ntfs: /dev/hda1 already mounted

mount.captive-ntfs: according to mtab, /dev/hda1 is mounted on /mnt/hda1

mount.captive-ntfs: Use '-o force' to mount the image notwithstanding.

Sans la partition montée:

root@ttyp2[/]# mount /dev/hda1 /mnt/hda1 -t captive-ntfs -o rw,nosuid,umask=000,uid=1000,gid=1000

Captive NTFS v1.1.5. Check a new version at: http://www.jankratochvil.net/

mais je n'ai plus la main apres dans le shell. Ou plutot, j'ai la main, mais je n'ai plus de prompt.

Bon, je file me coucher pour ce soir... Apparement, c'est vraiment un calvair pour écrire sur du NTFS à partir de Linux :francais:

Share this post


Link to post
Share on other sites

il ne te rends pas le prompt, même pas pour te dire qu'il y a une erreur?

c'est bizzare ça!

Share this post


Link to post
Share on other sites

×
×
  • Create New...