Jump to content

Pb chargement centre de contrôle Mdk


Recommended Posts

Bonjour,

Utilisatrice depuis peu de mandrake 10.1 Official, j'ai enfin pu configurer mandrake: réseau, urpmi, ...

En ce moment, j'ai un problème avec le centre de contrôle. Quand je le lance, il se bloque (dans 90% des cas).

Le pire, c'est que la fenêtre reste en plein milieu de l'écran sans que je puisse la retirer! J'ai tapé drakconf dans un terminal et ca me fait la même chose: chargement du centre de contrôle bloqué. Idem avec la commande mcc.

Je pense qu'il faut que je réinstalle le centre de contrôle...

Link to post
Share on other sites
et la console n'affiche rien au moment du plantage ?

(désolé d'avoir répondu dans l'autre topic)

Non, elle n'affiche rien. L'exécution de la commande drakconf lance le chargement du centre de contrôle comme lorsque je clique sur l'icône du tableau de bord.

# urpme drakconf

désinstallation de drakconf-10.1-2mdk.i586
# urpmi drakconf

   ftp://ftp.ciril.fr/pub/linux/mandrakelinux/official/10.1/i586/media/main/drakconf-10.1-2mdk.i586.rpm
installation de /var/cache/urpmi/rpms/drakconf-10.1-2mdk.i586.rpm
Préparation...              ##################################################
  1:drakconf               ##################################################
#

(tu n'as pas à être désolé :)

J'ai désinstallé puis réinstallé drakconf et j'ai redémarré mandrake.

Deux problèmes:

- le problème de son est réapparu (apparemment, les modifications ne sont pas prises en compte au démarrage)

- le centre de contrôle reste toujours bloquer

EDIT2: Je ne trouve pas grand chose sur ce problème de lancement du centre de contrôle. A croire que je suis la seule à l'avoir!

Link to post
Share on other sites

Comme indiqué sur le forum de clubic (tu dois être vraiment désespérée ! :D ), il se peut que ça soit dû à un problème drivers/hardware. Je répond aussi ici pour être sûr que tu tombes sur ce message.

Tu peux essayer de désactiver l'apic au démarrage de linux (option noapic) : à l'invite de lilo (là ou tu choisis le système à démarrer), tu tapes ECHAP pour avoir une invite de commande, puis "linux noapic" et tu valides

C'est un problème courant sous Linux, certains drivers supportent mal l'APIC, qui est est en gros une optimisation des interruptions sur les cartes mères récentes. Comme tu n'as pas une machine récente je ne suis pas très très optimiste, mais bon ... je ne suis pas du tout expert en APIC non plus donc je tente !

Si ça résout ton problème, tu peux forcer ce comportement en en allant dans le centre de controle mandrake / gestionnaire de démarrage / et en cochant forcer sans l'apic.

Sinon, tu peux aussi regarder si ce n'est pas l'acpi (gestion de l'énergie) qui pose problème avec l'option "acpi=off" : la ligne à taper est donc dans ce cas "linux noapic acpi=off"

Le strace c'est une bonne idée pour savoir lors de quel appel système ça bloque :D

Link to post
Share on other sites
c'est possible d'avoir la sortie de ça :

strace -c drakconf  

$  strace -c drakconf
execve("/usr/bin/drakconf", ["drakconf"], [/* 62 vars */]) = 0
% time     seconds  usecs/call     calls    errors syscall
------ ----------- ----------- --------- --------- ----------------
50.91    0.003138           4       739       672 open
14.42    0.000889           4       213       201 stat64
13.82    0.000852           9        99           read
 5.47    0.000337           5        62           old_mmap
 3.44    0.000212           3        67           close
 2.89    0.000178          89         2           clone
 1.80    0.000111           3        41           fstat64
 1.74    0.000107           3        41         3 _llseek
 1.33    0.000082           3        29        26 ioctl
 1.18    0.000073           5        14           brk
 1.01    0.000062           4        14           mmap2
 0.54    0.000033          33         1           readlink
 0.44    0.000027           9         3           munmap
 0.13    0.000008           8         1           waitpid
 0.11    0.000007           7         1           _sysctl
 0.11    0.000007           2         3           rt_sigaction
 0.08    0.000005           5         1           time
 0.08    0.000005           5         1           mprotect
 0.06    0.000004           4         1           futex
 0.05    0.000003           3         1           getppid
 0.05    0.000003           3         1           uname
 0.05    0.000003           3         1           rt_sigprocmask
 0.05    0.000003           3         1           getrlimit
 0.05    0.000003           3         1           fcntl64
 0.05    0.000003           3         1           set_thread_area
 0.03    0.000002           2         1           getuid32
 0.03    0.000002           2         1           geteuid32
 0.03    0.000002           2         1           getegid32
 0.03    0.000002           2         1           set_tid_address
 0.02    0.000001           1         1           getgid32
------ ----------- ----------- --------- --------- ----------------
100.00    0.006164                  1344       902 total

ensuite, j'ai le centre de contrôle qui se lance et qui reste bloquer.

Link to post
Share on other sites
Comme indiqué sur le forum de clubic (tu dois être vraiment désespérée ! :eeek2: ), il se peut que ça soit dû à un problème drivers/hardware. Je répond aussi ici pour être sûr que tu tombes sur ce message.

Tu peux essayer de désactiver l'apic au démarrage de linux (option noapic) : à l'invite de lilo (là ou tu choisis le système à démarrer), tu tapes ECHAP pour avoir une invite de commande, puis "linux noapic" et tu valides

C'est un problème courant sous Linux, certains drivers supportent mal l'APIC, qui est est en gros une optimisation des interruptions sur les cartes mères récentes. Comme tu n'as pas une machine récente je ne suis pas très très optimiste, mais bon ... je ne suis pas du tout expert en APIC non plus donc je tente !

Si ça résout ton problème, tu peux forcer ce comportement en  en allant dans le centre de controle mandrake / gestionnaire de démarrage / et en cochant forcer sans l'apic.

Sinon, tu peux aussi regarder si ce n'est pas l'acpi (gestion de l'énergie) qui pose problème avec l'option "acpi=off" : la ligne à taper est donc dans ce cas "linux noapic acpi=off"

Le strace c'est une bonne idée pour savoir lors de quel appel système ça bloque  :transpi:

lol, non, je ne suis pas désespérée mais j'essaie de voir si quelqu'un a la solution a mon problème avant que je décide de tout réinstaller. Je n'ai pas consulté le forum clubic depuis quelques jours (j'étais surtout sur celui d'inpact pour mon problème de driver ATI). Donc désolée si je n'ai pas vu ta réponse.

Sinon, j'ai une carte mère récente (elle a moins d'un an: Asus P4C800 Deluxe).

J'ai essayé en cochant 'Sans forcer l'APIC' mais j'ai toujours le même problème (après avoir redémarré bien sûr). Peut-être qu'il aurait fallu le faire au démarrage de lilo?

En ce qui concerne la gestion d'énergie, je n'ai pas encore testé (je dois réviser pour mon exam de demain en réseaux).

En tout cas, merci pour ton aide :transpi:

EDIT: Je viens de remarquer que le centre de contrôle marche à chaque fois que je le lance après le démarrage de linux. Même en fermant la fenêtre du centre de contrôle et en la réouvrant (toute de suite ou au bout de quelques minutes), elle marche.

Au bout d'un certain temps, quand je veux la relancer, elle se bloque. Mais aucun message d'erreur (seulement la fenêtre qui reste figer)

EDIT 2: Ok, je pense avoir trouvé la raison du blocage. A chaque fois que l'écran de veille se déclenche, je n'arrive plus à lancer le centre de contrôle après. :eeek2:

Pour l'instant, j'ai décoché l'option 'Démarrrer l'écran de veille automatiquement' histoire de voir si c'en est bien la cause...

Autre chose, comment récupérer les messages au lancement de mandrake. Je crois qu'il y a un message d'erreur sur l'activation d'alsa

Link to post
Share on other sites

bon, bah si c'est après une mise en veille, il y a effectivement de forte chance que ça ait à voir avec la gestion d'energie.

si tu arrive à lancer au moins une fois le MCC, alors tu devrais pouvoir modifier la gestion de l'energie dans lilo :byebye:

EDIT : essayes de lancer harddrake tout seul, ça ne métonnerais pas que ce soit lui qui plante. (c'est rare les erreurs sur ioctl...)

Link to post
Share on other sites

Si tu as mis sans forcer l'apic puis redémarré, c'est équivalent à avoir redémarrer avec l'option de lilo (puisqu'en utilisant cette option je suppose que c'est la config de lilo qui est modifiée).

Comme dit lorinc il y a donc des chances que ce soit la gestion d'énergie qui pose problème. Je suppose qu'il y a une option pour faire ça dans le centre de contrôle, mais je connais pas bien Mandrake.

Pour tes problèmes de son, les logs sont tous dans le répertoire /var/log/, il y a un log "général" du noyau /var/log/messages, et peut être des logs pour alsa, mais les noms de fichiers sont censés être presque explicites :-)

Bon courage ...

Link to post
Share on other sites

ah oui, pour alsa, c'est aussi possible que tous tes volumes soit à zero par défaut, dans ce cas, il faut enregistrer la conf (alsamixer) en ayant mis les niveaux à autre chose que zero... (on ne rigole pas, ça arrive super souvent ce genre de choses :reflechis: )

Link to post
Share on other sites

Slt tout le monde :|:chinois:

J'ai trouvé ces quelques lignes dans le fichier /var/log/messages:

Jan  5 09:13:53 localhost ifup: Failed to open connection to session message bus: Failed to connect to socket /tmp/dbus-NcBskjqmPN: Connection refused 
Jan  5 09:13:53 localhost network: Activation de l'interface eth0 :  succeeded 
Jan  5 09:13:54 localhost portmap: Démarrage de portmap succeeded 
Jan  5 09:14:06 localhost kernel: AC'97 0 analog subsections not ready
Jan  5 09:14:06 localhost kernel: intel8x0_measure_ac97_clock: measured 49629 usecs
Jan  5 09:14:06 localhost kernel: intel8x0: clocking to 48000
Jan  5 09:14:07 localhost sound: Loading sound module (snd-intel8x0) succeeded
Jan  5 09:14:07 localhost alsactl: /usr/sbin/alsactl: load_state:1139: 
Jan  5 09:14:07 localhost alsactl: No soundcards found...
Jan  5 09:14:07 localhost sound: Chargement des réglages du son failed
Jan  5 09:14:07 localhost xfs: Démarrage de xfs succeeded
Jan  5 09:14:07 localhost messagebus: Démarrage de messagebus succeeded
Jan  5 09:14:07 localhost xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/drakfont/Type1 (unreadable) 
Jan  5 09:14:07 localhost xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/drakfont/ttf (unreadable) 
Jan  5 09:14:07 localhost netfs: Montage des autres systèmes de fichiers :  succeeded
Jan  5 09:14:07 localhost xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/100dpi:unscaled (unreadable) 

Link to post
Share on other sites

Jan 5 09:14:07 localhost sound: Loading sound module (snd-intel8x0) succeeded

Jan 5 09:14:07 localhost alsactl: /usr/sbin/alsactl: load_state:1139:

Jan 5 09:14:07 localhost alsactl: No soundcards found...

effectivement, c'est genant...

Link to post
Share on other sites
Jan  5 09:14:06 localhost kernel: AC'97 0 analog subsections not ready
Jan  5 09:14:06 localhost kernel: intel8x0_measure_ac97_clock: measured 49629 usecs
Jan  5 09:14:06 localhost kernel: intel8x0: clocking to 48000
Jan  5 09:14:07 localhost sound: Loading sound module (snd-intel8x0) succeeded
Jan  5 09:14:07 localhost alsactl: /usr/sbin/alsactl: load_state:1139: 
Jan  5 09:14:07 localhost alsactl: No soundcards found...
Jan  5 09:14:07 localhost sound: Chargement des réglages du son failed 

c'est quoi, comme carte son?

à mon avis il faut charger le bon module...

Link to post
Share on other sites
c'est quoi, comme carte son?

à mon avis il faut charger le bon module...

Le son est intégré à la carte mère Asus P4C800 Deluxe (AC'97 je crois)

J'arrive à faire marcher le son une fois que j'ai lancé l'application alsaconf qui m'installe le son automatiquement après quelques clics (pr répondre aux questions). Mais je dois faire çà à chaque fois que je redémarre.

EDIT: Voilà un post très intéressant (ICI)

J'ai moi aussi dû mettre à jour les sources du noyau (ICI)

Le problème, c'est que je ne comprends pas grand chose à la solution donnée dans ce post ;)

Link to post
Share on other sites

tuxxx a raison (comme d'habitude, dailleurs ;) ), m'est d'avis que tu n'auras pas à recompiler un noyau, tu possede déjà le bon module (puisqu'en lançant draksoud, tu as du son), il faut donc que tu mettes le tout au démarrage.

dans draksound (ou sounddrake ou un truc du genre :mdr: ) tu dois pouvoir récupérer le nom du module, et vérifie qu'il est bien dans /etc/modprobe.conf ou modules.conf ou le fichier de chargement des modules de mandrake (je sais pas ce qu'il utilisent, probablement modprobe.conf...)

Link to post
Share on other sites

Pour finir, c'est confirmé cette histoire d'écran de veillle ou de gestion d'energie?

Parce que je te confirme que t'es pas la seule, j'ai eu le même problème en installant une 10.1 sur le pc d'un ami, le truc frezze si tu le lances après avoir travaillé un ptit temps sous mdk.

Le seul truc c'est que je n'avait le pc que pour quelques jours et donc c'est la seule chose que j'ai laissé en suspend.

Je ne connait pas mdk plus que ca mais si effectivement t'as trouvé la soluce tu peux le dire, je lui passerai un coup de fil vu qu'il habite pas tout près :byebye:

P.S. l'acpi est déjà désactivé et y a aucun conflit alsa ou autre. Et quand je l'avais dans les mains, ca freezait en l'ouvrant sans qu'il y ait besoin d'attendre l'écran de veille, juste après une dizaine de minutes d'utilisation.

Link to post
Share on other sites

Salut tout le monde! ;):fou:

Merci pour vos réponses. Donc j'ai regardé le fichier modprobe.conf et voilà ce qu'il contient:

# This file is autogenerated from /etc/modules.conf using generate-modprobe.conf command

alias eth0 sk98lin
remove snd-intel8x0 /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-intel8x0
install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 eth1394
alias ieee1394-controller ohci1394
alias net-pf-10 off
alias ipv6 off
options saa7134 radio=0 card=26 gbuffers=4

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
options snd  device_mode=0666
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

Apparemment, le module snd-intel8x0 est bien présent.

Y a-t-il une erreur?

Link to post
Share on other sites
Pour finir, c'est confirmé cette histoire d'écran de veillle ou de gestion d'energie?

Parce que je te confirme que t'es pas la seule, j'ai eu le même problème en installant une 10.1 sur le pc d'un ami, le truc frezze si tu le lances après avoir travaillé un ptit temps sous mdk.

Le seul truc c'est que je n'avait le pc que pour quelques jours et donc c'est la seule chose que j'ai laissé en suspend.

Je ne connait pas mdk plus que ca mais si effectivement t'as trouvé la soluce tu peux le dire, je lui passerai un coup de fil vu qu'il habite pas tout près ;)

P.S. l'acpi est déjà désactivé et y a aucun conflit alsa ou autre. Et quand je l'avais dans les mains, ca freezait en l'ouvrant sans qu'il y ait besoin d'attendre l'écran de veille, juste après une dizaine de minutes d'utilisation.

Non, je n'ai toujours pas réussi à trouver la solution à mon problème. Même en désactivant la gestion d'énergie et en cochant "Forcer sans ACPI"

EDIT: Quelle configuration a ton ami?

Link to post
Share on other sites

Salut, toujours en galère je vois ...

Je me demande si tu n'aurais pas intérêt à aller directement sur les forums du site de mandrake, ils connaitront mieux la distrib que nous. Un peu compliqué leur fichier modprobe sur la partie son !

Pour savoir si le module est chargé, la commande pour lister les modules chargés en mémoire est "lsmod" en root.

Link to post
Share on other sites

# lsmod
Module                  Size  Used by
fglrx                 228028  7
snd-pcm-oss            49480  0
snd-mixer-oss          17376  1 snd-pcm-oss
snd-intel8x0           30124  1
snd-ac97-codec         69392  1 snd-intel8x0
snd-pcm                81800  2 snd-pcm-oss,snd-intel8x0
snd-timer              20356  1 snd-pcm
snd-page-alloc          7400  2 snd-intel8x0,snd-pcm
gameport                3328  1 snd-intel8x0
snd-mpu401-uart         5856  1 snd-intel8x0
snd-rawmidi            19300  1 snd-mpu401-uart
snd-seq-device          6344  1 snd-rawmidi
snd                    45988  11 snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97
-codec,snd-pcm,snd-timer,snd-mpu401-uart,snd-rawmidi,snd-seq-device
ppp_async               8896  0
ppp_generic            24468  1 ppp_async
slhc                    6112  1 ppp_generic
crc-ccitt               1664  1 ppp_async
af_packet              16072  0
floppy                 55088  0
eth1394                17000  0
sk98lin               164808  1
ide-cd                 37280  1
cdrom                  37724  1 ide-cd
ohci1394               30788  0
ieee1394              292056  2 eth1394,ohci1394
loop                   12520  0
nls_iso8859-15          4224  6
ntfs                  147964  6
intel-agp              19584  1
agpgart                27752  2 intel-agp
tda9887                11204  0
tuner                  18320  0
saa7134                93232  0
video-buf              16868  1 saa7134
v4l2-common             4896  1 saa7134
v4l1-compat            13092  1 saa7134
soundcore               7008  2 snd,saa7134
i2c-core               19060  3 tda9887,tuner,saa7134
ir-common               3972  1 saa7134
videodev                7168  1 saa7134
joydev                  8032  0
usblp                  10592  0
tsdev                   5824  0
evdev                   7648  0
usbmouse                4256  0
usbhid                 41088  0
ehci-hcd               26244  0
uhci-hcd               28752  0
usbcore               103172  7 usblp,usbmouse,usbhid,ehci-hcd,uhci-hcd
ext3                  120680  1
jbd                    49080  1 ext3

Le module a l'air d'être bien chargé :chinois:

Link to post
Share on other sites

ben oui... alsamixer te permet de bien regler le mixage, ou donne-t-il une erreur genre pas de carte configurée?

est-ce-que les droits sur les fichiers relatifs au son sont bons (/dev/dsp /dev/sound/* /dev/mixer, ...)?

Link to post
Share on other sites

Tout semble marcher avec alsamixer:

┌───────────────────[AlsaMixer v1.0.6 (Press Escape to quit)]──────────────────┐
│ Card: Intel ICH5                                                             │
│ Chip: Analog Devices AD1985                                                  │
│ Item: Master [Off]                                                           │
│                                                                              │
│                                                                              │
│    ┌MM┐     ┌MM┐      ┌MM┐     ┌MM┐     ┌MM┐      ┌──┐     ┌MM┐     ┌──┐     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │  │     │
│    └──┘     └──┘      └──┘     └──┘     └──┘      └──┘     └──┘     └──┘     │
│    0<>0       0       0<>0     0<>0     0<>0                100              │
│ < Master >Master M  Master S   PCM    Surround  Surround  Center  Center/L   │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────

Voici les droits sur les fichiers donnés par lorinc:

$ ls -l /dev/dsp
crw-rw----  1 cassandra audio 14, 3 jan 17 21:52 /dev/dsp
$ ls -l /dev/sound/*
lrwxrwxrwx  1 root root 7 jan 17 21:52 /dev/sound/adsp -> ../adsp
lrwxrwxrwx  1 root root 8 jan 17 21:52 /dev/sound/audio -> ../audio
lrwxrwxrwx  1 root root 6 jan 17 21:52 /dev/sound/dsp -> ../dsp
lrwxrwxrwx  1 root root 8 jan 17 21:52 /dev/sound/mixer -> ../mixer
$ ls -l /dev/mixer
crw-rw----  1 cassandra audio 14, 0 jan 17 21:52 /dev/mixer

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...