Jump to content

Archived

This topic is now archived and is closed to further replies.

KzR

Configuration Mémoire/SWAP ?

Recommended Posts

Hello,

Je ne sais pas si le problème est exactement le même, mais chez moi c'est le flash player qui ralentie la machine. J'ai les mêmes symptomes que toi pour Firefox, qui commence à freezer.

Essaie soit de le virer, soit de le tuer :

ps aux | grep swf_player

kill -9 <son pid>

Link to post
Share on other sites

j'en profite au passage pour te faire découvrir l'excellente commande killall, qui comme son nom l'indique tue tous les process dont le NOM est passé en paramètre

killall -9 swf_player

Y'a t'il un routier du forum volontaire pour faire un petit topic sur les signaux ? je suis sur que découvrir le -HUP, le -STOP ou le -CONT pour émerveiller plus d'un nouveau :)

Link to post
Share on other sites
comment fait-on quand on a pas de swappiness? Et d'ailleurs autre question, comment se fait-il que j'en ai pas?

Euh, tout le monde a de la swapiness ... littéralement en anglais c'est la "propension à swapess" (comme happiness est la propension à être heureux, en plus de la joie proprement dit).

Après, a toi de faire un echo "0" > /proc/sys/vm/swappiness ou un echo "100" ou une valeur intermédiaire et de tester ce qui te convient le mieux

Link to post
Share on other sites

Merci je connais mon anglais :reflechis:

Par contre, look ça:

cat /etc/sysctl.conf

#

# /etc/sysctl.conf - Configuration file for setting system variables

# See sysctl.conf (5) for information.

#

# Be warned that /etc/init.d/procps is executed to set the following

# variables.  However, after that, /etc/init.d/networking sets some

# network options with builtin values.  These values may be overridden

# using /etc/network/options.

#kernel.domainname = example.com

#net/ipv4/icmp_echo_ignore_broadcasts=1

vm.swappiness=10

ls -R /proc |grep -i swap

swaps

swap_token_timeout

cat /proc/sys/vm/swappiness

cat: /proc/sys/vm/swappiness: Aucun fichier ou répertoire de ce type

Je dirais qu'il y a comme un problème, non?

Link to post
Share on other sites
Euh, tout le monde a de la swapiness ... littéralement en anglais c'est la "propension à swapess" (comme happiness est la propension à être heureux, en plus de la joie proprement dit).

Après, a toi de faire un echo "0" > /proc/sys/vm/swappiness ou un echo "100" ou une valeur intermédiaire et de tester ce qui te convient le mieux

non, tout le mode n'a pas ce paramètre du noyau...

il faut un patch pour l'avoir, et je sais que je ne l'avais pas avec mon 2.6.8-ck4

Link to post
Share on other sites

×
×
  • Create New...