Jump to content

Archived

This topic is now archived and is closed to further replies.

KzR

Configuration Mémoire/SWAP ?

Recommended Posts

j'ai un petit soucis sur ma Ubuntu, lors d'une utilisation prolongée j'ai la mémoire physique qui est de plus en plus sollicitée... au début du chargement de l'OS je suis à 150/885Mo (d'ailleurs c'est bizarre puisque j'ai 1Go de RAM) et au fils du temps cela augmente jusqu'à faire du swap en continue sur le DD, ce qui fait du Bruit/Perte de Perfs assez importante :p

j'aimerai savoir comment configurer cette mémoire pour lui dire de temps à autre de virer les trucs qui pompent et qui ne sont plus là :craint:

Parce que j'ai beau tuer des process, ça ne m'aide pas beaucoup :craint:

Share this post


Link to post
Share on other sites

Bon ben je viens de me faire une autre partition de Swap sur le second DD que je viens d'installer, ça me fait un total de 6,6Go de Swap :roll:

Share this post


Link to post
Share on other sites

Avec 1Go de RAM tu devrais presque pas avoir besoin de RAM (mis à part quelques grosses compilations).

Tu peux faire 256Mo sur chaque disque, en leur mettant la même propriété (en regardant l'article de Rem sur fstab), ça fera un genre de raid 0 pour le Swap.

Concernant ton problème, tu dois avoir un programme avec une fuite de mémoire vraiment importante !

Share this post


Link to post
Share on other sites
...

Concernant ton problème, tu dois avoir un programme avec une fuite de mémoire vraiment importante !

comment faire pour trouver l'application qui me fait défaut ?

Share this post


Link to post
Share on other sites

"ps aux" va te donner le pourcentage de mémoire utilisée par chaque processus (entre autre), je ne connais pas d'autres méthodes. Attendons les réponses des pros :transpi:

Share this post


Link to post
Share on other sites

+1 doit y avoir une fuite de mémoire. Normalement, avec 1Go de RAM, tu ne devrait pas swapper (sauf, comme déjà dit, lors de grosses compile genre OOo, eclipse, etc...)

fais le tour des applis exotiques que tu lances au démarrage, la fuite doit y être (en général, les programme 'connus' ont tres vite des correctifs pour ce genre de probleme...)

Share this post


Link to post
Share on other sites
+1 doit y avoir une fuite de mémoire. Normalement, avec 1Go de RAM, tu ne devrait pas swapper (sauf, comme déjà dit, lors de grosses compile genre OOo, eclipse, etc...)

fais le tour des applis exotiques que tu lances au démarrage, la fuite doit y être (en général, les programme 'connus' ont tres vite des correctifs pour ce genre de probleme...)

il y a une commande ou un fichier à éditer pour voir ce qui se lance au démarrage ?

Share this post


Link to post
Share on other sites

ben tu sais quand même tous les services que tu lances au démarrage, non :francais:

uptade-rc, je crois chez unbutu, mais il ne faut pas oublier ce qui est en autostart chez kde/cgnome, etc...

Share this post


Link to post
Share on other sites
acpid              fetchmail        module-init-tools  rmnologin

acpi-support      gdm              modutils          rsync

alsa              halt              mountall.sh        samba

apmd              hdparm            mountnfs.sh        screen-cleanup

atd                hostname.sh      mountvirtfs        sendmail

bootclean.sh      hotplug          networking        sendsigs

bootlogd          hwclockfirst.sh  nfs-common        single

bootmisc.sh        hwclock.sh        nfs-kernel-server  skeleton

checkfs.sh        ifupdown          ntpdate            stop-bootlogd

checkroot.sh      inetd            nvidia-glx        sudo

console-screen.sh  initrd-tools.sh  portmap            sysklogd

cron              keymap.sh        powernowd          udev

cupsys            klogd            ppp                umountfs

dbus-1            libdevmapper1.00  pppd-dns          umountnfs.sh

dhcp3-server      lokkit            procps.sh          urandom

discover          lvm              rc                vsftpd

dns-clean          makedev          rcS                webmin

evms              mdadm            README            winbind

fam                mdadm-raid        reboot            xfree86-common

Share this post


Link to post
Share on other sites

:byebye:

ça va pas, non :francais::chinois:

évite de faire ça pour montrer le contenu d'un répertoire : ouvre plutôt une console et tape "ls le_dossier"

(éventuellement "ls le_dossier > monfichier.txt" pour avoir un fichier texte avec le contenu du dossier)

ça évite de faire des photos d'écran, c'est plus facile à lire sur un forum, etc... :roll:

sinon, on ne te demande même pas le contenu de /etc/init.d, mais ce qui est lancé au démarrage (ce qui est totalement différent : le contenu de /etc/init.d pourrait être comparé à la liste des services windows, qu'ils se démarrent au démarrage ou pas...)

Share this post


Link to post
Share on other sites
et aussi ls /etc/rcS.d/ vu que ce répertoire permet de lancer des choses au boot :)

README              S20module-init-tools  S36mountvirtfs  S48console-screen.sh

S02mountvirtfs      S20modutils          S38pppd-dns    S50hwclock.sh

S04udev            S25libdevmapper1.00  S39dns-clean    S51ntpdate

S05bootlogd        S25mdadm-raid        S39ifupdown    S55bootmisc.sh

S05initrd-tools.sh  S26lvm                S40hostname.sh  S55urandom

S05keymap.sh        S27evms              S40hotplug      S70screen-cleanup

S07hdparm          S30checkfs.sh        S40networking  S70xfree86-common

S10checkroot.sh    S30procps.sh          S43portmap      S75sudo

S18hwclockfirst.sh  S35mountall.sh        S45mountnfs.sh

Share this post


Link to post
Share on other sites

souvent les softs p2p ont des fuites memoires.......a part le vrai client bittorrent entre ( )

jai aussi eu des soucis avec les drivers usb adsl de sagem a une certaine epoque

Share this post


Link to post
Share on other sites
souvent les softs p2p ont des fuites memoires.......a part le vrai client bittorrent entre ( )

jai aussi eu des soucis avec les drivers usb adsl de sagem a une certaine epoque

le problème c'est que je n'utilises pas de soft de P2P et que ma connexion internet passe par une station WinXPPro

Share this post


Link to post
Share on other sites

Merci à toi sandeman, je vais essayer ça ce soir, en espérant que cela fera avancer mon problème :rhooo:

Share this post


Link to post
Share on other sites

nopb sandeman.gif

d'ailleurs sur mon portable ça sert pas à grand chose j'ai *oublié* de créer une partition de swap, mais ça marche quand même (des freezes, de temps en temps, mais rien de méchant ça revient dans la seconde)

Share this post


Link to post
Share on other sites

en passant tite question...

faut lui envoyer quoi dans la tronche au nunux pour qui swap :rhooo::mad:

moi je depasse jamais plus de 10ko/1go au niveau du swap... ;):-D

Share this post


Link to post
Share on other sites
en passant tite question...

faut lui envoyer quoi dans la tronche au nunux pour qui swap :keskidit::keskidit:

moi je depasse jamais plus de 10ko/1go au niveau du swap... :keskidit::eeek2:

ben perso lors du rajout de mon Maxtor 200Go il freezait-repartait lorsque j'étais sous Firefox (avec beaucoup beaucoup d'onglets), j'avais regardé l'utilisation du swap et il était au taquet, j'ai rajouter une partition de swap sur le nouveau DD et hop c'est bon.

par contre ce qui m'énerve maintenant c'est cette fuite mémoire, je me demande comment c'est possible :eeek2:

Share this post


Link to post
Share on other sites
en passant tite question...

faut lui envoyer quoi dans la tronche au nunux pour qui swap :keskidit::keskidit:

moi je depasse jamais plus de 10ko/1go au niveau du swap... :keskidit::eeek2:

en recompilant OOo il swap :eeek2:

Share this post


Link to post
Share on other sites
ah ouais pas con :keskidit:

bon sinon a part quelques rares cas extremes ca swap jamais c'est ca :keskidit:

ben si tu ouvres 150 tofs de 2Mo chacune avec The GIMP il doit bien swaper, non ?

Share this post


Link to post
Share on other sites

en utilisation normale, ca swap pas :keskidit:

pas d'inquiétude à avoir :keskidit:

donc si ca swap: gros probleme

Share this post


Link to post
Share on other sites

×
×
  • Create New...