Jump to content

Archived

This topic is now archived and is closed to further replies.

-rem-

[Tutoriel] Fstab ou la gestion des FS.

Recommended Posts

Je te laisse faire pour supermount donc Sandeman, je ne maitrise pas trop, je ne m'en sers jamais.

Kzr : En fait, ca simule du raid software, car c'est un peu le meme principe mais ca n'en n'est pas. C'est comme la neige artificielle, et pourtant, on ne dit pas qu'il neige lorsqu'on sort les canons a neige ! :chinois:

Share this post


Link to post
Share on other sites
je fais un petit topo sur supermount ou toulemondsentap ?

à part ça :incline: -rem- ... alala avec des articles comme ça comment veux-tu ne pas passer à Linux ?

Arrrrrrgh...

si tu arrive à expliquer clairement que c'est pas parce que les dev du noyau l'ont dégagé du noyau que c'est forcement merdique, alors pourquoi pas... :D

:p

Share this post


Link to post
Share on other sites

Très bon tuto Rémy :transpi:

Le fichier /etc/fstab ayant pour fonction le montage automatique des systèmes de fichiers, je crois que l'on peut également préciser pour la culture unixienne de chacun que c'est, la commande mount -a, qui est exécutée au démarrage du système et qui commande de monter tous les systèmes de fichiers spécifiés dans /etc/fstab.

Concernant le champ 5:

Générallement, les partitions ont une valeur nulle par défaut ( donc pas de purge )  et à part pour un besoin vraiment particulier, je vous conseille de les laisser ainsi.

N'y a t'il pas une erreur? Il me semble que Dump ne sauvegarde pas le système de fichier si la valeur du champ est 0 (donc purge). Par ailleurs, j'ai souvent lu que ce champ pouvait être mis à 1 pour les systèmes de fichiers de type ext2 et ext3 ...

Eh bien c'est fini, il suffit juste de sauver avec son éditeur préféré, 'ZZ' pour ceux qui ont bon goût :mdr:

Pour le fun, j'ai appris qu'il était possible de le faire directement en ligne de commande, sans passer par un éditeur de texte. Donc, pour les newbs (comme moi :) ), je vous montre comment faire.

Admettons, que je souhaite monter avec les options par défauts, le fichier /home/chris se situant sur la 5ème partition de mon disque dur, dans /etc/fstab, il suffit de taper:

echo "/dev/hda5 /home/chris ext3 defaults 1 2" >> /etc/fstab

--> La commande echo affiche le texte donné en argument à l'écran;

--> Le signe >> "double supérieur à" redirige l'affichage vers un fichier. Si le fichier n'existe pas, il est créé, sinon l'affichage est ajouté à la fin du contenu actuel. Attention de ne pas pas utiliser le signe > car le contenu du fichier /etc/fstab serait écrasé;

--> L'utilisation des guillemets permet de neutraliser les espaces et donc d'éviter les erreurs d'interprétation.

Share this post


Link to post
Share on other sites

une tite question:

yatil un file system journalisé 100% compatible windows/linux (avec driver libre pour windows) ?

ext3 ca marche pas super sous windows

XFS ? JFS ? Reiser ?

cas pratique: disque dur externe que lon passe d'un OS (a moelle) a un autre OS .

jpense que bcp seront interresses par la reponse

Share this post


Link to post
Share on other sites

@bebe_pinguoin : Oui, mais mount et echo sont des commandes linux, j'ai fait un tuto sur fstab moi :mdr: Sinon, c'est plutot dangereux pour un débutant de jouer du echo, car '>' a la place de '>>' et il perd tout son fstab.

@fubiga : non. Faut se plainde à M$. Pour l'instant, le seul bon compromis reste le fat, mais taille des fichiers < 4 Go.

Share this post


Link to post
Share on other sites

Vi et le '>>' c'est pas très pratique pour voir ce qu'on fait, surtout pour les débutants. On met une ligne à la fin point barre. pas de confirmations, pas de possibilité de comparer avec les autres lignes ou d'enlever une ligne qui pourrait être en conflit etc...

Ça peut être pratique pour bien d'autres choses.

fubiga : Si tu veux absolument un système journalisé, tu peut toujours te mettre une partition en ext3 et explorer ça avec explore2fs qui n'est pas natif sous windows... ou abandoner windows :keskidit:

Share this post


Link to post
Share on other sites

ça commence à faire quelque temps que je m'arrache les cheveux pour monter mes partitions Windows sous Linux. Mon problème est que le disque dur windows à été installé après l'install de Ubuntu, ce disuqe dur n'apparait ni dans mtab, ni dans fstab, du coup je ne sais pas trop où sont localisé mes partitions.

J'ai essayé te les retrouver par fdisk, voici ces réponses:

vince@ubuntu:~ $ fdisk /dev/hda

Unable to open /dev/hda
vince@ubuntu:~ $

J'ai une parttion FAT32 sur le disuqe hda (celui de ubuntu) et une NTFS sur un disuqe de 4.3Go (hdb je pense).

Share this post


Link to post
Share on other sites

si tu es en serial ata ou en scsi tes disques ne s'appellent pas hda ou hdb

de même chez moi le premier device n'est pas un hdd, mes disques sont donc hdb et hdd

fais un dmesg, un ls /proc/ide, ls /proc/scsi ... tu retrouvera surement le nom de tes devices

edit> mieux vaut être root pour faire du fdisk, sinon - pense aussi à utiliser cfdisk (un peu plus convivial)

Share this post


Link to post
Share on other sites

Sympa le topic, et j'ai aussi apris le "raid" swap :zarb:

Par contre j'ai un probleme non exposé dans le topic. Normalement ca ne doit pas etre trop dur, mais j'ai du mal avec les autorisations, les users, les groupes... et je pense surtout avec fstab !! :mdr:

Donc j'ai ma machine en dual boot Debian 3.1/windows XP.

Toutes mes partitions windows XP sont en fat32.

Pour le moment j'ai qu'un utilisateur sur ma machine, mais comme je compte l'utiliser comme serveur de temps a autre, il se peut que d'autre utilisateurs aient acces a des dossiers.

Donc ce que je souhaite, c'est que le systeme monte automatiquement les partitions fat32 en lecture/ecriture. Seulement, qd le systeme les monte, il me semble que seul l'utilisateur root peut demonter et visionner + ecrire dans le montage.

Si jamais je ne met pas d'automount et surtout si je met user, alors seul mon utilisateur principal pourra le monter/le demonter et le visionner.

Ce qui serait bien, c'est qu'un groupe (disons "mount") ai acces au répertoire monté. Ainsi, n'importe quel user de ce groupe pourrait y acceder en lecture ecriture.

Du coup, mon /etc/fstab ressemble a ca :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/mapper/vroot-lroot1 /               ext3    defaults,errors=remount-ro 0       1
/dev/hdc2       /boot           ext3    defaults        0       2
/dev/mapper/vhome-lhome1 /home           ext3    defaults        0       2
/dev/mapper/vusr-lusr1 /usr            ext3    defaults        0       2
/dev/hdc9       none            swap    sw              0       0
/dev/hda        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdb        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hdc5       /mnt/las        vfat    rw,users,gid=500        0       0
/dev/hdc1       /mnt/win_xp     vfat    rw,users        0       0

Le repertoire en question est le /mnt/las.

Mon groupe mount a le gid de 500, donc je l'ai rajouté dans la ligne de montage, et j'ai rajouté users pour que n'importe qui puisse demonter.

Le but est par exemple d'avoir un lien symbolique dans le repertoire /home des users qui pointe vers des dossiers du partage (mp3 pour mon utilisateur principal pour le moment)

Je suis conscient que ca peut etre une faille de sécurité, alors si vous avez un moyen d'avoir mes mp3 dispo pour tous les utilisateurs du pc sans que ce soit une faille, je suis preneur.

pour le repertoire /mnt/las, j'ai changé le groupe a "mount" (sachant que le proprietaire est root), puis j'ai fais des

chmod g+rwx /mnt/las

Histoire que les users du groupe "mount" ai acces en lecture ecriture et execution.

Seulement ca ne marche pas car au reboot (ou si je fais mount -a), les droits du dossier /mnt/las passent a r-- pour le groupe.

Est ce les options de mon fstab qui merdent ? Est ce mes autorisations de groupes ou autre ? Est ce ma stratégie globale qui est un peu pourrie ? :francais:

Share this post


Link to post
Share on other sites

ajoute umask=002

Cela va te mettre les droits: 777-002=775, soit rwxrwxr-x.

Laisser le group en rwx est risqué, il vaudrait mieux ajouter noexec.

neologix

Share this post


Link to post
Share on other sites
ajoute umask=002

Cela va te mettre les droits: 777-002=775, soit rwxrwxr-x.

Laisser le group en rwx est risqué, il vaudrait mieux ajouter noexec.

neologix

Desolé pour le retard : juste pour dire que ca marche impec :)

Mais j'ai changé les droits en effet, j'ai mis umask 027 avec noexec.

Du coup, le groupe 500 y'a acces en lecture et execution, mais comme j'ai mis le noexec, je suppose que l'execution des droits ne permet que d'ouvrir les répertoires. J'ai bon ?

Share this post


Link to post
Share on other sites

essaie ça dans ton fstab (je suis aussi sous fedora et çà marche)

/dev/hda1 /mnt/windowsc ntfs defaults,umask=0222,user 0 0

/dev/hda2 /mnt/windowsd ntfs defaults,umask=0222,user 0 0

bien sur tu adapte les disk (hda ou hdb 1 2 3 ect selon tes partitions)

et tu n'oublie pas de créer avant de modifier ton fstab dans le répertoire /mnt un répertoir par disk que tu veux monter.

C'est le nom de ce répertoir qui doit figurer dans la commande de montage

exemple pour moi

sur le disk ''linux'' j'ai créé.

/mnt/windowsc et /mnt/windowsd

cest pour ça que le fstab contient

/dev/hda1 /mnt/windowsc ntfs defaults,umask=0222,user 0 0

Tu trouvera des infos sur le sujet ici

http://www.fedora-france.org :-D

et ici

http://perso.wanadoo.fr/fester/faq-fedora.html#ntfs :-D

voila :fumer:

Share this post


Link to post
Share on other sites

Mega-up :)

Petite question. J'ai une erreur quand je fais monte les partitions suivantes : sda1 et sda2.

Voilà le fstab. Que dois-je modifier pour que ça marche?

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/sdb5	   /			   reiserfs notail		  0	   1
/dev/sdb2	   /media/installs ntfs	defaults,nls=utf8,umask=007,gid=46 0	   1
/dev/sdb1	   /media/winxp	ntfs	defaults,nls=utf8,umask=007,gid=46 0	   1
/dev/sdb4	   /partage		vfat	defaults,user,utf8,umask=0,gid=46 0	   1
/dev/sdb6	   none			swap	sw			  0	   0
/dev/scd0	   /media/cdrom0   udf,iso9660 user,noauto	 0	   0
/dev/sda1	/home/dae/Desktop/Documents	ext2	defaults,umask=0	0	0
/dev/sda2	/home/dae/Desktop/Multimedia	ext2	defaults,umask=0	0	0

Et l'erreur après les manipulations:

dae@mozaruntu:~$ sudo mount -a
mount: type erroné de système de fichiers, option erronée, super bloc erroné sur  /dev/sda1,
   codepage manquante ou autre erreur
   Dans quelques cas certaines informations sont utiles dans syslog - essaye z
   dmesg | tail  ou quelque chose du genre

mount: type erroné de système de fichiers, option erronée, super bloc erroné sur  /dev/sda2,
   codepage manquante ou autre erreur
   Dans quelques cas certaines informations sont utiles dans syslog - essaye z
   dmesg | tail  ou quelque chose du genre

dae@mozaruntu:~$ dmesg | tail
[17179612.660000] Bluetooth: RFCOMM TTY layer initialized
[17179612.660000] Bluetooth: RFCOMM ver 1.7
[17179613.948000] eth0: no IPv6 routers present
[17179625.800000] cdrom: sr0: mrw address space DMA selected
[17179625.800000] Assertion failed! qc->n_elem > 0,drivers/scsi/libata-core.c,at a_fill_sg,line=2531
[17179625.900000] cdrom: sr0: mrw address space DMA selected
[17179625.900000] Assertion failed! qc->n_elem > 0,drivers/scsi/libata-core.c,at a_fill_sg,line=2531
[17179626.180000] ISO 9660 Extensions: Microsoft Joliet Level 1
[17179626.196000] ISOFS: changing to secondary root
[17184258.740000] NTFS volume version 3.1.

:up:

Share this post


Link to post
Share on other sites

Vérifies que c'est bien les bonnes partitions avec

fdisk -l

en root. Sinon essaye de les monter à la main voire ce qui ne va pas avant de les ajouter dans le fstab.

Share this post


Link to post
Share on other sites

Oui c'est bien le bon disque. J'arrives à monter mon disque avec comme seule option "defaults" mais c'est tout... j'peux pas rajouter d'options :up:

Impossible de le monter à la main :iloveyou:

EDIT:

Les options gid, uid, umask, mode,... ne sont pas utilisable avec les partitions ext2 et ext3. De plus sur les partitions ext2 et ext3, les droits sont gérés fichier par fichier et dossier par dossier, et donc ces options n'ont aucune utilité

Ok.

Alors va falloir modifier les droits avec chmod et cie :)

ça serait pas mal de le mettre dans le tuto ça :roll:

Share this post


Link to post
Share on other sites

pour changer tous les droit d'un coup: "chmod" et "chown" au besoin avec option "-R" pour changer le contenu des sous répertoire ;-)

Share this post


Link to post
Share on other sites

:chinois: à nouveau.

J'ai une question. Qu'est-ce qu'il existe une option dans le fstab pour éviter que les partitions systèmes ne s'affichent sur le bureau ?

Là j'ai sur le bureau : Multimedia, Volume 20.0 GO (ma partition /home) Volume 40.0 GO (ma partition Ubuntu), Stuff, et IAUDIO (avec l'icone d'un disque amovible).

En fait j'aimerais tout enlever sauf IAUDIO, c'est pour ça que je demande si c'est une option dans le fstab, parce que y'a bien gconf-editor ou on peut desactiver ces icones sur le bureau avec nautilus... mais y'a plus de CD ni de IAUDIO après...

:iloveyou:

Share this post


Link to post
Share on other sites

Non c'est pas dans le fstab que ça se trouve. C'est plutôt vers gnome-volume-manager par exemple (et c'est difficilement configurable).

Share this post


Link to post
Share on other sites

×
×
  • Create New...