Jump to content

Archived

This topic is now archived and is closed to further replies.

THC_WeeD

Kernel Panik

Recommended Posts

salut

j'ai une gentoo

kernel 2.6.9-gentoo-r4

j'ai reinstallé entierement ma machine par problem de place :) (pour ceux qui souvent mes soucis :pleure: )

et au reboot je me retrouve avec :

Kernel panic - not syncing: VFS : unable to mount root FS on unknow-block (1,0)

ca veut dire que ma table d'inode est pourrie quand j'ai formatté ma partition?

ou ca vient d'un soucis d'options dans le noyau??

Share this post


Link to post
Share on other sites

Je venais justement pour poster le même problème que toi, mais sur ma Debian, aussi avec le kernel 2.6.9 dispo sur www.kernel.org

VFS: Cannot open root device "302" or unknow-block (3,2)

Please append a correct "root=" boot option

Kernel panic - not syncing: VFS : unable to mount root FS on unknow-block (3,2)

J'ai chercher dans LILO et dans les options du kernel, mais toutes les phrases qui concernent le boot et où c'est marqué "root=" sont suivis de mon secteur "/", à savoir "dev/hda2" (dev/hda1 c'est le swap, et j'ai que les deux là)

Si quelqu'un pouvait nous aider, ca serait super. Merci a lui d'avance

Share this post


Link to post
Share on other sites

moi persolinux se trouve sur mon 2eme DD (he vi windaube refuse de s'installer sur le 2eme donc hda pour daube :) )

et ma part root en 1er place soit :/dev/hdb1

pour grub je lui aimit:

root (hd0,1)

setup(hd0)

Share this post


Link to post
Share on other sites
moi persolinux se trouve sur mon 2eme DD (he vi windaube refuse de s'installer sur le 2eme donc hda pour daube :) )

et ma part root  en 1er place soit :/dev/hdb1

pour grub je lui aimit:

root (hd0,1)

setup(hd0)

heu ca serait pas plutot (hd1,0)

Share this post


Link to post
Share on other sites

Ah toi tu te sert de Grub, moi, plus par fainéantise qu'autre chose ( :transpi: ) je me sert juste de LILO

(Bon j'avoue que je capte que dalle a Grub aussi, mais je viens tout juste de me mettre a Linux, et comme je suis un peu aventureux, j'ai décidé de passer à Debian, mais ca m'étonnerait pas que, vu mon jeune âge, j'ai louper un truc a paramétrer)

Share this post


Link to post
Share on other sites

title=Gentoo GNU/Linux 2.6.9
root=(hd0,2)
kernel /kernel-2.6.9-gentoo root=/dev/hda5

/boot sur hda3

et / sur hda5

Share this post


Link to post
Share on other sites

Et pour moi, personne à une solution ?

je rapelle:

Debian 3.0r3

essai de booter sur le kernel 2.6.9

dev/hda1: c'est le swap

dev/hda2 j'ai monter " dessus, cest mon DD

Si quelqu'un a une solution, qu'il me le dise, je suis un peu perdu là.

Share this post


Link to post
Share on other sites

:transpi:

Alors comme ça on lit pas les tutos sur le noyaux ;)

Pour pouvoir monter un FS, il faudrait peut-être que le noyau en ait la capacité. Donc faudrait peut-être mette le module du FS de la partition root en dur, non?...

:D

Share this post


Link to post
Share on other sites

Excuse moi de te prendre la tête, c'est pas mon intention, mais qu'est ce que le FS ? et dans quel menu du noyau je dois aller pour l'activer, car j'ai pas vu une chose concernant ce "FS" dans le tuto.

J'éspère que vous pardonnerez mon ignorance, mais je me suis mis a la Debian il y à 4 jours , et vu mon jeune âge, je comprend pas encore tout.

Un utilisateur très content d'être passé a Linux, et qui ne demande qu'a apprendre .

Share this post


Link to post
Share on other sites

whoups, au temps pour moi : FS == file system.

tu as toute une arborescance du menu de compilation du noyau qui parle de ça :freeposts:

Share this post


Link to post
Share on other sites

Merci pour le lien,mais je fais exactement comme indiqué dedans, notamment dans l'option "File systems"

File systems

Mettre le maximum de systèmes de fichiers en dur afin de pouvoir booter n'importe où...

(Ext2, Ext3, Reiserfs, JFS, XFS), ainsi que le NTFS éventuellement (pas en écriture! voire aide).

Activer aussi "SMB file system support" dans "Network File Systems"

Activer également "NLS ISO 8859-15 (Latin 9; Western European Languages with Euro)" sous "Native Language Support" afin de pouvoir accéder tranquillement aux données des disques ntfs et fat de windows.

Tout ca je fais, mais sans succès. Est ce que ca pourrait provenir de la partie "Devices", auquelle cas j'aurais mal configuré mon disque ?

EDIT: j'ai oublier de préciser, mais je suis sur un portable, est ce que cela peut jouer au niveau des drivers a compiler ??

EDIT2: je vois dans "file systems" l'option "kernel automounter", est ce que le problème pourrait venir de la si cette option est activée ?

Share this post


Link to post
Share on other sites

tu peux donner ton lilo.conf (et tu pense bien a relancer lilo dans un console après chaque changement, pour le rechager)

Share this post


Link to post
Share on other sites
# /etc/lilo.conf - See: `lilo(:freeposts:' and `lilo.conf(5)',

# ---------------      `install-mbr(:incline:', `/usr/share/doc/lilo/',

#                      and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+

# |                        !! Reminder !!                        |

# |                                                              |

# | Don't forget to run `lilo' after you make changes to this    |

# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |

# | computer will most likely fail to boot if a kernel-image      |

# | post-install script or you don't remember to run `lilo'.      |

# |                                                              |

# +---------------------------------------------------------------+

# Support LBA for large hard disks.

#

lba32

# Overrides the default mapping between harddisk names and the BIOS'

# harddisk order. Use with caution.

#disk=/dev/hde

#    bios=0x81

#disk=/dev/sda

#    bios=0x80

# Specifies the boot device.  This is where Lilo installs its boot

# block.  It can be either a partition, or the raw device, in which

# case it installs in the MBR, and will overwrite the current MBR.

#

boot=/dev/hda

# Specifies the device that should be mounted as root. (`/')

#

root=/dev/hda2

# Enable map compaction:

# Tries to merge read requests for adjacent sectors into a single

# read request. This drastically reduces load time and keeps the

# map smaller.  Using `compact' is especially recommended when

# booting from a floppy disk.  It is disabled here by default

# because it doesn't always work.

#

# compact

# Installs the specified file as the new boot sector

# You have the choice between: bmp, compat, menu and text

# Look in /boot/ and in lilo.conf(5) manpage for details

#

install=/boot/boot-menu.b

# Specifies the location of the map file

#

map=/boot/map

# You can set a password here, and uncomment the `restricted' lines

# in the image definitions below to make it so that a password must

# be typed to boot anything but a default configuration.  If a

# command line is given, other than one specified by an `append'

# statement in `lilo.conf', the password will be required, but a

# standard default boot will not require one.

#

# This will, for instance, prevent anyone with access to the

# console from booting with something like `Linux init=/bin/sh',

# and thus becoming `root' without proper authorization.

#

# Note that if you really need this type of security, you will

# likely also want to use `install-mbr' to reconfigure the MBR

# program, as well as set up your BIOS to disallow booting from

# removable disk or CD-ROM, then put a password on getting into the

# BIOS configuration as well.  Please RTFM `install-mbr(:transpi:'.

#

# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should

# wait before booting the first image.

#

delay=20

# You can put a customized boot message up if you like.  If you use

# `prompt', and this computer may need to reboot unattended, you

# must specify a `timeout', or it will sit there forever waiting

# for a keypress.  `single-key' goes with the `alias' lines in the

# `image' configurations below.  eg: You can press `1' to boot

# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.

#

# message=/boot/bootmess.txt

prompt

timeout=20

# prompt

# single-key

# delay=100

# timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)

#

# vga=ask

# vga=9

#

vga=normal

# Kernel command line options that apply to all installed images go

# here.  See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in

# the Linux kernel `Documentation' directory.

#

# append=""

# Boot up Linux by default.

#

default=Linux

root = /dev/hda2

image=/vmlinuz

label=Linux

read-only

# restricted

# alias=1

root = /dev/hda2

image=/vmlinuz.old

label=LinuxOLD

read-only

optional

# restricted

# alias=2

# If you have another OS on this machine to boot, you can uncomment the

# following lines, changing the device name on the `other' line to

# where your other OS' partition is.

#

# other=/dev/hda4

# label=HURD

# restricted

Par contre, quelle commande est a utiliser pour relancer LILO, car je l'ai jamais fait, et comme j'ai modifier des trucs, ca serait utile.

Pour le moment je recompile le oyau avec une config toute propre, et je verrais ce que sa donne .

Share this post


Link to post
Share on other sites

Ouais, il peut manquer plusieurs choses...

un driver de chipset, de contrôleur DD, de système de fichier...

faut essayer d'abord un "make defconfig", puis de configurer quelques trucs...

en général ça marche...

Share this post


Link to post
Share on other sites

J'ai tout tenter, mais en vain, il se borne a ne pas demarre, ca commence a me prendre le choux. J'ai bien installer les modules en dur pour ma carte mere, le disque dur, et ce pu**** de VFS me prend la tête, y'a pas moyens d'arriver a booter :cnul:

Share this post


Link to post
Share on other sites

Bon en fait, mon problème c'est que VFS, d'après ce que je comprend, ne boote pas sur le bon secteur, mais par contre mon message d'erreur a changé:

XFS: bad magic number

XFS: SB validate failed

Kernel panic - not syncing: VFS : unable to mount root FS on unknow-block (3,2)

Donc si quelqu'un pouvait me préciser si je dois modifier le chemin de boot pour VFS, soit dans un fichier .config ou dans un autre, qu'il me fasse signe. Par contre, je ne peut pas modifier cette option dans le noyau, vu que je n'ai même pas une option pour désactiver ce fameux VFS, ou alors pas dans "file systems"

Share this post


Link to post
Share on other sites

[mode honte]

salut

j'ai trouvé pour mon problem j'avais pas decommenté l'initrd dans mon menu.lst (grub.conf)

et init=/linuxrc avais : au lieu du = :8 :-D:craint: [/mode honte]

Share this post


Link to post
Share on other sites
[mode honte]

salut

j'ai trouvé pour mon problem j'avais pas decommenté l'initrd dans mon menu.lst (grub.conf)

et init=/linuxrc avais : au lieu du = :8 :-D:craint: [/mode honte]

attends...je cherche un smiley...

:craint:

Share this post


Link to post
Share on other sites

J'ai tout comme PSXBFLO (avec noyau 2.6.9-r6 et root = /dev/hda5)

après avoir passé 2 jours à compiler gentoo à partir du stage1 c'est ralent :yes:

config PC de bureau avec 2 HD IDE et des patitions ntfs, fat32 et reiserfs (+swap) un peu sur les 2 disques... mais çà machait avec Mandrake 10.0 community alors pourquoi pas là ?

lilo et grub donnent le même résultat et n'arrivent pas à lancer XP non plus... pour que ce gros démarre il me faut booter en IDE1 (XP sur /dev/hdc1) au lieu de IDE0 (hda) où se trouve grub (ou lilo)... sinon XP répond qu'il lui manque une dll dans son dossier system32 (que c'est même pô vrai vu que çà lui manque pas quand on boot sur IDE1). :-D

Si j'ai du nouveau je reviens (évidement) ;)

Share this post


Link to post
Share on other sites

Bon j'ai reussi, alors je t'explique, j'ai pris la config du noyau sur lequelle je bootais bien, je l'ai utilisé avec le 2.6.9, j'ai rentrer les bons parametres, etc, mais je n'ai PAS change une seule options dans "Files systems", et la, oh miracle, sa marche. :-D:fou:

Pour prendre la config de ton noyau actuel tu fais:

cp /boot/config-2.X.X .config 

c'est a faire apres avoir fait

cd linux-2.X.X

et apres un makemenuconfig et normalement si tu touche rien dans "File systems" ca marche :francais:

Share this post


Link to post
Share on other sites

pensez à activer le config.gz dans le noyau.

comme ça, pour récuperer la config du noyau en cours d'utilisation : zcat /proc/config.gz > mon_fichier_de_config

super utile :francais:

Share this post


Link to post
Share on other sites
J'ai tout comme PSXBFLO (avec noyau 2.6.9-r6 et root = /dev/hda5)

après avoir passé 2 jours à compiler gentoo à partir du stage1 c'est ralent :francais:

config PC de bureau avec 2 HD IDE et des patitions ntfs, fat32 et reiserfs (+swap) un peu sur les 2 disques... mais çà machait avec Mandrake 10.0 community alors pourquoi pas là ?

lilo et grub donnent le même résultat et n'arrivent pas à lancer XP non plus... pour que ce gros démarre il me faut booter en IDE1 (XP sur /dev/hdc1) au lieu de IDE0 (hda) où se trouve grub (ou lilo)... sinon XP répond qu'il lui manque une dll dans son dossier system32 (que c'est même pô vrai vu que çà lui manque pas quand on boot sur IDE1). :fou:

Si j'ai du nouveau je reviens (évidement) :reflechis:

pour gentoo, y'a toujours moyen de copier le noyau qui se trouve sur le CD... et donc de pouvoir booter sa distrib'

pour les bootloaders, il suffit de savoir configurer... y'a un topic pour ça!

Share this post


Link to post
Share on other sites

Merci !

ok maintenant çà boot... j'avais des erreurs dans mon /dev/hda5 et reiserfsck les a corrigées... Je me disais aussi que c'était bizarre que le fichier de configuration de mon noyau ne correspondait pas bien aux choix que j'avais fait dans menuconfig (dont support reiserfs et type de processeur...)

Bon maintenant vlà qu'il me dit que le Filesystem est marked as NOT cleanly umounted, partition /dev/hda5 is mounted wih write permissions, cannot check it, filesystem couldn't be fixed :(

ggrrrrrrrrrrrmmmbl

J'm'y recolle...

Share this post


Link to post
Share on other sites

×
×
  • Create New...