Jump to content

Archived

This topic is now archived and is closed to further replies.

lorinc

gravure avec K3b

Recommended Posts

Heu ben vas faloir que tu m'explique alors car moi non seulement il plante a 5-6 % mais en plus il grave en 0.62 x alors qu'il devrais graver en 4x :ouioui::mdr:

je n'ai pas encore tester avec le 2.6.8 mais avec le 2.6.7 c'est le problème que j'avais :(

Share this post


Link to post
Share on other sites

Moi j'ai jamais ey de pb pour graver des CDs !!!

Avec cdrecord, y'a jamais aucun problème !

C'est k3b qui est nul ! on peut même pas lui dire "tient, ça c'est un graveur"

Share this post


Link to post
Share on other sites

fo quand même vachement se faire chier pour se priver de gui quand tu grave un CD... :roll:

Share this post


Link to post
Share on other sites

Ben ça dépend...

Pour copier un CD, c'est tout simple et pas besoin de gui

Pour graver un iso, pareil...

Mais après, j'utilise eroaster à qui on dit où est le graveur et qui utilise cdrecord...

Share this post


Link to post
Share on other sites

Salut,

Mise à part le problème liée au noyau 2.6.8 et 2.6.8.1, tu n'as pas un porblème de compatibilité entre ton graveur DVD et les médias ?

Marque du Graveur ? des médias ? Déjà testé sous Win ?

Sinon, je viens de lire un article au sujet du driver pour les webcams Philips, ben çà fait peur ...

Plus de drivers pour les webcams philips et les webcams marchant avec ce driver, des difficultés pour graver ... pffff ... et les 2 dévellopeurs arrêtes pour des conflicts avec les développeurs du noyau ... Je veux pas débattre de qui est en tort, mais ça me fout un peu les boules ...

Share this post


Link to post
Share on other sites

Arofarn :yes:

Due to the newly added command filtering, you now need to run cdrecord as

root. Since cdrecord will drop root privileges before accessing the drive,

setuid root won't help.

This means you will have to run cdrecord *and* k3b as root!

Donc y'a un patch :

--- linux-2.6.8/drivers/block/scsi_ioctl.c~ 2004-08-16 14:16:57.000000000 +0200
+++ linux-2.6.8/drivers/block/scsi_ioctl.c 2004-08-16 14:36:22.562908552 +0200
@@ -196 +196 @@
- if (verify_command(file, cmd))
+/* if (verify_command(file, cmd))
@@ -198 +198 @@
-
+*/ 

qui commente tout simplement la ligne 196 du fichier scsi_ioctl.c ...

Et moi, je vais vérifier que le 2.6.8-ck4 contient le patch :eeek2:

Share this post


Link to post
Share on other sites

the power of Google:

trouver une solltuion dans les 200 commentire d'une news de Linuxfr

Share this post


Link to post
Share on other sites

Bon, ben je confirme : le 2.6.8.1-ck4 marche vraiment mieux pour ça...

k3b marche, maintenant !!!

Share this post


Link to post
Share on other sites

ouais enfin c'est surtout le make moodules qui est super long et qui me prive un peu de Q3... :keskidit:

Share this post


Link to post
Share on other sites

je suis sous debian sid avant j'ete avec noyau 2.6.7 tout marchait impec avec k3b

le jour de la sortiee du 2.6.8.1 je l'ai compilé et surprise k3b trouvait pas cdrecord .......

apres un petit

# adduser nom_user cdrom

tout marchait nickel en simple utilisateur que ca soit pour les CDR ou LES CD-RW

Share this post


Link to post
Share on other sites

Eh bien moi : 2.6.8 : ça marche pas : le graveur est reconnu en tant que lecteur

2.6.8.1-ck4 ; ça marche !

(mais ça dépend ce que tu as pris comme noyau...ceux de kernel.org, ou bien ceux qui viennent de debian et qui on pu être modifiés...)

Share this post


Link to post
Share on other sites
Eh bien moi : 2.6.8 : ça marche pas : le graveur est reconnu en tant que lecteur

2.6.8.1-ck4 ; ça marche !

(mais ça dépend ce que tu as pris comme noyau...ceux de kernel.org, ou bien ceux qui viennent de debian et qui on pu être modifiés...)

oué j'ai pris les sources de debian

Share this post


Link to post
Share on other sites
oué j'ai pris les sources de debian

alors ils ont du eux-même faire la modification :-D

Share this post


Link to post
Share on other sites
heu comment on applique ce genre de patch, je suis sous debian ?

a+ merci

D'après ce que dit flashball, le patch est déjà appliqué aux noyaux précompilés debian...ou bien à tous ceux téléchargés chez eux...

il reste ceux qui le compilent eux-même...

dans ce cas là, soit il faut utiliser le patch que j'ai donné plus haut en le modifiant légèrement.

Soit modifier directement le fichier (vu le nombre réduit de modifs à faire)

Share this post


Link to post
Share on other sites
if (copy_from_user(cmd, hdr->cmdp, hdr->cmd_len))

  return -EFAULT;

if (verify_command(file, cmd))

  return -EPERM;

/*

  * we'll do that later

  */

:keskidit:

c'est la qu'on vois que le développement du noyau c'est en grande partie du bricolage...

Share this post


Link to post
Share on other sites
:transpi:

c'est la qu'on vois que le développement du noyau c'est en grande partie du bricolage...

ouais...

quand j'ai vu ça, j'était :keskidit:

Share this post


Link to post
Share on other sites

:-D

c'est la qu'on vois que le développement du noyau c'est en grande partie du bricolage...

Bah oui, ils peuvent pas écrire "TODO" c'est breveté par M$.

Soyez pas mauvaise langue, c'est pour rester compatible GPL !

Share this post


Link to post
Share on other sites

Bonjour,

Je ne comprends vraiment pas ce qu'il faut faire avec ce patch, si quelqu'un pouvais exactement me dire ce que je dois faire je suis paumer la, j'ai essayé de capter mais je pense que je me susi completement planté...

j'ai commenté la ligne 196 par # de mon fichier scsi-ioctl.c et j'ai recompiler mais pense pas que c'étais ca qu'il fallait faire car ca marche toujours pas :)

alors si quelqu'un pouvais m'expliquer comment ca fonctionne .... merci d'avance

a+ RAM

Share this post


Link to post
Share on other sites

tu ajoute /* au debut de la ligne 196 et */ sur la ligne 198

c un bete commenaire en C...

Share this post


Link to post
Share on other sites

×
×
  • Create New...