Jump to content

Archived

This topic is now archived and is closed to further replies.

crome

pb config acceleration 3D

Recommended Posts

salut a tous,

j'ai pris la bonne decision de passer sous SUSE 9.1, tous se passe bien a part 2 choses.

apres plusieurs heures de recherche et d'essais ,je craque.

mes problèmes:

impossible de configurer ma carte graphique ATI 9600 se ,l'acceleration 3D ne fonctionne pas.

apres avoir fait un tourne chez SUSE et chargé le .rpm de fglrx puis suivit les indication, mais toujours pareil.

ensuite je n'arrive pas a lire de video avec TOTEM, KAFEINE, etc surement probleme de codecs mais je ne trouve pas .

quelqu'un pourrais m'aider ?

grand merci d'avance

Link to post
Share on other sites

impossible de configurer ma carte graphique ATI 9600 se ,l'acceleration 3D ne fonctionne pas.

apres avoir fait un tourne chez SUSE et chargé le .rpm de fglrx puis suivit les indication, mais toujours pareil.

Je ne connais ni suse ni ati, mais je vais ptet pouvoir t'aider pour la base, si c'est un peut trop specifique a Ati, Sandeman pourra certainement t'aider. Pour les codecs et la video, c'est un autre pb, pas besoin d'acceleration pour mater une video.

Regardes tout d'abord le modele exact de ta carte video vue par linux avec lspci. Ensuite, il faut regarder ce que donne dmseg | more ainsi que /var/log/messages. Ces deux fichiers permettent de connaitre comment s'est deroule le demarrage, ainsi, on pourra certainement voir si ta cg est reconnue ou inconnue au bataillon, lspci ne faisant que betement l'inventaire du matos present, sans savoir si ton noyau linux les connait.

Link to post
Share on other sites
Pour l'installation des drivers nvidia sur Suse, il est préférable d'utiliser les fichiers .run disponible sur leur site, il y a également une doc assez explicite pour la procédure à suivre: Nvidia Suse Install

Sinon, il reste la possibilité d'utiliser les sources et de compiler avec les bonnes options, mais je ne sais pas si c'est encore possible pour les derniers drivers nvidia. A voir !

On parlait d'installer des cartes ATI, pas NVIDIA ... :chinois:

Link to post
Share on other sites
j'ai pris la bonne decision de passer sous SUSE 9.1, tous se passe bien ... impossible de configurer ma carte graphique ATI 9600

je n'arrive pas a lire de video avec TOTEM, KAFEINE

Oui, en effet ... :chinois:

Facile tout ça sur Mandrake !

C'est bon, je men vais ! :accident:

Link to post
Share on other sites

Salut,

Regarde le petit topic sur la SuSE. (Oui je vais bientôt refaire un topic officiel)

Essayes ce que j'ai mis pour les cartes ATI.

Cela fonctionne très bien sur une mobility 9000, un radeon 8500 et 9700Pro.

http://www.pcinpact.com/forum/sujet_20840_20.htm (milieu de page)

Pour les codecs, le site de pacman contient ce qu'il faut.

http://ftp.gwdg.de/pub/linux/suse/apt/SuSE...6/RPMS.packman/

Tu prends les codecs Win32, divx, xvid, ...

Sinon, tu peux essayer apt4rpm pour récupérer les paquetages.

Link to post
Share on other sites

'lut,

Pour libdvdcss : (site de packman, oui encore :yes: )

http://packman.links2linux.de/?query=css&action=search

Pour l'install :

- Tu prends le script pour la 9.0 (enregistrer sous ...)

en root :

- Tu fais un chmod sur "install_libdvdcss2":

# chmod 777 install_libdvdcss2

- Puis tu le lances :

# ./install_libdvdcss2

Pour le reste, j'éditerai ici après avoir récupérer le net ...

( ce que je me rappelle de tête :

- il va downloader libdvdcss, et te mettre .tar.gz dans /usr/src/package.

- Tu décompresses, et là, tu dois faire un ./configure, make, make install

Enfin je te dis cela de tête, je complèterai par la suite :D )

@+,

Guile.

Link to post
Share on other sites

Si je prends la méthode générale de Trustonme :

libdvdcss :

libdvdcss qu'on ne présente plus, est un sympathique logiciel, qui vous permettra, de lire des dvds cryptés sous Linux. Avant de l'installer, assurez-vous qu'elle ne soit pas déjà installée :

whereis dvdcss

Si cette commande restait sans réponse, c'est qu'elle n'est pas installée. Pour ce faire, téléchargez la version la plus à jour des sources ici. L'installation se résumant à :

tar -xzvf /où_est/libdvdcss-xxxxx.tar.gz

cd libdvdcss-xxxxx/ && ./configure --prefix=/usr && make && make install

Ca ne marche pas ?

Ou le rpm de Mandrake ?

C'est incroyable ce rpm fait 10 ko !!!!

Link to post
Share on other sites

Je ne sais pas écrire de scripts mais je sais lire ...

Donc en fait si je comprends bien le rpm (proposé par le site Packman) tout seul on ne va rien en faire (ce qui explique sa taille), il faut le libdvdcss en tar.bz2 pour le construire grâce au script pour Suse 9 ...

Pourquoi faire simple quand ... etc ...

Link to post
Share on other sites

re bonjour,

merci pour ta reponse rapide.

je suis aller voir le type de carte detectée par linux : vga compatible controller ATI inc RV350 AQ [radeon 9600]

puis je suis aller voir le LOG et la ,il m'indique une erreur mais je ne vois pas comment la resoudre,voici l'erreur:

glrx: unsupported module, tainting kernel.

fglrx: module license 'Proprietary. © 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.

[fglrx] Maximum main memory to use for locked dma buffers: 928 MBytes.

[fglrx] module loaded - fglrx 3.7.6 [Mar 5 2004] on minor 0

Badness in do_no_page at mm/memory.c:1497

Badness in do_no_page at mm/memory.c:1497

[fglrx:firegl_unlock] *ERROR* Process 5068 using kernel context 0

[fglrx:drm_ioremapfree] *ERROR* [mappings] Attempt to free NULL pointer

d'avance grand merci pour ton aide

Link to post
Share on other sites

Salut,

Green, tu as bien rebuildé le rpm du site de Packman ? Comme indiqué plus haut ?

Packman ne peut plus distribuer le rpm près à l'emploi, due aux lois en Allemagne (Marqué sur le cite plus haut, faut lire).

Packman et SuSE sont allemands, donc ils ne peuvent distribués ce genre de paquetages. C'est pour cela aussi que la SuSE n'est livrés avec quasiment aucun codecs et aucun lecteur de DVD. Xine n'a pas cette option dans la version livrée.

C'est juste une histoire de juridiction ...

Crome, comme la dit TuXXX, essayes avec les 3.9.0 et tiens nous au courent :francais:

PS : Au fait, tu as la version Pro ? D'après certains sites, les drivers ATI DRI contiennent les drivers jusqu'aux Radeon 9600 inclus.

Link to post
Share on other sites
Green, tu as bien rebuildé le rpm du site de Packman ? Comme indiqué plus haut ?

Non, mais je vais le faire dans les jours qui viennent ... en fait j'avais enlevé définitivement Suse de mon micro suite aux nombreux pbs mais bon mis à part Mandrake évidemment, XP (beurk), ma (FAT32+swap) étendue et Conectiva 10, j'ai encore 4 partitions de libre.

J'en garde une pour Debian Sarge et comme il n'y a finalement pas tant que cela de distributions qui accrochent chez moi (j'en ai essayé un bon paquet), j'ai décidé de donner une nouvelle chance à Suse malgré les nombreux défauts que je lui trouve notamment au niveau simplicité par rapport à Mandrake (pour installer apt-get sur Mdk : urpmi apt-get mais ça n'a évidemment aucun intérêt sur Mdk, je l'avais d'ailleurs montré à Rémy) mais j'aime bien son look c'est vrai.

J'ai plus de recul maintenant. donc on verra.

Le problème que j'avais avec la lecture des swf je l'ai eu aussi avec Conectiva et je l'ai résolu en bidouillant kde (j'sais plus comment d'ailleurs ...), je pensais que cela venait de Suse ... pour la clé usb on verra.

:pleure:

Link to post
Share on other sites

Je m'y suis remis (à Suse) je dois être maso ...cela doit être parce que tout marche nickel sur ma Mandrake 10 PowerPack depuis son installation, inhabituel sous linux non ?

Pour la Sarge, je me prépare en lisant les docs, on verra plus tard.

Donc Suse 9.1 un seul Cd en hda4.

Installation : ras si ce n'est le choix que Suse veut imposer pour une raison inconnue (formater la partoche Mdk : il n'en est pas question !) - mode expert et le pb est réglé.

Tout de suite, j'installe le kernel 2.6.5-7.104-defaults pour ne pas à avoir à modifier le script de startmodem (tjs à cause de ce fichu modem de m... ECi Wanadoo usb).

Je redémarre.J'installe le rpm pour mon modem, en cliquant dessus YaST apparaît et si je clique sur "Install package with YaST" il le fait.

Truc bizarre : je peux faire autant de fois l'installation que je veux, YaST ne me signale même pas que le rpm est déjà installé !

Pourquoi certains rpms installés sont marqués d'un cadenas dans YaST ?

J'installe les fichiers synchro à partir d'un tar.bz2 (sur Suse, ça donne tar.bz2.tar ... bon...ok

Ensuite pour paramétrer on lance eciconf.sh qui est un joli tableau en tk/tcl ou un truc du genre:

Evidemment, /usr/local/bin n'est pas dans le PATH de root ... restons calme...

#cd /usr/local/bin

#./eciconf.sh >Xlib connection to ":0.0" refused by server ... etc ...

C'est la seule distrib qui me fait ça mais bon ... je garde mon sang froid car je m'y attendais et donc (c'est élégant) :

$cd /opt/kde3/bin

$./kdesu /usr/local/bin/eciconf.sh >ouf, ça marche

La connection se fait ensuite sans pb.

Je décide de compléter le PATH de root ... en modifiant /etc/bash.bashrc (avec /etc/profile ça ne marche pas, c'est pourtant ce que conseille le Guide de Survie).

J'y mets /usr/local/bin et /opt/kde3/bin évidemment.

Je fais un update (YOU), j'installe le driver Nvidia entre autres.

Résultat : glxgears :

Mandrake 10 : 1015 FPS

Suse : 312

??? (en gardant l'image telle qu'elle apparaît).

Si qqn a une explication ...

J'arrive pas à lire les xvid, seulement les divx pourtant j'ai installé le rpm xvid qui va bien ou cela vient de Kaffeine seul lecteur vidéo dont je dispose pour l'instant ?

Bon, assez pour aujourd'hui .

Ha si une bonne nouvelle : pour mon appareil photo numérique c'est nickel.

Ha oui je poste de Suse.

Bonne nuit les petits

:D

Link to post
Share on other sites
Cette distrib, c'est vraiment de la M***

Non, je ne dirais pas ça mais elle est spéciale, c'est sûr.

Je la préfère à Fedora par exemple mais c'est vrai que je suis peut-être trop attaché à la forme mais bon c'est comme ça ...

Elle n'a pas la facilité d'une mandrake c'est sûr.

Pour l'instant, il faut que je règle :

* Le pb de la lecture des xvid

* La synchro images / son pour les fichiers swf

* La lecture des dvd (sur mandrake sans la css on lit au moins les dvd non-cryptés, sur Suse non ou alors je sais pas faire).

* La clé usb qui met 4 mins 42 (j'ai chronométré) à être visible sur le bureau (alors que l'APN c'est tout de suite, comprends pas ...)

* L'installation de apt (pas de urpmi apt, c'est plus compliqué sous Suse )

...

Pour Nvidia, et bien oui j'ai pas modifié XF86Config, il était tard hier soir donc à faire...

:keskidit:

Link to post
Share on other sites

inhabituel sous linux non ?

Bah non, c'est meme plutot la routine.... Pourquoi ca marcherait pas ? :keskidit:

Pour la Sarge, je me prépare en lisant les docs, on verra plus tard.

C'est une bonne idee de lire la doc et de regarder un peu avant le fonctionnement de debian. Tu trouveras de bon tutos dans ma signature, ceux de debian et de de lattre sont pas trop mal pour rentrer un peu plus dans les details.

Pourquoi certains rpms installés sont marqués d'un cadenas dans YaST ?

Es tu bien sur d'avoir les privileges de root ( rappelles toi le su "-" ou "-l" ...), c'est suremlent parce que tu n'es pas root, ou parce que ce sont des packets vitaux pouyr le systeme. Cependant, sous linux, on est libre de faire ce que l'on veut, donc, j'ai horreur de ne pas pouvoir faire qqchose. Si meme en root tu peux pas les virer, je confirme que c'est de la m...

Je décide de compléter le PATH de root ... en modifiant /etc/bash.bashrc (avec /etc/profile ça ne marche pas, c'est pourtant ce que conseille le Guide de Survie).

Ben disons que le path de /etc/profile est le path pour tous les utilisateurs, donc il ne faut pas le completer avec des repertoires root. Par contre, ~/.bash_profile lui doit etre modifiable est peut servir a ca. .bashrc permet d'ajouter un path personnel aussi, c'est donc tout indique pour ce que tu veux faire, c'est bien. toutefois, un path root incomplet, c'est rare quand meme... Suse power ?

Mandrake 10 : 1015 FPS

Suse : 312

Pour un tel score, c'est que la resolution du bureau est differente, bcp d'applis tournent, et le nbr de couleurs est plus eleve. Tu peux aussi verifier si tu as bien l'agp :

cat /proc/driver/nvidia/agp/status

Bon courage jeune padawan*, la voie est longue

* aucun rapport avec les titres pcINpact, juste star wars !

Link to post
Share on other sites
Bah non, c'est meme plutot la routine.... Pourquoi ca marcherait pas ?

C'était une boutade, pour les serveurs je sais pas mais chez moi Mandrake 10 en utilisation desktop c'est un long fleuve tranquille ... que du bonheur .

En général, quand je poste pour un problème je fais référence à une autre distrib car sous Mdk ( :keskidit: ) RAS.

C'est une bonne idee de lire la doc

Tes docs sont très bien faîtes vraiment et je préfère attaquer Debian après avoir assimilé un certain nombre de concepts qui me sont étrangers.

Je connais déjà l'installateur de la Sarge qui ne me pose pas trop de pbs .

Elle sort quand la nouvelle Debian ? (à la place de la Woody ?)

certains rpms installés sont marqués d'un cadenas dans YaST ?

Le rpm pour le driver eci par exemple qui n'est pas un paquet vital ...

A creuser...

Merci pour explication sur le PATH, c'est vrai qu'il n'y a rien de plus énervant qu'un PATH incomplet ... beaucoup d'exécutables sur Suse sont dand /opt/kde3/bin, la moindre des choses aurait été de fixer le PATH root en conséquence ou alors cela relève d'une mogique qui me dépasse...

X-Guardian aurait sûrement une explication.

Promis pour fin août mon topo dsur urpmi, il y a beaucoup à en dire.

:byebye:

Link to post
Share on other sites


×
×
  • Create New...