Jump to content

[|DEBIAN 8.11] Mise à jour serveur souhaité vers Bullseye


Recommended Posts

Bonjour à toutes et tous, 

Je commence par vous souhaiter de bonne fête de fin d'année 😉

 

Je viens vers vous car nous venons de reprendre la main sur un VPS OVH sous DEBIAN 8.11 (Jessie) et nous souhaiterions mettre à jour le bébé.

Cependant fort de notre recherche sur le wiki officiel de DEBIAN, nous rencontrons des soucis quant au moment du Full-upgrade :

 

ps : au moment de faire :

$ sudo nano /etc/apt/sources.list /etc/apt/sources.list.d/*

je n'ai mis a jour les sources que dans sources.list et non dans .d (étant vide).

souces.list contient donc :

deb http://ftp.debian.org/debian/ bullseye main
deb http://security.debian.org/ bullseye/updates main

 

monadminsudo@monvpsovh:~$ sudo apt full-upgrade
[sudo] password for monadminsudo:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cloud-init : Depends: python-boto (>= 2.3) but it is not installable
 mount : Depends: util-linux (>= 2.29.2-3~) but 2.25.2-6 is installed
 openssh-sftp-server : Depends: openssh-client (= 1:6.7p1-5+deb8u8) but 1:8.4p1-                                                                                                                               5 is installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u13)
           Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.
monadminsudo@monvpsovh:~$ sudo apt full-upgrade -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... The following packages were automatically installed and a                                                                                                                               re no longer required:
  dh-python gir1.2-glib-2.0 iso-codes libalgorithm-c3-perl
  libany-uri-escape-perl libarchive-extract-perl libasprintf0c2
  libb-hooks-endofscope-perl libb-hooks-op-check-perl libcgi-fast-perl
  libcgi-pm-perl libclass-c3-perl libclass-c3-xs-perl
  libclass-method-modifiers-perl libclass-xsaccessor-perl libclone-perl
  libcpan-changes-perl libdata-optlist-perl libdata-perl-perl
  libdata-section-perl libdbd-mysql-perl libdbi-perl libdevel-callchecker-perl
  libdynaloader-functions-perl libencode-locale-perl libexporter-tiny-perl
  libfcgi-bin libfcgi-perl libfcgi0ldbl libfile-slurp-perl
  libgetopt-long-descriptive-perl libgirepository-1.0-1 libhtml-parser-perl
  libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libice-dev libimport-into-perl libio-html-perl
  libio-stringy-perl libjasper1 liblist-moreutils-perl
  liblist-moreutils-xs-perl libllvm3.5 liblog-message-perl
  liblog-message-simple-perl liblua5.1-0 liblwp-mediatypes-perl libmariadb3
  libmodule-build-perl libmodule-implementation-perl libmodule-pluggable-perl
  libmodule-runtime-perl libmodule-signature-perl libmoo-perl
  libmoox-handlesvia-perl libmpdec2 libmro-compat-perl libmysqlclient18
  libnamespace-autoclean-perl libnamespace-clean-perl libnet-libidn-perl
  libpackage-constants-perl libpackage-stash-perl libpackage-stash-xs-perl
  libparams-classify-perl libparams-util-perl libparams-validate-perl
  libpath-tiny-perl libpod-latex-perl libpod-markdown-perl libpod-parser-perl
  libpod-readme-perl libpthread-stubs0-dev libpython2-stdlib
  libpython2.7-minimal libpython2.7-stdlib libreadonly-perl libref-util-perl
  libref-util-xs-perl libregexp-common-perl librole-tiny-perl libsm-dev
  libsoftware-license-perl libstrictures-perl libsub-exporter-perl
  libsub-exporter-progressive-perl libsub-identify-perl libsub-install-perl
  libsub-name-perl libsub-quote-perl libterm-readkey-perl libterm-ui-perl
  libtext-soundex-perl libtext-template-perl libtimedate-perl libtry-tiny-perl
  libtxc-dxtn-s2tc0 libtype-tiny-perl libtype-tiny-xs-perl
  libunicode-utf8-perl liburi-escape-xs-perl liburi-perl
  libvariable-magic-perl libx11-dev libx11-doc libxau-dev libxcb1-dev
  libxdmcp-dev libxslt1.1 libxt-dev mariadb-common mysql-client-5.5
  mysql-common mysql-server-core-5.5 python-apt-common python-pkg-resources
  python-ply python-pycparser python-setuptools python-six python2
  python2-minimal python2.7 python2.7-minimal python3-apt python3-dbus
  python3-distro-info python3-gi rename sgml-base tcpd unattended-upgrades
  x11proto-core-dev x11proto-dev x11proto-input-dev x11proto-kb-dev xml-core
  xorg-sgml-doctools xtrans-dev
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  e2fslibs euca2ools libcpan-meta-perl libpython-stdlib libpython3.4-minimal
  libpython3.4-stdlib mysql-server mysql-server-5.5 openjdk-7-jdk
  openjdk-7-jre openjdk-7-jre-headless perl-modules python python-apt
  python-cffi python-chardet python-cheetah python-configobj python-crypto
  python-cryptography python-distro-info python-ecdsa python-json-pointer
  python-jsonpatch python-lxml python-minimal python-ndg-httpsclient
  python-oauth python-openssl python-paramiko python-prettytable python-pyasn1
  python-pyinotify python-requestbuilder python-requests python-serial
  python-software-properties python-support python-urllib3 python-yaml
  python3.4 python3.4-minimal tzdata-java
The following NEW packages will be installed:
  adwaita-icon-theme alsa-topology-conf alsa-ucm-conf apparmor at-spi2-core
  bsd-mailx bsdextrautils bzip2 cloud-guest-utils cloud-image-utils
  default-jre-headless dirmngr e2fsprogs-l10n eatmydata exim4-base
  exim4-config exim4-daemon-light fdisk gdisk genisoimage gir1.2-glib-2.0
  gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf
  gpgsm gtk-update-icon-cache initramfs-tools-core libany-uri-escape-perl
  libapt-pkg6.0 libassuan0 libatk-bridge2.0-0 libatspi2.0-0
  libb-hooks-endofscope-perl libb-hooks-op-check-perl libbpf0 libbrotli1
  libcairo-gobject2 libclass-method-modifiers-perl libclass-xsaccessor-perl
  libclone-perl libcpan-changes-perl libcurl4 libdata-perl-perl libdeflate0
  libdevel-callchecker-perl libdns-export1110 libdrm-amdgpu1 libdrm-common
  libdynaloader-functions-perl libeatmydata1 libefiboot1 libefivar1
  libencode-locale-perl libevent-2.1-7 libexporter-tiny-perl libext2fs2
  libfastjson4 libfcgi-bin libfcgi0ldbl libfile-slurp-perl libfontenc1
  libfribidi0 libgail-common libgail18 libgdbm-compat4 libgdbm6
  libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0 libgdk-pixbuf2.0-bin
  libgetopt-long-descriptive-perl libgirepository-1.0-1 libgl1 libglvnd0
  libglx-mesa0 libglx0 libgnutls-dane0 libgpm2 libhtml-parser-perl
  libhtml-tagset-perl libhttp-date-perl libhttp-message-perl libicu67
  libimport-into-perl libio-html-perl libio-stringy-perl libip6tc2
  libisc-export1105 libjansson4 libksba8 libldap-common liblist-moreutils-perl
  liblist-moreutils-xs-perl libllvm11 liblockfile-bin liblockfile1 liblognorm5
  liblua5.3-0 liblwp-mediatypes-perl libmagic-mgc libmariadb3 libmd0
  libmodule-implementation-perl libmodule-runtime-perl libmoo-perl
  libmoox-handlesvia-perl libmpdec3 libnamespace-autoclean-perl
  libnamespace-clean-perl libncurses6 libnet-libidn-perl
  libnetfilter-conntrack3 libnftables1 libnftnl11 libnghttp2-14 libnpth0
  libnsl2 libnss-systemd libopus0 libpackage-stash-perl
  libpackage-stash-xs-perl libpam-systemd libparams-classify-perl
  libparams-validate-perl libpath-tiny-perl libperl5.32 libpng16-16
  libpod-markdown-perl libpod-parser-perl libprocps8 libpsl5 libpython2-stdlib
  libpython3.9-minimal libpython3.9-stdlib libreadline8 libreadonly-perl
  libref-util-perl libref-util-xs-perl librole-tiny-perl librsvg2-2
  librsvg2-common librtmp1 libsensors-config libsensors5 libssh2-1
  libstrictures-perl libsub-exporter-progressive-perl libsub-identify-perl
  libsub-name-perl libsub-quote-perl libtimedate-perl libtirpc-common
  libtirpc3 libtry-tiny-perl libtype-tiny-perl libtype-tiny-xs-perl
  libuchardet0 libunbound8 libunicode-utf8-perl liburi-escape-xs-perl
  liburi-perl liburing1 libvariable-magic-perl libvulkan1 libwayland-client0
  libwebp6 libxaw7 libxcb-randr0 libxcb-shape0 libxcb-xfixes0 libxft2
  libxkbfile1 libxmu6 libxpm4 libxtables12 libxv1 libxxf86dga1 libxxhash0
  libz3-4 linux-image-5.10.0-10-amd64 logsave mailcap mariadb-common
  media-types mesa-vulkan-drivers ncal nftables openjdk-11-jre-headless
  pci.ids perl-modules-5.32 pigz pinentry-curses publicsuffix python2
  python2-minimal python3-attr python3-blinker python3-certifi
  python3-cffi-backend python3-chardet python3-configobj python3-cryptography
  python3-dbus python3-distro-info python3-distutils python3-gi python3-idna
  python3-importlib-metadata python3-jinja2 python3-json-pointer
  python3-jsonpatch python3-jsonschema python3-jwt python3-lib2to3
  python3-markupsafe python3-more-itertools python3-oauthlib
  python3-pkg-resources python3-pyinotify python3-pyrsistent python3-requests
  python3-setuptools python3-six python3-systemd python3-urllib3 python3-yaml
  python3-zipp python3.9 python3.9-minimal qemu-utils x11-utils x11proto-dev
  xxd
The following packages will be upgraded:
  acl acpi acpi-support-base acpid adduser apache2 apache2-bin apache2-data
  apache2-utils apt apt-utils authbind base-files base-passwd bash
  bsdmainutils bsdutils busybox ca-certificates ca-certificates-java
  cloud-init cloud-initramfs-growroot cloud-utils console-setup
  console-setup-linux coreutils cpio cron dash dbus debconf debconf-i18n
  debian-archive-keyring debianutils dh-python dictionaries-common diffutils
  discover discover-data distro-info distro-info-data dmidecode dpkg e2fsprogs
  eject emacsen-common fail2ban file findutils firmware-linux-free fontconfig
  fontconfig-config fonts-dejavu-core fonts-dejavu-extra fuse gettext-base
  gnupg gpgv grep groff-base grub-common grub-pc grub-pc-bin grub2-common gzip
  hicolor-icon-theme hostname iamerican ibritish ienglish-common ifupdown init
  init-system-helpers initramfs-tools initscripts insserv installation-report
  iproute2 iptables iputils-ping irqbalance isc-dhcp-client isc-dhcp-common
  iso-codes ispell java-common kbd keyboard-configuration klibc-utils kmod
  krb5-locales laptop-detect less libacl1 libaio1 libalgorithm-c3-perl
  libapache2-mod-jk libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libarchive-extract-perl libasound2 libasound2-data
  libasyncns0 libatk-wrapper-java libatk-wrapper-java-jni libatk1.0-0
  libatk1.0-data libattr1 libaudit-common libaudit1 libavahi-client3
  libavahi-common-data libavahi-common3 libbsd0 libbz2-1.0 libcairo2
  libcap2-bin libcgi-fast-perl libcgi-pm-perl libclass-c3-perl
  libclass-c3-xs-perl libcommons-dbcp-java libcommons-pool-java libcups2
  libdata-optlist-perl libdata-section-perl libdatrie1 libdb5.3
  libdbd-mysql-perl libdbi-perl libdbus-1-3 libdebconfclient0 libdiscover2
  libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libecj-java libedit2
  libelf1 libestr0 libexpat1 libfcgi-perl libflac8 libfontconfig1 libfreetype6
  libfuse2 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-data
  libgnutls-openssl27 libgraphite2-3 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libharfbuzz0b libhtml-template-perl libice-dev libice6
  libidn11 libjbig0 libjpeg62-turbo libkeyutils1 libklibc libkmod2 liblcms2-2
  libldap-2.4-2 liblocale-gettext-perl liblog-message-perl
  liblog-message-simple-perl liblua5.1-0 liblzma5 libmagic1 libmnl0
  libmodule-build-perl libmodule-pluggable-perl libmodule-signature-perl
  libmro-compat-perl libncurses5 libncursesw5 libnetfilter-acct1 libnewt0.52
  libnfnetlink0 libnspr4 libnss3 libnuma1 libogg0 libpackage-constants-perl
  libpam-modules libpam-modules-bin libpam-runtime libpam0g libpango-1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libparams-util-perl libparted2 libpci3
  libpciaccess0 libpcre3 libpcsclite1 libpipeline1 libpixman-1-0
  libpod-latex-perl libpod-readme-perl libpopt0 libpthread-stubs0-dev
  libpulse0 libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib
  libregexp-common-perl libsasl2-2 libsasl2-modules libsasl2-modules-db
  libsctp1 libsemanage-common libsemanage1 libsepol1 libslang2 libsm-dev
  libsm6 libsndfile1 libsoftware-license-perl libsqlite3-0 libss2 libstdc++6
  libsub-exporter-perl libsub-install-perl libterm-readkey-perl
  libterm-ui-perl libtext-charwidth-perl libtext-iconv-perl
  libtext-soundex-perl libtext-template-perl libtext-wrapi18n-perl
  libthai-data libthai0 libtiff5 libtinfo5 libudev1 libusb-0.1-4 libustr-1.0-1
  libuuid1 libvorbis0a libvorbisenc2 libwrap0 libx11-6 libx11-data libx11-dev
  libx11-doc libx11-xcb1 libxau-dev libxau6 libxcb-dri2-0 libxcb-dri3-0
  libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb1
  libxcb1-dev libxcomposite1 libxcursor1 libxdamage1 libxdmcp-dev libxdmcp6
  libxext6 libxfixes3 libxi6 libxinerama1 libxml2 libxmuu1 libxrandr2
  libxrender1 libxshmfence1 libxslt1.1 libxt-dev libxt6 libxtst6 libxxf86vm1
  libyaml-0-2 linux-base linux-image-amd64 lksctp-tools login logrotate
  lsb-base lsb-release man-db manpages manpages-de manpages-es manpages-fr
  manpages-it manpages-pl manpages-pt mawk mime-support mysql-common nano
  ncurses-base ncurses-bin ncurses-term net-tools netbase netcat-traditional
  nfacct openssh-sftp-server openssl os-prober parted passwd pciutils perl
  perl-base procps psmisc python-apt-common python-pkg-resources python-ply
  python-pycparser python-setuptools python-six python2.7 python2.7-minimal
  python3 python3-apt python3-minimal qemu-guest-agent rdnssd readline-common
  rename rsyslog sed sensible-utils sgml-base shared-mime-info ssl-cert
  startpar sudo systemd systemd-sysv sysv-rc sysvinit-utils tar task-english
  tasksel tasksel-data tcpd traceroute tzdata ucf udev unattended-upgrades
  unzip util-linux util-linux-locales vim-common vim-tiny wamerican wget
  whiptail whois x11-common x11proto-core-dev x11proto-input-dev
  x11proto-kb-dev xauth xdg-user-dirs xkb-data xml-core xorg-sgml-doctools
  xtrans-dev xz-utils zip zlib1g
384 upgraded, 236 newly installed, 43 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0 B/309 MB of archives.
After this operation, 706 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
WARNING: The following packages cannot be authenticated!
  login lsb-base sysvinit-utils util-linux tar liblzma5 init-system-helpers
  cron dpkg libudev1 systemd udev libklibc logsave libext2fs2 e2fsprogs
  initscripts initramfs-tools klibc-utils cpio coreutils busybox
  initramfs-tools-core startpar insserv sysv-rc base-files systemd-sysv
  console-setup-linux keyboard-configuration console-setup libaudit-common
  libaudit1 libterm-ui-perl debconf-i18n debconf libstdc++6 libfcgi0ldbl
  libfcgi-perl mysql-common mariadb-common libmariadb3 libdbd-mysql-perl
  libdbi-perl libparams-util-perl libtext-charwidth-perl perl-modules-5.32
  libgdbm6 libgdbm-compat4 libperl5.32 perl perl-base liblocale-gettext-perl
  libtext-iconv-perl libterm-readkey-perl libtext-soundex-perl
  libclass-c3-xs-perl libmodule-build-perl libbz2-1.0 libdb5.3 zlib1g
  liblog-message-perl liblog-message-simple-perl libtext-wrapi18n-perl
  libpam0g libsepol1 libsemanage-common libsemanage1 libkeyutils1
  libtirpc-common libtirpc3 libnsl2 libpam-modules-bin libpam-modules passwd
  adduser libelf1 libbpf0 libxtables12 libmd0 libbsd0 libmnl0 libcap2-bin
  iproute2 netbase ifupdown openssl ca-certificates libnspr4 libsqlite3-0
  libnss3 ca-certificates-java libbrotli1 libpng16-16 libfreetype6 libpcre3
  libglib2.0-0 libgraphite2-3 libharfbuzz0b java-common libavahi-common-data
  libavahi-common3 libexpat1 dbus libdbus-1-3 libavahi-client3 libcups2
  liblcms2-2 libjpeg62-turbo sensible-utils ucf fonts-dejavu-core
  libfontconfig1 fontconfig-config libuuid1 libasound2 libasound2-data
  libpcsclite1 openjdk-11-jre-headless default-jre-headless tzdata libedit2
  debianutils libpam-runtime acl libacl1 kmod libkmod2 linux-base kbd xkb-data
  openssh-sftp-server psmisc manpages-de manpages-pl procps manpages-fr
  libxxhash0 apt-utils libapt-pkg6.0 apt debian-archive-keyring gpgv
  libncurses6 libprocps8 libwrap0 init bash bsdmainutils bsdextrautils ncal
  bsdutils dash diffutils libpython3.9-minimal python3.9-minimal mime-support
  mailcap media-types libmpdec3 readline-common libreadline8
  libpython3.9-stdlib python3.9 python3-minimal cloud-init dh-python
  python3-apt python3 libpython3-stdlib python3-lib2to3 python3-distutils
  fdisk libpopt0 gdisk python3-six python3-configobj python3-markupsafe
  python3-jinja2 python3-json-pointer python3-jsonpatch python3-attr
  python3-more-itertools python3-zipp python3-importlib-metadata
  python3-pkg-resources python3-setuptools python3-pyrsistent
  python3-jsonschema python3-blinker python3-cffi-backend python3-cryptography
  python3-jwt python3-oauthlib python3-certifi cloud-guest-utils file
  libmagic1 libmagic-mgc genisoimage liburing1 libaio1 qemu-utils libpsl5 wget
  cloud-image-utils cloud-utils python3-chardet python3-idna python3-urllib3
  python3-requests libyaml-0-2 python3-yaml distro-info distro-info-data
  lsb-release net-tools python-apt-common findutils grep gzip hostname
  ncurses-bin sed libdebconfclient0 base-passwd libslang2 libncursesw5
  libtinfo5 libncurses5 ncurses-base libjansson4 libnftnl11 libnftables1
  nftables libestr0 libfastjson4 liblognorm5 rsyslog libuchardet0 groff-base
  libpipeline1 man-db acpid libsasl2-modules-db libsasl2-2 libldap-2.4-2
  libaprutil1-ldap libaprutil1-dbd-sqlite3 libaprutil1 libapr1 libnghttp2-14
  librtmp1 libssh2-1 libcurl4 liblua5.3-0 libicu67 libxml2 apache2 apache2-bin
  apache2-data apache2-utils libnuma1 irqbalance pigz python2.7
  libpython2.7-stdlib python2.7-minimal libpython2.7-minimal python2-minimal
  libpython2-stdlib python2 qemu-guest-agent rdnssd sgml-base tasksel-data
  task-english tasksel libassuan0 libksba8 libnpth0 dirmngr gnupg-utils
  gpgconf gpg pinentry-curses gpg-agent gpg-wks-client gpg-wks-server gpgsm
  gnupg-l10n gnupg libattr1 libss2 libusb-0.1-4 dmidecode iputils-ping
  libisc-export1105 libdns-export1110 isc-dhcp-client isc-dhcp-common less
  logrotate nano vim-tiny vim-common xxd libnewt0.52 whiptail mawk bzip2
  gettext-base krb5-locales liblockfile-bin libnss-systemd libpam-systemd
  manpages ncurses-term netcat-traditional pciutils pci.ids libpci3 traceroute
  wamerican xz-utils acpi acpi-support-base hicolor-icon-theme
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common shared-mime-info libdeflate0
  libjbig0 libwebp6 libtiff5 libgdk-pixbuf-2.0-0 libx11-xcb1 libx11-data
  libx11-doc libxau-dev libxau6 x11proto-core-dev x11proto-input-dev
  x11proto-kb-dev xorg-sgml-doctools x11proto-dev libxdmcp-dev libxdmcp6
  xtrans-dev libxcb1-dev libxcb1 libpthread-stubs0-dev libx11-dev libx11-6
  libgdk-pixbuf-xlib-2.0-0 libgtk2.0-common libatk1.0-0 libatk1.0-data
  libpixman-1-0 libxcb-render0 libxcb-shm0 libxext6 libxrender1 libcairo2
  libpangoft2-1.0-0 libpangocairo-1.0-0 fontconfig libfribidi0 libthai-data
  libdatrie1 libthai0 libpango-1.0-0 libxcomposite1 libxfixes3 libxcursor1
  libxdamage1 libxi6 libxinerama1 libxrandr2 libgtk2.0-bin libgtk2.0-0
  gtk-update-icon-cache adwaita-icon-theme alsa-topology-conf alsa-ucm-conf
  apparmor libatspi2.0-0 x11-common libxtst6 at-spi2-core authbind
  exim4-config exim4-base libevent-2.1-7 libunbound8 libgnutls-dane0 libidn11
  exim4-daemon-light liblockfile1 bsd-mailx cloud-initramfs-growroot
  emacsen-common dictionaries-common discover-data discover libdiscover2
  e2fsprogs-l10n libeatmydata1 eatmydata eject fail2ban firmware-linux-free
  fonts-dejavu-extra fuse libfuse2 libgirepository-1.0-1 gir1.2-glib-2.0
  grub-pc grub-pc-bin libefivar1 libefiboot1 grub2-common grub-common ispell
  ibritish iamerican ienglish-common installation-report libip6tc2
  libnfnetlink0 libnetfilter-conntrack3 iptables iso-codes laptop-detect
  libalgorithm-c3-perl liburi-perl liburi-escape-xs-perl
  libany-uri-escape-perl libapache2-mod-jk libarchive-extract-perl libasyncns0
  libatk-bridge2.0-0 libfontenc1 libdrm-common libdrm2 libdrm-amdgpu1
  libpciaccess0 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libz3-4 libllvm11 libsensors-config
  libsensors5 libvulkan1 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
  libxcb-present0 libxcb-sync1 libxcb-xfixes0 libxshmfence1 libxxf86vm1
  libglx-mesa0 libglvnd0 libglx0 libgl1 libice-dev libice6 libsm-dev libsm6
  libxt-dev libxt6 libxmu6 libxpm4 libxaw7 libxcb-shape0 libxft2 libxkbfile1
  libxmuu1 libxv1 libxxf86dga1 x11-utils libatk-wrapper-java
  libatk-wrapper-java-jni libb-hooks-op-check-perl
  libdynaloader-functions-perl libdevel-callchecker-perl
  libparams-classify-perl libmodule-runtime-perl libtry-tiny-perl
  libmodule-implementation-perl libsub-exporter-progressive-perl
  libvariable-magic-perl libb-hooks-endofscope-perl libcairo-gobject2
  libhtml-tagset-perl libhtml-parser-perl libcgi-fast-perl libcgi-pm-perl
  libclass-c3-perl libclass-method-modifiers-perl libclass-xsaccessor-perl
  libclone-perl libcommons-pool-java libcommons-dbcp-java libcpan-changes-perl
  libsub-install-perl libdata-optlist-perl libexporter-tiny-perl
  liblist-moreutils-xs-perl liblist-moreutils-perl librole-tiny-perl
  libstrictures-perl libdata-perl-perl libmro-compat-perl libsub-exporter-perl
  libdata-section-perl libecj-java libencode-locale-perl libfcgi-bin
  libfile-slurp-perl libogg0 libflac8 libgail18 libgail-common
  libgdk-pixbuf2.0-bin libio-stringy-perl libparams-validate-perl
  libgetopt-long-descriptive-perl libglib2.0-data libgnutls-openssl27 libgpm2
  libhtml-template-perl libtimedate-perl libhttp-date-perl libio-html-perl
  liblwp-mediatypes-perl libhttp-message-perl libimport-into-perl
  libldap-common liblua5.1-0 libmodule-pluggable-perl libmodule-signature-perl
  libsub-quote-perl libmoo-perl libmoox-handlesvia-perl libpackage-stash-perl
  libsub-identify-perl libsub-name-perl libnamespace-clean-perl
  libnamespace-autoclean-perl libnet-libidn-perl libnetfilter-acct1 libopus0
  libpackage-constants-perl libpackage-stash-xs-perl parted libparted2
  libpath-tiny-perl libpod-parser-perl libpod-latex-perl libpod-markdown-perl
  libtype-tiny-perl libpod-readme-perl libvorbisenc2 libvorbis0a libsndfile1
  libpulse0 libreadonly-perl libref-util-perl libref-util-xs-perl
  libregexp-common-perl librsvg2-2 librsvg2-common libsasl2-modules libsctp1
  libtext-template-perl libsoftware-license-perl libtype-tiny-xs-perl
  libunicode-utf8-perl libustr-1.0-1 libwayland-client0 libxcb-randr0
  libxslt1.1 linux-image-5.10.0-10-amd64 linux-image-amd64 lksctp-tools
  manpages-es manpages-it manpages-pt mesa-vulkan-drivers nfacct os-prober
  publicsuffix python-setuptools python-pkg-resources python-pycparser
  python-ply python-six python3-dbus python3-distro-info python3-gi
  python3-pyinotify python3-systemd rename ssl-cert sudo tcpd
  unattended-upgrades unzip util-linux-locales whois xauth xdg-user-dirs
  xml-core zip
Install these packages without verification? [y/N] y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: Aucun fichier ou dossier de ce type
Extracting templates from packages: 100%
Preconfiguring packages ...
locale: Cannot set LC_ALL to default locale: Aucun fichier ou dossier de ce type
locale: Cannot set LC_ALL to default locale: Aucun fichier ou dossier de ce type
locale: Cannot set LC_ALL to default locale: Aucun fichier ou dossier de ce type
locale: Cannot set LC_ALL to default locale: Aucun fichier ou dossier de ce type
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(Reading database ... 40274 files and directories currently installed.)
Preparing to unpack .../sysvinit-utils_2.96-7_amd64.deb ...
Unpacking sysvinit-utils (2.96-7) over (2.88dsf-59) ...
dpkg: error processing archive /var/cache/apt/archives/sysvinit-utils_2.96-7_amd                                                                                                                               64.deb (--unpack):
 trying to overwrite '/lib/init/vars.sh', which is also in package initscripts 2                                                                                                                               .88dsf-59
dpkg: considering deconfiguration of sysvinit-utils, which would be broken by in                                                                                                                               stallation of util-linux ...
dpkg: no, sysvinit-utils is essential, will not deconfigure
 it in order to enable installation of util-linux
dpkg: error processing archive /var/cache/apt/archives/util-linux_2.36.1-8_amd64                                                                                                                               .deb (--unpack):
 installing util-linux would break existing software
dpkg: considering deconfiguration of util-linux, which would be broken by instal                                                                                                                               lation of login ...
dpkg: no, util-linux is essential, will not deconfigure
 it in order to enable installation of login
dpkg: error processing archive /var/cache/apt/archives/login_1%3a4.8.1-1_amd64.d                                                                                                                               eb (--unpack):
 installing login would break existing software
Errors were encountered while processing:
 /var/cache/apt/archives/sysvinit-utils_2.96-7_amd64.deb
 /var/cache/apt/archives/util-linux_2.36.1-8_amd64.deb
 /var/cache/apt/archives/login_1%3a4.8.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

 

Merci d'avance pour vos retours 

Edited by ViriisXP
Link to comment
Share on other sites

  • ViriisXP changed the title to [|DEBIAN 8.11] Mise à jour serveur souhaité vers Bullseye

Change les sources list :

deb http://deb.debian.org/debian bullseye main
deb-src http://deb.debian.org/debian bullseye main

deb http://deb.debian.org/debian-security/ bullseye-security main
deb-src http://deb.debian.org/debian-security/ bullseye-security main

deb http://deb.debian.org/debian bullseye-updates main
deb-src http://deb.debian.org/debian bullseye-updates main


deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free


deb http://deb.debian.org/debian  bullseye-backports main contrib non-free
deb-src http://deb.debian.org/debian  bullseye-backports main contrib non-free

 

Puis : sur un terminal -->

apt-get update
apt-get upgrade
apt-get dist-upgrade

 

Edited by MeowMeow
Link to comment
Share on other sites

il y a 7 minutes, MeowMeow a dit :

Change les sources list :

deb http://deb.debian.org/debian bullseye main
deb-src http://deb.debian.org/debian bullseye main

deb http://deb.debian.org/debian-security/ bullseye-security main
deb-src http://deb.debian.org/debian-security/ bullseye-security main

deb http://deb.debian.org/debian bullseye-updates main
deb-src http://deb.debian.org/debian bullseye-updates main


deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free


deb http://deb.debian.org/debian  bullseye-backports main contrib non-free
deb-src http://deb.debian.org/debian  bullseye-backports main contrib non-free

 

Puis : sur un terminal -->

apt-get update
apt-get upgrade
apt-get dist-upgrade

 

 

 

root@serveur:/$ sudo apt-get update
Ign http://security.debian.org bullseye/updates InRelease
Ign http://security.debian.org bullseye/updates Release.gpg
Ign http://security.debian.org bullseye/updates Release
Get:1 http://ftp.debian.org bullseye InRelease [116 kB]
Err http://security.debian.org bullseye/updates/main amd64 Packages
  404  Not Found [IP: 151.101.66.132 80]
Ign http://ftp.debian.org bullseye InRelease
Ign http://security.debian.org bullseye/updates/main Translation-en_US
Ign http://ftp.debian.org bullseye/main amd64 Packages/DiffIndex
Ign http://security.debian.org bullseye/updates/main Translation-en
Ign http://security.debian.org bullseye/updates/main Translation-en_US.UTF-8
Ign http://security.debian.org bullseye/updates/main Translation-fr
Get:2 http://ftp.debian.org bullseye/main Translation-en [6,243 kB]
Get:3 http://ftp.debian.org bullseye/main Translation-fr [2,433 kB]
Get:4 http://ftp.debian.org bullseye/main amd64 Packages [8,183 kB]
Ign http://ftp.debian.org bullseye/main Translation-en_US
Ign http://ftp.debian.org bullseye/main Translation-en_US.UTF-8
Fetched 116 kB in 3s (29.5 kB/s)
W: GPG error: http://ftp.debian.org bullseye InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY 0E98404D386FA1D9 NO_PUBKEY 605C66F00D6C9793
W: Failed to fetch http://security.debian.org/dists/bullseye/updates/main/binary-amd64/Packages  404  Not Found [IP: 151.101.66.132 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

 

 

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cloud-init : Depends: python-boto (>= 2.3) but it is not installable
 mount : Depends: util-linux (>= 2.29.2-3~) but 2.25.2-6 is installed
 openssh-sftp-server : Depends: openssh-client (= 1:6.7p1-5+deb8u8) but 1:8.4p1-5 is installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u13)
           Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.

 

sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cloud-init : Depends: python-boto (>= 2.3) but it is not installable
 mount : Depends: util-linux (>= 2.29.2-3~) but 2.25.2-6 is installed
 openssh-sftp-server : Depends: openssh-client (= 1:6.7p1-5+deb8u8) but 1:8.4p1-5 is installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u13)
           Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.

 

Link to comment
Share on other sites

Du coup, vu qu'il me dit de faire un -f install :

 

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  apt apt-utils cloud-guest-utils cloud-image-utils cloud-init cloud-utils eatmydata fail2ban fdisk gdisk genisoimage libapt-pkg6.0 libeatmydata1 libmpdec3 libnsl2 libpython2-stdlib libpython2.7-minimal
  libpython2.7-stdlib libpython3-stdlib libpython3.9-minimal libpython3.9-stdlib libreadline8 libstdc++6 libtirpc-common libtirpc3 libudev1 liburing1 libxxhash0 login lsb-base lsb-release
  openssh-sftp-server python-pkg-resources python-ply python-pycparser python-setuptools python-six python2 python2-minimal python2.7 python2.7-minimal python3 python3-apt python3-attr python3-blinker
  python3-certifi python3-cffi-backend python3-chardet python3-configobj python3-cryptography python3-distutils python3-idna python3-importlib-metadata python3-jinja2 python3-json-pointer python3-jsonpatch
  python3-jsonschema python3-jwt python3-lib2to3 python3-markupsafe python3-minimal python3-more-itertools python3-oauthlib python3-pkg-resources python3-pyrsistent python3-requests python3-setuptools
  python3-six python3-urllib3 python3-yaml python3-zipp python3.9 python3.9-minimal qemu-utils systemd systemd-sysv sysvinit-utils udev util-linux
Suggested packages:
  apt-doc aptitude synaptic wajig dpkg-dev powermgmt-base btrfs-progs xfsprogs mailx monit sqlite3 wodim cdrkit-doc python-ply-doc cpp python-setuptools-doc python2-doc python-tk python2.7-doc binutils
  binfmt-support python3-doc python3-tk python3-venv python3-apt-dbg python-apt-doc python-attr-doc python-blinker-doc python-configobj-doc python-cryptography-doc python3-cryptography-vectors
  python-jinja2-doc python-jsonschema-doc python3-crypto python3-openssl python3-socks python-requests-doc python3.9-venv python3.9-doc debootstrap qemu-block-extra systemd-container policykit-1 dosfstools
Recommended packages:
  python3-pyinotify python3-systemd libpam-systemd libnss-systemd
The following packages will be REMOVED:
  euca2ools libpython-stdlib python python-apt python-cffi python-chardet python-cheetah python-configobj python-crypto python-cryptography python-distro-info python-ecdsa python-json-pointer
  python-jsonpatch python-lxml python-minimal python-ndg-httpsclient python-oauth python-openssl python-paramiko python-prettytable python-pyasn1 python-pyinotify python-requestbuilder python-requests
  python-serial python-software-properties python-support python-urllib3 python-yaml
The following NEW packages will be installed:
  cloud-guest-utils cloud-image-utils eatmydata fdisk gdisk genisoimage libapt-pkg6.0 libeatmydata1 libmpdec3 libnsl2 libpython2-stdlib libpython3.9-minimal libpython3.9-stdlib libreadline8 libtirpc-common
  libtirpc3 liburing1 libxxhash0 python2 python2-minimal python3-attr python3-blinker python3-certifi python3-cffi-backend python3-chardet python3-configobj python3-cryptography python3-distutils
  python3-idna python3-importlib-metadata python3-jinja2 python3-json-pointer python3-jsonpatch python3-jsonschema python3-jwt python3-lib2to3 python3-markupsafe python3-more-itertools python3-oauthlib
  python3-pkg-resources python3-pyrsistent python3-requests python3-setuptools python3-six python3-urllib3 python3-yaml python3-zipp python3.9 python3.9-minimal qemu-utils
The following packages will be upgraded:
  apt apt-utils cloud-init cloud-utils fail2ban libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libstdc++6 libudev1 login lsb-base lsb-release openssh-sftp-server python-pkg-resources python-ply
  python-pycparser python-setuptools python-six python2.7 python2.7-minimal python3 python3-apt python3-minimal systemd systemd-sysv sysvinit-utils udev util-linux
29 upgraded, 50 newly installed, 30 to remove and 355 not upgraded.
15 not fully installed or removed.
Need to get 0 B/27.2 MB of archives.
After this operation, 44.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  login lsb-base sysvinit-utils util-linux libudev1 systemd udev systemd-sysv openssh-sftp-server libstdc++6 libxxhash0 apt-utils libapt-pkg6.0 apt libpython3.9-minimal python3.9-minimal python3-apt
  python3-minimal python3 libmpdec3 libtirpc-common libtirpc3 libnsl2 libreadline8 libpython3.9-stdlib python3.9 libpython3-stdlib cloud-guest-utils genisoimage liburing1 qemu-utils cloud-image-utils
  cloud-utils fdisk gdisk lsb-release cloud-init python3-six python3-configobj python3-markupsafe python3-jinja2 python3-json-pointer python3-jsonpatch python3-attr python3-more-itertools python3-zipp
  python3-importlib-metadata python3-pkg-resources python3-lib2to3 python3-distutils python3-setuptools python3-pyrsistent python3-jsonschema python3-blinker python3-cffi-backend python3-cryptography
  python3-jwt python3-oauthlib python3-certifi python3-chardet python3-idna python3-urllib3 python3-requests python3-yaml python2.7 libpython2.7-stdlib python2.7-minimal libpython2.7-minimal
  python2-minimal libpython2-stdlib python2 libeatmydata1 eatmydata fail2ban python-setuptools python-pkg-resources python-pycparser python-ply python-six
Install these packages without verification? [y/N] y
Extracting templates from packages: 100%
(Reading database ... 40274 files and directories currently installed.)
Preparing to unpack .../sysvinit-utils_2.96-7_amd64.deb ...
Unpacking sysvinit-utils (2.96-7) over (2.88dsf-59) ...
dpkg: error processing archive /var/cache/apt/archives/sysvinit-utils_2.96-7_amd64.deb (--unpack):
 trying to overwrite '/lib/init/vars.sh', which is also in package initscripts 2.88dsf-59
dpkg: considering deconfiguration of sysvinit-utils, which would be broken by installation of util-linux ...
dpkg: no, sysvinit-utils is essential, will not deconfigure
 it in order to enable installation of util-linux
dpkg: error processing archive /var/cache/apt/archives/util-linux_2.36.1-8_amd64.deb (--unpack):
 installing util-linux would break existing software
dpkg: considering deconfiguration of util-linux, which would be broken by installation of login ...
dpkg: no, util-linux is essential, will not deconfigure
 it in order to enable installation of login
dpkg: error processing archive /var/cache/apt/archives/login_1%3a4.8.1-1_amd64.deb (--unpack):
 installing login would break existing software
Errors were encountered while processing:
 /var/cache/apt/archives/sysvinit-utils_2.96-7_amd64.deb
 /var/cache/apt/archives/util-linux_2.36.1-8_amd64.deb
 /var/cache/apt/archives/login_1%3a4.8.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Link to comment
Share on other sites

Euh, je dirais que faire le saut de Debian 8.1 vers la 11 d'un coup, c'était un peu osé.

Bon, il ne faut surtout pas le redémarrer, là il est dans un état intermédiaire.

Je propose de remettre le sources.list comme avant:

deb http://ftp.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free

Puis de relance un apt-get update && apt-get upgrade, ensuite de passe de la 8 à la 11 de version en version...

Mais il va falloir passer à l'église brûler des cierges pour le redémarrage...

Link to comment
Share on other sites

il y a 5 minutes, brice.wernet a dit :

Euh, je dirais que faire le saut de Debian 8.1 vers la 11 d'un coup, c'était un peu osé.

Bon, il ne faut surtout pas le redémarrer, là il est dans un état intermédiaire.

Je propose de remettre le sources.list comme avant:

deb http://ftp.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free

Puis de relance un apt-get update && apt-get upgrade, ensuite de passe de la 8 à la 11 de version en version...

Mais il va falloir passer à l'église brûler des cierges pour le redémarrage...

je vais commencer par faire un snapshoot alors déja 😉 

 

 

 

Link to comment
Share on other sites

il y a 11 minutes, ViriisXP a dit :

je vais commencer par faire un snapshoot alors déja 😉 

 

 

 

par contre toujours le même soucis de -f install : 

 

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cloud-init : Depends: python-boto (>= 2.3) but it is not installed
 mount : Depends: util-linux (>= 2.29.2-3~) but 2.25.2-6 is installed
 openssh-sftp-server : Depends: openssh-client (= 1:6.7p1-5+deb8u8) but 1:8.4p1-5 is installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u13) but 247.3-6 is installed
           Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.

 

Link to comment
Share on other sites

en même temps, on te refile un truc qui n'a pas été mis à jour depuis 6 ans... pas étonnant que tu galères!

je pense que la première chose à faire est de se remettre en jessie, résoudre les problèmes de dépendances (réinstaller cloud-init, mount, openssh-sftp-server et systemd dans les versions attendues) refaire un full-upgrade histoire d'être sûr que tout est bon puis essayer d'upgrader de version vers buster, en récupérant un sources.list pour cette version.

une fois l'upgrade vers buster effectuée, tu pourras récupérer le sources.list de bullseye et tenter la migration.

 

Edited by Minikea
Link to comment
Share on other sites

Le problème c'est que ca tourne en rond.

 

Pour installer cloud-init il me demande boto, pour installer boto, il me demande a nouveau de mettre a jour toutes les dépendances.

 

Je ne sais plus quoi faire la.

 

Une âme charitable pour m'aider (rien de spécial sur le serveur c'est une vitrine du site public), des snapshots sont réalisés, je pourrais presque créer un sudo a qui veut bien m'aider ^^.

Edited by ViriisXP
Link to comment
Share on other sites

Comme dit plus haut il ne faut jamais sauter les versions en cas d'upgrade sinon cela casse tout. Il existe des guides pour chaque mise à jour qu'il est préférable de suivre :
https://www.debian.org/releases/stretch/amd64/release-notes/ch-upgrading.fr.html
https://www.debian.org/releases/buster/amd64/release-notes/ch-upgrading.fr.html
https://www.debian.org/releases/stable/amd64/release-notes/ch-upgrading.fr.html
(la logique est la même avec quelques variantes donc jessie -> stretch devrait de durer plus longtemps que les suivantes)

Vu a quel point tout est cassé le plus important est de faire des sauvegardes des sites, bases de données et tout autre données qui serait présente. Le plus simple serait de formater la VM (ou en prendre une nouvelle) et tout réinstaller.

Je ne connais pas cloud-init mais a ce que j'ai compris cloud-init c'est pour faire la configuration initiale de la VM (sans certitude). Si c'est le cas pas besoin de le garder, au pire tu pourra réinstaller le paquet après (mais je doute même que ce soit utile). Par contre pour SSH, mount et systemd c'est bien plus gênant.

Aussi chez OVH il doit normalement y avoir un mode rescue qui permet d'accéder aux données et éventuellement faire un chroot pour modifier un système cassé depuis le système de secours. Il doit aussi y avoir un accès console/KVM au cas où SSH serait hors service. Après cela fait longtemps que je n'ai pas utilisé leurs services donc je ne peux être sûr de rien.

Link to comment
Share on other sites

Il y a 2 heures, RaphAstronome a dit :

Comme dit plus haut il ne faut jamais sauter les versions en cas d'upgrade sinon cela casse tout. Il existe des guides pour chaque mise à jour qu'il est préférable de suivre :
https://www.debian.org/releases/stretch/amd64/release-notes/ch-upgrading.fr.html
https://www.debian.org/releases/buster/amd64/release-notes/ch-upgrading.fr.html
https://www.debian.org/releases/stable/amd64/release-notes/ch-upgrading.fr.html
(la logique est la même avec quelques variantes donc jessie -> stretch devrait de durer plus longtemps que les suivantes)

Vu a quel point tout est cassé le plus important est de faire des sauvegardes des sites, bases de données et tout autre données qui serait présente. Le plus simple serait de formater la VM (ou en prendre une nouvelle) et tout réinstaller.

Je ne connais pas cloud-init mais a ce que j'ai compris cloud-init c'est pour faire la configuration initiale de la VM (sans certitude). Si c'est le cas pas besoin de le garder, au pire tu pourra réinstaller le paquet après (mais je doute même que ce soit utile). Par contre pour SSH, mount et systemd c'est bien plus gênant.

Aussi chez OVH il doit normalement y avoir un mode rescue qui permet d'accéder aux données et éventuellement faire un chroot pour modifier un système cassé depuis le système de secours. Il doit aussi y avoir un accès console/KVM au cas où SSH serait hors service. Après cela fait longtemps que je n'ai pas utilisé leurs services donc je ne peux être sûr de rien.

Merci mais pour moi c'est totalement du chinois. C'est pas mon domaine ce truc. 

 

Je vais le laisser ainsi, il tourne et c'est bien, on prends le risque de sa version tampis.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...