Jump to content
Edtech

Monter son propre routeur fibre OPNsense

Recommended Posts

Hello, j'arrive sur le sujet, je n'avais pas vu que tu t'étais lancé sur le sujet ...

Pas possible de mettre un SPF directement dans le boitier ? j'ai toujours un peu de mal à croire qu'il n'y a pas de baisse débit entre un ONT fibre-gigabyteEth et un SPF diretement plugué sur la CM ...

Edited by Chocobidou
Link to post
Share on other sites

Je n'ai pas essayé mais je crois que certains ont réussi. Ce qui est compliqué, c'est qu'une partie de l'accès est géré dans l'ONT (configuration de base à laquelle on n'a pas accès).

Avec l'ONT, ma connexion est à 800Mbps descendant et 300Mbps montant, je ne pense pas que je puisse avoir mieux !

Link to post
Share on other sites
Il y a 4 heures, Chocobidou a écrit :

Hello, j'arrive sur le sujet, je n'avais pas vu que tu t'étais lancé sur le sujet ...

Pas possible de mettre un SPF directement dans le boitier ? j'ai toujours un peu de mal à croire qu'il n'y a pas de baisse débit entre un ONT fibre-gigabyteEth et un SPF diretement plugué sur la CM ...

chez Orange, autant on peut sniffer le réseau entre l'ONT et le routeur pour en déduire les paramètres "maison" à mettre en place sur un routeur perso, autant entre l'ONT et le FAI, c'est un peu plus chaud et il y a aussi des réglages alakon à mettre en place.

Link to post
Share on other sites

La version v4.9.0.6 est disponible avec comme gros apport, le support  des haut débits pour les cartes SD (jusqu'à 100Mio/s).

https://pcengines.github.io/?utm_source=PC+Engines+Open+Source+Firmware+Release&utm_campaign=7eecd10286-EMAIL_CAMPAIGN_2019_05_10_09_20_COPY_03&utm_medium=email&utm_term=0_b9727cda45-7eecd10286-47182929#mr-23

Par contre, depuis la 19.1 d'OPNsense, le greffon Let's Encrypt ne fonctionne plus chez moi...

Link to post
Share on other sites

La version 19.7 d'OPNsense est disponible. Comme toujours, la mise à jour se fait en deux fois, une première légère qui permet ensuite de débloquer volontairement la mise à jour vers la version suivante.

De mon côté, la mise à jour a eu lieu sans problème, et (à confirmer), au reboot j'avais toujours mon IPv6 alors que je la perds à chaque fois et dois réenregistrer les paramètres (sans les modifier) de l'interface WAN pour qu'elle revienne.

https://opnsense.org/opnsense-19-7-jazzy-jaguar-released/

Link to post
Share on other sites

La seule différence que je vois, c'est le EOL (mais je ne sais pas ce que ça veut dire).

J'ai juste testé une fois le VPN, ça fonctionnait très bien.

En fait, pendant longtemps je n'ai pas payé (fibre), puis j'ai déménagé et suis repassé à l'ADSL quelques temps, je ne payais toujours pas. Mais depuis que je suis repassé à al fibre, il faut que je gueule pour qu'ils me remboursent, et chaque fois ils me promettent que ça sera bien déduit dorénavant, mais au final, ça ne l'ai pas.

Link to post
Share on other sites

Bonjour,

Actuellement je possède un firewall Sophs Utm, mais celui-ci ne gère pas les optoins DHCP sur le WAN, donc je souhaite migrer vers Opnsense.

J’ai fais l'acquisition un Shuttle de cette année avec 2 ports Ethernet et j’ai installé Opnsense 19.7 ce week end.

J’ai suivi la configuration proposée mais cela ne fonctionne pas chez moi ; je ne récupère pas d’adresse IP sur ma patte Wan.

Pour information, j'ai testé les  2 ports Ethernet sur un switch et ils sont bien Up au sein d'Opnsense.

Vous trouverez ci-dessous ma configuration.

Vlan :

<image.png.72c8b12ac9e0c64f335ae26650201400.png>

Assignation

<image.png.fbaf2f00910cea3dd0decf46f8f5ba82.png>

Wan :

<image.png.225f20aed904863adf8320b5a348253e.png>

<image.png.fa1208569fd479c6c22d495a3789b642.png>

<image.png.2770ed338122312737fbda96881d8380.png>

Send Options : dhcp-class-identifier “sagem”, user-class "+FSVDSL_livebox.Internet.softathome.Livebox4", option-90 00:00:00:00:00:00:00:00:00:00:00:1a:09:00:00:05:58:01:03:41:01:0d:66:74:69:2F:66:74:69:2f:64:70:6B:32:67:68:69

Request subnet-mask, broadcast-address, dhcp-lease-time, dhcp-renewal-time, dhcp-rebinding-time, domain-search, routers, domain-name-servers, option-90

<image.png.feefc40a6ddd46f59aa799941528cffa.png>

Send Options : ia-pd 0, raw-option 6 00:0b:00:11:00:17:00:18, raw-option 15 00:2b:46:53:56:44:53:4c:5f:6c:69:76:65:62:6f:78:2e:49:6e:74:65:72:6e:65:74:2e:73:6f:66:74:61:74:68:6f:6d:65:2e:6c:69:76:65:62:6f:78:33, raw-option 16 00:00:04:0e:00:05:73:61:67:65:6d, raw-option 11 00:00:00:00:00:00:00:00:00:00:00:1a:09:00:00:05:58:01:03:41:01:0d:66:74:69:2f:66:74:69:2f:64:70:6B:32:67:68:69

<image.png.a149b09136c33a5f9dcdf4f61e86d911.png>

Dans Prefix Interface, il est indiqué de saisir 0 comme Prefix Interface Site-Level Aggregation Identifier et 8 comme Site-Level Aggregation Length.

Cependant, je n’ai que Prefix Interface Site-Level Aggregation Length.

<image.png.6cfac7ad54b5270ebe07701f18485cd7.png>

<image.png.cc4a13f69299b6a709be768a6b51b4c2.png>

Nulle part je n'ai indiqué le mot de passe, est-ce normal ?

Auriez-vous une idée svp J ?

Bonn journée,

Kirky

Link to post
Share on other sites

Je viens de refaire ma configuration de 0 et tu peux simplement laisser tomber les paramètres qui n'existent plus, ça fonctionne. Je n'ai pas eu besoin par contre des paramètres que tu as ajouté.

Link to post
Share on other sites

PC Engines a mis à jour son firmware pour rester compatible avec les dernière version de Coreboot, mise à jour conseillée !

De mon côté, j'ai complété une partie du tutoriel pour la création du bridge et la configuration du par-feu.

Link to post
Share on other sites

Bonjour à tous,

Je suis le sujet depuis un petit moment et j'ai bien envie de me monter un petit APU2 moi aussi.

En plus, les devs de coreboot ont l'air réactifs, ça fait plaisir.

 

J'ai une petite question : quel est le débit maximal que les APU2 peuvent supporter ? 1gbps ça passe correctement ?

Merci des infos 🙂

Edited by rodgers-95
Link to post
Share on other sites

1Gbps sans problème, c'est ce que j'ai. Je ne sais pas s'ils font de nouveaux modèles pour des débits plus élevés.

 Après, ils recommandent si on a beaucoup de matériels connecté, d'utiliser des switchs externes plutôt que de tout brancher directement au routeur.

OPNsense donne le matériel requis selon ce qu'on veut en faire https://wiki.opnsense.org/manual/hardware.html

Link to post
Share on other sites
On 30/12/2019 at 15:46, KirkyJamesVador a écrit :

J’ai fais l'acquisition un Shuttle de cette année avec 2 ports Ethernet et j’ai installé Opnsense 19.7 ce week end.

Bonjour quel modèle de Shuttle as tu pris ?

je pense moi aussi monter un pfsense ou opensense pour remplacer mon USG UniFi qui rame.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...