Jump to content

Linux et multimedia


Recommended Posts

La discussion ayant dévié quelque peu, je me permets de faire un centralisation HTPC plus générale.

Message d'origine (résolu):

Salut à tous.

Bon, j'arrive pas à faire fonctionner mon pc en 1280*720 avec mon projecteur. J'arrive max à une résolution de 824*xx .. je ne sais plus exactement.

68

Alors j'ai installé les drivers proprios, et j'arrive à une résolution de 1024x768 ... mais c'est toujours pas ça.

Mon matos : c'est un pc récupéré Fujitsu-Siemens, avec une carte mère micro-atx avec VGA, et une carte graphique 9600pro avec sortie VGA et DVI. Je fais passer le signal en numérique avec une prise DVI-HDMI.

Quand j'essaie de reconfigurer X, il ne me propose même pas la résolution 1280x720... je sais pas quoi penser. Mon matos est trop vieux ? Linux est incapable d'afficher ça ?

Autre chose : l'affichage en 1024 avec les drivers ATI est très mauvais : il "clignote"...

Link to comment
Share on other sites

:D

Ça fait un mois que je cherche, j'ai pensé au trucs cons je crois... j'ai même redémarré le pc, j'ai branché un autre écran (et donc en dualscreen), j'ai tenté du dual screen, mais j'ai jamais réussi à afficher cette résolution...

D'ailleurs hier j'ai découvert que mon projo était incapable d'afficher le splash d'Ubuntu, mais par contre était capable d'afficher le mode texte... mais ça prend pas toute la place, ça prend que la moitié et sur l'autre moitié y'a des traits verts et roses... bneu.

Link to comment
Share on other sites

L'écran principal est le projecteur. L'autre petit écran fait du 1024x768

J'ai une terrible envie de descendre mon pc et tester avec le 7800GT ^^

Là j'ai un affichage en 1024, mais l'image n'est pas remplie. Et la police est minuscule. Et le clavier n'est plus reconnu. Sans clavier et sans pouvoir lire ce qui est écrit, j'peux pas faire grand chose. Même pas installer de serveur ssh pour me connecter depuis un autre poste... /me ouain. :roll:

C'est bizarre ce que tu dis quand meme, parce que la 9600pro est sensée pouvoir afficher du 1600x1200 et même plus non ? en tout cas le 1280x1024 fonctionnait très bien chez moi...

Bon, je descend la tour. J'ai toujours le lappy :mdr:

_________

EDIT:

J'ai testé avec mon fixe, sa carte mère pas-noname et sa carte graphique nvidia. Mais putain, c'est magnifique. Je branche en DVI, l'image apparaît du premier coup, bon, elle est en 1280x1024 comme je l'avais configuré avec mon écran, mais l'image est belle et nette...

Bref, soit c'est ATI qui pue, soit c'est la carte qui est trop vieille.

Deuxième chose qui pue, c'est ce clavier usb Logitech de médeu qui fonctionne pas avant le lancement de Linux... j'imagine que ça doit être le bios qui est trop vieux pour reconnaître un clavier usb... bneuh ?

Finalement je pense que je vais m'acheter une config digne de ce nom si c'est pas possible autrement.. ça permettra également de pouvoir jouir par la suite de la HD, et qui sait, je m'offrirais peut-être un lecteur hd-dvd ou blu-ray si les dev nous sortent un bon truc :)

Autre chose soit dit en passant : ça serait bien qu'AMD bouge son cul au niveau des specs, moi si j'veux m'acheter une carte graphique, c'est ATI avec specs, ou nvidia sans.

Toi, ô direction d'ATI/AMD si tu me lis, GROUILLE TOI :mdr::francais:

Link to comment
Share on other sites

Deuxième chose qui pue, c'est ce clavier usb Logitech de médeu qui fonctionne pas avant le lancement de Linux... j'imagine que ça doit être le bios qui est trop vieux pour reconnaître un clavier usb... bneuh ?

D'habitude y'a une options dans le buis pour activer la compatibilité (avec "usb keyboard" et "usb mouse")

Moi j'ai une carte de 2001 et ça y est :zarb:

Link to comment
Share on other sites

Ouaip merci, je verrais ça ce soir :up:

Mais c'est quand même bizarre, même si c'est pas vraiment la bonne catégorie : le pc "pourri" n'affiche rien sauf des traits verts et roses jusqu'au démarrage de GDM. C'est bizarre quand même non?

Avec mon pc l'affichage est nickel dès que j'appuie sur le bouton...

Link to comment
Share on other sites

Tu passes par quoi comme entrée sur ton videoproj (j'imagine que c'est ça que tu veux avoir en 1280x720)?

En VGA ou YUV (avec adaptateur vers VGA ou DVI analogique), en effet, ce serait bizarre...

En DVI/HDMI, c'est a priori normal de l'expérience que j'en ai eu (vu que seuls les modelines idoines peuvent activer l'affichage)...

En S-video/composite, en effet, ça va être la merde... c'est le truc chiant qui n'est pas supporté par les drivers libres (enfin si, mais aléatoirement, et en patchant le noyau dans son coin... donc bof)... auquel cas, la solution est de passer par un scaler externe à partir d'une sortie VGA (là, ça marche)... m'enfin, de toute façon, ce genre de connectique n'accepte pas de passer du 720p, il me semble...

Edit : en relisant le début du topic, c'est DVI->HDMI... chez moi, ça fait la même chose (enfin écran noir, mais bon) jusqu'à ce que le bon modeline soit chargé dans le xorg.conf... sur ton PC avec la nvidious, ce doit juste être le fait que la carte soit plus récente et accepte des résolutions exotiques sans trifouiler (même si ça me paraît bizarre que ça marche durant tout le boot, même si chez moi, l'écran de boot s'affiche une demi-seconde, puis écran noir jusqu'à X.org... ton écran accepte le 640x480 en HDMI? ou tu as un framebuffer et ça ne marche qu'à partir du moment où il se lance?)...

Link to comment
Share on other sites

Ah mais moi aussi javais mal compris... je pensait que tu cherchait à fair du 720p en sortie de ta CG (ça j'ai bon...) et que lorsque tu entrai dans le vidéoproj, il te mettait du 1080p en diffusion mais que tu ne pouvais pas envoyer du 1080p de ta CG directement.

Enfin maintenant tout est clair... Sauf la source de ton problème :D

Link to comment
Share on other sites

Et comment je fais pour l'activer sans clavier ? :ouioui:

(oui, je branche un autre clavier...)

Si le bios supporte l'émulation clavier usb, en général ils sont assez intelligents pour pour l'activer dans le bios, moi c'est comme ça que ça marche.

(Par contre il faut utiliser le contrôleur USB intégré à la CM, sinon c'est sûr que ça ne peut pas marcher.)

Link to comment
Share on other sites

T'inquièques, j'ai bien compris...

HS : Ton avatar, c'est la pochette d'un album du groupe Tri^d, tu connais ou c'est un hazard?

t r y ^ d, c'est, hein, et j'suis fan :)

Et comment je fais pour l'activer sans clavier ? :ouioui:

(oui, je branche un autre clavier...)

Si le bios supporte l'émulation clavier usb, en général ils sont assez intelligents pour pour l'activer dans le bios, moi c'est comme ça que ça marche.

(Par contre il faut utiliser le contrôleur USB intégré à la CM, sinon c'est sûr que ça ne peut pas marcher.)

Okay :)

Bon en fait le clavier fonctionne pas du tout, même sous Linux, j'imagine que ça vient du fait que j'ai installé le bouzin avec un autre clavier (PS2)...

Link to comment
Share on other sites

  • 2 weeks later...

j'ai un peu le même souci ( 8800gts et videoprojceteur en 1280*720.

impossible d'avoir cette résolution sous ubuntu.

impossible en plus d'installer le driver propio ( via apt ou avec le driver )

il me ma écran non trouvé.

par contre pour l'insatll de l'écran pas sur que ça veinne dde la résolution ou du videO projecteur .

il faudra que je teste avec un écran .....

Link to comment
Share on other sites

Y'a pas d'écran avec cette résolution :cartonrouge:

Sinon le projo il me le trouve (quand j'ai fait X-configure avec les drivers frglx) mais la police est minuscule... vous auriez une idée d'où ça peut venir ?

startx -- -dpi 133

pour se mettre en 133 dpi par exemple, si tu lances xorg en shell...

Sinon, si tu veux mettre ça en dur dans le xorg.conf, rajoute, dans la section monitor :

DisplaySize		 340 270

pour un écran de 340mmx270mm, par exemple (~15")

Si tu veux connaître les dimensions précises de ton écran :

xdpyinfo

ou

xrandr --query

En bi-écran, je ne connais qu'avec le driver libre : il faut aller voir du côté de mergeddpi si tu utilises mergedfb...

Link to comment
Share on other sites

Nop, en fait j'ai deux écrans lcd de quelques pouces à peine... mais bon, ils sont dans le projo on s'en fout. Y'a moyen de régler les dpi directement dans xorg.conf?

EDIT: j'ai rien dit :chinois: Merci :craint: Je pense que j'ai réglé la dimension de l'écran trop grand, (soit 2m80 sur 1m50, ce qui est la taille de l'image affichée... forcément on voit rien :dd:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...