Jump to content

[résolu]monter des DD slt pour un utilisateur


Recommended Posts

Bonjour,

Etant débutant sous linux Ubuntu 6.06, j'étais assez content de moi d'avoir réussi à monter automatiquement des DD en modifiant le fichier fstab mais voilà, ils se montent pour tous les utilisateurs.

Comment faire pour que les DD ne se montent que pour certains utilisateurs ?

Merci de vos réponses.

Link to comment
Share on other sites

Comment faire pour que les DD ne se montent que pour certains utilisateurs ?

2 solutions possibles :

soit tu veux que les disques soit monter a la volee quand un utilisateur souhaite y acceder, et ca ca se fait

avec automount, la doc est particulierement bien faite et abondante dessus.

Sinon tu veux que seules certaine personne puissent voir ces disques :

$ groupadd hdisk
$ adduser my_user hdisk

Il faut recommencer la commande adduser avec tout les nom des utilisateurs dont tu veux qu'ils accedent

au disque.

et tu ajoute l'option gid=hdisk,mode=770 a la ligne du /etc/fstab qui contient le disque dur que tu veux restreindre.

une fois les utilisateur relogger et le disque remonter avec l'option ca devrait faire ce que tu voulais.

Link to comment
Share on other sites

soit tu veux que les disques soit monter a la volee quand un utilisateur souhaite y acceder, et ca ca se fait

avec automount, la doc est particulierement bien faite et abondante dessus.

Ouais c'est pratique autofs, mais il ne me semble pas (si mes souvenirs sont bons) que tu puisse gérer les users.

Par contre avec pam-mount c'est possible. Mais c'est un petit peu plus compliqué.

Link to comment
Share on other sites

Comment faire pour que les DD ne se montent que pour certains utilisateurs ?

2 solutions possibles :

soit tu veux que les disques soit monter a la volee quand un utilisateur souhaite y acceder, et ca ca se fait

avec automount, la doc est particulierement bien faite et abondante dessus.

Sinon tu veux que seules certaine personne puissent voir ces disques :

$ groupadd hdisk
$ adduser my_user hdisk

Il faut recommencer la commande adduser avec tout les nom des utilisateurs dont tu veux qu'ils accedent

au disque.

et tu ajoute l'option gid=hdisk,mode=770 a la ligne du /etc/fstab qui contient le disque dur que tu veux restreindre.

une fois les utilisateur relogger et le disque remonter avec l'option ca devrait faire ce que tu voulais.

Alors voilà le fichier /etc/fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/hda2	   /			   ext3	defaults,errors=remount-ro 0	   1
/dev/hda5	   none			swap	sw			  0	   0
/dev/hdd		/media/cdrom0   udf,iso9660 user,noauto	 0	   0
/dev/sdb1	/media/diskH	vfat	umask=0000 0 0,gid=hdisk,mode=770
/dev/sdb2	/media/diskD	vfat	umask=0000 0 0
/dev/hda1	/media/diskG	vfat	umask=0000 0 0
/dev/sda1	/media/windowsXP	ntfs	umask=0222 0 0

mais çà ne marche pas.

J'ai créé le groupe et ajouté les utilisateurs autorisés pour le montage du DD mais il ne se monte plus (erreur).

J'ai surement du mal écrire l'option mais je ne sais pas où.

Merci de votre aide.

Link to comment
Share on other sites

Peux-tu préciser l'erreur obtenue ?

Quels sont les droits de /media/diskH ?

Voilà l'erreur:

Impossible de monter le volume selectionné

[mntent]: ligne 8 dans /etc/fstab est erroné

mount: ne peut repérer /dev/sdb1 dans etc/fstab ou /etc/mtab

Donc, je n'ai plus le DD.

Je souhaite que ce DD ne soit accessible que par certains utilisateurs (groupe hdisk).

Merci de votre aide

Link to comment
Share on other sites

/dev/sdb1 /media/diskH vfat umask=0000 0 0,gid=hdisk,mode=770

Le message est plutôt clair.

Ton fichier fstab n'est pas correct.

En effet, tes options ne sont pas placées dans la colonne des options. Tu devrais plutôt avoir :

/dev/sdb1	/media/diskH	vfat	umask=0000,gid=hdisk,mode=770 0 0

Bon courage :D

Link to comment
Share on other sites

Nouveau /etc/fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/hda2	   /			   ext3	defaults,errors=remount-ro 0	   1
/dev/hda5	   none			swap	sw			  0	   0
/dev/hdd		/media/cdrom0   udf,iso9660 user,noauto	 0	   0
/dev/sdb1	/media/diskH	vfat	umask=0000,gid=1003 0 0
/dev/sdb2	/media/diskD	vfat	umask=0000 0 0
/dev/hda1	/media/diskG	vfat	umask=0000 0 0
/dev/sda1	/media/windowsXP	ntfs	umask=0222 0 0

Mais çà ne marche pas.

Tous les utilisateurs ont accès au DD.

edit : et si je les montent sur /mnt/...., ce qui serai plus propre, je ne peux y accéder, message seul root y a accès (et seul le DD ntfs est monté).

si quelqu'un a une idée (sur /mnt/... de préférence).

C'est bon, çà marche en remplacant umask=0000 par umask=007 et en mettant 1 à la place du dernier 0 (réponse obtenu sur le forum ubuntu).

Merci à tous de votre aide.

Link to comment
Share on other sites

Voilà le nouveau fichier fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/hda2	   /			   ext3	defaults,errors=remount-ro 0	   1
/dev/hda5	   none			swap	sw			  0	   0
/dev/hdd		/media/cdrom0   udf,iso9660 user,noauto	 0	   0
/dev/sdb1	/mnt/diskH	vfat	defaults,utf8,umask=007,gid=1003	0	1
/dev/sdb2	/mnt/diskD	vfat	defaults,utf8,umask=007,gid=1003	0	1
/dev/hda1	/mnt/diskG	vfat	defaults,utf8,umask=007,gid=1003	0	1
/dev/sda1	/mnt/windowsXP	ntfs	defaults,nls=utf8,umask=007,gid=1003	0	1

Et çà marche !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...