Jump to content

[contourné] Encore une galère de drivers ATI


Recommended Posts

Salux à tous,

j'ai eu ce matin la très mauvaise idée de vouloir mettre à jour les drivers de ma CG (Radeon 9600) sur ma Suse 10.0. Ayant déjà souffert avec les drivers ATI, je savais un peu à quoi m'attendre, mais j'avais une journée à perdre :transpi: .

Donc me voilà parti, je vire les anciens drivers et je lance le script fraichement téléchargé chez ati. Je reboote gentiment, et j'arrive sur la console. Pas cooool :francais:

Après un bon moment de galère, j'isole le problème: fglrx-install.log me donne ca:

[Message] Kernel Module : Trying to install a precompiled kernel module.

[Message] Kernel Module : Precompiled kernel module version mismatched.

[Message] Kernel Module : Found kernel module build environment, generating kernel module now.

ATI module generator V 2.0

==========================

initializing...

cleaning...

assuming new VMA API since we do have kernel 2.6.x...

Assuming default VMAP API

doing Makefile based build for kernel 2.6.x and higher

make -C /lib/modules/2.6.13-15-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules

make[1]: Entering directory `/usr/src/linux-2.6.13-15-obj/i386/default'

make -C ../../../linux-2.6.13-15 O=../linux-2.6.13-15-obj/i386/default modules

CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o

/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2143: warning: 'deferred_flush' defined but not used

LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o

Building modules, stage 2.

MODPOST

Warning: could not find /lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC4.cmd for /lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC4

CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o

LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko

make[1]: Leaving directory `/usr/src/linux-2.6.13-15-obj/i386/default'

build succeeded with return value 0

duplicating results into driver repository...

done.

==============================

- recreating module dependency list

- trying a sample load of the kernel modules

failed.

[Error] Kernel Module : Failed to install compiled kernel module - please consult readme.

Je googlise là-dessus depuis midi, sans succès. Le peu de réponses que je trouve, je n'y comprends rien :non:

Si une bonne âme se sent d'humeur à m'aider, qu'elle ne se prive pas !!!!

Link to comment
Share on other sites

Voilà ce que ca donne:

fglrx: module not supported by Novell, setting U taint flag.

[fglrx] Maximum main memory to use for locked dma buffers: 929 MBytes.

ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11

[fglrx:firegl_stub_register] *ERROR* Unable to the open some already present DRM kernel module!

Bizarrement, j'aime pas trop quand je vois "ERROR" ;) Si je comprends un peu, j'ai déjà un module à un endroit nécéssaire aux drivers ati. Et en effet, lsmod | grep drm me sort:

drm 61844 2 radeon

agpgart 33096 2 drm,via_agp

(Le radeon c'est normal, je suis repassé en radeon à la place de fglrx pour pouvoir démarrer X).

Donc faudrait désactiver l'agpgart, nan ? :yes: Y'a moyen de faire ca sans recompiler le noyau (je suis pas très chaud pour ce genre de truc :fume: )

EDIT: Apparememnt il faut utiliser rmmod, mais pour agpgart il faut quitter X. Je vais essayer ca, touchons du bois :).

Link to comment
Share on other sites

Bon, on peut bien virer les modules avec rmmod, j'ai donc pu installer les drivers ati, sans messages d'erreur cette fois:

Message] Kernel Module : Trying to install a precompiled kernel module.

[Message] Kernel Module : Precompiled kernel module version mismatched.

[Message] Kernel Module : Found kernel module build environment, generating kernel module now.

ATI module generator V 2.0

==========================

initializing...

cleaning...

assuming new VMA API since we do have kernel 2.6.x...

Assuming default VMAP API

doing Makefile based build for kernel 2.6.x and higher

make -C /lib/modules/2.6.13-15.11-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules

make[1]: Entering directory `/usr/src/linux-2.6.13-15.11-obj/i386/default'

make -C ../../../linux-2.6.13-15.11 O=../linux-2.6.13-15.11-obj/i386/default modules

CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o

/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2143: warning: 'deferred_flush' defined but not used

LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o

Building modules, stage 2.

MODPOST

Warning: could not find /lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC4.cmd for /lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC4

CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o

LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko

make[1]: Leaving directory `/usr/src/linux-2.6.13-15.11-obj/i386/default'

build succeeded with return value 0

duplicating results into driver repository...

done.

==============================

- recreating module dependency list

- trying a sample load of the kernel modules

done.

Mais X ne démarre toujours pas avec les drivers fglrx ;) le module agpgart revient au démarrage, alors que ati recommande de le virer :fume: Y'a-t-il une commande pour empêcher ce module de se charger au boot ?

Link to comment
Share on other sites

ce que je vais dire ne vas pas t aider, mais en ayant vraiment marre des problemes avec les drivers ati, je viens d aller chercher une 6200 (NVIDIA) juste aujourd hui.. Ben franchement aucun regret. (j avais une ATI 9600 avant). je redecouvre mes jeux, TOUT marche maintenant et Oblivion (avec oldblivion) tourne vraiment nickel. Comme promis il y a un an j ai completement viré ati de mes machines...

C est de la pub mais vraiment ATI se fout de la gueule du monde (en tout cas des linuxiens). Leurs drivers sont vraiment a chier.

Link to comment
Share on other sites

Ca je l'ai vite compris, quelques semaines après avoir vraiment démarré sous nux. C'est clair que pour l'isntant, c'est pas la joie (c'est même plutôt le vraie m*****), et je compte bien acheter une nvidia "cheap" dès que j'aurais un peu de sous (va déjà falloir trouver un taff :craint: )

Link to comment
Share on other sites

Bon, je me suis arraché les cheveux dessus une bonne partie de la nuit, et ce matin je suis revenu à une situation presque normale: je suis revenu aux drivers 8.16.20, le module fglrx se charge bien, sax2 le reconnait, tout est ok. Sauf que... je n'ai pas d'accélération OpenGL :francais:fglrxinfo me sort un

display: :0.0 screen: 0

OpenGL vendor string: Mesa project: www.mesa3d.org

OpenGL renderer string: Mesa GLX Indirect

OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Pas coool :resolu:

A priori pourtant le dri est bien activé dans xorg.conf:

Section "Module"

Load "dri"

Load "glx"

Load "type1"

Load "extmod"

Load "dbe"

Load "freetype"

Load "v4l"

EndSection

...

Section "DRI"

Group "video"

Mode 0666

EndSection

Si quelqu'un a une idée je suis ouvert à toutes propositions :-D

Link to comment
Share on other sites

Si tu as Mesa dans fglrxinfo, c'est que les drivers ne sont pas du tout installé.

A mon humble avis, et sans être un expert linuxien, il y a plusieurs possibilités:

1. Soit il faut essayer de réinstaller avec plusieurs versions des drivers ATI

2. Soit il faut recompiler une autre version du kernel

3. Soit ta version de Xorg n'est pas compatible avec les drivers ATI (donc > à la 7.0), j'ai eu ça avec la version 7.1 sous les cooker mdv2007.

Mais je penche pour la 2, une petite compilation d'un kernel plus récent, ou le chargement des headers/sources/etc ... devrait résoudre ton problème.

C'est toujours sous une de ces 3 formes-là que j'ai pu résoudre le problème du driver qui reste sous Mesa.

Link to comment
Share on other sites

Je viens de rentrer d'une longue journée...

@meczalbert: A priori je suis sous Xorg 6.8.2, donc ca devrait coller. Je vais tenter l'aventure avec d'autres drivers, mais sans doute pas avant ce WE, faute de temps. En ce qui concerne la recompilation du kernel, j'y ai justement pensé, j'ai lu et imprimé le tuto de tuXXX à ce propos, mais ca me fait encore un peu peur ;) Mais au vu de la version annoncé sur kernel.org, je suis pas vraiment au gout du jour, va sans doute falloir que je me lance :p

Link to comment
Share on other sites

Salut, j'ai eut le même problème avec la suse 10.0.

Ma solution était donnée par

http://www.rage3d.com/board/showpost.php?p...mp;postcount=18

En gros : tapes dans une console

$ cat /proc/mtrr

si la réponse est quelque chose comme ça (size > 2000000MB)

reg00: base=0x00000000 ( 0MB), size=984064MB: write-back, count=1

Alors regarde mon post à l' adresse

http://www.pcinpact.com/forum/index.php?sh...=80182&st=0

Une autre solution est la mise à jour du noyau (pas de problème avec 2.6.16 et plus, des rpm doivent être dispo sur le net, sinon il faut le compiler soi-même)

Bonne chance.

Link to comment
Share on other sites

Je viens de faire un cat /proc/mtrr, et tout à l'air bon de ce coté là:

reg00: base=0x00000000 ( 0MB), size=1024MB: write-back, count=1

reg01: base=0xe0000000 (3584MB), size= 256MB: write-combining, count=1

reg07: base=0xf0000000 (3840MB), size= 128MB: write-combining, count=1

Donc je vais tenter une upgrade du noyau par rpm. Ce qui m'embête un chouilla, c'est que si je fait ca par un rpm, je ne peut pas choisir d'options, ca risque de faire de la crotte, nan ? Par exemple, il semble que le "Direct Rendering Support" doit être décoché à la compilation du kernel, comment faire ca si on upgrade avec un rpm ???

Bon, je vais quand même le tenter, ca coute rien :iloveyou:

Link to comment
Share on other sites

Re-salut,

bon alors si tu n'as pas de problème mtrr, as-tu bien suivi la méthode donnée dans ce tuto, par exemple?

http://wiki.alionet.org/doku.php?id=ati-driver-installer

Sauf l'étape de configuration par sax2, moi je tape juste : sax2 -r -m 0=fglrx

Sinon, sur un autre PC, une fois je n'ai pas pu installer ces drivers en passant par un rpm, j'ai du passer directement par l'installeur ati à cause d'un problème de librairie (libexpat.so.0... fourni par compat-expat1-1.95.8-6.i586.rpm par exemple). Essaies de chercher de ce côté aussi

Link to comment
Share on other sites

C'est exactement ce tuto que j'ai suivi et qui m'a permit d'avoir un X-server qui se lance avec un fglrx dans xorg.conf. Mais malgré ca, pas d'accélération 3D :mdr:

Je laisse provisoirement tomber, j'ai des trucs plus important à faire en ce moment, mais je repasse à l'attaque ce WE :smack:

Link to comment
Share on other sites

Bon, j'ai finit par résoudre le problème d'une manière assez radicale: installation de kubuntu 6.06 ;)

Drivers fglrx installés en 2 min chrono, accélération 3D qui marche au poil ;)

Je garde la suse de coté un moement, le temps de tout récupérer. Et ensuite, bye bye le caméléon :transpi:

Merci quand même à tout ceux qui se sont dévoués pour me sortir de ce bourbier. Promis, ma prochaine CG sera une nvidia :craint:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...