Jump to content

[Gentoo 2006] Problème de lancement du WM (résolu)


Recommended Posts

Bon, je commence à désespérer, alors je fais un petit topic.

Suite à un redémarrage brutal du serveur X (ctrl + alt + backspace), il est devenu impossible de lancer ICEwm (et les autres WM). Le seul qui fonctionne étant GNOME failsafe terminal.

J'ouvre mes sessions avec GDM, qui lui semble fonctionner parfaitement.

J'ai vérifié les fichiers de config de X et gdm qui ont l'air cohérents, ré-émergé GDM, une mise à jour de xorg n'a rien changé au problème.

J'ai été faire un petit tour sur la FAQ de gdm, rien trouvé non plus

Voici ce que dit l'un des logs de GDM :

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.15-gentoo-r1 i686 [ELF] 
Current Operating System: Linux tux 2.6.15-gentoo-r1 #4 SMP PREEMPT Sat Apr 29 15:40:52 CEST 2006 i686
Build Date: 29 June 2006
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 29 16:56:48 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) RADEON: No matching Device section for instance (BusID PCI:2:0:1) found
Symbol drmGetClient from module /usr/lib/modules/drivers/radeon_drv.o is unresolved!
Could not init font path element /usr/share/fonts/local/, removing from list!
AUDIT: Thu Jun 29 17:12:47 2006: 4383 X: client 2 rejected from local host
AUDIT: Thu Jun 29 17:12:47 2006: 4383 X: client 2 rejected from local host
AUDIT: Thu Jun 29 17:12:47 2006: 4383 X: client 2 rejected from local host
AUDIT: Thu Jun 29 17:12:47 2006: 4383 X: client 2 rejected from local host
AUDIT: Thu Jun 29 17:12:47 2006: 4383 X: client 2 rejected from local host
Could not init font path element /usr/share/fonts/local/, removing from list!
Could not init font path element /usr/share/fonts/local/, removing from list!
AUDIT: Thu Jun 29 17:14:49 2006: 4383 X: client 2 rejected from local host
AUDIT: Thu Jun 29 17:14:49 2006: 4383 X: client 2 rejected from local host
Could not init font path element /usr/share/fonts/local/, removing from list!
Could not init font path element /usr/share/fonts/local/, removing from list!

J'avoue avoir un peu de mal à comprendre :zarb:

Merci d'avance :oops:

EDIT : J'ai encore oublié un détail, j'ai une ATI radeon 9600pro, j'utilise le driver libre radeon (fourni avec xorg).

J'ai essayé de passer les BusID de la carte graphique en dur dans xorg.conf, avec le résultat du lspci, ça marche encore moins bien... X ne se lançait même plus.

Contenu de .xsession-errors :

/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "damien"
/etc/X11/gdm/Xsession: Beginning session setup...
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- icewm-session
icewm-session: using /home/damien/.icewm for private configuration files
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

icewmbg: Can't open display: :0. X must be running and $DISPLAY set.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

icewmtray: Impossible d'ouvrir le display :0. X doit être lancé et 
$DISPLAY doit être positionnée.
IceWM: using /home/damien/.icewm for private configuration files
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

IceWM: Impossible d'ouvrir le display :0. X doit être lancé et 
$DISPLAY doit être positionnée.

Link to comment
Share on other sites

Me revoila !

Bon, après avoir viré dans /, /home et /tmp, les fichiers commencant par .X, j'ai retesté. Aucun changement :chinois:

Ensuite, j'ai viré tous les fichiers en rapport avec x dans les répertoire susnommés, et j'ai constaté un léger changement. Au lieu de m'afficher un message d'erreur au lancement de IceWM, j'attend quelques secondes, et il retourne sous gdm.

J'ai revérifié les logs, il n'y a aucun changement

J'ajoute le contenu de /var/log/gdm/:0.log.1 :

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.15-gentoo-r1 i686 [ELF] 
Current Operating System: Linux tux 2.6.15-gentoo-r1 #4 SMP PREEMPT Sat Apr 29 15:40:52 CEST 2006 i686
Build Date: 29 June 2006
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 30 15:31:24 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) RADEON: No matching Device section for instance (BusID PCI:2:0:1) found
Symbol drmGetClient from module /usr/lib/modules/drivers/radeon_drv.o is unresolved!
Could not init font path element /usr/share/fonts/local/, removing from list!
AUDIT: Fri Jun 30 15:31:45 2006: 6421 X: client 2 rejected from local host
AUDIT: Fri Jun 30 15:31:46 2006: 6421 X: client 2 rejected from local host
AUDIT: Fri Jun 30 15:31:47 2006: 6421 X: client 2 rejected from local host
AUDIT: Fri Jun 30 15:31:47 2006: 6421 X: client 2 rejected from local host
AUDIT: Fri Jun 30 15:31:47 2006: 6421 X: client 3 rejected from local host
Could not init font path element /usr/share/fonts/local/, removing from list!

Link to comment
Share on other sites

Bon, ma Gentoo est réparée ;)

J'allais poster sur les forums de Gentoo, mais je me suis dit que je pouvais encore bricoler un peu et m'en sortir tout seul !

Après une mise à jour vers Xorg modulaire, la mise à jour des fichiers de configuration a résolu mon problème. Il devait y avoir un petit soucis dans certains scripts qui ne correspondaient pas à la version du paquet installée (je fais souvent mon etc-update quelques jours après mes updates ;) )

Voila, J'espère que ça servira à quelqu'un ! Je passe en résolu !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...