Jump to content

Mon gdm est deviendu fou !


Recommended Posts

Coucou !

Bon, woala, j'ai un piti problème.

Hier soir, plein de bonne volonté et armé d'une patience à toute épreuve, je me décide à installer et tester XLG/compiz.

On me donne donc un tuto plutot bien fait (sur Ubuntu-fr) que je m'empresse de lire et de suivre.

Ok, tout est installé, je reboot.

Je reboot...

oui oui...

Bref ! Je passerai les problèmes de démarrage après la fenêtre de connection, il a fallu corriger et désisntaller /etc/gdm/gdm.conf-custom.

Puis, après encore qques manip, tout est rentré dans l'ordre (tout viré quoi !)

Sauf !

Sauf que, quand maintenant je vais dans Système>administration>Fenêtre de connection, celle-ci s'affiche et se referme aussitot !

Sur les conseils de TuXXX et autres, on a fait une réinstallation de gdm, puis de ubuntu-desktop, mais même après un redémarrage pas mieux: la fenêtre s'ouvre et se referme aussitot :craint:

Une idée ?

D'avance merci :)

PS: du coup ça m'a refroidi niveau XGL ! Je vais m'en passer si ça fout la zone comme ça... enfin bon, pour les noobs comme moi hein :)

Link to comment
Share on other sites

Tu as désinstallé comment ?

Tu as purgé la conf ?

aptitude purge gdm
aptitude install gdm

En faisant "désinstallation complète" dans synaptic, ce qui purge la config.

Le principe c'était de récupérer le fichier gdm.conf-custom, donc y'avais pas le choix.

Ensuite puisque la désinstallation de gdm a désinstallé ubuntu-desktop, réinstaller ubuntu-desktop provoque (forcément) la réinstallation de gdm.

Link to comment
Share on other sites

moi quand j'ai installer XGL j'ai suivi ce tuto, en suivant la methode deux qui te crée une entrée special pour XGL et qui donc te laisse le choix d'avoir un gnome non XGL aussi.

seul probleme c'est que je n'ai plus les bordure de fenetre dans le gnome normal. si quelqu'un a une idée sur comment les retrouver, ca srait cool.

Link to comment
Share on other sites

Apparement la solution est sur Le Tuto d'Ubuntu-fr :

Problème de bordures pour Gnome

Il se peut que le passage à XGL / Compiz provoque la disparition des bordures sous Gnome. Pour y remédier, il faut remplacer dans Système → Préférences → Sessions → Programmes au démarrage , ce code

gnome-window-decorator

par celui ci

nohup gnome-window-decorator

De plus, des versions plus récentes de compiz corrigent d"autres absences de bordures (comme VLC ou aMule).

Si cela ne fonctionne toujours pas il peut etre aussi nescessaire de desactiver le plugin dock soit dans gconf-editor ou alors avec gset-compiz.

Link to comment
Share on other sites

En même temps, XGl ça reste du programme en développement...

Alors moi je m'étonnerais pas trop que ça segfault de temps en temps sur certaines machines avec leur matos/logiciels/distribs spécifiques.

(Ce qui ne veut pas dire que ton problème n'est pas solutionnable hein :kimouss: )

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...