Jump to content

[Debian] [Résolu] dpkg-reconfigure xserver-xorg


Recommended Posts

Hello tout le monde !

Bon bon bon, c'est les vacances, et cette année, faudrait que j'passe sous Linux (soyons fous!). Mon Windows 2000 adoré commence à se faire tout doucement vieux ... et j'ai envie de découvrir d'autres choses ...

J'essaie donc de m'installer une Debian Etch 3.1r2 (oui je sais, je ferais mieux de prendre une Ubuntu pour débuter :modoreussi: ).

Mais la j'ai un problème lorsque je souhaite configurer le serveur X. J'en avais déjà parlé hier soir sur le chat.

Après l'installation de "base" de Debian, un petit apt-get update et upgrade (et aussi un petit apt-get install udev, sinon je n'arrive plus à rebooter après avoir fait le apt-get upgrade, je ne sais pas si cela à de l'importance pour la suite !).

Ensuite, j'installe le paquet x-window-system-core, avec un apt-get install.

Il ne me pose aucune question concernant la configuration de X, à l'installation.

Je fais donc un ptit dpkg-reconfigure xserver-xorg ...

A la fin de la configuration, je ne sais pas si ça à de l'importance, le message suivant s'affiche :

xserver-xorg postinst warning: not updating /etc/X11/X; file has been customized

(Ah bon ... ?)

Ensuite, je vais voir si il a bien pris en compte mes changements, dans le fichier /etc/X11/xorg.conf (que je ne fait que visionner, je ne sauve pas !) ... Et la, non :)

Donc, quand je fais le dpkg-reconfigure, où va t'il, si il le fait, sauver ma configuration ? Bon, au pire je peux configurer à la main le /etc/X11/xorg.conf, mais bon ... C'est ptetre un peu chaud chaud. Et puis j'aimerais comprendre pourquoi il ne va pas écrire la nouvelle configuration dans ce fichier.

J'ai regardé dans le log /var/log/Xorg.0.log, il utilise bien le fichier de configuration /etc/X11/xorg.conf.

Y'a pas un log ou je peux voir les erreurs/actions générées par le dpkg-reconfigure ?

J'ai cherché sur le forum, apparement, d'autres auraient le problème, avec le passage à Xorg 7, la commande dpkg-reconfigure xserver-xorg ne modifierait plus le /etc/X11/xorg.conf

(http://www.pcinpact.com/forum/index.php?s=&showtopic=82489&view=findpost&p=1443246).

J'ai aussi été lire le tutoriel sur X réalisé par tuXXX, j'ai vu qu'il y avait des utilitaires ... je teste le X -config [/chemin_fichier_de_config]

Sans donner de chemin, il me crée un nouveau fichier de configuration, dans /root/xorg.conf.new. Il me dit qu'il ne trouve pas la souris, m'enfin, soit.

J'essaie un X -config /root/xorg.conf.new : ça plante

J'essaie un X -config /etc/X11/xorg.conf : tient ça ne plante pas ... X se lance ...

Ca, ça m'étonne ... Parce que, quand je fais startx, il va bien chercher le fichier de configuration /etc/X11/xorg.conf, et la ça plante (complètement, je dois rebooter, ALT+CTRL+Backspace ne réagit pas) ...

Si vous pouviez un peu m'aider ... Parce que la ça fait des heures que j'essaie de comprendre, et j'ai finalement l'impression que je perds plus mon temps qu'autre chose, à chercher là où je ne dois pas ...

Merci d'avance pour votre aide :)

Link to comment
Share on other sites

Qu'est-ce que tu veux modifier dans xorg.conf ?

As-tu essayé de supprimer /etc/X11/xorg.conf (en le sauvegardant bien sûr) ? Ça risque de régler ton problème en permettant à 'dpkg-reconfigure xserver-xorg' d'écrire un nouveau xorg.conf.

Si X se lance et que startx plante, il me semble qu'il n'y a pas de problème avec xorg.conf cependant. As-tu installé un gestionnaire de fenêtres (genre WindowMaker, Gnome, KDE,...) ?

Link to comment
Share on other sites

Ce que je veux modifier ... Hmm je ne sais pas encore très bien :)

Je compte m'appuyer sur le tutoriel, et puis ... On verra ce qui arrivera ... ou pas :yes:

J'ai déjà essayé en supprimer xorg.conf, et en relançant dpkg-reconfigure, mais il ne va pas le créer dans /etc/X11/ je en tout cas ...

Je n'ai pas encore installé un gestionnaire de fenêtre non ...

J'aimerais d'abord que X fonctionne avant, une chose à la fois :)

Normalement X devrait pouvoir se lancer, et ne pas planter, même si il n'y a pas de window manager.

X c'est pas la même chose que startx (qui lance X en fait ?)

Merci !

Link to comment
Share on other sites

ben startx, si tu n'as rien dans ton ~/.xinitrc, il ne va pas lancer grand chose d'autre que X... :non:

Oui, c'est bien ce que je veux pour le moment donc ?

Ne lancer que X via startx, à part qu'en tapant startx : ça plante ; et en tapant X -config /etc/X11/xorg.conf ça fonctionne ;)

Link to comment
Share on other sites

Salut

Sinon avec etch, maintenant c'est apt-get install xorg qu'il faut taper .

Ça t'installe tous, meme un peu trop mais bon cela reste pratique :) .

Apres pour avoir un kde leger, dans le cas ou tu choisi kde, il faut apt-get install kdebase kdm .

Avec ça tu as une interface graphique fonctionnelle :)

a+

Link to comment
Share on other sites

Hello tout le monde !

Merci pour vos réponses ... J'ai finalement édite /etc/X11/xorg.conf à la main ...

Et choisi de ne plus me casser la tête avec ce dpkg-reconfigure.

J'ai installé gnome-base, et j'aimerais mettre une résolution de 1280x1024,

mais Gnome ne m'autorise pas à aller plus haut que 1024x768 en 61Hz ;):transpi:

Je suis donc allé modifier le xorg.conf, rajouter dans les modes le 1280x1024,

je lui ai même mis un ptit ModeLine (bien que je ne pense pas que ce soit vraiment nécessaire ?), le module dcc se charge bien ...

Mais gnome me propose toujours le 1024x768 maximum :(

Apparemment, avec le driver vesa, il y a un hsync out of range avec le 1280x1024 ...

En plus, quand je lui donne les fréquences horizontale et verticale de l'écran, X ne veut plus se lancer ...

Le driver nv ne fonctionne pas chez moi ...

Donc, il faudrait que je teste avec le driver nvidia (et du coup apparemment faudrait que je recompile le noyau, parce que je n'arrive pas à installer le kernel-header de mon noyau, apt-get ne trouve pas ce paquet :( )

Si vous pouviez jeter un coup d'oeil, à mon fichier de configuration xorg.conf et au fichier log :mdr2:

Link to comment
Share on other sites

Bizarre que nv ne fonctionne pas, mais tu as des noyaux avec le driver propriétaire nvidia (apt-cache search kernel nvidia).

Ton écran c'est un lcd non ? (1280x1024) Si c'est le cas, 60Hz c'est très bien normalement, et il ne faut pas monter trop haut (voir la doc de ton écran).

Dans ta conf tu as :

Section "Monitor"

Identifier "Écran générique"

Option "DPMS"

HorizSync 28-51

VertRefresh 43-60

# HorizSync 30-96

# VertRefresh 50-160

"# VertRefresh 50-160" est commenté, donc c'est normal que la valeur max retenue soit 60.

édit : je sais pas si c'est orthodoxe comme méthode, mais moi je mets la plage HorizSync autorisée et je mets une valeur unique à VertRefresh qui correspond à la fréquence que je désire (dans la limites des specs de l'écran toujours).

Link to comment
Share on other sites

En fait quand je met nv comme driver, j'ai gnome qui se lance, mais y'a des trucs qui s'affichent pas, comme la souris ou certaines fenêtres :(

Mon écran est un CRT 19".

J'ai justement comment VertRefresh et HorizSync parce que X ne se lance plus avec ces 2 infos la.

J'ai donc laissé celles par défaut.

Pourrais-tu me passer le contenu de ton /etc/apt/sources.list ?

Le résultat du apt-cache search kernel nvidia ne me retourne que le paquet cpufreqd :pleure:

Merci

Link to comment
Share on other sites

Salut

Sinon truc pratique, installe xdebconfigurator .

Tu l'installe ce logiciel, tu le lance en ligne de commande et ça fait un nouveau fichier de configuration .

Par contre sauvegarde l'autre avant .

Mais avec ça, tu devrais avoir un fichier de conf qui fonctionne bien .

a+

Link to comment
Share on other sites

Bizarre que nv ne fonctionne pas, mais tu as des noyaux avec le driver propriétaire nvidia (apt-cache search kernel nvidia).

Ok, maintenant je les vois :transpi:

Apparemment, y'en a qu'un qui correspondrait à mon noyau :

nvidia-kernel-legacy-2.6.15-1-486 - NVIDIA binary kernel module for Linux 2.6.15-1-486 (legacy version)

Mais je fais quoi avec ça en fait ?

Salut

Sinon truc pratique, installe xdebconfigurator .

Tu l'installe ce logiciel, tu le lance en ligne de commande et ça fait un nouveau fichier de configuration .

Par contre sauvegarde l'autre avant .

Mais avec ça, tu devrais avoir un fichier de conf qui fonctionne bien .

a+

J'ai installé xdebconfigurator, et quand je le lance il m'affiche des trucs ...

Qui n'ont pas l'air très corrects. Par exemple, il trouve que mon écran est un 15 pouces.

Il ne trouve pas dans /usr/sbin/ les programmes suivants : ddcprobe, kudzu, detect.

xdebconfigurator me crée où le nouveau fichier ?

Apparemment pas dans /etc/X11 (même en supprimant xorg.conf).

Merci pour votre aide.

Link to comment
Share on other sites

Apparemment, y'en a qu'un qui correspondrait à mon noyau :

nvidia-kernel-legacy-2.6.15-1-486 - NVIDIA binary kernel module for Linux 2.6.15-1-486 (legacy version)

Mais je fais quoi avec ça en fait ?

apt-get install nvidia-kernel-legacy-2.6.15-1-486 (apt-get -s install nvidia-kernel-legacy-2.6.15-1-486 pour tester)

Ensuite il faut certainement éditer xorg.conf pour mettre nvidia comme driver et supprimer load glx aussi je crois : si quelqu'un qui a déjà fait la manip peut décrire l'ensemble des opérations. Y'a un readme sur le site de nvidia.

Tu remarqueras qu'il y a aussi des noyaux optimisés 686 et K7.

J'ai installé xdebconfigurator, et quand je le lance il m'affiche des trucs ...

Qui n'ont pas l'air très corrects. Par exemple, il trouve que mon écran est un 15 pouces.

Il ne trouve pas dans /usr/sbin/ les programmes suivants : ddcprobe, kudzu, detect.

apt-cache show xdebconfigurator

-> Suggests: xresprobe

apt-cache show xresprobe

-> It contains the 'ddcprobe' package ...

Link to comment
Share on other sites

Hello :)

Je viens donner des nouvelles ...

En ce qui concerne la résolution, en mode vesa, je suis finalement passé en 1280x1024.

Je ne sais pas trop si ça c'est passé en réinstallant Debian ou en commentant les lignes concernant les fréquences de l'écran.

Reste toujours le problème de la fréquence verticale qui reste à 60Hz.

J'ai donc compilé les sources du dernier noyau disponible, et installé les drivers nvidia, et ... Ca fonctionne, résolution en 1280x1024 @ 85Hz.

Si ça peut servir à quelqu'un, le lancement de X, après la modification du fichier /etc/X11/xorg.conf pour qu'il prenne en charge le driver nvidia, ne s'est pas passé correctement du premier coup. J'avais ce problème :

(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Il allait chercher au mauvais endroit certains fichiers.

Plus d'informations et la résolution sur cette page

Voilou ...

Link to comment
Share on other sites

Ouaip bin nvidia et les drivers linux y comme qui disait de la bisebrouille dans le potage ! Perso j'ai sux avec ma carte son...Mais bon now ça fonctionne nikel; mais j'ai pas eus des crasses que tu t'es prises ! Allez courage avec Debian ça fonctionne nikel ! Quand les driver et la bonne résolution fonctionne :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...