Jump to content

[RESOLU] Montage d'un raid0 avec le paquet dmraid


Recommended Posts

Bonjour,

J'aurai voulu savoir comment monté des partitions NTFS situées sur un Raid0 moitié software, moitié hardware, géré par une puce Silicon d'un Asus A7N8X-E Deluxe ?

J'ai lu sur le Net qu'il etait necessaire d'avoir le paquet "dmraid" d'installer ... j'ai donc été sur les serveurs d'APT, et j'ai installer dmraid !

J'ai ouvert une console, et en root, j'ai entré :

dmraid -ay

Et voila comment sont détectées lespartitions de mon Raid0 :

RAID set "sil_acababaaagcc" already active
RAID set "sil_acababaaagcc1" already active
RAID set "sil_acababaaagcc5" already active
RAID set "sil_acababaaagcc6" already active
RAID set "sil_acababaaagcc7" already active

J'ai donc tenté de les montées, en créant un repertoire "raid0" dans le repertoire /mnt, voila ce que sa donne :

mount /dev/mapper/sil_acababaaagcc1 /mnt/raid0/system -t ntfs

Et la, la partition est accessible via la console en root en listant les repertoires avec "ls". J'ai ensuite essayer d'éditer le fichier /etc/fstab et d'y inclure la ligne correspondant à la partition montée ci-dessus :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/hdb2	   /			   ext3	defaults,errors=remount-ro 0	   1
/dev/hdb5	   none			swap	sw			  0	   0
/dev/hdc		/media/cdrom0   udf,iso9660 user,auto  0	   0
/dev/hdb1	   /mnt/stock	  ntfs	rw,gid=500,uid=500,umask=002,auto,user 0	   0
/dev/mapper/sil_acababaaagcc1   /mnt/raid0/system	   ntfs	defaults,gid=1000,umask=002,auto,user,nouser	0	   0

Apres tout ça, j'ai rebooter la machine en pensant que les partitions de mon Raid0 allait etre montées automatiquement et accessibles une fois dans l'environnement Gnome ... mais nan ... en plus, quand je tante de listé a nouveau les fichiers contenus dans une des partitions Raid montés avant le reboot ... ben y'a pu rien, comme si la partition avait été démontée apres avoir rebooté !! :yes:

Aidez-moi s'il vous plait ! :zarb:

Merci d'avance. :chinois:

Link to comment
Share on other sites

Si je comprends bien ton histoire de semi-soft semi-hard, c'est que tu as certains disques durs branchés sur un contrôleur hardware RAID-0 et que tu as également des disques durs branchés sur le contrôleur standard IDE et/ou SCSI, puis tu veux regrouper l'array hardware avec les disques IDE/SCSI sur les contrôleurs standard pour refaire un RAID-0 software avec tous les disques ?

--------------------------------------

C'est pas un peu foireux comme plan :chinois: déjà que si un des disques plante dans le RAID, le reste est innaccessible. J'ai déjà vu des RAID 1+0 ou 5+1 qui combinait le RAID-1 (miroir) de 2 RAID-0 hardware, mais combiner 2 types de contrôleurs dont 1 est déjà un contrôleur RAID pour en faire un seul RAID-0 non.

Link to comment
Share on other sites

euh non, juste faire en sorte de voir mes partitions sur mon raid0 sous linux ^^

m'enfin en tout cas j'ai reussi (avec l'aide d'un pote), mon probleme venait du fstab qui etait mal configurer! donc maintenant mon raid est accessible sous linux !!

Link to comment
Share on other sites

Bah c'est bien ce qu'il me semblait pour le nouser et user en meme temps, mais apparement d'apres mon pote ca fonctionnait chez lui (sur un DD normal), bah ma fois c'est en faisant des erreurs qu'on ne fait plus d'erreur (phrase magnifique... )

ps : desolé pour le [resolu] je decouvre un peu le fofo ^^

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...