Jump to content

Archived

This topic is now archived and is closed to further replies.

Pepours

Vsftpd:passive mode

Recommended Posts

En me connectant en passif ça ne marche pas :

227 Entering Passive Mode (192,168,1,12,112,79)

192.168.1.12 c'est pas vraiment une adresse internet :francais:

Par contre en normal ça marche j'ai téléchargé une image png :

% md5sum Capture-1.png
bbb2b5a1aa5b75d51cb7f50a8a850833  Capture-1.png

Share this post


Link to post
Share on other sites

En me connectant en passif ça ne marche pas :

227 Entering Passive Mode (192,168,1,12,112,79)

192.168.1.12 c'est pas vraiment une adresse internet :francais:

Par contre en normal ça marche j'ai téléchargé une image png :

% md5sum Capture-1.png
bbb2b5a1aa5b75d51cb7f50a8a850833  Capture-1.png

Je change cela comment?

Share this post


Link to post
Share on other sites
Je change cela comment?

C'est marqué dans la doc :byebye:

http://download.pureftpd.org/pub/pure-ftpd/doc/README

- '-P <ip address or host name>': Force the specified IP address in reply to

a PASV/EPSV/SPSV command. If the server is behind a masquerading (NAT) box

that doesn't properly handle stateful FTP masquerading, put the ip address

of that box here. If you have a dynamic IP address, you can put the public

host name of your gateway, that will be resolved every time a new client will

connect.

Share this post


Link to post
Share on other sites

Désolé si j'ai du mal mais...

Mon ip est dynamique donc je fais:

pure-ftpd -P pep.podzone.org 

mais il me le prend pas.

Share this post


Link to post
Share on other sites
Désolé si j'ai du mal mais...

Mon ip est dynamique donc je fais:

pure-ftpd -P pep.podzone.org 

mais il me le prend pas.

Il faut que cette adresse retourne l'adresse publique (et non l'adresse du LAN comme on le voit souvent)

Share this post


Link to post
Share on other sites

Oui mais mon ip est dynamique,donc je dois bien mettre mon dyndns comme ip publique?

J'ai essayé au bout d'un moment il l'a pris si tu pouvais ressayer.

Merci de ton aide et de celle des autres aussi.

Share this post


Link to post
Share on other sites

 ftp pep.podzone.org
Connected to pep.podzone.org.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 21:37. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
Name (pep.podzone.org:root):  anonymous
230 Anonymous user logged in
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
150 Connecting to port 1683
-rwxr-xr-x	1 1001	 1001	   950067 Apr 27 18:16 Capture-1.png
-rwxr-xr-x	1 1000	 1000	  1883648 May  7 16:49 Projet pluridisciplinaire encadr??2.ppt
-rwxr-xr-x	1 1001	 1001		13973 Apr 30 11:39 av-23103.png
-rwxr-xr-x	1 1002	 1002		 3188 May  5 20:30 compteur.php
-rwxr-xr-x	1 1001	 1001	  8207328 Apr 27 20:16 firefox_1.5.dfsg-2bpo1_i386.deb
-rwxr-xr-x	1 1002	 1002		 2409 May  5 20:30 sources.list
-rwxr-xr-x	1 1001	 1001	   145129 Apr 28 10:23 t??l??chargement_xgl.png
-rwxr-xr-x	1 1002	 1002		15108 May  5 20:31 ubuntu-title.ttf
-rwxr-xr-x	1 1001	 1001	   634965 Apr 27 18:40 ubuntubyjustinp2nu.jpg
-rwxr-xr-x	1 1001	 1001	 60738974 Apr 27 20:15 xgl-demo1.xvid.avi
226-Options: -l
226 10 matches total
ftp>  get Capture-1.png
local: Capture-1.png remote: Capture-1.png
200 PORT command successful
150-Connecting to port 1785
150 927.8 kbytes to download
226-File successfully transferred
226 29.837 seconds (measured here), 31.10 Kbytes per second
950067 bytes received in 32.49 secs (28.6 kB/s)
ftp> quit
221-Goodbye. You uploaded 0 and downloaded 928 kbytes.
221 Logout.


;)

edit> ça sent le [RESOLU] à plein nez :chinois:

Share this post


Link to post
Share on other sites
:D

edit> ça sent le [RESOLU] à plein nez :zarb:

Après ça dépend si il veut avoir le mode passif qui marche ou pas, parce que :

% ftp -p pep.podzone.org

Connected to pep.podzone.org (83.196.252.35).

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

220-You are user number 1 of 50 allowed.

220-Local time is now 22:15. Server port: 21.

220 You will be disconnected after 15 minutes of inactivity.

Name (pep.podzone.org:user): anonymous

500 This security scheme is not implemented

SSL not available

230 Anonymous user logged in

Remote system type is UNIX.

Using binary mode to transfer files.

ftp> ls

227 Entering Passive Mode (192,168,1,12,73,103)

ftp: connect: Aucun chemin d'accès pour atteindre l'hôte cible

ftp> 221-Goodbye. You uploaded 0 and downloaded 0 kbytes.

221 Logout.

Share this post


Link to post
Share on other sites

Effectivement pas très concernté moi ... mais bon Shaolin Soccer vient de finir sur Arte et ça divertit toujours autant :zarb:

Share this post


Link to post
Share on other sites

Oui j'aimerai que le passif marche mais la commande que tu m'as donnée pure-ftpd -P tu met quoi apres car mon ip change.

Share this post


Link to post
Share on other sites

D'après ce que je vois, tu fais la même erreur qu'avec VSFTPD.

L'adresse que tu dois spécifier doit absolument être une adresse IP en chiffre, et doit être celle du côté Internet de ton modem DSL.

Si ton adresse IP est dynamique, ce que tu peux faire est utiliser effectivement un service comme DynDns.com ou no-ip.com pour tes clients, et toi tu dois faire un script récupérant ton adresse IP du côté Internet du modem de façon régulière (avec Cron) puis mettre à jour ton démon à chaque fois que l'adresse change !

Sinon, si tu peux utiliser le FTP en mode PORT (non-PASV), ce sera la solution la moins longue.

Share this post


Link to post
Share on other sites
D'après ce que je vois, tu fais la même erreur qu'avec VSFTPD.

L'adresse que tu dois spécifier doit absolument être une adresse IP en chiffre, et doit être celle du côté Internet de ton modem DSL.

Si ton adresse IP est dynamique, ce que tu peux faire est utiliser effectivement un service comme DynDns.com ou no-ip.com pour tes clients, et toi tu dois faire un script récupérant ton adresse IP du côté Internet du modem de façon régulière (avec Cron) puis mettre à jour ton démon à chaque fois que l'adresse change !

Sinon, si tu peux utiliser le FTP en mode PORT (non-PASV), ce sera la solution la moins longue.

Avec pure-ftpd, comme c'est écrit dans la doc, si on met une adresse DNS, elle sera résolue à chaque demande, donc c'est bon.

Par contre, il faut éviter d'avoir son adresse dans /etc/hosts, en gros il faut que "host pep.podzone.org" depuis le serveur retourne l'adresse IP internet.

Share this post


Link to post
Share on other sites

Merci de cet éclaircissement Tuxxx, je ne savais pas que Pure-FTPD le permettait. Finalement c'est intéressant comme option !

Probablement que l'adresse, si DNS dynamique doit être de type (A) pour que ça fonctionne bien et non une redirection.

Share this post


Link to post
Share on other sites

Sur ce tu n'as pas le choix, il faut que tu utilises un nom DNS dynamique avec DynDNS de type (A) ou (CNAME (pas sur)), mais pas une redirection du genre: toto.dyndns.org = 222.222.222.222:2121 ou encore toto2.dyndns.org = ftp://toto.mondomaine.com.

Ça doit vraiment être un toto3.dyndns.org = 222.222.222.222

Si tu utilises un port pour le FTP non standard (ex.: 2121), il faudra passer par la méthode-ci:

- Tu crées un nom de machine de type (A) chez DynDNS toto.dyndns.org qui sera égal à ton adresse IP.

- Tu utilises ensuite cette adresse DNS (toto.dyndns.org) dans ton pure-ftpd.conf

- Tu spécifies aux clients d'utiliser l'adresse ftp://toto.dyndns.org:2121 pour se connecter à ton serveur FTP.

Share this post


Link to post
Share on other sites

Pour forcer le mode actif j'ai fait pure-ftpd -N -S 192.168.1.12,21.

Mais pourquoi est-il si long à prendre la commande?

Share this post


Link to post
Share on other sites

×
×
  • Create New...