Jump to content

[Résolu] Problème d'install drivers NVIDIA


Recommended Posts

Bonjour à tous,

Je viens d'installer ma Ubuntu sur mon PC, et par défaut il m'a installé les drivers génériques de NVIDIA (sans openGL)

Donc, j'ai télécharger les drivers NVIDIA sur leur Site et lancer le .run avec sh NOM_DU_FICHIER.run :

Je configure le pilote puis lance l'install et ou bout de deux minutes, il m'affiche un message d'erreur :

Err => La commande 'ld' n'a pu être trouvée, vérifier que "BinUtils" est bien installé, si c'est le cas, vérifier qu'il soit bien dans le PATH User

donc binutils, je pense que c'est un package du système de base, donc je dois déjà l'avoir, non ?

Peut-être que quelqu'un à une Idée ?

P.S. : j'ai fait une recherche avant de poster ce topic, mais rien trouvé de similaire... :pleure:

Merci d'avance

Link to comment
Share on other sites

http://www.google.fr

Recherche "Ubuntu Nvidia" et tu tombes direct la dessus :

http://doc.ubuntu-fr.org/materiel/nvidia

Pas compliqué, non ? :craint:

`

Non , ca n'a pas l'air compliqué, mais je ne suis pas du tout passé par ce type d'intallation propre à la distribution, mais je vais essayer comme ça ce soir ...

Tous les moyens sont bons ... :chinois:

Merci en tout cas, je vous tiens au courant (en même temps cette méthode ne m'apprendra pas à l'installer sur n'importe quelle distribution ... :pleure: )

PS : si j'installe ces drivers avec succès et que demain je change de CG pour une autre NVIDIA (je pensais à la GEForce 6200 256Mo en AGP 8x), normalement c'est le même pilote donc il devrait démarrer tout de suite dessus (ma carte actuelle est une GeForce2 MX 200) ?

Merci d'avance

Link to comment
Share on other sites

tant que c'est exactement le même driver ('nvidia' ici), oui, ça devrait marcher. faudra juste tweaker un peu différament le xorg.conf pour être à fond ;)

Ok, merci lorinc

Je vais la chercher ce soir ma CG et de la RAM car 256 Mo c'est juste ... je vous tiens au courant :yes:

Link to comment
Share on other sites

Pour ubuntu utilise le paquet de la distribution, essaye pas le .run du site NVIDIA ca marchera pas.

Oui c'est ce que j'ai cru comprendre ;)

donc j'ai installé via le lien que m'a fourni "Minux",

mais le problème c'est qund je lance la "commande nvidia-glx-config enable", il cherche le fichier /etc/X11/xorg.conf.md5sum mais comme X11 a été installé par Ubuntu lui je l'ai pas moi ce fichier :D

J'ai vérifié s'il y avait des options sur la commande lui demandant de ne pas vérifier l'intégrité du fichier avec md5sum mais il me propose que enble ou disable ...

Je suis un peu bloqué jvais essayer de suite de retrouver ce fichier et de le copier ...

En fait, le problème est que dans /var/lib j'ai un répertoire x11 et non pas xfree86

Voici le message d'erreur :

Error: /etc/X11/xorg.conf or /var/lib/xfree86/xorg.conf.md5sum

are missing from your system. Please be sure that your xserver package is

installed correctly.

donc c'est normal qu'il ne trouve pas, comment faire pour changer le répertoire ?

Link to comment
Share on other sites

Resalut,

En fait, tu peux manuellement faire l'equivalent de la commande demandée, ouvre ton xorg.conf ("sudo gedit /etc/X11/xorg.conf"), va dans la section "Device", et en remplace "nv" (driver open source sans la 3D) par "nvidia" (driver proprio nvidia avec 3D). Une fois sauvegardé ta modif, relance X et tu devrais voir apparaitre le logo nvidia, qui indique que le driver est bien chargé. Pour t'en assurer, un petit "glxgears -printfps" te confirmera que le pilote 3D est bien présent (fais en un avant la modif, tu verra la différence comme ça :eeek2: )

Link to comment
Share on other sites

Oui, c'est ce que j'ai fait,

et ca a marcher d'ailleurs ;-)

mais finalement j'ai insallé la Elive, parce qu'avec ma mémoire en plus et ma CG, ca tourne niquel !!

A part que j'ai du rentrer les HorizSync et VertRefresh moi-même pour mon écran sinon je n'avais que du 1024x768..

Merci pour toute votre aide...

Guy

Link to comment
Share on other sites

Resalut,

En fait, tu peux manuellement faire l'equivalent de la commande demandée, ouvre ton xorg.conf ("sudo gedit /etc/X11/xorg.conf"), va dans la section "Device", et en remplace "nv" (driver open source sans la 3D) par "nvidia" (driver proprio nvidia avec 3D). Une fois sauvegardé ta modif, relance X et tu devrais voir apparaitre le logo nvidia, qui indique que le driver est bien chargé. Pour t'en assurer, un petit "glxgears -printfps" te confirmera que le pilote 3D est bien présent (fais en un avant la modif, tu verra la différence comme ça 8) )

mouais...

sur ma ubuntu64, j'ai juste installé les 3 paquets correspondant aux drivers nvidia depuis synaptic. et puis c'est fini ca marche! pas besoin de changer nvidia en nv dans les fichiers, apparemment ca c'est fait tout seul!

Link to comment
Share on other sites

Oui, généralement ça se fait tout seul, mais j'ai eu le meme pb que Guys, du coup édition manuelle du xorg.conf et ça reviens au même. En plus ça permet d'apprendre à le faire en cas de pb et de non redémarrage du serveur X :yes:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...