Jump to content

[RESOLU] Kernel Panic sur Debian après install


Recommended Posts

Salut tt le monde, et principalement les amis de la banquise,

J'ai installé avant Debian Etch (testing). Mais pour ce faire, j'avais pris quelques précautions (peut être pas les meilleures, mais bon) :

- J'ai débranché le disque dur où était installé Windows afin d'éviter toute mauvaise manipulation

- J'ai mis le disque dur où j'allais installer Debian en Master (hda donc) (précédemment en slave).

Donc tout c'est bien passé, reboot, login, etc... j'ai installé FluxBox pour voir si tout marchait. Donc jusqu'à la vous me direz : mais où est le problême ?

Eh bien il est simple :

J'ai voulu repasser sous Windows (oui je sais pas taper...), j'ai donc rebranché le disque dur équipé de Windows en master (hda), relancé, etc... enfin bref ça marchait (ce dont je ne doutais guère, mais bon on sait jamais).

Puis après j'ai voulu profiter de ma Debian. Passage dans le BIOS lui dire de boot sur le disque dur équipé de linux (hdb) mais là : Kernel Panic !

Je pense donc que le problême vient du fait que j'ai changé le status du disque dur (Master à l'install et Slave au boot) sur lequel j'ai installé Debian (passage de hda à hdb, car le kernel ne trouve pas /sbin/init.

Y a-t-il donc un moyen de booter sur hdb (disque où Debian est installé), sans avoir à tout réinstaller ? A moins que le problême ne vienne d'autre part (même si j'en doute) ?

Merci d'avance.

Link to comment
Share on other sites

Salut

En fait ton erreur viens d'une chose auquel tu n' as pas du penser .

Bon reprenons comme marche las gestions des disques durs sous linux .

rien que ça ;) .

Donc dans un pc normal on a des disque dur IDE .

On a aussi la possilité de brancher 4 peripherique IDE .

Deux master avec dessus chacun un slave .

Donc deux master et deux slave .

Linux prend en compte cela pour nomer les disques dur .

Windows lui nome les hdd par des lettres : c, d, e, g ....

Linux lui diras que le premier master s'appel : hda .

Puis la permiere partition primaire du premier master hda1

et a permiere partition primaire du premier logique hda5

Linux est un systeme de type Unix, ba oué ça certain l'on oublié, donc tout est fichier chez lui et il utilise un fichier pour se souvenir des ses partitions et a quel point de montage elles corespondent .

Car pour linux tous dossier peut avoir sa partition, il est classique de faire tois partition voir 4 .

Une pour la racine ce qui donne dans le fstab des chose comme ça :

/dev/hda1	   /			   ext3	defaults,errors=remount-ro 0	   1

Une pour usr et une pour home .

Le probleme c'est que ton linux fraichemen installer va se dire en demarrant :

Bon je vais voir mon fstab.

C'est cool, les fichiers donc j'ai besoin, dont ceux du kernel il sont sur /dev/hda1

Bah oué mais toi tu a remis le dur en slave .

Donc il sont sur /dev/hdb1, et linux ne le sais pas.

Donc kernel panic .

La solution est de booter sur un live cd, de modifier ton fichier /etc/fstab pour prendre en compte le changement .

a+

Link to comment
Share on other sites

Bon quelques nouvelles :

(j'ai fais ces modifs avant d'avoir lu le post de zoto ;) )

J'ai modifié mon lilo.conf pour qu'il boot sur hdb (donc le disque en slave), mais toujours mon joli kernel panic :

pivot_root: No such file or directory
/sbin/init/: 423: cannot open dev/console: No such file
Kernel panic - not syncing: Attempted to kill init!

P.S. : pour le faire j'avais remis le DD linux en master

J'ai essayé un live CD (un ancien Knoppix et la dernière Damn Small Linux), mais j'arrive pas à enrengistrer les fichiers (faut certainement lui donner les droits, mais je sais pas trop comment faire).

Le contenu de mon /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>	   <dump>  <pass>
proc			/proc		   proc	defaults		0	   0
/dev/hda5	   /			   ext3	defaults,errors=remount-ro 0	   1
/dev/hda7	   /home		   ext3	defaults		0	   2
/dev/hda6	   none			swap	sw			  0	   0
/dev/hdc		/media/cdrom0   udf,iso9660 ro,user,noauto  0	   0
/dev/hdd		/media/cdrom1   udf,iso9660 ro,user,noauto  0	   0
/dev/fd0		/media/floppy0  auto	rw,user,noauto  0	   0

dont je dois certainement modifier les a en b.

Voila voila, me reste plus qu'a trouver un LiveCD me permettant d'écrire ce fichiers là. Une suggestion ?

Merci d'avance.

Link to comment
Share on other sites

Euh Knoppix te permet d'écrire ces fichiers.

Par contre, il faut le faire via un "root shell" car le terminal simple utilisateur n'a pas les droits de modifier ces fichiers.

Cherche dans le menu K, cherche le lien "Root Shell" ou "Root Terminal". Une fois dans ce terminal :

# vi /mnt/hda5/etc/fstab

Tu remplaces vi par un autre éditeur de texte si tu préfères autre chose ... Là tu auras les droits d'enregistrer ton fichier.

Allez, courage ! Tu es proche de te libérer du grand méchant loup ;-) :fumer:

Link to comment
Share on other sites

J'ai fais ce que vous m'aviez dis, mais j'ai toujours mon Kernel Panic :francais: .

Je ne comprends toujours pas, j'ai modifié le lilo.conf et fstab avec les bonnes lettres, et toujours le même message d'erreur que précédemment.

SVP help me :mdr: .

Salut

A ce niveau là, desolé de te le dire mais reinstall .

cette fois çi, branche tes hdd comme il faut .

N'ais pas peur de faire des betises .

Toutes façon un windows en moins c'est toujour du bon :cartonrouge:

Voit le bon coté des choses ça fait des GO en plus pour stocker :non: .

Plus serieusement, si tu fait bien attention au partitionnement ça devrais passer :-D .

L'installeur de la debian va te demander quel HDD utiliser, tu lui indique celui que tu veux et apres c'est bon :francais:

a+

Link to comment
Share on other sites

Attention, une fois que tu as modifé le lilo.conf, il faut relancer lilo pour qu'il écrive les modifications dans le MBR.

Si tu redémarres sous Knoppix, et tu as monté ta partition système dans /mnt/debian, il va falloir que tu fasses :

# chroot /mnt/debian /sbin/lilo

Voilà, après ça, si ça fonctionne toujours pas, c'est que tu as certainement fait une erreur dans un des 2 fichiers.

Link to comment
Share on other sites

Bon je dois me débrouiller vraiment très mal, mais en tout cas avec ma Kaella Linux Live CD je n'arrive pas à executer cette commande. Il me marque que je n'ai pas le droit d'écrire sur cette partition :francais: .

Pourtant je suis bien en root...

Décidément Debian ne veut pas me faire entrer dans le monde de linux, seulement mon ancienne Mandrake.

Link to comment
Share on other sites

Pour en finir avec ma Debian :

J'ai réinstallé ce matin même, mis Grub à la place de Lilo et ça fonctionne (enfin presque) :

Il faut que je modifie le boot dans Grub à chaque démarrage. Me reste plus qu'a trouver comment enrengistrer pour qu'il prenne les modif en compte et ça sera (enfin) fini :roll: .

Voila voila.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...