Jump to content

Archived

This topic is now archived and is closed to further replies.

Minimalist

Portables sous Linux [Avancement 50%]

Recommended Posts

Tu t'en sers pour quoi, du suspend to disk ? J'étais tenté de l'installer, mais j'en vois pas l'utilité. Si tu pouvais m'éclairer sur ce point...

Si tu veux détailler un peu plus ce qui marche sur ton portable, et les composants, je pourrai t'ajouter à la liste, si ça te tente :D

ben suspend to disk permet de sauvegarder la ram sur le DD pour faire une "mise en veille prolongée"

...y'a même suspend to ram qui à l'air bien puissant (mais pas fini :up: )

Share this post


Link to post
Share on other sites

Je voyais en gros le principe, mais ce que j'aimerais comprendre, c'est l'utilité réelle de cette option. Pourquoi utiliser ça plutôt que sauvegarder ses fichiers et de quitter, vu qu'en plus Gnome replace toutes les fenètres quand on revient.

Il y a forcement une utilité, c'est peut-être génial, mais j'ai pas trouvé pourquoi. :up:

Share this post


Link to post
Share on other sites

Salut,

Sandeman, tu pourrais m'expliquer la manip que tu as utilisé pour le port pcmcia ?

Moi j'ai pas de freeze au démarrage, mais j'ai un truc appelé hw_ramdow, qui me fait une erreur d'Input/Output ...

Merci,

:D

PS : Pour Info, Dell Latitude D600 aussi :

(Pentium M 1,7 Ghz + 2 Go DDR 2100 + Radeon M9000 )

Debian / Sarge - 2.6.7-3 un peu modifié

Faut que je trouve l'option pour activer les 2 Go de mémmoire.

Et arrêter d'utiliser la méthode Debian pour recompiler un noyau (alors que je trouve cela génial :D, tant que je n'ai pas trouver pourquoi il ne reboote pas ! ( J'utilise Grub, et j'avais recompiler avec l'option --initrd ).

Sinon, l'infrarouge marche bien ?

Share this post


Link to post
Share on other sites
Faut que je trouve l'option pour activer les 2 Go de mémmoire.

Highmem (regarder dans le topic noyau dans ma signature)

(partII, processor, 18)

Share this post


Link to post
Share on other sites

Merci Tux !

Les portables vont êtres heureux ! Comme ils ont tous au moins 1 Go de mémoire et que par défault ils sont limités à 880Mo avec cette option désenclencher ^^.

Bon, faut que je me réinstalle une gentoo mais cette fois, je ne sais pas si je vais tout recompiler ^^.

Mon boss ne m'a pas vu beaucoup avancer sur mon projet depuis un petit moment (m'en fout, il est parti en vacances, et moi je suis juste embaucher pour faire mumuse sous Linux. (Tester la compatibilité avec certaines périphs, certains logiciels, notemment PostresSQL <> MS-SQL, ...).

M'enfin, j'aime bien que le travail que l'on m'a confié soit terminé :byebye:

Share this post


Link to post
Share on other sites
Bon, faut que je me réinstalle une gentoo mais cette fois, je ne sais pas si je vais tout recompiler ^^.

Stage3, c'es déjà pas mal :chinois:

Share this post


Link to post
Share on other sites

Et arrêter d'utiliser la méthode Debian pour recompiler un noyau (alors que je trouve cela génial , tant que je n'ai pas trouver pourquoi il ne reboote pas ! ( J'utilise Grub, et j'avais recompiler avec l'option --initrd ).

Tu as essayer avec make mrproper ( sauf ton .config avant ).

Sinon, tu peux regarder dans ./arch/i386/boot/ si l'image du noyau est la et de quand elle date, elle s'appelle bzImage.

Idem pour ./ il doit y avoir un System.map.

Apres, il suffit juste de les copier dans /boot et c'est parti. Ce qui est fort possible, c'est que tu aies renomme le nom des liens vers les noyaux, et du coup grub ne sait pas les retrouver....en tous cas, lilo a ce pb la...

Share this post


Link to post
Share on other sites

pour le PCMCIA, petite modif à faire :

#cat /etc/pcmcia/config.opts

.../...
include port 0x100-0x4ff,port 0xc00-0xcff
exclude port 0x4d0-0x4d7
.../..

station d'accueil : voir http://www.dell.com/downloads/emea/product...ccueil_D_fr.pdf

résultat d'un lsmod :

delpm1400-17l:~$ lsmod
Module                  Size  Used by
Win4Lin               289768  7
mki_adapter            40292  1 Win4Lin
tg3                    82436  0
snd_intel8x0           30472  1
snd_ac97_codec         67204  1 snd_intel8x0
snd_mpu401_uart         6208  1 snd_intel8x0
snd_rawmidi            20608  1 snd_mpu401_uart
uhci_hcd               30284  0
ehci_hcd               39876  0
i2c_sensor              2368  0
rtc                    10552  0

tiens deux modules USB ... huhu ...

Share this post


Link to post
Share on other sites

Pour les ceusses qui n'auraient pas utilisé grub encore, je précise que ce dernier permet de browser les répertoires, utiliser la complétion, etc. pour corriger une ligne de commande défectueuse ... grandiose :)

également de faire des tests disques, mémoire, modifier les tables de partitions, swapper les disques ...

Grub, c'est GRAND (et un peu Unified Bootloader aussi :)

en + me suis tapé un trip grave :

l'image de fond de grub est la même (en moins belle certe, 16 couleurs powa) que mon bootsplash (verbose) et mon fond d'écran de kdm, donc ... c'est BEAU : dès le boot j'ai une interface graphique homogène jusqu'à la session de login ...

Share this post


Link to post
Share on other sites

Ben oui, grub c'es génial!

En plus, je viens de voir que le grub qu'on connais ("GRUB legacy") est en train d'être remplacé par grub2...qui devrait être encore mieux...

Mais déjà, l'avantage de grub sur lilo est indéniable...pas besoin de taper "lilo", possibilité de changer la ligne de commande "on the fly", etc...

Share this post


Link to post
Share on other sites

Tiens, Sandeman, tu dois savoir ça : est-ce que Grub sait charger un linux sur une partition en raid logiciel ? Et en LVM ?

Share this post


Link to post
Share on other sites

bah je me connecte à la maison et je te dis ...

zut madame a éteint le PC

il faut que le /boot ne soit pas en RAID.

ensuite

boot=/boot/kernel/... root=/dev/md0 ... et ça roule (sur, j'ai bien dix machines comme ça sous la main, y compris celle @home)

pour les lvm ... idem /boot pas sur un lv

boot=/bot/kernel/... root=/dev/rootvg/... (là c'est plus de mémoire je n'en ai plus sous la main)

ensuite tout est une question de fstab ...

Share this post


Link to post
Share on other sites

OK, merci, mais si j'ai /boot sur le RAID ou le LVM justement ? Parce que je crois que c'est une des choses que Lilo sait faire et pas Grub. Je voulais juste une confirmation d'un spécialiste :)

A+

Gauret

Share this post


Link to post
Share on other sites

Ton topic va certainement m'intéresser fortement ( comme Elie Semoun et ses blondes a forte poitrine...rmq je ne crache pas dessus non plus :mad2: ) car je vais certainement investir dans un portable d'ici un mois ou deux. Je me tate bcp d'ailleurs quant a l'élu...

Share this post


Link to post
Share on other sites

Un PC ou n'importe ?

Parce que moi, je vais vraisemblablement me prendre un powerbook et j'en suis très impatient.

Share this post


Link to post
Share on other sites

J'hésite entre un ibook12" et un Asus ultra portable S5N.

Ca serait principalement pour faire du developpement objet ( Eclipse ) et ptet de l'admin systeme/reseau via ssh. L'ibook a des avantages, mais le S5N a l'air quand meme extra ! 1.35kg en prime, avec un Centrino 1Mo de cache... ca reste correct.

Le pb, c'est que sur l'ibook, j'ai lu sur le net que pas mal de debianneurs avait ete decue de debian ppc par rapport a la version x86, et bcp conseillent la yellow dog, une distrib basée sur debian ( y en a un max...:censored: ) mais faite pour les Apple. Et je vois difficilement autre chose que debian sur mon portable, et je me dis que la version x86 marche tres bien. Et j'ai un leger penchant pour gentoo aussi, donc, ce n'est pas impossible que je prenne l'asus et que j'installe debian ou gentoo.

Share this post


Link to post
Share on other sites
Le pb, c'est que sur l'ibook, j'ai lu sur le net que pas mal de debianneurs avait ete decue de debian ppc par rapport a la version x86, et bcp conseillent la yellow dog, une distrib basée sur debian ( y en a un max...:kimouss: ) mais faite pour les Apple.

Hmm, Yellowdog est basé sur Red Hat et marche avec des RPMs...

http://www.terrasoftsolutions.com/products/

Share this post


Link to post
Share on other sites

Merci de la precision gauret....

en fait, les seuls avis que j'ai lu sur yellow dog etait dans des forum sur des sujets debian/ibook, ou les mecs disaient en gros prends yellow dog, c'est plus simple. Et y en a un qui disait qu apt-get etait installe de base et que la distrib etait basée sur debian.... :kimouss:

Bon, comme dirait coluche* : "encore pire, et pire, c'est deja grave, ben ENCORE pire !" ²

* moi z'aussi j'aime bcp Coluche gauret...

Share this post


Link to post
Share on other sites

Tu peux rjajouter sur cette liste que je découvre aujourd'hui:

Nec versa M500

Pentium M 1,5 Ghz + 512 Mo

Mandrake community 10.1 2.6.8.1 + qemu

marche :

tout est ok.

(la ou j'ai le plus cherché c'est wifi cause smartcard d-link G650+) même si je ne fais rien d'exotique dessus:

dev eclipse et netbean

serveur J2EE, postgres, apache et ssh

client mail, dhcp, webdav etc. ...

le truc de bureau/dev simple en somme.

Share this post


Link to post
Share on other sites

Pour ta liste :

Acer Aspire 2001 WLCi

Pentium-M 1.4 GHz (banias) + 512 Mo de Ram

Radeon Mobility M9 (Mobility 9200) 64 Mo VRAM

Carte Wifi Intel Pro/Wireless Lan 2100 mini pci

Tout ça sur une gentoo avec un kernel 2.6.10, Xorg 6.8.0

Ce qui fonctionne :

- le Speedstep

- l'ACPI

- le 1280x800

- la sortie TV

- le Wifi

- l'accélération 3D (drivers proprios ATI)

- le touchpad synaptic

Ce que j'ai pas testé :

- le PCMCIA

- le lecteur de cartes

- le bi-écran

Ce qui marche pas :

- les touches "multimédia" --> son, mode "arcade", lecture/pause ... etc

Il ya peut-être d'autres choses, mais c'est ça qui me vient à l'esprit en premier :devil:

Share this post


Link to post
Share on other sites

Je viens d'essayer à l'instant.

J'ai lancé xed et pressé les touches ... que dalle :mdr:

Ca m'étonne que très moyennement, il fallait installer un programme particulier sous Windows pour les faire fonctionner :p

Faudra que je fasse encore quelques recherches pour trouver une solution. Je pensais notemment à la touche "mail" qui clignote lors de l'arrivée d'un mail ...

Plutôt sympa comme fonction ;)

Au pire si je trouve comment ça fonctionne, je peux toujours tenter de coder un truc, mais bon :p

Share this post


Link to post
Share on other sites

×
×
  • Create New...