Jump to content

Archived

This topic is now archived and is closed to further replies.

SkizoSnake

Probleme liee a la mauvaise config de Fstab

Recommended Posts

oui, mais pour y accéder, il faut savoir sur quelle partition il est, et ça c plutôt la base .... tu es sûr qu'il est sur /dev/hda4 ??

Share this post


Link to post
Share on other sites

remy.harel => j ai tester ta solution et il me met:

NFS: Can't find ext3 filesystem on dev ide0(3,4).
mount: wrong fs type, bad option, bad superblock on /dev/hda4 or too many mounted filesystems

Share this post


Link to post
Share on other sites

tu n'as pas changé la configuration de périhpériques IDE, genre en ajoutant un lecteur CD-ROM ou un disque dur ?

Share this post


Link to post
Share on other sites

ton fstab n'a rien à voir avec le fait que tu ne sais pas faire ton mount, il n'est pas appelé dans ce cas ci ...

fais ça :

cfdisk /dev/hda

une fois dans cfdisk : tu choisis print --> sectors --> tu donnes un nom au fichier

et tu postes ici le résultat

Share this post


Link to post
Share on other sites

remy.harel => j ai tester ta solution et il me met:

Ca veut donc dire que ton systeme de fichiers sur hda4 n'est pas un ext3. Donc soit tu t'es gourre de partition, soit c'est pas de l'ext3 ton fs surlequel tu as installe ton systeme...

On ne cherche pas trop loi, pour acceder a ton /, il faut le monter depuis le liveCd, sur /mnt/gentoo qui est reserve a cet effet.

Share this post


Link to post
Share on other sites

Bon voila le resultat de cfdisk:

NAME     FLAGS      PART TYPE       FS TYPE         LABEL     SIZE

hda1     Boot       Primary         NTFS            [^B]      18079.17

hda5                Logical         NTFS            [^B]      20966.24

hda3                Primary         Linux Swap                509.97

hda4                Primary         Linux                     20464.50

Share this post


Link to post
Share on other sites

tu peux essayer de remplacer ext3 par ext2, puisque c'est juste precise linux...

Share this post


Link to post
Share on other sites

tu avais bien formate ta partition au format ext3 puis installe entierement gentoo ? Depuis quelle stage ?

Share this post


Link to post
Share on other sites

avec le stage 3

.... hum !

essaies successivement :

mount -t reiserfs /dev/hda4 /mnt/gentoo

mount -t xfs /dev/hda4 /mnt/gentoo

C'est pas de l'ext2 ou ext3 ta partoche, ou alors, comme le dit fabien29200 elle est flinguee.

Share this post


Link to post
Share on other sites

Ouais donc surement flingue... sa me soul lol j ai vraiment pas de chance...

Sa arrive souvent ce genre de probleme ? (si il s agit ici d une partition corronpu)

Share this post


Link to post
Share on other sites

jamais arrive pour ma part, et des linux, je ne sais pas combien j'ai pu en installer depuis 5, mais un certain nombre tout de meme, puisque j'en installe aussi pour des potes... !

Pour moi, 95% de chances pour que ca soit toi qui ait fait le con, et 5% de chances que ca soit un pb externe. Et encore, je suis large en accordant 5% de deffaillance au systeme.

Share this post


Link to post
Share on other sites

... j'en sais rien moi... y a 1 milliard de facon de merder sous linux, notamment gentoo...

Si t'es patient et que tu attends que tuxxx reviennent de we, ils pourra ptet t'aider, mais moi, le conseil que je peux te donner, et que je te donne depuis le debut, c'est essaie d'abord une autre distrib. tu connais a peine la commande mount et tu veux installer une gentoo.. C'est delire.

Share this post


Link to post
Share on other sites

Installer une gentoo en stage 3 n'a strictement aucun interet. Et on a beau apprendre vite, linux est extrement complexe a maitriser, tu crois toujours que tu connais linux, et je t'assures qu'on est tres tres loin de connaitre bien linux. Je parle pour moi en tous cas.

Share this post


Link to post
Share on other sites

J ai pas dis le contraire :yes: je sais que je ne maitrise pas totalement linux, d ailleur loin de la... lol mais bon j ai su me debrouiller pour l installer ... donc sa ve rien dire je pense qu avec la motivation on peux tout reussir nan ? :$

Share this post


Link to post
Share on other sites

j ai su me debrouiller pour l installer ...

Sans vouloir etre mechant, non. tu as installer un stage 3 ( donc tout automatise, autant prendre debian dans ce cas ) et tu n'arrives pas a booter dessus. Pour moi, reussir une install, c'est booter sur un noyau et arriver a se logguer dessus, puis d'avoir un systeme fonctionnel, la ca marche.

donc sa ve rien dire je pense qu avec la motivation on peux tout reussir nan ? :$

Oui, mais long est le chemin qui mene le heros a sa quete.... Et surtout, il ne faut pas griller les etapes. Comme je le dis souvent, mieux vaut une bonne mandrake qu'une mauvaise debian ( ou gentoo ). Donc, tu as voulu t'obstiner, et aujourd'hui tu as un linux sur lequel tu n'arrives pas a booter et comprendre ce qui s'est passe. Du coup tu es sous windaube, pas mal ... C'est pas mechant, je veux juste te montrer que vaut mieux partir dans de bonnes conditions que de chercher a griller les etapes pour dire "j'ultise gentoo ou debian, ca pete". Plus de la moitie des debian sont configurees comme des m... donc, c'est nul. Et bien que j'adore debian et gentoo, je deconseille ces distributions a un debutant, aussi motive soit il. toutes les semaines on voit des newB sous linux et tous pensent comprendre vite et pouvoir s'adapter. Je repete, je dis ca pour ton bien, pas mechamment, moi je m'en fous, j'utilise debian et gentoo, que le monde entier ou non les utilise ne changera rien pour moi, meme si je preferais voir des linux partout. J'espere que tu comprends ce que je veux dire, sinon je dois paraitre pour un vrai c... ard. desole.

donc sa ve rien dire je pense qu avec la motivation on peux tout reussir nan ? :$

tu devrais lire le topic de fester avec sa fedora sur plib 1.6, il a ete raisonnable, c'est un tres bon exemple, pourtant, il fait preuve de bcp de motivation et evolue rapidement sous sa fedora.

Share this post


Link to post
Share on other sites

ton problème de fsck vient probablement du fait que tu l'as lancé sur tout le hda ...

tu dois le faire par partition, donc dans ton cas :

fsck.ext3 /dev/hda4

il faut que ta partition ne soit pas montée (ce qui ne sera pas un problème dans ton cas ;-)

et vu que tu ne sais même pas exactement de quel type est ta partition,il faudra essayer jusqu'à tomber sur le bon type :

fsck.ext2
fsck.reiserfs
fsck.xfs
...

sinon, recommence de 0, ça vaudra mieux à mon avis

:iloveyou:

Share this post


Link to post
Share on other sites

remy.harel- => je le prend pas mal mais bon je te trouve un peu critique nan ? d ailleur j ai deja pu booter sur la gentoo et m identifier dessus 3 fois :iloveyou: mais le prob c que lors de la quatrieme fois sa na pas marcher, je pense savoir a present d ou sa viens, auparavant j avais essayer de modif un parametre avec le logiciel explore2fs mais bon celui ci avait planter et c apres au boot suivant que s est manifester le prob... donc faute a windows et son plantage ^^

Du coup suis en train de tout reinstaller proprement et je referais plus la meme erreur :incline: et je ne suis pas retourner sous windaube si sa peu te rassurer seulement sur un des mes autres PC qui sont equipes de windows...

Sinon pour le reste je suis tout a fait d accord avec toi...

Bon je finalise mon install de la Gentoo...

Share this post


Link to post
Share on other sites

×
×
  • Create New...