Jump to content

Archived

This topic is now archived and is closed to further replies.

riska

installation sarge net

Recommended Posts

C'est encore moi, le galérien sous Debian.

Bon hier j'ai installé une woody avec succes.

mais je me suis vite rendu compte que niveau prog et noyau c'était pas le top.

J'ai donc télécharger le CD minimaliste de Sarge.

Bizzarement l'installation se fait presque plus rapidement que sous Woody.

Par contre j'ai des nouveaux problemes:

1°: comme loader on me propose juste d'installer grub, ce que j'ai fait. mais j'aimerais comprendre pourquoi il met presque 2min à se charger à chaque boot alors que lilo était instantanée....... :keskidit:

2°: grace a tasksel j'ai DL une bonne dose de packages, de quoi me faire un jolie system, mais startx ne marche pas et dpkg-reconfigure xserver-xfree86 ne résoud pas mon problème ( ça passait pourtant tout seul sur woody avec VESA). :pleure:

je vais peut etre essayé d'installer directement les drivers ATI.

au fait j'ai choisis le noyau 2.6.

sur ceux merci a tout les debianistes ( ça se dit ??) qui répondront

:chinois:

Share this post


Link to post
Share on other sites

Bon hier j'ai installé une woody avec succes.

C'etait tres bien. Il fallait telecharger l'image complete de l'iso de la sarge, apt-cdrom add de ce cd puis apt-get update && apt-get dist-upgrade.

Ou mieux, tu installes internet ( eventuellement petite mise a jour + recompil d'un noyau plus recent ) et hop, tu configures /etc/apt/sources.list et tu n'as plus qu'a mettre ta debian a jour en ligne.

L'interet d'une debian est de pouvoir facilement migrer une stable vers une testing ou une unstable. Si ton install de woody etait nickel, il fallait la laisser et la mettre a jour. Les dernieres versions des installeurs debian ne me plaisent pas trop, elles installent beaucoup de chose par defaut pour faciliter la tache de l'utilisateur, c'est nul. On se retrouve avec un systeme "pollue". Donc perso, je prefere conserver l'ancien installer debian de la woody, et configurer ce que je veux par la suite.

Pour tes drivers ati, oui, c'est evident il faut les installer. C'est le probleme des installations modernes. Il ne devrait y avoir rien, a la gentoo. Et comme ca, les utilisateurs comprendraient qu'il faut compiler un driver pour chacun des peripheriques que l'on veut employer. Sentinel a fait un excellent tutoriel pour l'installation des drivers ati pour newbie, je te le recommande.

bonne chance

Share this post


Link to post
Share on other sites

Bon j'ai remis ma woody en place.

Je ve toujours passé en Sarge, alors jai édité mon sources.list en recopiant mes urls et en changeant les "stables" en "testing".

un petit apt-get update et voila ce qui m'arrive :

hit ftp://ftp.fr.debian.org testing/contrib Release

Reading Package Lists... Error!

E: Dynamic MMap ran out of room

E: Erro occured while processing smb2www (NewVersion1)

E:Problem with Mergelist /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_testing_main_binary-i386_packages

E: The package lists or statuts file could not be parsed or opened

 

ça doit encore etre tout con mais je vois pas. :transpi:

Help me please !!!!!!!!! :chinois:

Share this post


Link to post
Share on other sites

avec ton autre post , j'ai cru comprendre que tu a une knoppix

Demarre dessus et fait

vi etc/apt/sources.list

Normalement tu doit avoir une liste complete de source (woody , sarge , testing)

soit tu t'arrange pour le sauvegarder ou tu note un exemple sur un papier pour comparer.

deb ftp://ftp2.fr.debian.org/debian/ unstable main non-free contrib

deb-src ftp://ftp2.fr.debian.org/debian/ unstable main non-free contrib

#deb ftp://ftp.fr.debian.org/debian/ unstable main non-free contrib

#deb-src ftp://ftp.fr.debian.org/debian/ unstable main non-free contrib

sa c'est pour une sid

le # sert a garder la ligne sans la prendre en compte.

Share this post


Link to post
Share on other sites
Il ne devrait y avoir rien, a la gentoo. Et comme ca, les utilisateurs comprendraient qu'il faut compiler un driver pour chacun des peripheriques que l'on veut employer.

Oué, gentoo c'est bien :francais:

(je suis pas fou, moi de dire ça sur un post debianiste :D )

Share this post


Link to post
Share on other sites

merci mais je suis pas teubé !!!!

j'ai déja testé knoppix mais le chargement de multiples modules au démarage m'a saoulé.

actuellement je suis sur une vrai debian (WOODY) et j'ai déja modifié a la main mon sources.list (je sais utiliser google contrairement à beaucoup de noob).

je sais pas si c'est moi qui ai dut mal à m'exprimer mais j'obtiens peu de réponses intéressante (désolé).

Donc j'ai bien modifié mon sources.list que voici :

deb cdrom:[Debian GNU/Linux 3.0 _Woody_ - LordSutch.com MiniCD i386 Binary-1 (20020920)]/ unstable main non-US/main

# deb http://security.debian.org/ stable/updates main

#STABLES

deb ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

deb-src ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

#TESTING

deb ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb-src ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free

deb cdrom:[Debian GNU/Linux 3.0 _Woody_ - LordSutch.com MiniCD i386 Binary-1 (20020920)]/ unstable main non-US/main

# deb http://security.debian.org/ stable/updates main

#STABLES

deb ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

deb-src ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

#TESTING

deb ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb-src ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free

j'ai aussi créer un fichier préférence :

"Package: *

Pin: release a=stable

Pin-Priority: 50

Package: *

Pin: release a=testing

Pin-Priority: 600"

et donc mon problème survient en fin de apt-get update avec le message d'erreur que j'expose dans mon quote au dessus...

j'ai essayé plusieur fois de changer les urls de mon sources.list sans succes. :francais:

Je vais cracker c'est pas loin, et j'ai pas envie de me réinstaller une Knoppix, une Debian bien propre me plairait davantage.

:D

Share this post


Link to post
Share on other sites

:yes: je crois que tu l'est un peut quand meme :mad2:

pourquoi tu a mis toute les sources (woody , sarge ) ?

fait ton choix stable ou testing mais pas les deux en meme temps

c'est a sa que sert #

et vire le deb cdrom ou tu devra a chaque fois inserrer un cd qui sert a rien

sa devrait aller mieux apres

:D

#STABLES

#deb ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

#deb-src ftp://ftp.fr.debian.org/debian/ stable main non-free contrib

#deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

#deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

#TESTING

deb ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb-src ftp://ftp.fr.debian.org/debian/ sarge main non-free contrib

deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

Share this post


Link to post
Share on other sites

oki merci

mais sur plein de site je voyais qui laissait tout les urls actifs et que à partir du preference, il installait des pack stable ou testing.

m'enfin avoue qu'il avait rien compris à ce que je demandais....

jmen vais testé ça de suite !!!

Share this post


Link to post
Share on other sites

je suis pas fou, moi de dire ça sur un post debianiste

C'est sur mon post...Tu es en terre amie ptit gars ! :francais:

Share this post


Link to post
Share on other sites

sur ceux merci a tout les debianistes

=> debianneur :francais:

m'enfin avoue qu'il avait rien compris à ce que je demandais....

C'est de moi la que tu parles ??? :(

Voici mon fichier /etc/apt/sources.list :

deb ftp://debian.via.ecp.fr/debian sid main contrib non-free

deb ftp://debian.via.ecp.fr/debian-non-US sid/non-US main contrib non-free

deb ftp://ftp.videolan.org/pub/videolan/debian sid main

Sature a 130kb/s mon 1024 freeadsl !!

Share this post


Link to post
Share on other sites

actuellement je suis sur une vrai debian (WOODY) et j'ai déja modifié a la main mon sources.list (je sais utiliser google contrairement à beaucoup de noob).

:francais::fumer:

Share this post


Link to post
Share on other sites

après une mini install de woody, je change tout les stables en testing,

puis apt-get dist-upgrade.

la mise a jour se passe s'en probleme, a part au moment du startx......

j'ai droit a un début d'interface graphique (espece de fond blanc rayé), puis zoup retour en console...

j'ai reconf xfree plusieurs fois sans résultat, alors qu'en woody ça passais niquel (en vesa).:non:

je crois que je vais etre obligé d'installer directement les drivers ati. (en passant par knoppix pour copier le rpm de ma partoche ntfs a ext3, quel bordel)

m'enfin avoue qu'il avait rien compris à ce que je demandais....

ben nan je parlais de zaverel ( qui m'a quand meme résolu mon probleme de sources.list) lorsque qu'il me parlait de knoppix alors que je disais clairement que j'installais une woody. m'enfin c'est pas bien grave .... : :yes:

Share this post


Link to post
Share on other sites
QUOTE

m'enfin avoue qu'il avait rien compris à ce que je demandais....

ben nan je parlais de zaverel ( qui m'a quand meme résolu mon probleme de sources.list) lorsque qu'il me parlait de knoppix alors que je disais clairement que j'installais une woody. m'enfin c'est pas bien grave .... :

desolé d'insister mais c'est plutot l'inverse , je te disait sa de facon a recuperer facilement un

source.list pour l'utiliser sur ta woody

avec ton autre post , j'ai cru comprendre que tu a une knoppix

Demarre dessus et fait

vi etc/apt/sources.list

Normalement tu doit avoir une liste complete de source (woody , sarge , testing)

soit tu t'arrange pour le sauvegarder ou tu note un exemple sur un papier pour comparer.

c'est plutot moi qui doit avoir du mal a me faire comprendre :non:

sinon essait sa :

en root

xdm start

ou

kdm start

(le start n'est pas obligatoire, je crois)

si sa marche pas , test :

startx , en root , mais juste pour voir si sa marche

Suivant la procedure d'installation j'ai eu le cas que l'user ne pouvait pas lancer X a la difference

du root.

Un redemmarage et la c'etait bon (pour l'user)

Share this post


Link to post
Share on other sites

ça me saoule, pas moyen d'avoir une interface graphique avec ma woody fraichement upgrader en sarge.

déprimé je me suis dit que je pouvais me réinstaller une knoppix 3.4 pour voir ( ptetre pas une bonne idée d'aiileurs) pour plus de faciliter.

comme un con j'ai modifié direct le sources.list qui m'a encore fait galerer ( apt-get update voulais pas se terminer) . j'ai fini par lui mettre juste 2 url de sid ( ben oé parce ke knoppix c un vieu mélange et je crois qu'il ne voulait pas trop que je lui mette que des urls sarge)

finalement l'update a fonctionné (heuresement que je suis aussi en 1024, sinon bonjour les heures d'attente).

suivi d'un upgrade et d'un dist upgrade ( c utile de faire les 2 ?? un ordre conseillé ??)

et me voilou sous ma knoppix sid, jve installer kopete par kpackage, et là, impossible. y me dit de faire

apt-get -f install mais ça change rien.

avec tout ça j'y passe un temps fou (en pleine période de bac c'est malin :D)

Je suis maintenant ouvert à toute proposition pour m'installer une debian propre et à jour. ( et me dite pas d'installer une mdk10)

la gentoo me semble sympa mais vu mes galere sur debian je crois que je vais encore attendre un peu.

allez @+

Share this post


Link to post
Share on other sites

recommence mais par directement d'une sarge ou d'une sid.

Pour knoppix , j'aurais tendance a dire qu'il vaut mieux desinstaller le plus de truc possible

avant de faire l'update.

Pour l'upgrade woody /sarge t'avait aussi changer le kernel ?

Share this post


Link to post
Share on other sites

alors, essayons de repondre vite fait a qq questions, le reste demain, fatigue le rem....

recommence mais par directement d'une sarge ou d'une sid.

:francais: Ca ne sert a rien. L'upgrade fonctionne tres bien, j'y ai moi meme recourru sur ma machine il y a 10j pour avoir l'ancien installeur debian ( plus soft que les nouveaux ).

Finalement l'update a fonctionné (heuresement que je suis aussi en 1024, sinon bonjour les heures d'attente).

suivi d'un upgrade et d'un dist upgrade ( c utile de faire les 2 ?? un ordre conseillé ??)

apt-get update && apt-get dist-upgrade

Avec tout ça j'y passe un temps fou (en pleine période de bac c'est malin )

C'est comme ca qu'on devient bon, les mains dans le cambouis, et apres ; :iloveyou:

Pour ton interface graphique, on fait marcher ca demain. T'en fais pas, ca va marcher. La force debian sera avec toi ! :oops:

Plus serieusement, on reprend demain matin sur ce post ce qui merde sur ton interface graphique mais elle va fonctionner. Mon ami Sentinel a ecrit le tuto pour les drivers ati et moi celui pour les Nvidia...on devrait pouvoir s'en sortir, et puis debian, je commence a connaitre un peu....

:smack::transpi:

Share this post


Link to post
Share on other sites

Pour avior une base pour ton XF86Config, tu peux déjà partir de celui de la KNOPPIX

(démarre sur le live-CD, monte ta partition linux, copie /etc/x11/XF86Config-4 chez toi...)

Tu enlèvera après ce qui est inutile (quand ça marchera...)

Sinon, l'autre moyen est d'utiliser xf86config ou bien xf86cfg ...

Une fois que ça marchera avec le driver de base (nv pour les nvidia) ... ça sera facile !!

EDIT : bon, ce sera pas nv parce que tu as une ATI ...

[troll]

Donc tu vas en chier...

[/troll]

non en fait, tu vas pas en chier ... c'est juste que t'aura des perfs de merde ( j'aurais ptet dû laisser ça dans le troll :iloveyou: )

(Je dis ça parce qu'on a installé linux chez un gars qui avait une 9700Pro, et il avait des pers pourries ... moins de 3000 à glxgears ... oui c'est pas un super test, mais bon ... en fait, c'était peut-être KDE ... oulà, un autre troll :francais: ... j'arrête là sinon ça va partir en couille et :transpi: )

Enfin bref, tout ça pour dire que les drivers ATI sont pas si durs à installer que ça ...

Et que il te faut déjà avoir une base stable (un X qui marche, quoi) pour commencer.

Share this post


Link to post
Share on other sites

=> Riska

Que donne

dpkg -l | grep xfree

dpkg -l | grep font

ls -lh /usr/src/

qu'as tu fait pour les drivers ati ? Recompiler les drivers ? autres solutions ...... Faudrait reprendre de A a Z, je vais essayer de te guider.... :iloveyou:

Share this post


Link to post
Share on other sites

bon j'ai foiré les maths :ouioui:

pour ce qui est des drivers ati, je l'ai est déja installé facilement, mais pas sur debian.

en plus d'apres le tuto de sentinel, on peut pas les installer tant qu'on a le noyau bf24 de la woody (pas de kernel source), et la mise a jour de noyau j'ai encore jamais fait.

là je me réinstalle encore une knoppix ( la derniere avec le noyau 2.4) et à la prochaine merde , je remet une woody.

j'ai pris note de tout vos conseil et je vous tiens au courant ( peut etre meme cet aprem, qui sait):-D

Share this post


Link to post
Share on other sites

:yes: Faut arreter les changements comme ca, ca ne mene a rien. tu essaies qqchose, tu cherches a comprendre comment ca, ou plutot, tu choisis qqchose, tu cherches a comlprendre comment ca marche, puis tu l'essaies....

Mais tu n'arriveras a rien et tu vas te galere a faire des reinstall comme ca a tout va !! Tu va finir par limer tes plateaux de disque dur si ca continue ! :roll: :mortdr:

Share this post


Link to post
Share on other sites

ça y est, j'ai enfin une jolie sarge exploitable.

y manque plus que les drivers ati (mais vu la qualité je sais meme pas si je vais les installer, c'est pas dit qu'il me servent).

d'ailleurs j'avais lu je ne sais plus où que ati était censer se bouger un peu plus le cul au sujet des drivers linux, pourtant pas de nouvelles version depuis un baille.

si on avait droit a qq chose de simple à installer et performant ,ça ferait des heureux je pense. :p

par contre jvai peut etre tenté une mise a jour du noyau. :mdr:

( des conseils pour noob en kernel serait bien venu d'ailleurs :roll: ).

sinon que dire à part :pleure:

:pleure: finalement, j'ai un probleme bizarre. quand je lance kde en root, j'ai du son ça marche nickel, mais des que je me log en tant que user je me prend ça:

Sound server informational message:

Error while initializing the sound driver:

device /dev/dsp can't be opened (Permission denied)

The sound server will continue, using the null output device.

Help me please !!!! :craint:

Share this post


Link to post
Share on other sites
ça y est, j'ai enfin une jolie sarge exploitable.

y manque plus que les drivers ati (mais vu la qualité je sais meme pas si je vais les installer, c'est pas dit qu'il me servent).

d'ailleurs j'avais lu je ne sais plus où que ati était censer se bouger un peu plus le cul au sujet des drivers linux, pourtant pas de nouvelles version depuis un baille.

si on avait droit a qq chose de simple à installer et performant ,ça ferait des heureux je pense. :pleure:

par contre jvai peut etre tenté une mise a jour du noyau. :craint:

( des conseils pour noob en kernel serait bien venu d'ailleurs :pleure: ).

sinon que dire à part :mdr:

=> driver ATI : le 3.9 vient de sortir (y'a pas un mois ...) et le nvidia met du temps à arriver (il vont nous sortir un 62.xx à tous les coups, donc wait ...)

Bon pour configurer ... que dire ...

make menuconfig ...

Et tu modifie ce que tu as besoin ...

tu peux mettre "M" pour faire en module ...

"N" pour les enlever du noyau (genre tout ce qui est VIA :p)

"Y" pour inclure ... (genre le support de tous tes contrôleurs et de tous les fs ...

Configure bien pour ton processeur ...

Et je te conseille de mettre "preemptible kernel"

et "Magic sys keys" (dans debugging, d'abord cocher la première option, puis ça...) : ça permet s'utiliser :

Alt+sys+s (sync : vide le cache des disque en écriture...)

Alt+sys+u (umount, ou plutôt, remount read-only ...)

Alt+sys+o (pour éteindre...)

Il suffit de faire les 3, l'un après l'autre quand ça plante méchant ... et ça permet de ne pas niquer son fs ...

Share this post


Link to post
Share on other sites

finalement, j'ai un probleme bizarre. quand je lance kde en root, j'ai du son ça marche nickel, mais des que je me log en tant que user je me prend ça:

QUOTE

Sound server informational message:

Error while initializing the sound driver:

device /dev/dsp can't be opened (Permission denied)

The sound server will continue, using the null output device.

rajoute ton user dans le groupe audio

en root

adduser toi_ton_user audio

a faire pour chaque compte (present et futur)

Share this post


Link to post
Share on other sites

Bon pour configurer ... que dire ...

make menuconfig ...

Et tu modifie ce que tu as besoin ...

configurer quoi ?? make menuconfig marche pas ( meme en root). :D

je crois que je vais devoir investir dans un gros bouquin regroupant les (trop?) nombreuses commandes parce que je m'y perd un peu quand mm.

Share this post


Link to post
Share on other sites

×
×
  • Create New...