Jump to content
Sign in to follow this  
RFN

Wifi "mobile" pour raspberry

Recommended Posts

Bonjour,

J'ai des Raspberry PI (un "1", des 2 et des 3) que j'utilise essentiellement chez moi et toujours en wifi. Ils n'ont ni clavier ni écran : je prends le contrôle à distance pour leur faire faire divers tâches : surveillance, site perso, streaming,...

Chez moi, pas de problème, j'ai déclaré mon router dans le fichier /etc/network/interfaces.

Où cela se complique, c'est quand j'ai voulu apporter l'un des Raspberry (en l’occurrence un 3 donc avec l'interface wifi intégré) en vacances avec moi dans la belle famille. Là, il y a une box wifi (SFR), un router et un répéteur. Donc selon l'endroit où je pose le raspberry, il vaut mieux se connecter sur l'un des ces éléments actifs (qui on tous un mode 2.4GHz).

Premier problème, je ne peux déclarer qu'un seul réseau dans le fichier "interfaces". J'ai essayé avec wpa_supplicant de déclarer les différents routers, en laissant la référence dans  "interfaces" vers wpa_supplicant:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Ca refuse de fonctionner : il faut impérativement que le router soit dans "interfaces". Voila le fichier wpa_supplicant:

update_config=1
ctrl_interface=DIR=/run/wpa_supplicant GROUP=netdev
network={
        ssid="RFN_2.4"
        psk="******************"
        id_str="Maison"
        priority=1
}
network={
        ssid="NEUF_B214"
        psk="*************"
        id_str="Box_SFR"
        priority=2
}
network={
        ssid="NALETTO_RPT2.4G"
        psk="*************"
        id_str="Répeteur_PHN"
        priority=3
}

Deuxième problème, je ne vois depuis le Raspberry (sous VNC avec WiCD) que la box : pas le roouter ni le répéteur. Bizarre.

Quelqu'un aurait un avis ?

Share this post


Link to post
Share on other sites

Bon, déjà j'avais un mauvais SSID dans le fichier wpa_supplicant. Une fois l'erreur corrigée, ça à l'air de fonctionner.

Reste cependant le problème de non visibilité du router et du répéteur...

Share this post


Link to post
Share on other sites

Bon ben après un jour d'essai et d'agacement, je vous livre mes résultats:

Le fonctionnement avec wpa_supplicant : erreur dans l’orthographe du SSID

Pour les SSID invisibles (router et répéteur), il faut savoir que le routeur n'avait pas de mot de passe : la mise d'un mot de passe sur le router a permis de voir le répéteur (qui lui avait un mot de passe), mais je ne voyais toujours pas le router même après des redémarrages de l'installation. Finalement, en passant le router du canal 12 au canal 10, je peux enfin le voir... Étrange n'est-ce pas ? Mais au moins ça fonctionne !

Edited by RFN

Share this post


Link to post
Share on other sites

Merci pour ton retour. Je vais regarder de plus prêt les options autour de wpa-roam.

Share this post


Link to post
Share on other sites

avec cette option il n'y a pas de réseau à preciser dans interfaces.

wpa_supplicant tourne en daemon et choisis lui-même le réseau le plus proche et/ou selon les priorités.
couplé a wpa_gui pour e desktop il est plus puissant que n'importe quel network manager

Share this post


Link to post
Share on other sites

Cela fonctionne maintenant avec wpa_supplicant mais normalement on peut définir une priorité parmi les SSID mais cela ne semble pas respecter par le daemon. Pas grave sauf que du coup j'ai un peu de mal à connaitre l'IP pour me loguer sur le Raspberry. mais bon, pas grave, je le retrouve rapidemment.

Share this post


Link to post
Share on other sites

il prend en compte les priorités mais aussi les niveaux de réception pour se connecter au meilleur. Pour contacter le pi tu peut utiliser son nom d'hote à la place de son adresse IP (à condition d'être sur le même réseau que lui)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...