Jump to content

Disque dur inutilisable suite à une sortie de veille


Recommended Posts

Bonjour à tous,

il y a quelques jours, j'ai fait sortir mon PC d'une veille système. Le PC s'est rallumé mais l'écran est resté noir, sans réaction.

J'ai appuyé sur power une première fois, mais sans succès. J'ai donc éteint violemment (en laissant le bouton appuyé)

Et depuis, mon disque dur seagate 2To fait un drôle de bruit au démarrage (un bruit de mouvement suivi d'un léger tic, tout cela 4 ou 5 fois) puis se tait totalement.

Durant le temps du bruit, l'uefi est figé puis windows démarre, mais nettement plus lentement qu'avant (mon disque système est un SSD qui marche très bien)

Le disque incriminé n'est plus reconnu ni par l'uefi ni par windows (il n'apparaît pas dans la gestion des disques)

Manifestement ça a à voir avec cette sortie de veille foireuse et je cherche à creuser la question et bien-sûr des moyens d'accéder à mes données (raah cochonnerie de monde numérique)

Le fait qu'il n'apparaisse plus du tout dans l'uefi me laisse circonspect. Je m'attendais à une panne du genre atterrissage de la tête de lecture mais je ne vois pas en quoi ça l'empêcherait d'apparaître...

J'ai 2 hypothèses principales en tête:

- saute de tension dans la carte contrôleur du disque (donc je dois chercher un disque dur similaire et échanger la carte)

- tête de lecture qui s'est mal rangée lors de l'arrêt violent, et que le disque dur n'arrive pas à parquer (problème de tête "collée" dont j'ai entendu que cela pouvait survenir), suite à quoi le DD estime qu'il est défectueux et ne répond plus à l'uefi (??)

J'ai tendance à privilégier la 2e hypothèse mais bon...

Dans ce cas, j'ai appris qu'un passage au congélo pouvait avec un peu de chance remettre certains éléments en place. Je suis sur le point de tenter cette solution, avec une bonne protection contre l'humidité (double plastique et riz sec). Certains d'entre vous ont-ils déjà été confrontés à ce genre de soucis et / ou ont déjà tenté le congélo ?

Je sais qu'il y a une polémique sur l'efficacité du truc, mais vu le nombre de personnes qui font état de succès, je me dis que ça peut se tenter... A noter que je ne cherche pas à remettre définitivement en marche mon DD, mais juste à le relancer une fois pour récupérer quelques Go de données.

 

Bref, un chaleureux remerciement à tous !

Link to comment
Share on other sites

Salut, j'ai eu le même truc il y a peu de temps. Essaye de le brancher en secondaire, à coté d'un OS sur un second dur. Si t'es comme moi, au bout d'un moment il va finir par démarrer, mais sans forcément être lisible. Après tu lui flashe le firmware. Et ça tient un peu, si c'était un ST2000DM001 va voir ici : http://knowledge.seagate.com/articles/en_US/FAQ/223651en?language=fr

Si t'as jamais flashé le firmware c'est connu. Le truc c'est de le chopper quand il repart. Le soir ou il a pété j'étais sûr que c'était naze, mais au bout de quelques heures de bidouilles pour mettre un SSD à la place, il a popé tout seul comme disque de boot (du coup erreur). C'est la que j'ai tenté le firmware.

J'ai eu le temps de copier mes données, et il est resté comme ça quelques jours, visible, lisible. Et puis bah la plus rien. C'est super bizarre.

Pour moi le coup du congel ne marche pas dans un cas de non détection.

Bonne chance !

Link to comment
Share on other sites

il y a 6 minutes, sata a dit :

Salut, j'ai eu le même truc il y a peu de temps. Essaye de le brancher en secondaire, à coté d'un OS sur un second dur. Si t'es comme moi, au bout d'un moment il va finir par démarrer, mais sans forcément être lisible. Après tu lui flashe le firmware. Et ça tient un peu, si c'était un ST2000DM001 va voir ici : http://knowledge.seagate.com/articles/en_US/FAQ/223651en?language=fr

Si t'as jamais flashé le firmware c'est connu. Le truc c'est de le chopper quand il repart. Le soir ou il a pété j'étais sûr que c'était naze, mais au bout de quelques heures de bidouilles pour mettre un SSD à la place, il a popé tout seul comme disque de boot (du coup erreur). C'est la que j'ai tenté le firmware.

J'ai eu le temps de copier mes données, et il est resté comme ça quelques jours, visible, lisible. Et puis bah la plus rien. C'est super bizarre.

Pour moi le coup du congel ne marche pas dans un cas de non détection.

Bonne chance !

Ouep, le fameux ST2000DM001 de la mort, lui-même ^^,

Effectivement je suis en firmware d'origine.

Je vais faire comme tu dis, merci beaucoup. (et croiser les doigts donc)

Mais qu'est-ce que tu appelles "en secondaire" ? Mon seagate foireux est déjà "secondaire" par rapport à mon SSD système. Donc je dois juste lancer et relancer (par exemple en hot plug) le disque, jusqu'à ce qu'il apparaisse ?

Quel genre de bruit ça faisait toi ? Pareil et tout ?

Merci à fond !

Link to comment
Share on other sites

Pour être plus précis sur le bruit, j'entends bien la rotation du disque se lancer correctement pendant quelques secondes, puis il fait son bruit foireux une dizaine de fois (une sorte de plong plong plong tic) (oui mon imitation du disque dur est exceptionnelle)

Link to comment
Share on other sites

Bon, après avoir écumé le net et constaté la détresse de beaucoup de gens au sujet de cette série de DD, j'arrive aux conclusions suivantes:

- le disque n'a probablement pas de soucis mécanique (les plateaux tournent et la tête se déplace)

- d'une certaine manière, le firmware a été corrompu et / ou la carte PCB a été endommagée lors de l'arrêt sauvage. C'est pour ça qu'il n’apparaît même plus dans l'uefi.

- dans le cas de cette série de DD, le firmware serait (en partie ?) stocké sur le disque lui-même (!!) Bravo seagate, très durable comme solution.

- du coup, changer le PCB ne résoudrait rien ?? Je me suis quand même renseigné, et j'ai trouvé le site http://www.onepcbsolution.com qui parait tout à fait sérieux et très séduisant. Ils évoquent un transfert de firmware en remplaçant par un nouveau PCB... est-ce à dire qu'ils arrivent à court-circuiter le firmware stocké sur le disque lui-même ? En tout cas, ils référencent le numéro exact de mon PCB. Est-ce que quelqu'un a déjà eu à faire à eux ?

- bref, j'avance mais j'ai plus de questions qu'au début.

- je mets du coup en attente la solution du congélo

Link to comment
Share on other sites

J'ai eu ce genre de soucis apres une coupure sauvage (Merci ErDF)

Il était pas completement mort. Une fois sur deux il ne montrait aucun soucis. Au vu du SMART apres ça, je l'ai renvoyé en garantie.

A 1 mois pres je l'avait dans l'os :transpi: 

Capture du 2016-08-06 12:52:21.png

Link to comment
Share on other sites

  • 3 weeks later...

Petit point pour ceux que ça intéresse, j'ai bien reçu le nouveau PCB de PCBsolution. Service impec, rapide, aucun problème.

Bon par contre ça n'a absolument rien changé au problème caramba.

J'ai continué à fouiner, j'ai trouvé la vidéo du bruit exact que ça fait:

 

@sata et @Krapace, est-ce que vous vous souvenez de ce bruit-là ? Moi c'est EXACTEMENT ça.

Aujourd'hui il me reste deux hypothèses à creuser qui sont régulièrement soulevées autour de ce genre de soucis et de cette série de disques, après avoir éliminé celle du PCB:

1/ bug dans le diskware (donc le bout de code stocké sur le disque lui-même) => il faut le réinitialiser par le port rs232. J'attends le petit câble pour le faire et ya plein de tuto sur l'interweb. Même si selon le modèle c'est pas toujours sûr à 100% que ce soit adapté. Mais je vais tenter la semaine prochaine (et je tiendrai au courant le thread). Ce serait lié, si j'ai compris à l'état "busy" du disque, dont il n'arrive pas à sortir. Soucis touchant plusieurs séries de seagate.

2/ un pétage mécanique (genre tête cassée) auquel cas je suis empapaouté jusqu'à l'os. Mais en secouant doucement je n'entends rien de suspect, ce qui éloigne de cette hypothèse (mais bon...) Pourtant certaines personnes semblent avoir constaté ce genre de pétage sur leur ST2000DM001. Bordel je croise les doigts pour que ce soit pas ça.

La porte des mers (oué oué seagate, prise de conscience après 20 ans) fait quand même un peu mal à l'arrière-train.

 

Link to comment
Share on other sites

J'ai eu un disque de 320 Go SATA (seagate) qui faisait ça une fois ... juste après une reconfiguration de machine ... donc j'avais fait des sauvegardes avant et (entre autre) formaté mes 2 disques avant. Aucun accès, boot interminables ... Nunux en livecd qui peinait à voir la configuration.

Mais, plutôt que de l'envoyer sans état d'âme à la poubelle ainsi qu'il le méritait, je l'ai juste ... oublié dans une boîte à chaussure avec des vieux câbles ethernet.

Deux ans après, j'ai besoin de me refaire une vielle machine de quoi tenir 6 mois en disque de boot (root et des backups), le /home utilisateur étant sur un increvable HDD ide de 120 Go acheté en 2002 (seagate aussi et qui tiens encore la route en 2016 !!!). Je l'ai retrouvé, essayé dans un boîtier externe, puis intégré comme disque maître ......... le PC a tenu 3 ans en étant utilisé par ma mère pour du surf quasiment tous les jours :D , et maintenant ce 320 Go me sert de disque de troisième backup au cas où (1 DD, puis un second DD puis un troisième pour une même info ... ce qui coûte moins de temps et de sous que des DVDs).

 

Morale ... ne jetez pas vos vieux disques cassés ... parfois un miracle se produit.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...