Jump to content

Archived

This topic is now archived and is closed to further replies.

doubleneck

M� J Manjaro bloquée

Publications recommandées

Lors de la dernière mise à jour de Manjaro, le message suivant s'affiche à la fin et annule celle-ci :

 

 

la validation de la transaction a échoué (conflit de fichiers):
stk: /usr/lib/libstk.so.4 est déjà présent dans le système de fichiers
 

Une idée qui traînerait dans le secteur ? :chinois:

Partager cette publication


Link to post
Share on other sites

Rien de mortel, à moins que les deux versions du fichier soient différentes, et risquent de poser problème. Ça apparait souvent quand on commence à faire joujou avec AUR, qui peut installer pas mal de choses qui ne sont pas prises en compte par les paquets de Manjaro.

Partager cette publication


Link to post
Share on other sites

Oui mais c'est bloquant ! je n'ai qu'une solution "valider" qui me ramène au point zéro de la mise à jour ! Sinon, je pense que je n'aurai pas fait un sujet pour si peu ! :mad2:

Je teste ce soir une solution trouvée sur manjaro.fr qui propose de renommer le fichier incriminé.

Partager cette publication


Link to post
Share on other sites

Suite à ce topic sur manjaro.fr :

 

http://www.manjaro.fr/forum/viewtopic.php?f=23&t=5041

 

pour l'instant, rien de bien interressant sinon le pacman qui tourne en continue

-> une première tentative pendant deux heures sans résultats

-> une deuxième tentative pendant un peu plus d'une heure

et ça continue de tourner...

Je vais voir avec ta commande option --force ce que je peux faire ce soir en rentrant du boulot.

Partager cette publication


Link to post
Share on other sites

Je ne sais plus quelle commande il faut passer pour savoir à quel paquet "appartient" un fichier. Ça permettrait de déterminer un éventuel conflit de paquet.

 

D'ailleurs, ça dit pas quel paquet est concerné par l'erreur ? Ce qui peut se produire aussi, c'est que c'est une "nouvelle" dépendance, hors une autre version a été installée depuis AUR. J'ai eu le tour récemment en voulant "jouer" avec les différentes versions d'Opera. J'ai tout viré/purgé avant de réinstaller pour être tranquille.

Partager cette publication


Link to post
Share on other sites

après plusieurs manips dont celle-ci (merci seboss666) 

sudo rm /var/lib/pacman/db.lck

précedé d'une commande --force... (je ne me souviens plus laquelle ayant fait ça tard hier soir !) j'ai réussi à finaliser ma màj ! ouf !

puisque la commande :

sudo mv /usr/lib/libstk.so.4 /usr/lib/libstk.so.4.old

ne donnait rien.

Merci de vos passages sur le sujet ! :chinois:

Partager cette publication


Link to post
Share on other sites

×