Jump to content

[Problème] Transmission son par HDMI - Asus Vivobook


barben360

Recommended Posts

Bonjour à tous !

J'aimerais demander votre expertise sur un problème que j'ai sur mon Asus VivoBook S551LB-CJ103H, que je n'arrive pas à résoudre après de nombreuses et longues recherches.

Cet ordinateur portable sous Windows 8.1 64 bits possède une nVidia GT 740M couplée à sa CG intégrée Intel 4400. Il est muni d'un port HDMI dont j'ignore de quelle carte il sort. Le son est géré par les pilotes Realtek High Definition Audio.

Pour regarder des films sur la télé, j'utilise donc cette sortie HDMI. Pas de problème pour faire sortir l'image, mais pour ce qui est du son, je suis obligé de redémarrer le PC pour pouvoir le transmettre par HDMI plutôt que de le laisser sur le haut-parleur du PC.

J'ai essayé plein de bidouilles (affichage des périphériques de lecture audio désactivés, débranchages-rebranchages du câble, activation, désactivation de périphériques audio...) mais rien n'y fait, impossible de voir la sortie HDMI dans les périphériques de lecture audio sans redémarrer le système.

Ma question est donc la suivante : y a-t-il une manipulation à faire pour que, lorsque je branche le câble HDMI à mon PC, le son soit automatique transmis via HDMI, ou qu'au moins ce dernier soit visible dans les périphériques de lecture audio ?

Merci d'avance pour votre précieuse aide !

Link to comment
Share on other sites

Bonjour et bienvenue sur le forum ;)

Hummm. Ca augure d'un problème de logiciel / driver.

Contournement en attendant : Si tu rajoutes un câble jack son de ton PC à ta TV en plus du câble HDMI, ça t'amène le son ?


Tu peux tenter ça :

http://webcache.googleusercontent.com/search?q=cache:NLs0G3sLcmgJ:support.asus.com/search/kdetail.aspx%3Fno%3D720295b6-3e60-f8ef-0c3f-2c221be31dc5%26t%3D2+&cd=2&hl=fr&ct=clnk&gl=fr&client=firefox-a


Il faudrait aussi comparer les services processus lancés avant sans son et après quand ça fonctionne pour voir s'il y a une différence ou vérifier les messages dans l'obs d'évènements dans les 2 cas (chercher un message lié au HDMI ou au son).

Link to comment
Share on other sites

Bonjour,

Merci pour ta réponse.

Pour ce qui est de la méthode sur le site de Asus, elle ne fonctionne pas, comme je l'ai mentionné dans mon premier message. Pour ce qui est de la prise jack, je n'ai pas essayé (étant donné que le redémarrage suffit à faire passer le son). Pour la comparaison des processus, il faut que j'essaie ! :ouioui:

Je pense qu'il pourrait s'agir du fait que le port HDMI se trouve (sûrement) sur la carte graphique nVidia, qui n'est pas celle utilisée par défaut au démarrage de l'ordinateur, et que le fait de brancher le HDMI après avoir allumé le PC ne fait balancer que l'image, les drivers Realtek "n'étant pas au courant" du branchement. J'imagine qu'en redémarrant le PC, la connexion HDMI est détectée au lancement de Windows et que la carte nVidia est alors choisie temporairement comme carte par défaut, et qu'elle gère elle-même la transmission du son par HDMI sans passer par les pilotes Realtek. Maintenant, je ne sais pas comment contourner ça...

Link to comment
Share on other sites

1/ Pour ce qui est de la prise jack, je n'ai pas essayé (étant donné que le redémarrage suffit à faire passer le son).

2/ Pour la comparaison des processus, il faut que j'essaie ! :ouioui:

1/ Mon contournement vise à ce que tu n’aies pas besoin de redémarrer ton PC. Tu installes ton PC sur la TV avec 2 câbles au lieu d'un. C'est ce que je fais chez mes parents qui sont en liaison VGA PC - TV.

2/ Si tu arrives à isoler le processus responsable, tu pourrais arriver à le démarrer par une commande .BAT par exemple (nécessite juste un double-clic sur le fichier une fois écrit), bien que je ne sois pas expert.

Link to comment
Share on other sites

  • 2 weeks later...

Bonjour,

Merci pour ta réponse.

Pour ce qui est de la méthode sur le site de Asus, elle ne fonctionne pas, comme je l'ai mentionné dans mon premier message. Pour ce qui est de la prise jack, je n'ai pas essayé (étant donné que le redémarrage suffit à faire passer le son). Pour la comparaison des processus, il faut que j'essaie ! :ouioui:

Je pense qu'il pourrait s'agir du fait que le port HDMI se trouve (sûrement) sur la carte graphique nVidia, qui n'est pas celle utilisée par défaut au démarrage de l'ordinateur, et que le fait de brancher le HDMI après avoir allumé le PC ne fait balancer que l'image, les drivers Realtek "n'étant pas au courant" du branchement. J'imagine qu'en redémarrant le PC, la connexion HDMI est détectée au lancement de Windows et que la carte nVidia est alors choisie temporairement comme carte par défaut, et qu'elle gère elle-même la transmission du son par HDMI sans passer par les pilotes Realtek. Maintenant, je ne sais pas comment contourner ça...

J'ai le problème sur le PC portable de ma fiancée, je l'ai résolu en changeant le périphérique de lecture par défaut via le composant du panneau de config "Son".

Son

L'icone qui a la coche verte est celui par défaut, pour avoir le son dans l'HDMI, je suis obligé de sélectionner le "Realtek HDMI Output" et de le mettre en périphérique par défaut avec le bouton adhoc.

Cela marchera peut être.

Link to comment
Share on other sites

Tu as essayé en virant cette merde que sont les pilotes Realtek ? Généralement Windows fait beaucoup mieux sans ces pilotes qu'avec... D'ailleurs, je ne les installe jamais !

Dans les problèmes qu'amène ce pilote : le changement automatique de volume sur changement de sortie son (qui existe depuis Vista) ne fonctionne plus si les pilotes Realtek sont installés... Ça ressemble un peu à ton problème (pas de basculement auto).

Normalement, les piloes nVidia/AMD installent leur propre pilote audio HDMI et fonctionnent très bien d'ailleurs.

Link to comment
Share on other sites

  • 2 weeks later...

Le changement de périphérique par défaut solutionne le problème dans la majorité des cas, par contre cela t'oblige à changer manuellement les paramètres à chaque fois que tu change de source. J'ai le même soucis avec mon ASUS ROG les pilotes Realtek sont une vraie merde !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...