Jump to content

Archived

This topic is now archived and is closed to further replies.

Terminou

Dur dur le passage de Win à Linux

Recommended Posts

Mon disk IDE Primaire (cavalier en mode MS) est detecté en hde avec les partions hde1,etc...

Et il y a quoi en hda et hdb? Les disques de la carte controlleur?

Ma carte controleur RAID est une carte fille sur PCI à 27Euros.....ya pas de marque particiliere mais comme mes disk sont correctement detecte, j'en conclue ke le pilote est inclue dans la distrib 9.2

Donc il reste quoi comme problème? T'arrives pas à arriver à l'ecran de boot de lilo?

bon C deja pas mal la 7.2, je me contenterai de cela...on verra plus tard pour le reste...

Tu fais comme tu veux, mais bon... une distrib qui a plus de 3 ans, c'est pas très marrant :/ Bon, bien sûr tu peux updater les packages, mais tu va sûrement pas le faire immédiatement...

Y'a des bugs et des incompatibilités qui sont corrigées tous les jours, y'a des nouvelles fonctionnalitées tous les jours... c'est un peu bête de débuter sous linux avec un vieux système :/ Bon d'accord, ça fait une semaine que t'essaies, mais quand même :p

Share this post


Link to post
Share on other sites
Mon disk IDE Primaire (cavalier en mode MS) est detecté en hde avec les partions hde1,etc...

Et il y a quoi en hda et hdb? Les disques de la carte controlleur?

Hda :mes 2 disk RAID1, HDB mes 2 disk Raid0 (linux a l'air de me faire une brouille dessus lors du partionnement me je m'en tape car je m'en sers pour win2k seulement)

Ma carte controleur RAID est une carte fille sur PCI à 27Euros.....ya pas de marque particiliere mais comme mes disk sont correctement detecte, j'en conclue ke le pilote est inclue dans la distrib 9.2

Donc il reste quoi comme problème? T'arrives pas à arriver à l'ecran de boot de lilo?

Maintent G pu de probleme, enfin pour le moment. juste kelke trucs bizarre coché en rouge lors du boot mais g pas le temps de lire.....

bon C deja pas mal la 7.2, je me contenterai de cela...on verra plus tard pour le reste...

Tu fais comme tu veux, mais bon... une distrib qui a plus de 3 ans, c'est pas très marrant :/ Bon, bien sûr tu peux updater les packages, mais tu va sûrement pas le faire immédiatement...

Y'a des bugs et des incompatibilités qui sont corrigées tous les jours, y'a des nouvelles fonctionnalitées tous les jours... c'est un peu bête de débuter sous linux avec un vieux système :/ Bon d'accord, ça fait une semaine que t'essaies, mais quand même :p

Ouiaip C vrai, apres 15 ans de PC en bossant avec MSDOS5.1 et win 2.0 jusqu'a Win2k , G malheureusement des reflexe conditionner d'ou mes nombreuses question qui peuvent etre stupide pour kelkun ki n'a pas tous mes autmoatismes et ki connaitaussi Linux..

Dur dur de reapprendre l'informatique.... mais bon j'y arriverai. Patience.... C klr ke Linux à l'air puissant mais fo reconnaitre ke c pas aussi simple à installer si on veut un multi OS....

Tu dis ke c bof bof de bosser avec une distribution de plus de 3 ans. JE te razppelle ke je bosse sur Win2k....A ton avis, il est sorti kan? :keskidit:

Share this post


Link to post
Share on other sites

Déjà, il vaut mieux ne mettre que une seule partition pour linux ( / ) ... ça simplifie pas mal la vie ...

Ensuite ... j'aime pas trop la mandrake 9.2 ... il y a trop de merdes avec, par contre la 9.1 marche très bien (pour moi ...)

De même, j'ai jamais aimé lilo ... si il y a un problème, c'est la merde, je préfère largement grub, un peut moins joli, c'est vrai, mais si il y a une merde, on oeut passer en ligne de commande pour booter ...

(en parlant de ça, la mandrake 9.2 installe automatiquement lilo sur la mbr du hda1 avant de proposer un autre loader ... et un autre disque ... Alors que moi, je veux installer grub sur hdb, je me retrouvais avec lilo sur hda :keskidit: Il n'y a pas de pb comme ça sur la 9.1 ...)

Je conseille d'installer le loader (lilo ou grub) sur le disque linux !!!

Si jamais par la suite il y a un problème (par exemple, si tu retire le disque linux, formatte ...) si le loader est sur le disque windows ... ce sera impossible de démarrer (sutout avec lilo, grub il faudra le faire à la main ...) et donc il faudra faire un fdisk /mbr ...

D'autre part, les cartes sATA ne sont pas toujours très bien gérées par linux, c'est d'autant plus vrai pour les cartes qui font le RAID en plus ... car certaines (par exemple sur l'A7N8X-E Deluxe) sont des contrôleurs émulés (comme les winmodems) ...

En espérant que ça puisse aider ceux qui débutent ...

Share this post


Link to post
Share on other sites

Tu dis ke c bof bof de bosser avec une distribution de plus de 3 ans. JE te razppelle ke je bosse sur Win2k....A ton avis, il est sorti kan?

Certes, certes :-) Mais tu vas bien vite constater la différence énorme de vitesse d'évolution entre Windows et Linux :-)

A+

Gauret

Share this post


Link to post
Share on other sites
Maintent G pu de probleme, enfin pour le moment. juste kelke trucs bizarre coché en rouge lors du boot mais g pas le temps de lire.....

Tapes "dmesg > fichier.txt" pour copier tout ce qui a été affiché au boot (et les messages du kernel après le boot) dans le fichier "fichier.txt".

[Edit: Ensuite, tu copies la partie importante du message d'erreur dans google, et t'as toutes les chances de trouver la solution à ton problème :mad2:]

G malheureusement des reflexe conditionner d'ou mes nombreuses question qui peuvent etre stupide pour kelkun ki n'a pas tous mes autmoatismes et ki connaitaussi Linux..

Le "c'est un peu bête" était général, hein :mad2: C'est normal d'avoir beaucoup de questions au début ^_^

C klr ke Linux à l'air puissant mais fo reconnaitre ke c pas aussi simple à installer si on veut un multi OS....

Disons que t'as quand même une configuration de disques-durs assez particulière :) (enfin c'est pas des simples disques en IDE sans RAID, quoi...)

Mais le problème du boot multi-OS n'est pas propre à Linux, et on pourrait facilement renverser le problème, et dire que Windows (surtout avec XP) est très envahissant, et a beaucoup de mal à cohabiter avec d'autres OS... (même avec d'anciens windows :yes:)

Tu dis ke c bof bof de bosser avec une distribution de plus de 3 ans. JE te razppelle ke je bosse sur Win2k....A ton avis, il est sorti kan?

Oui, mais Win2k, c'est un OS qui contient... qu'un OS ^_^ Je doute que tous les logiciels sur ton système date de 3 ans... et que tu n'as pas patché Win2k depuis 3 ans non plus :fou:

Bien entendu, tu peux aussi facilement updater Linux depuis ta Mandrake 7.2, mais si faut updater absolument tout les packages, autant débuter directement avec une version plus récente de Mandrake :)

Déjà, il vaut mieux ne mettre que une seule partition pour linux ( / ) ... ça simplifie pas mal la vie ...

Tout dépend de la notion que tu associes au terme 'simplification' :) Dès ma toute première installation de Linux, j'avais déjà toutes les partitions qu'il est conseillé d'avoir, et je peux affirmer que ce n'est pas plus compliqué à gerer, pour peu qu'on si prennen correctement... Et pour celà, il existe tout un tas de documentation à ce sujet...

Rappelons les bases: un partitionnement bien orchestré permet de limiter les risques de remplissage de certaines partitions sensibles (/ notamment) par des logs (et un fichier de log peut augmenter très rapidement pour peu qu'un firewall soit reglé pour logguer toute tentative de connection infructueuse, et que quelqu'un tente de vous attaquer), ou simplement par mégarde; mais surtout, il permet de monter certaines partitions en lecture seule, ou avec quelques autres options, ce qui permet de sécuriser davantage le système...

Bien entendu, celà permet également de limiter les risques de corruption de la partition / (qui sera la plus petit possible) permettant ainsi de restaurer un système endommagé...

De même, j'ai jamais aimé lilo ... si il y a un problème, c'est la merde, je préfère largement grub, un peut moins joli, c'est vrai, mais si il y a une merde, on oeut passer en ligne de commande pour booter ...

S'il y a un problème, tu peux simplement utiliser un cd ou une disquette de boot... c'est un peu fait pour ça. Et quand on est habitué au système de nommage des disques dur sous Linux, il est souvent déroutant d'utiliser Grub... (D'autant qu'avec Devfs, ça nous fait encore un 3ème système de nommage...)

Lilo ne pose aucun problème, quand on prend le temps de le configurer correctement -mais il est vrai que Grub est légèrement plus avancé que Lilo pour le boot multi-OS...

(en parlant de ça, la mandrake 9.2 installe automatiquement lilo sur la mbr du hda1 avant de proposer un autre loader ... et un autre disque ... Alors que moi, je veux installer grub sur hdb, je me retrouvais avec lilo sur hda  Il n'y a pas de pb comme ça sur la 9.1 ...)

Ca par contre, c'est un problème... Mandrake agit également comme ça en mode 'expert'?

Share this post


Link to post
Share on other sites

MErci Messieu pour vos conseils

Maintenant j vais essayer de voler d mes propres ailes et de temps en temps je vous poserai kelkes kestions ici......

En tout au premier abord, j'aime bien le les bureaux et le cote Mac des fenetres des applications. C la seule chose que j'ai fe c bidouiller aussi le lilo pour mettre Win2k en boot par defaul car j'avais mal configuter au depart.

Bon j'ai pas encore etudier le chapitre mais si jamais vous trainer par la.

Je creer un autres user car je n'ai que le root.

C bizarre il m'affiche dans une fenetre reduite tout le tralala comme si j'instalait linux pour la premiere fois ...(choix des package, type d'install : serveur , dev, station)

C normal ?

Edit: G oublie. c curieux mais le fuseau horaire ce calle toujours sur CET au lieu de GMT et pourtant en dessous j'ai choisis PARIS

Share this post


Link to post
Share on other sites
Maintenant j vais essayer de voler d mes propres ailes et de temps en temps je vous poserai kelkes kestions ici......

Google est ton ami ^_^ Je suis sous LFS, j'ai eu tout un paquet de messages d'erreurs au début, et j'ai absolument tout trouvé sur google ou dans la doc locale... :)

En tout au premier abord, j'aime bien le les bureaux et le cote Mac des fenetres des applications

Ahem, ahem... *se racle la gorge à en produire des interferences sur son ecran* Je ne saurai te conseiller plus de précautions sur un forum Linux... ^_^ Je veux dire... Il y a des choses à ne pas dire, quoi... hein? :) Enfin tu sais quoi...

Je creer un autres user car je n'ai que le root.

C'est important que tu t'y habitues dès le début :) (fait attention d'avoir un mot de passe root que tu peux retenir facilement, parce que tu va le taper souvent au début :p Le mieux est genre un pass de 8 caractères, avec quelques caractères spéciaux...)

C bizarre il m'affiche dans une fenetre reduite tout le tralala comme si j'instalait linux pour la premiere fois ...(choix des package, type d'install : serveur , dev, station)

Quand tu fais quoi exactement?

[Edit:

Edit: G oublie. c curieux mais le fuseau horaire ce calle toujours sur CET au lieu de GMT et pourtant en dessous j'ai choisis PARIS

CET, c'est GMT+1 :) (Central Europe Time)

]

Share this post


Link to post
Share on other sites
Maintenant j vais essayer de voler d mes propres ailes et de temps en temps je vous poserai kelkes kestions ici......

Google est ton ami ^_^ Je suis sous LFS' date=' j'ai eu tout un paquet de messages d'erreurs au début, et j'ai absolument tout trouvé sur google ou dans la doc locale... :)

En tout au premier abord' date=' j'aime bien le les bureaux et le cote Mac des fenetres des applications[/quote']

Ahem, ahem... *se racle la gorge à en produire des interferences sur son ecran* Je ne saurai te conseiller plus de précautions sur un forum Linux... ^_^ Je veux dire... Il y a des choses à ne pas dire, quoi... hein? :) Enfin tu sais quoi...

Je creer un autres user car je n'ai que le root.

C'est important que tu t'y habitues dès le début :) (fait attention d'avoir un mot de passe root que tu peux retenir facilement' date=' parce que tu va le taper souvent au début :roll: Le mieux est genre un pass de 8 caractères, avec quelques caractères spéciaux...)

C bizarre il m'affiche dans une fenetre reduite tout le tralala comme si j'instalait linux pour la premiere fois ...(choix des package' date=' type d'install : serveur , dev, station)[/quote']

Quand tu fais quoi exactement?

[Edit:

Edit: G oublie. c curieux mais le fuseau horaire ce calle toujours sur CET au lieu de GMT et pourtant en dessous j'ai choisis PARIS

CET' date=' c'est GMT+1 :) (Central Europe Time)

]

ouuaaa lalalaalalala komment il se la pete le monsieur...

Oki ca fe debutant de dire c sympa l'interface graphique de linux et blabla bla mais bon c ma ch'tite recompese apres en avoir chier kan meme :mdr::mdr:

C bizarre il m'affiche dans une fenetre reduite tout le tralala comme si j'instalait linux pour la premiere fois ...(choix des package' date=' type d'install : serveur , dev, station)[/quote']

Quand tu fais quoi exactement?

Ba lors de la procedure pour creer un user Pardis

;):mdr::keskidit::keskidit::chinois: :copain: :humour::heben:

QUOTE=You're TERMINATED....]Edit: G oublie. c curieux mais le fuseau horaire ce calle toujours sur CET au lieu de GMT et pourtant en dessous j'ai choisis PARIS

CET, c'est GMT+1 :) (Central Europe Time)

okay okay mais bon j'ai kan meme une heure d'avance :mdr:

Share this post


Link to post
Share on other sites
Ca par contre, c'est un problème... Mandrake agit également comme ça en mode 'expert'?

Ah bon, ça existe un mode "pas expert" ? ;):mdr:

J'installe toujours en expert ...

...Et mandrake 9.2 installe toujours (enfin ça faisait ça chez moi...) lilo sur hda juste avant de configurer le lanceur de démarrage ... pour 90% des utilisateurs ce n'est pas grave ... mais perso ça me lourdait bien (installer grub sur hdb ... puis disquette W98 => fdisk /mbr ... je sais pas faire autrement) ...

Share this post


Link to post
Share on other sites
Oki ca fe debutant de dire c sympa l'interface graphique de linux et blabla bla mais bon c ma ch'tite recompese apres en avoir chier kan meme

*tousse très fort* mac *eternue violemment*

Mis à part ce petit détail malencontreux, bien entendu que Linux, c'est beau :p Par contre, attention, il n'y a pas "une interface", mais une infinité ^_^ Non seulement, il est presque toujours possible d'utiliser des thèmes, mais surtout, il existe énormément de gestionnaires de fenêtres (et quelques desktop ^_^)

Tu peux consulter pas mal d'informations ici: http://www.xwinman.org/ :) Chaque gestionnaire de fenêtre a ses particularités, il n'y a que l'embaras du choix -chose rare si on regarde la concurrence.

Ba lors de la procedure pour creer un user Pardis

Tu utilises quoi comme commande aussi pour créer un utilisateur? (faut être précis :p y'a aussi une infinité de façons de créer un utilisateur :p)

okay okay mais bon j'ai kan meme une heure d'avance

Dans ce cas, c'est que Mandrake pense que l'horloge de ton PC n'est pas reglée à l'heure locale, mais à l'heure GMT (Lors de l'installation, tu n'as eu aucun message te demandant si l'heure de ton pc était locale ou gmt?)

Si t'as le fichier "/etc/sysconfig/clock" ouvres le, et met UTC à 0 au lieu de 1...

Si t'as pas le fichier, c'est que Mandrake le met autre part, alors essaie de le retrouver... :p (enfin je suppose qu'il existe aussi quelques commandes pour configurer ça, mais les fichiers texte, c'est tellement mieux :p

...Et mandrake 9.2 installe toujours (enfin ça faisait ça chez moi...) lilo sur hda juste avant de configurer le lanceur de démarrage ... pour 90% des utilisateurs ce n'est pas grave ... mais perso ça me lourdait bien (installer grub sur hdb ... puis disquette W98 => fdisk /mbr ... je sais pas faire autrement) ...

Je suis bien de ton avis ^_^ Si je suis sous Linux, s'pas pour retrouver les mêmes comportement que sous Windows :/

Bon, je vais manger :p

Share this post


Link to post
Share on other sites
G telecharge la version de UT2004 sur linux, vous l'utliser ou pas celle la? ca marche bien?

C'est ce que j'utilise pour jouer à ut2k4 :p

Ils ont desactivés la recherche sur le site officiel, et j'ai la flemme de chercher manuellement des solutions (et je sais pas si c'est specifique à la version windows ou non), mais pour l'instant la console veut pas s'afficher, une fois sur deux, on peut pas supprimer de serveurs, de la liste des favoris (et puis la liste semble pas updatée en direct, il faut recharger la page des favoris..), et puis y'a un certain nombre de petits bugs graphiques, à certains moments... enfin rien de grave, quoi... (mais le pb avec la console, c'est gênant quand même :p)

Share this post


Link to post
Share on other sites

Hello Again

j'arrive po à installer Mozilla . kelkun peut m'expliquer svp?

ils disent ceci :

The installer is now located in a subdirectory of

Mozilla named mozilla-installer.

4. Change to the mozilla-installer directory

(cd mozilla-installer) and run the installer with the

./mozilla-installer command.

voici le contenu de mon repertoire

G un repertoire mozilla-installer/

oki j'y vais comme c'est marqué et je tape : ./mozilla-installer y compris le point et G le message suivant

./mozilla-installer-bin: /lib/libc.so.6: version `GLIBC_2.2.4' not found(required by ./mozilla-installer-bin)

Je pige riennnnnnnnnnnnnnnnnnn!!!! j'chui vraiment trop nul c po posible

Share this post


Link to post
Share on other sites

Bon rectifions un peu les choses. J'ai installer dernièrement la version 9.2 de Mandrake, et on peut facilement choisir d'installer lilo sur une disquette. Bon, je comprend pas pourquoi vous dites que ca ne marche pas. J'ai peut-être une version spéciale. :incline:

You're Finish : Mozilla est supposé être installer avec Mandrake, à moins que tu ais décochez l'option. :non:

PS : Je doit dire qu'ayant essayer linux plusieurs fois, la première remonte à 98, je suis impressioné des progrès réalisés. En installant Linux, tout les drivers ont été correctement installé. Ce que j'aime aussi de linux, c'est le fait que l'interface est séparé du os. ctrl-alt-efface est pratiquement une jouissance pour moi. :incline::yes:

Share this post


Link to post
Share on other sites

Pour rebondir sur les loader... le point dommage de lilo qui fait chier, je trouve, c'est de devoir ré-écrire le mbr à chaque modif... Perso, j'ai un /boot de 64Mo, et un à deux nouveau noyau par semaine... (test en full exp chez Gentoo)

Bref, jepréfère Grub...

Share this post


Link to post
Share on other sites
Bon rectifions un peu les choses. J'ai installer dernièrement la version 9.2 de Mandrake, et on peut facilement choisir d'installer lilo sur une disquette. Bon, je comprend pas pourquoi vous dites que ca ne marche pas. J'ai peut-être une version spéciale. :keskidit:

You're Finish : Mozilla est supposé être installer avec Mandrake, à moins que tu ais décochez l'option. :keskidit:

PS : Je doit dire qu'ayant essayer linux plusieurs fois, la première remonte à 98, je suis impressioné des progrès réalisés. En installant Linux, tout les drivers ont été correctement installé. Ce que j'aime aussi de linux, c'est le fait que l'interface est séparé du os. ctrl-alt-efface est pratiquement une jouissance pour moi. :D:byebye:

ba nan G rien decocher dans l'install et pis d'abord G la mandrake 7.2 car la 9.2 je ne peux faire de MultiOS a cause de mes disk RAID...

Enfin bref je penche plus sur mon manque d'experience dessus sans mettre win2K HS....

Pour revenir à mon pb de mozila, je n'ai certainement pas la derniere version tout comme netscape. Sur la 7.2 G netscape 4.52 alors que nous avons sur le site la 7.02 dispo. Je ne peux afficher correctement le site pcinpact correctement car apparment je n'ai pas les fonctionnalite java (ou javascript) dessus.

Bref kelkun peut m'expliquer la foutue commande a taper pour installer Mozila ou Netscape version 7.2car C le meme genre de bleme.

Share this post


Link to post
Share on other sites
ki j'y vais comme c'est marqué et je tape : ./mozilla-installer y compris le point et G le message suivant

./mozilla-installer-bin: /lib/libc.so.6: version `GLIBC_2.2.4' not found(required by ./mozilla-installer-bin)

C'est pas bien compliqué :p Mozilla a besoin d'une version recente de glibc pour fonctionner, et ta vieille Mandrale 7.2 possède une version trop ancienne :p Je t'ai dis, faudra que t'updates tous tes programmes si tu restais avec Mandrake 7.2 :p Si vraiment tu sais plus quoi faire pour faire fonctionner correctement Mandrake 9.2, testes une autre distribution... (Parce que bon, Glibc, je suis pas sûr qu'on puisse l'updater d'un claquement de doigts :p (enfin je suis vraiment pas sûr du tout, mais vu son rôle central...))

Essaies peut-être Opera, temporairement... avec un peu de chance, il fonctionnera... Mais je te dis, tu rencontrera ce genre de problèmes avec un tas de logiciels... Linux evolue tous les jours... (niveau kernel, regardes simplement la longueur des changelogs...) et niveau compatibilité, c'est pas toujours ça.. Mais ce n'est pas bien grave, car de toutes façons, pour des raisons de securité, tu dois mettre à jour ton système regulièrement... (limite tu te fais pas insulter si tu check pas les cvs de tous les programmes de ton système 2 fois par jours :p (bon d'accord, j'exagère un peu :p (mais y'en a qui le font :p)))

Tu es prêt à passer combien de temps pour installer et faire fonctionner tout ton système, la première fois? (histoire de voir quel genre de distribution tu peux choisir ^_^)

Share this post


Link to post
Share on other sites
(Parce que bon, Glibc, je suis pas sûr qu'on puisse l'updater d'un claquement de doigts :D (enfin je suis vraiment pas sûr du tout, mais vu son rôle central...))

Euh sous Gentoo... emerge -u world... et t'as la dernière version de glibc compilé sur ta machine...

Vu que je suis en exp, ca change assez souvent...

Share this post


Link to post
Share on other sites
Euh sous Gentoo... emerge -u world... et t'as la dernière version de glibc compilé sur ta machine...

Oki ^_^ Faudrait que je me renseigne davantage sur ce genre de trucs :keskidit:

Bon alors il me reste plus qu'a mettre DL la RED HAT alors?

J'ai pas vraiment suivi ce qu'il s'était passé avec Red Hat, mais je suppose que c'est plutôt Fedora qu'il faut que tu dl, si tu veux du RH ^_^

Mais sinon, tu as bien d'autres choix: http://www.distrowatch.com/

Aucune distribution majeure n'est réellement compliquée à installer... Et la detection du materiel dépend très principalement du kernel... Va sur Distrowatch, et choisi une distribution bien à jour, et qui te semble sympatique :D C'est plus amusant si tu y va au feeling ^_^

Share this post


Link to post
Share on other sites
Euh sous Gentoo... emerge -u world... et t'as la dernière version de glibc compilé sur ta machine...

Oki ^_^ Faudrait que je me renseigne davantage sur ce genre de trucs :byebye:

remarque, pour glibc, il suffit de

emerge -u glibc

et roule ma poule... avec les dépendances

Share this post


Link to post
Share on other sites
remarque, pour glibc, il suffit de

emerge -u glibc

et roule ma poule... avec les dépendances

Et t'as les instructions sous LFS? :p

Another rule of thumb is: don't upgrade

the toolchain (gcc, glibc and binutils) unless you're going to rebuild

your entire system. These packages form the heart of your LFS system,

destroying them means destroying the ability to compile packages or even

run binaries.

Quand il dit "destroying them", il veut simplement dire foirer la compilation/installation?

Question: Est-ce qu'updater Glibc ou GCC peut poser des problèmes avec tous les programmes déjà installés, et linkés dynamiquement (donc en gros, tous les programmes, et le kernel)? (ou bien tout est réellement retro-compatible?)

Enfin bon, c'est pas vraiment l'endroit :p Je chercherai ça, parce que c'est un point important que j'ai pas encore eclairci :p

Share this post


Link to post
Share on other sites

normalement, c'est retro-compatible... mais sur des lib aussi importante, je me renseignerais davantage à ta place...

Share this post


Link to post
Share on other sites

eeeu j'vudrais pas derangerdans la conversation mais bon je pige rien a votre charabia!!!!!!!! :D

Share this post


Link to post
Share on other sites
eeeu j'vudrais pas derangerdans la conversation mais bon je pige rien a votre charabia!!!!!!!!

Glibc regroupe tout un tas de librairies C, et quelques utilitaires... La plupart des programmes sous linux sont compilés de telle sorte qu'ils ont besoin de librairies independantes pour fonctionner... (ces librairies contiennent des fonctions generiques, qui peuvent être utilisées par de nombreux programmes) Glibc est donc une des bases d'un système GNU/Linux...

Le problème qui se pose, c'est si, en updatant Glibc, y'a pas des noms de fonctions ou des fonctionnalités des fonctions (:p) qui changent, à tel point que certains programmes compilés pour telle ou telle version de Glibc, pourraient ne plus fonctionner... Mais c'est vrai que ça doit sûrement être pleinement retro-compatible...

J'ai encore quelques problèmes dans ce genre à resoudre.. :p C'est sûr que LFS m'a ouvert les yeux sur la modularité de Linux, mais le livre ne dit pas tout, loin de là :/

Quoi qu'il en soit, pour ton problème => changes de distribution :p Tu n'as que l'embaras du choix ^_^

Share this post


Link to post
Share on other sites

×
×
  • Create New...