Jump to content

Archived

This topic is now archived and is closed to further replies.

keneda212

Migration Win XP -> Linux

Recommended Posts

comment as tu pu perdre des fichiers avec aoe :dd:

j'ai pas trop compris comment tu as fait . :D

Perso, ( et je ne sais pas si c'est la bonne solution ou pas ) ce que je monte, c'est la partition physique de mon disque dur ( en fait c'est même pas ça , la pseudo partition après le déchiffrement de la partition.) et pas le système de fichier.

le montage de la partition se fait sur l'hôte, et AUCUNE partition n'est monté sur le serveur blade, a aucun moment.

avant d'étendre le blade, il faut qu'ancune partition ne soit monter à aucun endroit :D. ( ni le blade ni le serveur)

Sinon c'est la galère ultime.

explication : Si ça ne s'arrête pas normalement, lors du remontage de la partition, il y a un scan du disque ( je suis en ext3).

Mais ce qui est marrant, c'est que c'est le client qui gère le système de fichier, et c'est donc lui qui lance le fsck :p et pas le serveur. :p

le scan d'un disque de 750 Go prend normalemnt beaucoup de temps, mais le tout via le réseau = :kill:

je crois que ça avais mis plus de 3h ;) .

et encore il a fallu que je fasse un top pour savoir pouquoi le pc ne voulait pas me donner la main sur le répertoire :pleure: .

sinon perso, je monte les partition avec autofs, comme ça, ça démonte automatiquement après une periode d'inactivité

mais si ça foire :transpi: , alors c'est pas cool ( style la partition qui ne veut pas se démonter sans aucune raison apparente., même si je pense que c'était samba qui essayé d'accèder au système de fichier)

je t'aurais bien mis ma config du vblade, mais je suis pas à la maison :transpi: , et j'ai tellement blindé mon serveur que je ne peux pas me connecter sur la machine virtuelle qui va bien :transpi:.

Share this post


Link to post
Share on other sites

ce que tu veux dire que c'est sur le serveur ou tu as le blade, tu n'as aucune partition de monté dessus c'est ca ?

parce que, ce que j'avais fait, c'est : mon serveur est allumé, je lance l'export du blade de la partition physique de mon home par exemple

sur le client, je monte le blade sans aucun pb. Par contre, j'ai des soucis de transferts de fichier : quand j'envois des fichiers sur le blade (depuis le client en direction du serveur), en local sur le serveur, je ne trouve pas le fichier, ou 10 a 15 minutes apres, ou defois avec des ?? ?? ??????????? ??

Share this post


Link to post
Share on other sites
ce que tu veux dire que c'est sur le serveur ou tu as le blade, tu n'as aucune partition de monté dessus c'est ca ?

parce que, ce que j'avais fait, c'est : mon serveur est allumé, je lance l'export du blade de la partition physique de mon home par exemple

sur le client, je monte le blade sans aucun pb. Par contre, j'ai des soucis de transferts de fichier : quand j'envois des fichiers sur le blade (depuis le client en direction du serveur), en local sur le serveur, je ne trouve pas le fichier, ou 10 a 15 minutes apres, ou defois avec des ?? ?? ??????????? ??

forcément si ton sytème de fichier est monté a 2 endroits différents en même temps ..... :zarb:

Si tu veux faire ça, il faut utiliser NFS et pas AOE.

Share this post


Link to post
Share on other sites

bah le but c'est que je puisse monter les partitions sur plusieurs pc en reseau :D

avec nfs je peux pas exporter toute une partition facile, y'a plein de conf a faire à chaque fois

hs : avec ton systeme tu décripes en local sur le serveur ou sur le client ? tu exportes la partition une fois déchiffrée ou encore chiffrée

Share this post


Link to post
Share on other sites

pour le nfs, une simple ligne dans le /etc/exports sur le serveur et une ligne dans le fstab sur le client :byebye:

sinon, avec du sshfs.

actuellement, je décryte en local sur le serveur, et je monte donc la partition dechiffré sur le poste client.

serveur (sda--> partition sda1 chiffrée luks --> déchiffrement --> sda1_cryt ) --> AOE(sda1_cryt) --> client ( mount /dev/etherd/e0.1 /mnt/data )

Mais rien n'empêche de "partager" la partition chiffré et de tout faire sur le client.

je crois qu'on peut même partager directement le disque dur et non les partitions. ( sachant que je n'ai qu'une partition sur mes disue de sauvegarde, j'ai pas de problèmes de ce côté la :chinois: ).

Share this post


Link to post
Share on other sites

pour le nfs, tu rajoutes le module assez spécial a charger + 3 ports à ouvrir dans le firewall :chinois:

Share this post


Link to post
Share on other sites

Ok j'ai lu un peu de truc, et je comprend mieu le concept d'aoe : le but c'est d'avoir une machine ou il n'y a que des dd par exemple, et en faire un export sur la machine serveur ou seront montés les partitions ; de la, faire un petit NFS pour faire de l'export à tout va.

Je comprend mieu pourquoi ca m'a foutu le bordel :D

sinon j'ai récupéré un vieu pc et j'en fais un terminal X

mais j'ai des soucis d'export de son la (pas facile de trouver une doc qui en parle correctement)

Share this post


Link to post
Share on other sites

×
×
  • Create New...