Jump to content

[résolu] Serveur FTP Filezilla


Recommended Posts

Salut à tous

J'aurais besoin d'aide pour peaufiner la configuration d'un serveur ftp sous Filezilla.

En effet, les fichiers sont bien accessibles dans le LAN, mais quand je tente de m'y connecter en externe, la connexion arrive bien, mais je ne peux pas lister les fichiers.

L'accès Internet se fait avec une Livebox, sur lesquels sont forwardés les ports 20 et 21 (pour le FTp) 5900 (pour l'accès VNC pour la config à distance) et 8245 (pour le client no-ip).

Pouvez-vous m'aider ?

Merci.

Link to comment
Share on other sites

Voici le log du client (filezilla)

Statut :	Résolution de l'adresse IP pour @@@@@.@@@@@.com
Statut :	Connexion sur 90.33.@@.@@:21...
Statut :	Connexion établie. Attente du message d'accueil...
Réponse :	220-FileZilla Server version 0.9.24 beta
Réponse :	220-written by Tim Kosse (Tim.Kosse@gmx.de)
Réponse :	220 Please visit http://sourceforge.net/projects/filezilla/
Commande :	USER bourriks
Réponse :	331 Password required for bourriks
Commande :	PASS ********
Réponse :	230 Logged on
Commande :	SYST
Réponse :	215 UNIX emulated by FileZilla
Commande :	FEAT
Réponse :	211-Features:
Réponse :	 MDTM
Réponse :	 REST STREAM
Réponse :	 SIZE
Réponse :	 MLST type*;size*;modify*;
Réponse :	 MLSD
Réponse :	 UTF8
Réponse :	 CLNT
Réponse :	 MFMT
Réponse :	211 End
Statut :	Connecté
Statut :	Récupération du contenu du répertoire...
Commande :	PWD
Réponse :	257 "/" is current directory.
Commande :	TYPE I
Réponse :	200 Type set to I
Commande :	PASV
Réponse :	227 Entering Passive Mode (192,168,1,27,5,237)
Statut :	Le serveur a retourné une adresse non routable, remplacée par l'adresse du serveur.
Commande :	LIST
Réponse :	425 Can't open data connection.
Erreur :	Échec à la lecture du contenu du répertoire

Et voici le log côté serveur

(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> Connected, sending welcome message...
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> 220-FileZilla Server version 0.9.24 beta
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> 220 Please visit http://sourceforge.net/projects/filezilla/
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> USER bourriks
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> 331 Password required for bourriks
(000764) 10/06/2008 08:26:57 - (not logged in) (90.33.)> PASS ********
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> 230 Logged on
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> SYST
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> 215 UNIX emulated by FileZilla
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> FEAT
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> 211-Features:
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  MDTM
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  REST STREAM
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  SIZE
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  MLST type*;size*;modify*;
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  MLSD
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  UTF8
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  CLNT
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)>  MFMT
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> 211 End
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> PWD
(000764) 10/06/2008 08:26:57 - bourriks (90.33.)> 257 "/" is current directory.
(000764) 10/06/2008 08:26:58 - bourriks (90.33.)> TYPE I
(000764) 10/06/2008 08:26:58 - bourriks (90.33.)> 200 Type set to I
(000764) 10/06/2008 08:26:58 - bourriks (90.33.)> PASV
(000764) 10/06/2008 08:26:58 - bourriks (90.33.)> 227 Entering Passive Mode (192,168,1,27,5,237)
(000764) 10/06/2008 08:26:58 - bourriks (90.33.)> LIST
(000764) 10/06/2008 08:27:08 - bourriks (90.33.)> 425 Can't open data connection.

Quand tu parles de la config de Filezilla, tu parles du serveur ou d'un client ?

Link to comment
Share on other sites

ca a tout l'air d'un problème de port ouvert lié au mode actif ou mode passif

j'ai eu des soucis similaire mais je ne rapelle plus exactement. Une histoire que les ports 20-21 servent à la connection et après ca tourne sur des ports 5000 ou un truc du genre

si tu tentes une connection en mode forcant le mode active, ca fonctionne non ?

edit : quelques infos si tu veux regarder : http://3psilon.info/FTP-Actif-ou-Passif.html (avec les histoires de ports -- pas la meilleur doc mais la premiere que j'ai trouvé. google est ton ami :craint:)

Link to comment
Share on other sites

Je crois que mon souci est résolu:

Dans les options du serveur >> passive mode settings, j'ai décoché la case "don't use external ips for local connexions"

J'ai pas eu le temps de tester, je suis parti en intervention chez un client, puis j'ai fait un essai de chez lui, et j'ai pu non seulement lister les épertoires, mais aussi uploader un fichier.

Je vais faire un test complémentaire, mais je crois que c'est OK.

Je mets le [résolu] d'avance.

Link to comment
Share on other sites

up

j'enlève le [résolu]

En fait, ca marche très bien avec une session ftp sous DOS, mais avec un client filezilla, je n'arrive pas à lister les fichiers

Je craque ! :embarassed:

Edit: Filezilla marche si je le mets en mode actif, mais pourquoi ne puis-je pas utiliser le passif ?

Link to comment
Share on other sites

tu as lu le document que je t'ai indiqué ?

http://slacksite.com/other/ftp.html

en actif, il utilise le port 21 pour faire la connection et le port 20 pour transferer les données

en passif il utilise le prot 21 pour faire la connection et un port > a 1000 pour les données

(j'ai résumé et j'espere ne pas avoir dit de connerie :embarassed:

ce qui resumerai par ce schema :

Active FTP :
 command : client >1023 -> server 21
 data	: client >1023 <- server 20

Passive FTP :
 command : client >1023 -> server 21
 data	: client >1023 -> server >1023

tiré du document linké si dessus

Link to comment
Share on other sites

oui, à partir du port 1023.

Donc en fait, il me suffirait d'ouvrir une plage de ports, par exemple entre 1023 et 1100 ?

edit: cette fois, ca semble bel et bien marché. J'ai bien forwardé une plage de ports entre 1023 et 1300 et sur le serveur, j'ai coché (dans "passive mode settings") le paramètre "use custom port range" et les valeurs entre 1023 et 1300.

Merci à tous ^^

Link to comment
Share on other sites

le mieu c'est de fixer toi meme les ports

dans filezilla, tu as dans les parametrages, un onglet spécial mode passif (passive mode setting)

dedans tu fixes ta plage de port que tu veux utiliser en mode passif. Ensuite tu n'as plus qu'a les ouvrir dans ton firewall

edit : bon tu m'a grilled la :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...