Jump to content

[XP] Lecteurs réseaux qui se mappent tout seul


Recommended Posts

Bonjour,

voila sur un PC de mon domaine, j'ai des lecteurs réseaux qui se créent tout seul...

Il y a un script qui connecte des lecteurs à l'ouverture de session, jusque là pas de soucis, et puis curieusement au bout d'un moment (ce n'est même pas au démarrage...) des nouveaux lecteurs se créent et pointent vers les mêmes partages que les lecteurs crées par le script...cela jusqu'à qu'il n'y ait plus de lettres dispos...

Y a t il un moyen d'éviter cela (la création des lecteurs supplémentaires) ? Ou en gros, une fois que les lecteurs se sont montés via un script à l'ouverture de session, bloquer la possibilité de monter de nouveaux lecteurs ?

Je ne sais plus trop où chercher, si vous avez des idées.

Merci

Link to comment
Share on other sites

Combien tu as de machines?

Et combien de machine utilise le même script?

Le script se lance à l'ouverture de session ou au démarrage de windows?

Le script est executé en local ou est stocké sur le controleur de domaine?

Il y a forcément quelque chose qui fait que soit ton script tourne en boucle soit il subit une redondance due à une action.

Link to comment
Share on other sites

Combien tu as de machines?

Et combien de machine utilise le même script?

Le script se lance à l'ouverture de session ou au démarrage de windows?

Le script est executé en local ou est stocké sur le controleur de domaine?

Il y a forcément quelque chose qui fait que soit ton script tourne en boucle soit il subit une redondance due à une action.

Alors, c'est un parc d'environ 650 PC. Environ le même nombre de users qui ont dans leur netlogon la connexion des lecteurs réseaux, donc à l'ouverture de session.

Le script est dans le profil de chaque utilisateur AD, c'est un script qui est stocké dans le sysvol.

Le problème intervient chez un utilisateur (le boss en plus...).

Merci

Link to comment
Share on other sites

LOL, tu as bien choisi ta cible ! :craint:

Ne vois-tu rien qui différencierait son compte/poste des autres ?

Il doit forcément y avoir quelque chose puisque déjà une chose est sur, ton script est niquel puisqu'il marche pour environ 649 postes/utilisateurs.

Aprés si tu es dans l'urgence, (si tu risque ta place) tu peux toujours télécharger TweakUI pour empêcher l'affichage des lecteurs non souhaités.

Télécharger : TweakUI

Link to comment
Share on other sites

Non, je ne vois rien qui pourrais différencier son compte...

Je suis pas dans l'urgence (oufffffff), j'aimerais bien trouver ce qui monte ces lecteurs mais impossible...

Les lecteurs se remappent a intervalle régulier ? Ou après une mise en veille ?

C'est complétement aléatoire...pendant que le user travaille ou pas...

Link to comment
Share on other sites

OK, j'ai compris...

Ce que j'ai vu c'est qu'à chaque fois qu'un lecteur se crée c'est avec le process explorer.exe avec un path HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\##nomserveur#nompartage

Link to comment
Share on other sites

+1 pour le test avec un compte user neuf, et un autre compte.

Et surtout un compte user lambda, sans droits particuliers.

Sinon, tu n'as pas une config VLAN, ou des refreshs de DNS qui déconnecterais / reconnecterais le PC, relançant le script ??

:transpi:

Link to comment
Share on other sites

Alors pour répondre à tous :

- non pas forcément de fenetre poste de travail ouverte

- pour le profil, j'ai déja essayé de le supprimer mais cela recommence dans le nouveau

- pas de config particulière VLAN ou DNS

Merci

Link to comment
Share on other sites

Et le compte du "boss" sur un autre poste pose le même problème ?

Si c'est non, alors on pourra déjà on conclure que le problème est bien local et pour le résoudre, la solution radicale qui serait de refaire une installation de windows pourrait fonctionner.

Mais appart ça je ne vois plus trop où chercher. On voit bien que le script s'execute à partir du compte utilisateur et pourtant le script se "répete" alors que la session est toujours ouverte...

Link to comment
Share on other sites

Même si normalement un lecteur ne peut pas être monté plusieurs fois par le même utilisateur il se pourrait que ce soit une déconnection par le serveur de l'utilisateur.

Et comme y aurait pas démontage auto sur le poste client il remonte quand la ressource est inaccessible.

Enfin si je me fait comprendre...

Link to comment
Share on other sites

Le compte ne pose problème que sur ce PC.

Les lecteurs sont tous identiques.

Donc la solution la + rapide : on lui a mis un .bat en taches planifiés qui déconnecte toutes les 30 mns les lecteurs qui sont superflus.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...