Jump to content

[test] FireWire 800 en RAID0


falou

Recommended Posts

  • Replies 69
  • Created
  • Last Reply

Enfin la voix de la raison ;)

Tes performances sont interessantes falou. Je pense de plus en plus à franchir le pas et changer le disque dur de mon iBook. C'est dans un autre ordre de grandeur s'est sur mais vu ce que tu gagnes en performances augmentant les performances de ton/tes DD je me dis que le gain devrait aussi être significatif de mon côté ...

Tu as désactivé l'option "arrêter les disques dur en cas d'innactivité" par contre ? Mes disques de stockage externes sont en FW aussi et s'éteignent automatiquement. Je suis assez content de ce système, déjà ça ralonge leur durée de vie je pense vu qu'ils ne sont pas beaucoup sollicités et puis ça soulage pas mal mes oreilles :transpi:

Le seul soucis c'est qu'ils sont assez longs à repartir ... laisser cette option activée est pas trop handicapant lorsque le système est sur ces disques ? (je suppose qu'ils s'arrêtent eux aussi, au moins quand le système passe en veille ...)

A moins que tes Lacie repartent beaucoup plus vite que les miens et que ça ne se fasse pas ressentir !

Link to post
Share on other sites

Oui je garde la mise en veille des disques. Le réveil est long (les disques se réveillent successivement) mais bon, ça ne me dérange pas dans la mesure où ils ne se mettent pas en veille tant qu'on se sert du Mac, le système étant dessus et que tant qu'on est sur une appli en mémoire ça n'en empêche pas l'usage entre-temps.

Ce qui m'énervait avec le SATA par contre c'était des délais aberrant pour avoir une fenêtre du finder par exemple. Après prendre un disque rapide ET rajouter de la mémoire, c'est un duo gagnant à coup sûr.

Link to post
Share on other sites

Un point non négligeable est la charge processeur engendrée par l'intensité de l'exploitation du RAID logiciel. Pour ainsi dire, plus on utilise intensivement le Raid, plus l'activité processeur augmente. Elle semble aussi consommer de la RAM (100 Mo ?).

Duplication d'un dossier d'approximativement 170 Mo et 800 fichiers : 22s sur SATA, 8s sur RAID

Link to post
Share on other sites
  • 2 weeks later...

Pour ceux que ça intéresserait, voici un petit bilan.

-Les perfs restent toujours l'aspect essentiel. OS X met 30 secondes à charger un profile "vierge" (sans rien démarrer en auto). Certaines choses très lourdes et lentes (comme le lancement de Front Row) deviennent quasi instantanées.

-Pour la fiabilité, je ne déplore toujours aucun problème, aucune erreur sur le disque malgré des soucis de débranchement des alims (hum). Bref : aussi stable que le système sur disque interne.

-Les disques sont assez silencieux, mais on est loin de l'inaudibilité du SATA interne.

-Mes sauvegardes sont à présent quotidiennes et non plus hebdomadaires. On ne sait jamais.

-La veille des disques entraîne des réveils assez longs. Ils doivent se synchroniser avant d'être opérationnels chaque fois.

Pas grand chose d'autre à dire sauf parler de cet extravagant produit que j'ai découvert :

http://www.lacie.com/fr/products/product.htm?pid=10849

Il s'agit ni plus ni moins d'une solution RAID matérielle 4 disques SATA interchangeables à chaud en interface FW800. Mais où vont-ils chercher tout ça :cartonrouge:

Link to post
Share on other sites
ça donne envie comme manip

bon pet pas tester car que du FW 400 sur mon macbook

D'après les pré-tests, un Raid0 de bons disques FW400 doit déjà donner un gain de perfs sensible. Note importante : on peut choisir la taille des blocs du Raid à sa création. Plus on choisit de petits blocs, plus la gestions des petits fichiers sera optimisée, alors que plus on va prendre de gros blocs, plus la vitesses sur les gros fichiers sera rapide. J'ai choisi pour ma part des blocs de 64k. J'ai donc une perf moyenne de 120 points (toujours sur xbench) sur les traitements 256k.

Mes meilleurs score sont:

-77 MB/s en lecture séquentielle sans cache 256k (score de 153) contre 45 (90 points) pour le SATA interne. Cela correspond apparemment à une saturation de l'interface au niveau des disques durs.

-28 MB/s en lecture aléatoire sans cache 256k (149) contre 22 MB/s (score 118) pour le SATA interne.

Le plus mauvais score est en lecture sans cache 4k : 14 MB/s (score 48) contre 21 (score 71) pour l'interne. C'est le seul score où le RAID est moins performant que le SATA.

Link to post
Share on other sites
  • 5 weeks later...

Comme dit ailleurs j'ai perdu mon RAID0. Après avoir bataillé sans succès, et récupéré l'intégralité des données jusqu'à la veille (merci la sauvegarde quotidienne incrémentale).

Puis une succession d'incidents m'a révélé la nature exact de mon problème. En recablant en FW400 mon Raid a refonctionné instantanément. En FW800 rien. En débranchant mon disque FW400 tout remonte. Puis j'ai fini par remonter un fil relié à un iPod FW de ma belle-soeur. Je l'ai débranché et là, plus aucun problème. Cet iPod m'a foutu une grouille... soit dit en passant, mon raid a passé la vérification sans encombre et fonctionne à nouveau comme une fleur. Retourner à la ramouille de l'hd interne ne me satisfaisait pas du tout...

Link to post
Share on other sites

Si je puis m'immiscer dans ce sujet, puisque j'utilise des DD externes SCSI et Firewire depuis ... 1986 :D

Ce qui est important pour un boitier externe, c'est la puce qui fait le pont PATA/SATA vers le Firewire (400 ou 800). Et dans ce domaine, je ne saurais que vous conseiller les puces oxford 911, 912, 922 ou 924. Et donc des boitiers qui l'utilisent.

Je suis équipé avec un modèle de chez OWC (MacSales). C'est un boitier double (une seule prise comme ça). J'en suis très content même si pour mon utilisation j'ai choisi le RAID 1, mon préoccupation étant plus la sécurité que la vitesse. Je compte d'ailleurs en acheter un deuxième et plusieurs de mes amis s'en sont équipé.

Ce boitier existe aussi en SATA.

Quel logiciel de bench utilisez-vous ?

Link to post
Share on other sites

Le raid matériel c'est mieux, n'empêche que le résultat est sensiblement le même car de toute façon je sature l'interface. Je suis à +-75 mbs en lecture et aucun disque FW800 -raid ou pas- ne fait mieux que ça. Donc je vais essayer de mixer le SATA et FW800 pour tâcher d'aller au-delà et garder l'autre disque FW800 pour la sauvegarde (car avoir des disques FW800 sans raid intégré à l'avantage d'être configurable à volonté). mais je ne suis pas pressé, les perfs sont déjà correctes et j'ai peur de me casser le fion pour un gain peut-être insignifiant.

Link to post
Share on other sites
Bon boîtier, qui a l'avantage de gérer le RAID en hard.

J'ai du oublier de dire que son silence est impressionnant par rapport à pas mal de boitiers :transpi:

De toute façon OWC c'est de la qualité et je suis client chez eux depuis longtemps. Ils ont aussi pas mal de trucs qu'on ne trouve pas forcément ici.

Link to post
Share on other sites

Ha, je voulais préciser : contrairement à ce que j'ai dit le Raid0 ne travaille pas forcément de manière symétrique ; dans l'absolu un disque peut lire les données quand l'autre les écrit. Donc si un disque est plus rapide que l'autre, le plus lent ne tire pas les perfs du plus rapide vers le bas. En principe.

Link to post
Share on other sites

Je viens d'être confronté à un premier problème : le RAID logiciel FW800 (tout du moins) semble générer des instabilités sur la chaîne FW. le coup de l'iPod n'est pas isolé ; je viens d'avoir le problème avec un camescope DV que je viens d'acheter (Canon B160 pour les curieux). Lui aussi fait dégringoler la chaîne, et même si il est sur le FW400 - ce qui est fortiche. C'est donc un bug du raid logiciel d'Apple (il y en a d'autres apparemment).

Link to post
Share on other sites
Tu n'as pas fait une erreur en mettent le nom du caméscope? Car le B 160 semble être un fax ;)

Oui, précisément j'ai fait l'erreur puisque ce sont ces fax que j'installe au boulot ; mon camescope est un Canon MD160 qui vient en remplacement de mon JVC GR-D20E, mais c'est un autre sujet. La documentation indique que le camescope doit être le seul appareil IEEE1394 branché à l'ordinateur en cas de soucis. Mais en fait dès que je débranche mon RAID, même avec mon FW400, il fonctionne.

Link to post
Share on other sites
Oui cela ne change rien au fait, mais il ne fallait pas laisser cette aberration :chinois:

Oui tu as raison, fallait corriger. J'avais même déjà corrigé mon post précédent avant que je ne vois ta réponse, je suis intenable ;)

Link to post
Share on other sites
  • 4 months later...

Ca fait un peu plus de 6 mois que mon RAID tourne; j'ai appris à faire avec les quelques problèmes dus à la sensibilité de la chaîne, à part ça je n'arrive pas à me passer des gains de perf. La solution se montre finalement fiable, relativement contraignante (disques externes connectés en permanence, coûts d'acquisition de disques FW800 silencieux, sauvegardes fréquentes obligatoires car risque de panne doublé), efficace.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...