Jump to content

Archived

This topic is now archived and is closed to further replies.

typhoon006

[RESOLU]probléme réseau Linux->XP

Recommended Posts

Salut

j'ai fraichement installé Ubuntu Edgy en dual-boot sur mon PC

j'ai donc voulu recreer mon réseau local

j'arrive parfaitement à acceder aux dossiers partagés sur mes autres postes tournant sur XP

par contre a partir de ces Pc ,si j'arrive a acceder a mon poste sur linux, je ne peux ouvrir aucun dossiers ...

j'ai fais quelques recherches et trouver diverses infos dont modifier le smb.conf

en ajoutant

Create mask = 0644

directory mask =0775

ainsi que

security = share

je précise que le dossier que je souhaite partager se trouve sur une partition Windows et que le probléme vient de là ...

puisque j'ai partager le dossier "HOME" et qu'il est parfaitement accessible

Aussi , meme a partir de mon poste donc de Linux quand je tente d'y acceder via samba (smb://...), je ne vois pas le dossier et j'ai un message d'erreur me disant :

"Impossible d'afficher le contenu de ce dossier. le dossier a peut-être était effacé recemment "

alors qu'il est accessible via l'arborescence du disque dur

j'ai passé 2h30 là donc j'en appel a votre aide :transpi:

Link to post
Share on other sites

dossier racine ??

heu le chemin en partant de la racine est :

media/sdb5/****/*****

le service est lancé au démarrage

du moins je pense ,je sais pas comment vérifié

Pour les service, avec cette commande tu peux vérifié que samba démarre bien :

sudo sysv-rc-conf

Pense à installer avec synaptic le paquet : sysv-rc-conf

Pour savoir si le paquet démarre bien faut regarder la colonne S, si tu as une croix c'est bon, autrement un coup de barre d'espace et il démarrera au prochaine boot :fou:

non moi je veux pas de mdp

J'ai jamais réussi sans mot de passe, enfin j'ai jamais cherché non plus :/ essai tu n'as rien à perdre :)

Link to post
Share on other sites

j'y arrive sans mdp ...

Ha oué j'avais mal lu dsl :arrow: Ça ressemble en effet à un problème de droit :fou:

Si la commande ne fonctionne pas tu peux essayer de le faire avec l'interface graphique (je suis plus habitué à ça perso) .

Là tu fais un coup de alt+F2 , gksu nautilus, tu cherches ton dossier, bouton droit, et tu met tout en lectur écriture ^^ Après je laisse tomber, je fais rarement du partage réseau :arrow:

Link to post
Share on other sites

Je connais pas Ubuntu, mais si ton dossier est un dossier NTFS, bonjour la galère. La lecture, ça va, l'écriture, c'est pas top.

Si c'est du FAT32, c'est mieux.

Peut-être que Ubuntu détecte ton dossier mais que c'est difficile d'y accéder.

Est-ce que tu as essayé de monter la partition au boot ? (Vérifie le fstab)

Je crains de ne pouvoir t'aider plus mon cher Typhoon. :transpi:

Link to post
Share on other sites
# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

# /dev/sda6

UUID=ec9c765f-15b6-4004-b1d5-bdce5f17b547 / ext3 defaults,errors=remount-ro 0 1

# /dev/sda5

UUID=F030B65030B61E12 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb1

UUID=B84CA99A4CA953C2 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb3

UUID=54C07207C071EF9A /media/sdb3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb5

UUID=CE4CB2EC4CB2CE89 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sda7

UUID=0c782a9e-ebd7-41ef-b426-b4453d5a4149 none swap sw 0 0

/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

/dev/ /media/floppy0 auto rw,user,noauto 0 0

voila mon fichier fstab

Link to post
Share on other sites
# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

# /dev/sda6

UUID=ec9c765f-15b6-4004-b1d5-bdce5f17b547 / ext3 defaults,errors=remount-ro 0 1

# /dev/sda5

UUID=F030B65030B61E12 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb1

UUID=B84CA99A4CA953C2 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb3

UUID=54C07207C071EF9A /media/sdb3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb5

UUID=CE4CB2EC4CB2CE89 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sda7

UUID=0c782a9e-ebd7-41ef-b426-b4453d5a4149 none swap sw 0 0

/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

/dev/ /media/floppy0 auto rw,user,noauto 0 0

voila mon fichier fstab

Salut Typhoon!

Bon on va bien trouver une solution à ton problème.

1- On va commencer par faire une sauvegarde de ton fichier fstab donc dans une console et en root tu tapes :

cp /etc/fstab /etc/fstab.old

de cette manière on fait une copie de fstab qui se nomme fstab.old, si on fait une grosse couille, on pourra facilement faire marche arrière.Note que sous ubuntu, tu devras faire précéder les commandes par sudo!

2- Puis on va modifier le fichier fstab en tapant

gedit /etc/fstab&

dans le terminal.

on va modifier le umask qui actuellement est donné à 007, autrement dit, les propriétaires et groupes ont tous les droits et les autres n'ont aucun droit donc pour les lignes qui contiennent ntfs on va mettre le umask à 002 de cette manière, les fichiers seront lisibles par tous!

le gid est donné à 46 chez toi, je ne sais pas qui appartient à ce group, pour le savoir on va encore taper une petite commande dans le terminal: cat /etc/group | grep 46

Cette commande te retournera toutes les lignes contenant 46, c'est à dire que si le gid146 ou 462 existe il te l'affichera mais je doute qu'il y ai beaucoup de lignes... Bref je pense que le gid (GroupID) 46 correspond au tien, m'enfin on va le mettre sur 100 qui doit être le groupe "users".

Selon le fstab, tes partitions windows sont montées avec les droits en écriture ce qui sur une partition ntfs est peu recommandé, on va rajouter une option "ro" pour read only.

On a donc plusieurs modifications qui sont notées dans l'exemple ci dessous:

# /dev/sda5
UUID=F030B65030B61E12 /media/sda5	 ntfs	defaults,[b]ro[/b],nls=utf8,umask=002,gid=100 0	   1
# /dev/sdb1
UUID=B84CA99A4CA953C2 /media/sdb1	 ntfs	defaults,[b]ro[/b],nls=utf8,umask=002,gid=100 0	   1
# /dev/sdb3
UUID=54C07207C071EF9A /media/sdb3	 ntfs	defaults,[b]ro[/b],nls=utf8,umask=002,gid=100 0	   1
# /dev/sdb5
UUID=CE4CB2EC4CB2CE89 /media/sdb5	 ntfs	defaults,[b]ro[/b],nls=utf8,umask=002,gid=100 0	   1

Une fois les modifs faites, enregistrer les modifications!!!

Maintenant on va s'attaquer au fichier de configuration de samba qui se nomme smb.conf et se trouve dans /etc/samba/ donc pas besoin de fermer gedit il suffit d'ouvrir le fichier concernant avec le même éditeur de texte.

On ouvre donc smb.conf et on cherche les lignes qui concernent les dossiers que tu partages, une fois trouvé on rajoute une option qui est:

guest = ok 

ça permet d'accéder à un répertoire partagé sans devoir se loguer. On n'oublie pas d'enregistrer la modif puis dans le terminal on relance samba en tapant :

/etc/init.d/samba stop

le service s'arrète, on le redémarre avec la commande suivante:

/etc/init.d/samba start

et là on retente d'accéder à ses répertoires partagés...

Dis moi ce que ça donne!

Link to post
Share on other sites
# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

# /dev/sda6

UUID=ec9c765f-15b6-4004-b1d5-bdce5f17b547 / ext3 defaults,errors=remount-ro 0 1

# /dev/sda5

UUID=F030B65030B61E12 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb1

UUID=B84CA99A4CA953C2 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb3

UUID=54C07207C071EF9A /media/sdb3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb5

UUID=CE4CB2EC4CB2CE89 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sda7

UUID=0c782a9e-ebd7-41ef-b426-b4453d5a4149 none swap sw 0 0

/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

/dev/ /media/floppy0 auto rw,user,noauto 0 0

voila mon fichier fstab

Heu, il te manque quelque chose à mon avis. T'as installé "smbfs" ? Parce que umask devraient être remplacé par fmask et dmask.

Link to post
Share on other sites
# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

# /dev/sda6

UUID=ec9c765f-15b6-4004-b1d5-bdce5f17b547 / ext3 defaults,errors=remount-ro 0 1

# /dev/sda5

UUID=F030B65030B61E12 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb1

UUID=B84CA99A4CA953C2 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb3

UUID=54C07207C071EF9A /media/sdb3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sdb5

UUID=CE4CB2EC4CB2CE89 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/sda7

UUID=0c782a9e-ebd7-41ef-b426-b4453d5a4149 none swap sw 0 0

/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

/dev/ /media/floppy0 auto rw,user,noauto 0 0

voila mon fichier fstab

Heu, il te manque quelque chose à mon avis. T'as installé "smbfs" ? Parce que umask devraient être remplacé par fmask et dmask.

Je dis peut etre une bétise mais, le directory mask et le file mask c'est pas dans smb.conf? et umask c'est dans fstab non?

demande d'infos pour mourir moins con :modoreussi:

Link to post
Share on other sites

Ton répertoire samba doit être monté pour être partagé. Donc c'est dans le fstab que ça se passe. De plus, fmask et dmask n'ont rien a voir avec umask. Ca équivaudrait plutot a chmod (pour les droits qui semble poser des soucis à Typhoon006), donc ça collerait. Mais bon, je suis pas spécialiste non plus. :modoreussi:

Link to post
Share on other sites

×
×
  • Create New...