Jump to content

easyphp, wamp... php incompatibles!


Recommended Posts

Bonjour a tous,

je suis actuellement sur un projet et j'ai meme pas commencer de l'installé que ca me prend déja la tete...

Et en plus comme c'est pas chez moi j'ai pas envi de tout foutre en l'air donc je prefre me référer a vos précieux conseil ^^

Je dois installer Apache MySQL et PHP oui d'accord autant prendre des packs.

Je vais pour installer wamp5 monsieur est passé au php5 et mon CMS n'en veut pas...

Donc j'installe easyphp1-8 avec php4 ouai youpi!

je lance mon installe de mon CMS et la il veut une version php4.4 au minimum et easyphp a une version php 4.3...

je vais m'arracher les cheuveux...

J'ai trouver une version de wamp qui possede un add on pour PHP4 alors je l'install mais je ne le vois pas...

Je souhaiterais un peu d'aide SVP avant de me mettre la tete dans les murs...

:D

Link to comment
Share on other sites

Bon, quelques petits éclaircissements:

EasyPHP est une bouze, on va pas tourner autour du pot, appelons un chat un chat!

Ce truc n'évolue quasiment plus, n'est jamais passé à PHP5 (vieux de 2-3 ans maintenant), et n'a même pas une version récente de PHP4 (comme tu as pu le constater)

Je te recommande plus wampServer qui est beaucoup mieux suivi par son créateur, ou l'install de php+apache+mysql morceau par morceau (plus long mais tu auras les versions les plus récentes à chaque fois)

Ensuite, ton pb est assez bizarre: PHP5 est normalement capable de faire tourner du code PHP4 (il y a cependant quelques changements pouvant entraîner des incompatibilités). Quel est ce CMS que tu utilises et quel(s) est(sont) le(s) message(s) d'erreur qu'il te renvoie lorsque tu veux l'exécuter avec PHP5?

Ensuite, ce CMS exige-t-il une configuration particulière? Car un gros pb avec php (et les codes déjà tout fait), c'est que certains exigent de régler d'une certaine façon le php.ini (et certains de ces réglages sont des abominations en ce qui concerne la sécurité :cartonrouge: )

Link to comment
Share on other sites

franchement je vois ce qu'il y a de compliqué à installer chacun séparement...

A une époque c'était la galère mais maintenant les instaleurs font tout le boulot ;)

La seule intervention manuelle c'est activer php dans apache... 2 lignes à récupérer sur google (apache + php -> rechercher) et à copier/coller dans la conf d'apache.... :fumer:

Link to comment
Share on other sites

Merci pour vos réponses j'utilise eZ publish (enfin j'essaye et il ne prend pas de php5 c'est écris en gros en gras quand on le lance)

On m'a demandé d'installer un pack car c'est plus pratique.

Je vais essayer d'installer wamp sinon je verrais si y'a des version moins recente qui prenne php 4.3

Merci a tous

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...