Jump to content

[SUSE] - Ati Linux Et La 3d


Recommended Posts

Bonsoir à tous.

Je tourne sous Linux SuSE 10.0 depuis quelques temps, j'ai appris énormément de choses grâce à Linux (en particulier à me débrouiller!) mais j'ai TOUJOURS été em...dé par la 3D avec ma carte ATI... Je ne pense pas être le seul alors j'espère que ceci pourra servir à ceux qui, comme moi se sont retrouvés à se casser la tête pour ne serait-ce que faire fonctionner GL-117...

Suse 10 = 10 points pour avoir la 3D!

Installation drivers ATI pour une carte ATI Radeon X700Pro avec SuSe 10.0

1 - Être sur d'avoir installé "kernel-source", "gcc" et "make" avec Yast ou Apt

2 - Télécharger l'installeur ATI à partir du site ATI : http://www.ati.com –> Drivers & Software –> Linux et l'enregistrer sur le bureau (cd /home/machintruc/Desktop). Le dernier s'appelle "ati-driver-installer-8.26.18-x86.run"

3 - Une fois ceci effectué, on prépare le kernel (pas nécessaire mais bon...)

# cd /usr/src/linux

# make mrproper

# make cloneconfig

# make modules_prepare

4 - Passer en root (su -) et lancer l'executable

# cd /home/machintruc/Desktop
# sh ./ati-driver-installer-8.26.18-x86.run

5 - Lancer la création d'un RPM pour une Suse 10.0 (en l'occurence SUSE100-IA32), le RPM devrait être enregistré automatiquement sous le même répertoire que l'installeur ATI. Le mien s'appelle "fglrx_6_8_0_SUSE100-8.26.18-1.i386.rpm"

6 - En mode console, passer en init 3

# init 3

7 - Se connecter en root et installer le driver

# cd /home/machintruc/Desktop
# rpm -Uvh fglrx_6_8_0_SUSE100-8.26.18-1.i386.rpm

8 - Lancer l'utilitaire Sax2

# sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

9 - Accepter les réglages par défaut ou alors les modifier si besoin.

10 - Repasser en mode graphique

# init 5

puis redémarrer!

Pour vérifier que tout fonctionne, une fois redémarré, lancer quelques tests en tant qu'utilisateur dans la console

~> fglrxinfo

~> glxgears ( simple test 3D OpenGL)

J'ai enfin pu mettre un bel économisateur d'écran qui ne saccade plus et mes vidéos tournent nickel

4785b90fadefdfaeb6efe8a88a4c4924.png

Le grand soulagement vient de cette page internet :

http://linux.wordpress.com/2005/10/11/suse...s-installation/

Sans cet article je serais encore en train de galérer...

Link to comment
Share on other sites

Sympa tout ca :arrow:

Ca doit etre valable pour une autre distrib non?

Et un p'tit plus pour ton tuto serait de mettre ~ a la place de /home/machintruc car le ~ représente le home de l'utilisateur en cours :arrow:

Oui effectivement c'est valable pour d'autres distributions, au moins celles mentionnées dans l'install ATI... Pour les distros RedHat et SuSe, il y a juste à selectionner la bonne dans la liste, pour les autres, c'est un poil plus compliqué... mais c'est expliqué dans l'installeur.

Par contre j'ai pas tout compris pour le ~ à la place de /home/machintruc... En fait pour ce genre de commandes je me mets toujours en root parce que de toute façon il va finir par me le demander à un moment où un autre... D'où le cd /home/machintruc :chinois:

Merci en tout cas pour le feedback.

Link to comment
Share on other sites

Salut,

en fait ta méthode est assez connue pour les utilisateurs de suse (c'est la page que j'ai utilisé moi aussi), mais elle ne fonctionne pas chez tout le monde (pour preuve les nombreux posts sur les forums alionet, juste après les tuto d'installation de driver ati). D'ailleurs chez moi ça ne marchait pas... :keskidit:

Sinon, c'est une bonne idée de la mettre sur pcINpact. Peut etre faudrait il la déplacer vers un tuto suse ou opensuse?

A noter qu'à partir de suse 10.1 on peut aisément remplacer le point n°8 (Lancer l'utilitaire Sax2)

par

# sax2 -r -m 0=fglrx

Pour les autres distributions, certains points sont à modifier, surtout la méthode avec sax2 (propre à suse), qu'il faut remplacer par l'utilitaire aticonfig --initial ..... afin de modifier le fichier xorg.conf

On peut aussi remplacer la commande rpm par une autre, pour ceux que ça tente.

Pour MoOstick, maintenant que ta 3D fonctionne, tu peux essayer de faire tourner xgl... :yes:

tu verras, c'est vraiment :transpi:

Link to comment
Share on other sites

Ce qui pourrait être très cool c'est que celui qui a une autre méthode la mette à la suite comme ça ceux qui sont confrontés à ce problème pourront essayer les différentes méthodes jusqu'à ce que ça marche.

Juste une idée comme ça...

@ styx2 : ça se trouve sur yast Xgl? et ça se lance comment? ça me tente bien du peu que j'ai lu dessus...

Link to comment
Share on other sites

Pour suse 10.0 je ne sais pas trop, par contre, pour la 10.1, c'est déjà sur le dvd, et on trouve des mises à jour à l'adresse suivante par exemple

http://software.opensuse.org/download/Comp...E_Factory/i586/

Pour le lancer, j'ai choisi une méthode donnée dans un tuto ubuntu qui me permet de démarrer soit kde classique, soit en xgl+compiz, au choix.

Dans ton cas (suse 10.0), vas faire un tour sur

http://en.opensuse.org/Using_Xgl_on_older_...s_of_SUSE_Linux

ils expliquent ce qu'il faut installer...

bon courage

Link to comment
Share on other sites

  • 1 month later...

Bonsoir à tous,

c'était trop beau, j'avais la 3D activée sous Suse, je pouvais regarder des films et tout et tout... Mais j'ai remarqué depuis quelque temps que mon économisateur d'écran était un peu saccadé... Et j'avais un beau MESA écrit à la place de RADEON X700 dans l'utilitaire ATI. J'ai du faire la mise à jour du kernel qui m'a shooté ma config...

Alors la question est : peut-on refaire un reglage tout propre d'origine sans fglrx, tout remettre à zéro et réinstaller les drivers ATI avec ma belle méthode?

Merci et bonne soirée

Link to comment
Share on other sites

Bonsoir à tous,

c'était trop beau, j'avais la 3D activée sous Suse, je pouvais regarder des films et tout et tout... Mais j'ai remarqué depuis quelque temps que mon économisateur d'écran était un peu saccadé... Et j'avais un beau MESA écrit à la place de RADEON X700 dans l'utilitaire ATI. J'ai du faire la mise à jour du kernel qui m'a shooté ma config...

Alors la question est : peut-on refaire un reglage tout propre d'origine sans fglrx, tout remettre à zéro et réinstaller les drivers ATI avec ma belle méthode?

Merci et bonne soirée

J'avais eut le même souci sous suse 10.0 avec un nouveau noyau. Pour moi la solution avait été un retour à une version du noyau pour lequel la 3D fonctionnait. Et surtout ne pas oublier de réinstaller les sources correspondantes (tu l'avais bien fait après ta mise à jour?)

Sinon, tu peux toujours poster tes fichiers log, peut etre que quelqu'un pourra mieux t'aider.

Link to comment
Share on other sites

Bonsoir à tous,

c'était trop beau, j'avais la 3D activée sous Suse, je pouvais regarder des films et tout et tout... Mais j'ai remarqué depuis quelque temps que mon économisateur d'écran était un peu saccadé... Et j'avais un beau MESA écrit à la place de RADEON X700 dans l'utilitaire ATI. J'ai du faire la mise à jour du kernel qui m'a shooté ma config...

Alors la question est : peut-on refaire un reglage tout propre d'origine sans fglrx, tout remettre à zéro et réinstaller les drivers ATI avec ma belle méthode?

Merci et bonne soirée

J'avais eut le même souci sous suse 10.0 avec un nouveau noyau. Pour moi la solution avait été un retour à une version du noyau pour lequel la 3D fonctionnait. Et surtout ne pas oublier de réinstaller les sources correspondantes (tu l'avais bien fait après ta mise à jour?)

Sinon, tu peux toujours poster tes fichiers log, peut etre que quelqu'un pourra mieux t'aider.

Merci styx, du coup , j'ai fait plus radical encore... J'ai réinstallé... :pleure:

Et je ferais plus gaffe lors de la prochaine mise à jour...

C'est chiant quand même tout ça...

Faut peut-être que je mette [Résolu]?

Link to comment
Share on other sites

Sinon, si tu as une X700, tu as essayé les drivers libres radeon?

Drivers Radeon

Même si ce n'est pas encore très stable, ça passe sur les r300 (95xx à 98xx) et r400 (X17xx et X18xx)...

Il leur manque quelques trucs (transparence composite et sortie TV, mais je passe de la première et je passe par un convertisseur pour la deuxième), mais ils permettent d'avoir de l'accélération 3D, notamment en bi-écran, l'overlay xVideo...

Moyennant X.org-7.1, ils m'ont permis de faire du tri-écran PCI+AGP, chose impossible avec les drivers proprios...

Un howto assez simple pour Gentoo est disponible là : Howto radeon

Link to comment
Share on other sites

  • 4 months later...

UPDATE !

Du temps a passé et depuis je suis passé sous openSUSE 10.2 (et re-galère avec ATI...)

Du coup j'ai trouvé ça sur Internet :

(merci linux-facile pour le super blog!)

Installer les Drivers ATI pour un X200M sur Suse 10.2

Rappellez vous, hier, j' ai passé ma journée à tester Suse 10.2 et j' étais gêné de ne pas avoir d' accélération graphique et de ne pas bénéficier des effets de bureau 3D livrés avec cette version de Suse ...

Finalement, j' ai réussi à installer l' accélération 3D avec les derniers drivers ATI ... j' ai choisi de vous délivrer la façon de procèder ...

Tout d' abourd, rendez vous dans l' installateur de paquetages Yast et recherchez et installez les paquets suivants : "gcc", "kernel-source", "make".

maintenant ouvrez un terminal et tapez ceci :

cd /usr/src/linux && sudo make mrproper && sudo make cloneconfig && sudo make modules-prepare

ensuite

sudo make clean

on enleve les anciens drivers ATI si ils sont installés

sudo rpm -e $(rpm -qa | grep fglrx)

maintenant, on revient dans le repertoire /home

cd

on télécharge les derniers drivers ATI

wget --no-check-certificate https://a248.e.akamai.net/f/674/9206/0/www2...-x86.x86_64.run

maintenant on crée le paquet .rpm du driver ATI

sudo sh ./ati-driver-installer-8.32.5-x86.x86_64.run --buildpkg SuSE/SUSE102-IA32

une fois que le paquet est créé, on l' installe avec cette commande :

sudo rpm -ihv *rpm

maintenant nous allons éditer ld.so.conf

kdesu kate ld.so.conf

et nous y ajoutons à la première ligne du fichier et ensuite on n' oublie pas d' enregistrer le document :

/usr/lib/fglrx/lib

maintenant nous allons éditer le xorg.conf à la main car aticonfig a tendance à mettre le bordel dans le fichier xorg...

kdesu kate xorg.conf

nous allons dans la section "modules" et nous y ajoutons la ligne :

Load "dri"

nous allons dans la section "device" et à la ligne "driver", nous remplacons "ati" ou "radeon" par "fglrx"

toujours dans la section device nous ajoutons les deux lignes suivantes en dessous de "driver" et de "BusID"

Option "UseInternalAGPGART" "no"

Option "kernelModuleParm" "agplock=0"

maintenant on se rend dans la section "extensions" et on y ajoute (avant "endsection").

Option "Composite" "off"

maintenant vous devez rebooter pour bénéficier de l' accélération graphique ...

Et ça a marché sauf que la version des pilotes décrite ici n'est plus la bonne, mais en remplaçant par les actuels ça marche super bien et j'ai mes effets de bureau..

Que ça serve!

Link to comment
Share on other sites

  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...