Jump to content

[Debian] nagios et virtual host


Recommended Posts

bonjour à tous,

j'ai installé il y a peu de temps un serveur sous Debian 2.6.12-2-686

je souhaite mettre en place un système de supervision, ainsi qu'un intranet pour mon service 8):-D

aussi, j'ai pensé utiliser cacti pour ses stats d'utilisation et nagios pour détecter la connectivité des serveurs sur mon réseau local :francais:

pour la partie intranet, j'ai pensé installer un CMS (Content Management System) qui s'appelle Joomla (anciennement Mambo) et qui a un peu le meme fonctionnement que Spip pour ceux qui connaissent :yes:

sachant que Cacti, Nagios et Joomla sont basés sur Apache, j'ai d'abord installé le package Apache2 sur ce serveur en faisant un apt-get install apache2

jusque là tout va bien :yes:

ce que j'aimerais faire, c'est que par exemple, les utilisateurs atteignent via une interface web, l'outil de supervision nagios, cacti et mon intranet, en saisissant dans la barre d'adresses :

cacti.mondomaine.com

nagios.mondomaine.com

www.mondomaine.com

pour résoudre la zone mondomaine.com, j'ai installé un serveur DNS (Bind9) en faisant un apt-get install bind9

ce service DNS tourne aussi sur le meme serveur :sucre:

j'ai déjà renseigné tous les fichiers nécessaires au serveur DNS pour la résolution de ma zone, à savoir les fichiers :

named.conf

db.mondomaine.com

db.mondomaine.com.inv --> pour la résolution inverse :yes:

j'aimerais savoir comment, à l'aide des virtual host, configurer mon fichier /etc/apache2/httpd.conf pour répondre aux critères cités précédemment ? :-D

faut-il créer des interfaces virtuelles pour que chaque service (cacti, nagios et joomla) correspond à une seule adresse IP ? est-ce nécessaire ? :reflechis:

dernière question :oops: :

j'aimerais aussi que mon domaine soit reconnu par les utilisateurs d'un autre réseau que le mien

j'ai déjà fait déclarer ma zone DNS sur le serveur DNS autoritaire de l'autre réseau

j'ai aussi ouvert les flux sur le Firewall interconnecté entre mon réseau et l'autre réseau pour autoriser le flux udp sur le port 53 vers ce serveur

me manque t-il quelque chose d'autre à faire ? est-ce que la résolution va pouvoir se faire lorsque l'utilisateur va saisir par exemple nagios.mondomaine.com dans la barre d'adresses ?

en tout cas, au niveau du ping, ça marche lorsque je fais toto.mondomaine.com

je suis conscient que ça fait beaucoup de questions et je vous remercie d'avance de votre aide :transpi::chinois:

encore merci de vos précisions :yes:

sunfun :byebye:

Link to comment
Share on other sites

Salut

Bon deja ça se jout sur le dns .

Il te faut créer les alias .

il te faut un fichier de conf par zone, puis dans ta zone declarer les machines avec leur nom dns .

de la tu créer un alias .

on a par exemple le domaine toto.titi ave la machine tata ça va donner un fichier de zone comme celui là :

$TTL	604800
@ IN SOA toto.titi. root.toto.titi. (
	  20041122   
	  604800	
	  86400	  
	  2419200   
	  604800 )   



			 NS	  toto.titi.   

tata		A	   192.168.0.1
www						  CNAME		tata
nagios						CNAME		  tata
cacti							CNAME			tata 

Dans mon exemple on aura : www.tata.toto.titi, nagios.tata.toto.titi et cacti.tata.toto.titi .

Apres il va te falloir trois vhost .

car dans Le virtualhost, il faut indiquer ceci :

...
ServerAlias   tata.toto.titi

...

Biensure cela ne suffit pas a faire un vhost, mais ces cette valeur qui va permettre de resoudre les nom .

pas besoin de faire un vhost avec comme serveralias www. tata.toto.titi

Par contre il en faut un avec cacti. tata.toto.titi et un aute avec nagios. tata.toto.titi .

Ensuite debian preconfigure les paquets comme cacti ou nagios, il te faut aller dans /etc/apache2/conf.d et copier le contenu des fichier des conf de nagios et cacti dans leur vhost respectif .

Puis du deplace les fichiers de conf pour qu'apache ne les utilise plus .

Apres avec redemarrer apache tu devrais avoir un truc a peu pres bon.

Mais ça devrais marcher :) .

a+

Link to comment
Share on other sites

bonjour zoto,

merci de tes confirmations ;)

mis à part la partie configuration des fichiers /etc/apache2/httpd.conf personnalisés, j'aurais suivi la meme procédure

et notamment DNS :byebye:

par contre, peux-tu m'expliquer pourquoi il n'y a pas nécessité de créer des adresses ip virtuelles associées à chaque service ? :-D

par exemple

192.168.0.2 pour www
192.168.0.3 pour nagios
192.168.0.4 pour cacti

si ce n'est pas nécessaire, j'aimerais savoir dans quels cas est-ce qu'il est nécessaire d'utiliser des adresses ip virtuelles ? merci de vos précisions :zarb::byebye:

sunfun :yes:

Link to comment
Share on other sites

Salut

il n' y a pas besoins .

Le but des vhost c'est de pouvoir mettre plusieur site sur la meme ip :) .

c'est apache qui fait sa tambouille apres .

Quand on lui demande tel ou tel site il se debrouille avec .

Au niveau dns bind se depatouille aussi avec les alias

Pense aussi aux zones inverses :)

a+

PS : sinon les ip virtuel, en fait des alias dans la conf de la carte réseaux, peut etre util si derriere tu gére les acces au site en te basant sur les ip .

Du style l'ip 192.168.0.7 n'est accessible que par l'admin dont le post possede l'adresse ip 192.168.1.8 .

TU peux utiliser le filtrage sur un firewall couplet a une restriction d'acces dans apache .

Link to comment
Share on other sites

Le but des vhost c'est de pouvoir mettre plusieur site sur la meme ip :) .

c'est apache qui fait sa tambouille apres .

Quand on lui demande tel ou tel site il se debrouille avec .

Au niveau dns bind se depatouille aussi avec les alias

Pense aussi aux zones inverses :)

bonjour zoto,

merci de tes précisions :transpi:

d'où justement cette question sur la différence entre les virtual host et les ip virtuelles

maintenant, si apache peut se débrouiller tout seul avec les virtual host ça m'arrange

il me suffira juste de renseigner mon fichier /etc/bind9/named.conf pour la résolution DNS :chinois:

j'ai pensé aussi à la résolution inverse, merci de la suggestion :p

PS : sinon les ip virtuel, en fait des alias dans la conf de la carte réseaux, peut etre util si derriere tu gére les acces au site en te basant sur les ip .

Du style l'ip 192.168.0.7 n'est accessible que par l'admin dont le post possede l'adresse ip 192.168.1.8 .

TU peux utiliser le filtrage sur un firewall couplet a une restriction d'acces dans apache .

ok je vois ce que tu veux dire :transpi:

dans mon cas, y a-t-il réellement besoin d'ip de management ?

pour ma part je ne pense pas parce que j'ai besoin que les gens agissent sur l'interface web

le reste, je m'en moque vu que je serai en direct sur le serveur (avec la meme ip disons que celui de www) et puis je ferai mes modifs tranquillou :yes:

merci pour tes réponses zoto :yes:

sunfun ;)

Link to comment
Share on other sites

Salut

Pense aussi au ssl .

C'est pas tres dur a mettre en place, mais au moins ça protége tes mots de passe .

Si il faut je t'aiderais a le mettre en place .

De plus n'oublie pas de limiter l'acces qu'au personnes autorisées .

Un peu de securité ne peu faire de mal .

a+

Link to comment
Share on other sites

Pense aussi au ssl .

C'est pas tres dur a mettre en place, mais au moins ça protége tes mots de passe .

Si il faut je t'aiderais a le mettre en place .

De plus n'oublie pas de limiter l'acces qu'au personnes autorisées .

Un peu de securité ne peu faire de mal .

bonsoir,

pour les accès limités, j'ai pensé à utiliser htaccess. ;)

pour le ssl, j'ai une doc qui permet de le mettre en place, mais je n'ai pas encore essayé de coupler apache et ssl

je ne manquerai pas de faire appel à tes connaissances pour cela :p:oops:

merci encore :fumer:

sunfun :smack:

Link to comment
Share on other sites

salut

Pour limiter l'aces tu as le htacces, c'est bien ça met un mot de passe .

Mais si comme moi, tu a une crise de parano aigue tu peux aussi n'uatoriser que certaines ip a se connecter grace a allo/deny .

Pense aussi a forcer les gens a utiliser le ssl .

c'est assez simple il faut qu'apache redirige tous ce qui viens du port 80 ver le 443

a+

Link to comment
Share on other sites

bonjour,

tjrs dans le meme ordre d'idée, j'ai mis en place un serveur DNS sur cette machine

une question :

à chaque fois qu'on modifie le fichier de zone, combien de temps faut-il attendre pour que la zone soit reconnue ?

voici mon fichier de conf :


$TTL	86400
@	   IN	  SOA	 mondomaine.com. root.mondomaine.com.  (
	2004050103  ; Serial
	3600	; Refresh
	900	; Retry
	608400   ; Expire
	38400 )  ; Minimum

faut il attendre la fin du TTL ? ça fait super long non ?

merci de vos réponses

sunfun ;)

Link to comment
Share on other sites

bonjour,

tjrs dans le meme ordre d'idée, j'ai mis en place un serveur DNS sur cette machine

une question :

à chaque fois qu'on modifie le fichier de zone, combien de temps faut-il attendre pour que la zone soit reconnue ?

voici mon fichier de conf :


$TTL	86400
@	   IN	  SOA	 mondomaine.com. root.mondomaine.com.  (
	2004050103 ; Serial
	3600; Refresh
	900; Retry
	608400  ; Expire
	38400 ) ; Minimum

faut il attendre la fin du TTL ? ça fait super long non ?

merci de vos réponses

sunfun :reflechis:

bon en fait, il y avait juste un souci dans le fichier de configuration

il manquait un ;

:|:|

Link to comment
Share on other sites

bonjour zoto,

j'arrive à la partie où il faut mettre en place du ssl et du virtual host :sucre:

alors j'ai déjà créé 3 virtual host dans le répertoire /etc/apache2/sites-available en me basant sur le fichier default déjà présent dans ce répertoire

du coup j'en ai créé 3 nouveaux :

- intranet

- nagios

- cacti

voici le contenu de intranet par exemple :


NameVirtualHost intranet:443
<VirtualHost intranet:443>
	ServerAdmin webmaster@mondomaine.com
	SSLEngine on

	DocumentRoot /var/www/intranet/
	<Directory />
			Options FollowSymLinks
			AllowOverride None
	</Directory>
	<Directory /var/www/intranet/>
			Options Indexes FollowSymLinks MultiViews
			AllowOverride None
			Order allow,deny
			allow from all
			# This directive allows us to have apache2's default start page
			# in /apache2-default/, but still have / go to the right place
			#RedirectMatch ^/$ /apache2-default/
	</Directory>

 .....
 .....

	ErrorLog /var/log/apache2/error_intranet.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access_intranet.log combined
	ServerSignature On

Alias /doc/ "/usr/share/doc/"
.....
.....
</VirtualHost>

est-ce que jusque là, le code est bon ? je ne t'ai mis que les principales parties du fichier, le reste est inchangé, ce sont que des balises scripts alias auxquelles je n'ai pas touché :yes:

dans le fichier /etc/apache2/httpd.conf, j'avais rajouté les 2 lignes suivantes :


#NameVirtualHost 10.104.23.22:80
#NameVirtualHost 10.104.23.22:443

puis je les ai décommentées, à cause du message d'erreur suivant :

phoenix:/etc/apache2# /etc/init.d/apache2 start
Starting web server: Apache2[Sat Jul 29 10:08:27 2006] [warn] NameVirtualHost 10.104.23.22:80 has no VirtualHosts
[Sat Jul 29 10:08:27 2006] [warn] NameVirtualHost 10.104.23.22:443 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs

j'ai ajouté dans le fichier /etc/apache2/ports.conf la ligne

 Listen 443 

pour le SSL :zarb:

j'ai suivi aussi le tuto de ce site http://www.destination-linux.org/Serveur-W...L-Virtual-Hosts

j'ai surement dû louper une étape pour mettre en place le ssl et le virtual host :byebye:

alors si tu peux m'expliquer la procédure à suivre pour faire ça correctement, ça serait sympa :chinois:

merci d'avance de ton aide :yes:

sunfun :non:

Link to comment
Share on other sites

bonjour à tous,

voici la manipulation que j'ai trouvé incohérente


phoenix:/etc/apache2/sites-available# apache2ctl graceful
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs

phoenix:/etc/apache2/sites-available# ps -ef | grep apache2
www-data  8986	 1  0 Jul28 ?		00:00:00 /usr/sbin/apache2 -k start -DSSL
root	 11060 10867  0 14:36 pts/0	00:00:00 grep apache2
phoenix:/etc/apache2/sites-available#

pouvez-vous m'aider s'il vous plait ?

merci :p

sunfun :chinois:

Link to comment
Share on other sites

Salut

Étant tres occupé j'ai pas pu te répondre plus tot .

En fait c'est plus simple que ça pour le ssl :craint:

il faut d'une part generer le certification ssl .

apache2 possede, du moins sous debian, une commande :

apache2-ssl-certificate .

Une fois cette commandes lancée, quelques question te seront posées pour generer un certificat ssl .

Apres cela il faut editer le fichier /etc/apache2/ports.conf .

Il faut y ajouter Listen 443 .

De là, ton serveur apache saura qu'il doit aussi etre en ecoute sur le port 443 .

De là tu va dans /etc/apache2/mod-aviable, tu fait a2enmod ssl

Ensuite, tu va dans site-aviable, tu edite ton default, dedans tu créer deux virtual host .

Un pour le http, l'autre pour le https .

cela doit donner quelque chose comme cela :


NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
	Options Indexes MultiViews FollowSymLinks
	AllowOverride None
	Order deny,allow
	Deny from all
	Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

NameVirtualHost *:443
<VirtualHost *:443>
ServerAdmin webmaster@localhost
SSLEngine On
SSLCertificate /etc/apache2/ssl/apache.pem
DocumentRoot /var/www
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
	Options Indexes MultiViews FollowSymLinks
	AllowOverride None
	Order deny,allow
	Deny from all
	Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

Pour tes nouveaux vhost, par exemple pour nagios ça donnera ça :


<VirtualHost *:443>

mes directives ici 

</Virtualhost>

Avec ça, ça devrait etre bon .

Pour la redirection du http cers le https, je vais fouiller dans mes archives :transpi:

Je te donne ça plus tard ce week end :ouioui:

a+

Link to comment
Share on other sites

bonjour zoto,

c'est pas grave si tu n'as pas pu me répondre plus tot :ouioui:

ok pour la partie ssl et pour le code dans le fichier /etc/apache2/sites-available/default :yes:

Par contre, je n'ai pas très bien saisi ce que tu as voulu me dire par "mes directives ici" dans le code ci-dessous :


<VirtualHost *:443>

mes directives ici 

</Virtualhost>

que dois-je faire si je dois faire la meme chose pour nagios, cacti et www par exemple ? :roll:

est-ce que je dois me baser sur le meme modèle que le fichier /etc/apache2/sites-available/default par exemple ?

est-ce que ça ressemble à ceci :

NameVirtualHost nagios:80
<VirtualHost nagios:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/nagios
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/nagios/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

....

ErrorLog /var/log/apache2/error_nagios.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access_nagios.log combined
ServerSignature On

....

</VirtualHost>

NameVirtualHost nagios:443
<VirtualHost nagios:443>
ServerAdmin webmaster@localhost
SSLEngine On
SSLCertificate /etc/apache2/ssl/apache.pem
DocumentRoot /var/www/nagios
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/nagios/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

....

ErrorLog /var/log/apache2/error_nagios.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access_nagios.log combined
ServerSignature On

......

</VirtualHost>

est-ce bien nagios que je dois mettre à la place de * ou est-ce que je dois mettre nagios.mondomaine.com par exemple ? :yes:

ensuite, il y a une partie dans un de tes posts précédents sur lequel j'aimerais revenir, le voici :

Apres il va te falloir trois vhost --> ça j'ai bien saisi, merci encore :yes:

car dans Le virtualhost, il faut indiquer ceci :


...
ServerAlias   tata.toto.titi

...

ou est-ce que je renseigne le paramètre ServerAlias ? dans quel fichier exactement ? :youhou:

dans mon fichier /etc/bind/db.mondomaine.com, j'ai mis ceci :


www			 IN	  CNAME   phoenix
nagios		  IN	  CNAME   phoenix
cacti		   IN	  CNAME   phoenix

ça doit permettre de faire les résolutions, mais je ne vois tjrs pas comment renseigner le champ ServerAlias :zarb:

ensuite, pour installer cacti et nagios, je pense que ça devrait aller :youhou:

mais pourquoi faut il que j'aille dans /etc/apache2/conf.d et copier le contenu des fichier des conf de nagios et cacti dans leur vhost respectif ? que veux tu dire par là ? :D:youhou:

pour rediriger le http sur du https, je crois qu'il faut faire comme ceci :


<Virtualhost 192.168.0.1:80>
	Redirect / https://www.mondomaine.com/
</Virtualhost>

merci d'avance de ton aide :yes:

sunfun :youhou:

Link to comment
Share on other sites

salut

la directive nagios:80 n'est pas bonne .

*:80 

serais plus adapté

De meme on ne remet pas NameVirtualHost dans les vhost autre que defaut .

one ne modifie pas le httpd.conf

Pour les directive c'est les valeurs comme "ServerName", "ServerAlias" .

En fait ce qui decrit ton vhost .

a+

Link to comment
Share on other sites

De meme on ne remet pas NameVirtualHost dans les vhost autre que defaut .

on ne modifie pas le httpd.conf

Pour les directive c'est les valeurs comme "ServerName", "ServerAlias" .

En fait ce qui decrit ton vhost .

bonsoir zoto,

pour les virtual host, j'ai ajouté ceci dans le fichier /etc/apache2/sites-available/nagios

ServerName nagios.mondomaine.com
ServerAlias nagios

ça semble bon ? ou pas ? :transpi:

désolé pour le httpd.conf :eeek2:

autre chose : voici la dernière erreur que j'ai trouvée :reflechis:

phoenix:/etc/apache2/sites-enabled# /etc/init.d/apache2 start
Starting web server: Apache2Syntax error on line 52 of /etc/apache2/sites-enabled/000-default:
Invalid command 'SSLCertificate', perhaps mis-spelled or defined by a module not included in the server configuration
phoenix:/etc/apache2/sites-enabled#

quand je regarde dans le fichier 000-default (d'ailleurs petite question : il vient d'où ce fichier ?), voici ce que je trouve à la ligne 52 :

SSLCertificate /etc/apache2/ssl/apache.pem

ce qui est bizarre, c'est que c'est le certificat ssl que j'ai généré avec la commande apache2-ssl-certificate

peux-tu m'aider s'il te plait ? :transpi::sucre:

merci beaucoup :yes:

sunfun :byebye:

Link to comment
Share on other sites

c'est parceque ce n'est pas placé au bon endroit :) .

Sinon met tes vhost ici je vais te les corriger ;)

bonjour zoto,

voici ce que j'ai mis dans le fichier /etc/apache2/sites-available/default :


NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin localhost@webserver

DocumentRoot /var/www
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
	Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
	Options Indexes MultiViews FollowSymLinks
	AllowOverride None
	Order deny,allow
	Deny from all
	Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

NameVirtualHost *:443
<VirtualHost *:443>
ServerAdmin localhost@webserver
SSLEngine On
SSLCertificate /etc/apache2/ssl/apache.pem
DocumentRoot /var/www
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
	# Uncomment this directive is you want to see apache2's
	# default start page (in /apache2-default) when you go to /
	#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
	Options Indexes MultiViews FollowSymLinks
	AllowOverride None
	Order deny,allow
	Deny from all
	Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

8):D:yes:

et voici ce que j'ai créé dans /etc/apache2/sites-available/nagios :


<VirtualHost *:80>
ServerAdmin localhost@webserver
ServerName nagios.mondomaine.com
ServerAlias nagios
DocumentRoot /var/www/nagios

ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

<Directory "/usr/local/nagios/sbin">
   Options ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /usr/local/nagios/etc/htpasswd.users
   Require valid-user
</Directory>

Alias /nagios /usr/local/nagios/share

<Directory "/usr/local/nagios/share">
   Options None
AllowOverride None
   Order allow,deny
   Allow from all
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /usr/local/nagios/etc/htpasswd.users
   Require valid-user
</Directory>
</VirtualHost>

<VirtualHost :443>
ServerAdmin localhost@webserver
ServerName nagios.mondomaine.com
ServerAlias nagios
SSLEngine On
SSLCertificate /etc/apache2/ssl/apache.pem
DocumentRoot /var/www/nagios

ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

<Directory "/usr/local/nagios/sbin">
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

Alias /nagios /usr/local/nagios/share

<Directory "/usr/local/nagios/share">
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

</VirtualHost>

je les ai tous les 2 créés dans /etc/apache2/sites-available :p

et bizarrement l'erreur m'indique que ça vient d'un fichier dans le répertoire /etc/apache2/sites-enabled :zarb:

un fichier 000-default que je n'ai moi meme pas du tout créé, et qui ressemble au contenu du fichier /etc/apache2/sites-available/default :zarb:

merci de ton aide :yes:

sunfun :byebye:

Link to comment
Share on other sites

bonjour à tous,

j'ai désactivé les lignes SSL de mes fichiers /etc/apache2/sites-available/default et /etc/apache2/sites-enable/000-default

mais j'ai toujours ces erreurs :

phoenix:/etc/apache2/sites-enabled# /etc/init.d/apache2 stop
Stopping web server: Apache2httpd (pid 8798?) not running
.
phoenix:/etc/apache2/sites-enabled# /etc/init.d/apache2 start
Starting web server: Apache2(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
phoenix:/etc/apache2/sites-enabled#

est-ce que quelqu'un sait pourquoi ? :arrow:

merci de votre aide :arrow:

sunfun :arrow:

Link to comment
Share on other sites

bonjour à tous,

je viens de changer le fichier /etc/apache2/ports.conf et j'ai donc ceci maintenant

Listen 80
Listen 443

SSLEngine On
SSLCertificateFile /etc/apache2/ssl/phoenix.cert
SSLCertificateKeyFile /etc/apache2/ssl/phoenix.key

mais ça me génère tjrs la meme erreur

phoenix:/etc/apache2# apache2ctl graceful
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
phoenix:/etc/apache2#

du coup, j'ai tenté de désintaller le package apache2 et de le réinstaller

mais lorsque j'ai fait ça, j'obtiens l'erreur suivante :

Starting web server: Apache2invoke-rc.d: initscript apache2, action "start" failed

phoenix:/# /etc/init.d/apache2 stop
Stopping web server: Apache2httpd (pid 8798?) not running
.
phoenix:/# /etc/init.d/apache2 start
Starting web server: Apache2phoenix:/# ps -ef | grep apache2
phoenix:/#

pouvez-vous m'aider s'il vous plait ? :francais:

je ne sais pas comment trouver la solution à mon probleme :p:-D

merci d'avance :yes:

sunfun :-D

Link to comment
Share on other sites

bonjour,

j'ai un souci sur apache2 :chinois: et à vrai dire, en fait, c'est très bizarre :chinois:

j'ai recompilé apache2 en téléchargé le package httpd sur www.apache.org :roll:

j'ai recréé le script de démarrage, recréé les liens symboliques pour que ça démarre au boot de debian

j'ai utilisé la commande update-rc.d apache2 defaults :yes:

lorsque je fais un ps -ef | grep apache, je vois bien que apache est démarré :

phoenix:/# ps -ef | grep apache
root	  3935	 1  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	3936  3935  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	3937  3935  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	3938  3935  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	3939  3935  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	3940  3935  0 Aug03 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	6209  3935  0 00:52 ?		00:00:00 /usr/local/apache2/bin/httpd -k start

quand j'essaie d'utiliser la commande apache2ctl graceful, voici ce que j'obtiens :

phoenix:/# apache2ctl graceful
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
phoenix:/#

pouvez-vous me dire où se trouve mon erreur ?

je poste mon erreur ici, car c'est tjrs sur le meme serveur sur lequel je veux faire cohabiter nagios, cacti et un intranet via un CMS nommé joomla :transpi::yes:

merci de votre aide :transpi:

sunfun :yes:

Link to comment
Share on other sites

bonsoir zoto,

j'ai résolu une partie de mon probleme, à savoir la partie SSL :mdr2:

en fait, je n'écoute plus que sur le port 443 dans le fichier /etc/apache2/ports.conf

ainsi, je n'ai plus le message d'erreur pour le port 80

par contre, j'aimerais savoir un truc :p

j'aimerais savoir comment fonctionne les processus/demons et notamment nagios

en fait, je me suis basé sur ce tutorial pour l'installation de nagios:

http://www.debianhelp.co.uk/nagios.htm

et j'ai aussi utilisé le script de démarrage en annexe 14 (fin du document) de ce tutorial :

http://www.l0t3k.net/biblio/linux/debian/f...ian-secinst.txt

j'ai aussi créé les liens symboliques en faisant update-rc.d init_nagios.sh defaults :transpi:

j'aimerais savoir à quoi correspond un UID avec comme valeur #-1 :mdr2:

voici ce que me renvoie un ps -ef

phoenix:/home/swong# ps -ef
UID		PID  PPID  C STIME TTY		  TIME CMD
root	  1972	 1  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	1973  1972  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	1974  1972  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	1975  1972  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	1976  1972  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
daemon	1977  1972  0 20:01 ?		00:00:00 /usr/local/apache2/bin/httpd -k start
....
#-1	   2061	 1  0 20:01 ?		00:00:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg

nagios semble bien démarré, jusque là pas de souci

mais comment se fait-il que ça soit avec cet UID, j'aurais pensé plutot nagios comme UID ? :gne:

ensuite, par rapport à la commande apache2ctl graceful, est-il possible de la faire exécuter au boot de la debian

et que ce script de démarrage saisisse automatiquement le mot de passe saisi lors de la génération du certificat SSL ?

merci de ton aide :mdr:

sunfun 8)

Link to comment
Share on other sites

  • 3 weeks later...

bonjour à tous,

j'ai pu installer nagios 2.5 sur debian :mad2:

en fait, pour changer l'UID, il fallait démarrer le démon nagios sous l'utilisateur nagios

à ce propos, j'ai une question :

maintenant que nagios 2.5 est installé manuellement, je suis obligé de démarrer le processus nagios par la commande /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg

je pense qu'il est possible de l'optimiser avec un fichier genre /etc/init.d/nagios par exemple, qui permet de faire les commandes nagios start/stop/restart

j'ai donc regardé dans le fichier /etc/init.d/nagios qui a été créé lorsque j'avais installé nagios-text

par contre, je me heurte à un probleme

celui du fichier /var/run/nagios/nagios.pid

en effet, il n'existe pas et sans ce fichier, le démon ne peut pas se lancer (dites moi si je me trompe)

du coup, comment faire ? :transpi::mdr:

j'ai donc voulu le créer en faisant un vi /var/run/nagios/nagios.pid, mais il me dit que je n'ai pas les droits d'écriture sur le fichier, après que j'ai mis le numéro de processus dans ce fichier

merci de votre aide :yes:

sunfun :yes:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...