Jump to content

Archived

This topic is now archived and is closed to further replies.

Killator

Ubuntu dapper, NetInstall & système de fichier...

Recommended Posts

Salut à tous...

Je suis en chantier depuis 1 semaine... A part mon iBook, ya pu un ordi qui tourne correctement chez moi :p

En effet, j'ai décidé sur un coup de tête de quitter Windows et d'installer Ubuntu sur ma station de travail et mon serveur.

Pas de soucis pour mon serveur: config simple, un seul disque dur IDE...

Mais alors, pour ma station de travail, c'est une autre histoire....

Les détails de la config se trouve dans mon profil, mais pour faire simple j'ai 4 périph SATA branchés sur une carte mère P4C800E-dlx:

- Un DD 250Go pour le stockage

- Un graveur DVD Plextror

> Ils sont branchés sur le SouthBridge (ICH5)

- 2 DD de 80Go pour le "system"

> Ils sont branchés sur le controleur Promise intégré de la CM.

Ce controleur FAKE-RAID gérait les 2 disques dans un Array RAID0 qui marchait très bien sous windows...

Pour Ubuntu, j'ai donc détruit mon Array afin de laisser le noyaux Linux s'occuper des disques. A partir de la, j'ai fait une série d'essais pour tenter d'installer Ubuntu directement avec une config équivalente mais sans succés...

Depuis quelques jours, je tente de faire plus simple, en utilisant les disques normalement... Seulement, ça marche pas bcp mieux... :eeek2:

Le seul disque proprement bootable est le 250 Go. Je le partitionne donc comme cela:

/boot - ext3 - 1Go principale

/data - ext3 - 249Go logique

Le 1er disque de 80:

/ - ext3 - 27 Go principale Bootable

/swap - swap - 3 Go logique

/home - ext3 - 50 Go logique

Le 2eme disque de 80:

/temp - ext3 - 80Go principale

Seulement voilà Grub plantouille ou ne trouve pas de point de montage... bref, la galere :roll:

Ai-je le droit de partitionner de la sorte ? de créer un /data et un /temp... ?

Merci pour vos réponses ! :vante:

:roule:

Link to post
Share on other sites

le partitionnement à l'air bon (même si perso, j'aurais mi la /home sur le premier disque, et je lui aurai laissé plus de place)

c'est quelle version de deb ?

une fois, j'ai tenté de passer à Etch, et impossible d'installer grub ou lilo, il ne trouvait pas le secteur 0, ou un truc du genre (ça fait déjà longtemps, et je suis retourné désespéré sous sarge)...

Link to post
Share on other sites

Les détails de la config se trouve dans mon profil, mais pour faire simple j'ai 4 périph SATA branchés sur une carte mère P4C800E-dlx:

- Un DD 250Go pour le stockage

- Un graveur DVD Plextror

> Ils sont branchés sur le SouthBridge (ICH5)

- 2 DD de 80Go pour le "system"

> Ils sont branchés sur le controleur Promise intégré de la CM.

Ce controleur FAKE-RAID gérait les 2 disques dans un Array RAID0 qui marchait très bien sous windows...

Pour Ubuntu, j'ai donc détruit mon Array afin de laisser le noyaux Linux s'occuper des disques. A partir de la, j'ai fait une série d'essais pour tenter d'installer Ubuntu directement avec une config équivalente mais sans succés...

bonjour lpimpti,

jusque là, tout semble correct dans tes démarches d'installation :p

Le seul disque proprement bootable est le 250 Go. Je le partitionne donc comme cela:

/boot - ext3 - 1Go principale

/data - ext3 - 249Go logique

Le 1er disque de 80:

/ - ext3 - 27 Go principale Bootable

/swap - swap - 3 Go logique

/home - ext3 - 50 Go logique

Le 2eme disque de 80:

/temp - ext3 - 80Go principale

j'ai un peu de mal à comprendre ici

en fait, tu démarres sur le disque de 250Go et ta partition de swap se trouve sur le disque de 80Go

je ne sais pas si ce partitionnement est faisable

je peux me tromper :roule:

j'aurais pensé plutot que la partition de swap se trouve sur le meme disque où se trouve la partition de boot :vante:

regarde sur ce lien

http://www.breizh-ardente.fr/dotclear/inde...-les-partitions

Seulement voilà Grub plantouille ou ne trouve pas de point de montage... bref, la galere :|

Ai-je le droit de partitionner de la sorte ? de créer un /data et un /temp... ?

normalement tu peux créer autant de point de montage que tu veux

mais de la sorte, j'en sais rien :eeek2:

pour ma part, j'aurais créé :

1) une partition de swap

2) une partition racine / en ext3

3) une partition /boot en ext3

4) et ensuite ce que tu veux, que ce soit /usr, /var, /tmp et /home, tjrs en ext3

les 3 premières, je les aurais mises sur le meme disque, parce que ça te permet de booter

mais bon, je ne suis moi meme pas expert en partitionnement, donc je préfère ne pas trop dire de bétises

logiquement, je le ferai comme ça

bon courage :|

sunfun :roll:

Link to post
Share on other sites

2 PArtitions a faire pas la peine de chercher midi a 14 heures ( ensuite tu peux avoir des partos suppl. de data )

- 1 / de mini 10 giga

- 1 Swap de mini 700 mo

Ensuite du peux te creer tes disques de data comme tu veux:

- /home/user/disque1 150 giga

- /home/user/disque2 150 giga

etc etc .

Link to post
Share on other sites
en fait, tu démarres sur le disque de 250Go et ta partition de swap se trouve sur le disque de 80Go

je ne sais pas si ce partitionnement est faisable

je peux me tromper :-D

j'aurais pensé plutot que la partition de swap se trouve sur le meme disque où se trouve la partition de boot :francais:

Seulement voilà Grub plantouille ou ne trouve pas de point de montage... bref, la galere :transpi:

Ai-je le droit de partitionner de la sorte ? de créer un /data et un /temp... ?

normalement tu peux créer autant de point de montage que tu veux

mais de la sorte, j'en sais rien :reflechis:

pour ma part, j'aurais créé :

1) une partition de swap

2) une partition racine / en ext3

3) une partition /boot en ext3

4) et ensuite ce que tu veux, que ce soit /usr, /var, /tmp et /home, tjrs en ext3

les 3 premières, je les aurais mises sur le meme disque, parce que ça te permet de booter

mais bon, je ne suis moi meme pas expert en partitionnement, donc je préfère ne pas trop dire de bétises

logiquement, je le ferai comme ça

Globalement avec GNU/Linux on peut mettre n'importe quelle partition sur n'importe quel disque, ça ne pose pas de pb...

genre :

/boot sur un disque (dison /dev/hdb1)

/ sur un autre (/dev/hdc2)

swap sur un autre (/dev/hdd3)

/home sur un autre (/dev/sda4)

/usr sur un autre (/deb/sdb5)

/tmp en ram

/machin n'importe où

/truc pareil

...etc...

et grub sur un dernier (hd0)

Et ça marche quand même! :chinois:

Ici ça a plutôt d'être l'installeur qui n'arrive pas à détecter tout comme il faut...

Link to post
Share on other sites

c'est quelle version de deb ?

Euh, bonne question... Je sais pas trop quoi te répondre (je débute, dsl)

Distrib: Ubuntu 6.06 LTS Dapper Drake

Noyau: 2.6.15-26-686

Je sais qu'Ubuntu est basée sur Debian mais selon quel paramètre ?

Sinon, je commence à voir un peu plus clair... J'ai encore fais 2 installs... Pour le fun... :chinois:

Le but était d'utiliser un système de fichier + simple... Juste pour voir...

Install #1:

Sys + Swap + Home sur le 250Go

/data sur un RAID0 logiciel de 160Go -> 2x80Go

=> Plantage lamentable au démarrage

Install #2:

Sys + Swap + Home sur le 250Go

/data1 sur un 80Go

/data2 sur un 80Go

=> Plantage lamentable au démarrage

Je commence à croire que l'utilisation de mes 2 disques de 80Go a travers le controleur Promise est impossible :-D

Que ça soit en mode RAID (sans array defini) ou en mode IDE, il me casse les couilles... :francais:

Inutile de vous dire que les installations faites en le désactivant en hard parfaitement. :reflechis:

(dans ce cas seul le disque de 250Go est accessible...)

Est-ce que ces nouveaux éléments vous inspire d'autre conseil ?

Link to post
Share on other sites
Est-ce que ces nouveaux éléments vous inspire d'autre conseil ?

Oui, si tu veux faire du raid logiciel, il faut désactiver complètement le raid des différentes cartes.

Link to post
Share on other sites

Oui, si tu veux faire du raid logiciel, il faut désactiver complètement le raid des différentes cartes.

C fait... J'ai bien saisi que mon controleur Promise ne servirai à rien... Tout sera géré à 100% par le noyaux linux...

J'ai donc détruit mon array (qui marchait sous windows), il me reste 3 possibilités dans le bios:

- OnBoard Promise Controleur: disabled, les disques de 80Go sont totalement innaccessibles.

- Enabled > Mode RAID, (ce que j'avais sous windows) il m'insulte en détectant les disques alors qu'il n'y a pas d'array dessus, et poursuit le démarrage... (Ubuntu voit les 2x80Go)

- Enabled > Mode IDE, il me liste les deux disques et poursuit (Ubuntu voit les 2x80Go)

Rien que là... Je dois choisir quelle option... :byebye:

:chinois:

Link to post
Share on other sites
Rien que là... Je dois choisir quelle option... :francais:

à priori mode IDE...

Mais bon de toute façon du moment que tu installe pas le système dessus tu peux désactiver le temps d'installer la distrib...

Link to post
Share on other sites

c'est quelle version de deb ?

Euh, bonne question... Je sais pas trop quoi te répondre (je débute, dsl)

Distrib: Ubuntu 6.06 LTS Dapper Drake

Noyau: 2.6.15-26-686

Je sais qu'Ubuntu est basée sur Debian mais selon quel paramètre ?

oublie ce que j'ai dit, je sais pas pourquoi je suis parti sur debian...

quoi qu'il en soit, j'avais plus ou moins (le pétard détruit le cerveau, enfin, la mémoire en tout cas) le même problème sur Etch

Link to post
Share on other sites

Mais bon de toute façon du moment que tu installe pas le système dessus tu peux désactiver le temps d'installer la distrib...

Et losrque je vais activer les disques de 80Go, le system va faire quoi ?

Faudra que je monte les 2 disk à la main ? Vous pourrez m'aider ?

Et si l'opération s'avère impossible, j'aurrais "abimé" l'install du system ?

J'demande car j'ai plus le courage de faire 40 milles install encore... :roll:

:zarb:

oublie ce que j'ai dit, je sais pas pourquoi je suis parti sur debian...

quoi qu'il en soit, j'avais plus ou moins (le pétard détruit le cerveau, enfin, la mémoire en tout cas) le même problème sur Etch

MDR, pas de soucis :zarb:
Link to post
Share on other sites
Faudra que je monte les 2 disk à la main ?

Oui

 Vous pourrez m'aider ?

Bien sûr :transpi:

C'est pas bien dûr, il suffit de formater (avec un outil genre gparted c'est tout simple) et de rajouter 1 ligne par partition dans un fichier (/etc/fstab)...

Link to post
Share on other sites

Je ne connais pas le chipset Intel de ta carte mère. Mais d'expérience, le mélange de disques durs ATA et SATA ne se passe pas toujours de manière heureuse;

Avec un chipset NF3 sur une ASUS K8N, il y avait une incompatibilité avec un SATA Maxtor Diamond max 160G .

J'ai dû changer de carte mère possédant un chipset VIA et me procurer un DD Maxtot SATA 200G . Ensuite, il a fallu d'abord installer Windows en SATA 1, puis une distribution Linux en SATA 2 ( avec GRUB pour le MBR) et par la suite seulment, brancher, j'écris bien brancher , les disques durs en ATA sur IDE 0.

De plus, il faut retourner dans le bios pour règler la boot setting sur le disque SATA et ensuite les disques en IDE 0.

J'ignore si ce que je te relate te sera utile ou non. Sait-on jamais?

Link to post
Share on other sites

/!\ Changement de pseudo: lpimpti >> M@T, c'est plus simple non ? :transpi: (Merci à Tristan de PCI)

@kool56: merci pour ton retour d'expérience, mais ici tous mes disques sont en SATA...

Seulement, je commence à m'orienter vers un problème/incompatibilité matériel dûe au controleur Promise... :yes:

Link to post
Share on other sites

Bonsoir à tous...

J'apporte un peu d'eau au moulin... Attention, ça devient devient incompréhensible... :roll:

Toujours dans ma quête d'un monde meilleur où Kro$oft ne serait pas sur mon PC, j'ai décidé de faire une install (une de plus) toute bête, pour voir les réactions de la machine...

A savoir: Sys + swap + home sur le 250Go, les deux disques de 80Go totalement vierge (aucune partition) et le controleur actif en mode IDE...

La distrib s'installe sans prb et moment fatidique: le reboot...

Grub loading... Plz wait... Uncompressing Linux... OK, booting the kernel... (splash screen d'UBUNTU)

Mounting file system... ... ... 10 sec... 20 sec... 30 sec... Retour sous le mode console... 10 sec... 20 sec... 30 sec...

Alert ! /dev/sda1 does not exist. Dropping to a shell !

BusyBox v1.01 (Debian 1:1.01-4ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built)in commands.

/bin/sh: can't access tty; job control turned off
#

Et voila, encore dans les choux... :mdr:

Seulement voilà, si je désactive le controleur Promise dans le bios de ma carte mère, la distrib boot sans aucun problème !!! :byebye:

J'en conclu que ce fameux controleur est géré par l'installeur mais pas par la distrib ?!? Je sais plus quoi faire moi :(

Si la simple présence du controleur fait tout planté, je suis bien barré moi ! :yes:

Plz, help ! :transpi:

Link to post
Share on other sites

Ca métonnerait pas que tes disques de 80Go soient sur un controleur prioritaire et donc au reboot, il trouve /dev/sda mais pas /dev/sda1 puisque il n'est pas formaté...

J'ai eu le problème avec un disque que j'avais pas branché pour etre sur de pas l'effacer :chinois:

Démarre sur ton live cd, et comme theo l'a dit, fait un sudo fdisk -l et va falloir aller modifier ton menu.lst dans /boot/grub pour que ce ne soit plus sda1 mais sdXY correspondant au bon disque :yes:

Link to post
Share on other sites

fdisk -l te donne quoi ?

Démarre sur ton live cd, et comme theo l'a dit, fait un sudo fdisk -l et va falloir aller modifier ton menu.lst dans /boot/grub pour que ce ne soit plus sda1 mais sdXY correspondant au bon disque :chinois:

J'men occupe ce soir... :yes:

Link to post
Share on other sites

Eh au fait, Linux étant bien + modulaire que Windows, faire 36 installations est inutile.

Tu peux corriger ton problème de boot, créer le RAID, déplacer les répertoires sur les autres disques le tout sans jamais rebooter.

Réinstaller est un réflexe Windows que tu vas pouvoir perdre :ouioui:

Link to post
Share on other sites

Bien entendu, je n'avais d'ailleurs meme pas soulevé la possibilité :ouioui:

Pour tout dire, j'ai meme eu un gros probleme avec le pc de mon frere... Freeze pendant une mise a jour du kernel... Devinez ce qui se passe :keskidit:

Boot sur live cd et mise a jour du kernel :rhooo: Hop c'est reparti :reflechis:

Linux powaaaaaa :ouioui:

Et au fait, tes disques étaient branchés lors de l'install?

Parce que si ils l'étaient, ca risque d'etre autre chose... :reflechis:

Link to post
Share on other sites

Eh au fait, Linux étant bien + modulaire que Windows, faire 36 installations est inutile.

Tu peux corriger ton problème de boot, créer le RAID, déplacer les répertoires sur les autres disques le tout sans jamais rebooter.

Réinstaller est un réflexe Windows que tu vas pouvoir perdre ;)

Bien entendu, je n'avais d'ailleurs meme pas soulevé la possibilité :move:

Ouaih, c'est certain... Mais mon exposition a windows a été longue... ;)

Du coup, je n'ai pas encore toutes les armes pour affronter le shell en face à face...

Mais je ne m'inquiète pas... Avec un peu de pratique, ça devrait aller mieux...

Pour l'instant, la présence du GUI est rassurante...

Je comprends ce que les outils graphiques font pour moi...

Je regarde régulièrement les fichiers de conf, avt / après une modif...

Bref...

Et au fait, tes disques étaient branchés lors de l'install?

Parce que si ils l'étaient, ca risque d'etre autre chose... ;)

Oui, oui, ils étaient branchés ! Sinon ça fait longtemps que j'aurrais jetté mon PC par la fenêtre ! ;)
Link to post
Share on other sites

@ M@T

Un plus haut, tu as écris: " Grub loading... Plz wait... Uncompressing Linux...".

D'après une discusion sur un forum, en lieu et place de GRUB, Lilo, un autre chargeur,peut être installé.

Regarde ici et lis

Peut-être que cela t'aidera à résoudre ton problème.

:cartonjaune::byebye:

Link to post
Share on other sites

Grub ou Lilo, l'éternel troll lol

L'avantage indéniable de Lilo est de se paramétrer avec les mêmes "noms" de partitions que ceux sous linux.

Si tu as une partition sdc1, tu pourras l'indiquer tel quel et non pas avec (hd2,1) ...

Link to post
Share on other sites

bonjour à tous,

fondamentalement, je ne pense pas que grub ou lilo change quelque chose :chinois:

maintenant, rien n'empeche à M@T de faire le test

au moins on saura vraiment d'où ça vient

et puis au point où il en est, il n'est pas à un test près, mais ce test pourrait effectivement être la solution à son souci de grub

peut être que grub n'est pas le linux loader approprié, enfin bon...

à M@T : je pense que tu vas t'habituer petit à petit au shell

en plus, comme tu le sais, les interfaces graphiques sont là pour faire joli :transpi:

bon courage :transpi:

sunfun ;)

Link to post
Share on other sites

×
×
  • Create New...