Jump to content

[Résolu][Ubuntu][grub][il démarre pas...]


Recommended Posts

hellow,

C'est bien bizarre quand meme que lorsqu'il y a une install de win sur un disque sata, grub ne veut pas démarrer apres l'installation de ubuntu...

Moi pas comprendre

J'avais eu le meme probleme avec mandriva, j'avais du mettre LILO (pouaaaaah)

Et ici j'ai encore ce probleme mais avec le pc de mon frere...

Je vais tenter de faire une install de grub a la main, mais bon je trouve que c'est pas normal quand meme...

Link to comment
Share on other sites

Ben voila, j'ai tenté d'installer mon ami grub...

démarrage sur le cd d'install, terminal :

sudo mkdir /mnt/partoche
sudo mount /dev/sda3 /mnt/partoche
sudo chroot /mnt/partoche
*ici je tombe dans un nouveau terminal*
grub

Jusque la, tout va pour le mieux...

Ensuite, je voudrais faire mon root...

root (sd0,2)

--> Error 21: Selected disk does not exist

Je peux essayer avec toutes les combinaisons que je veux, j'ai toujours la meme erreur...

J'ai essayé aussi avec hd

Moi pas comprendre....

Link to comment
Share on other sites

Quelques vérifications :

-> vérifie bien les partitions pour avoir les bons numéros (avec fdisk par exemple) (et n'oublie pas que sur grub, ca commence à zéro)

-> tu as bien les bons fichiers dans /boot/grub ? (à savoir les fichiers reiserfs_stage1_5, ou bien e2fs_stage1_5 ou encore jfs_stage1_5.... Enfin ce qui correspond au FS de ta partition quoi...)

edit : c'est un peu bête ce que j'ai dit puisque visiblement, c'est le disque lui même qu'il ne trouve pas....

Link to comment
Share on other sites

root@ubuntu:/# fdisk -l
cannot open /proc/partitions

:up:

Merci deja pour ces réponses :cartonrouge:

En fait, je n'ai ca qu'avec les disques sata... Je sais pas pourquoi...

Est-ce que c'est possible que ce soit a cause du fait que nux est dans une partition étendue?

Je vais sauvegarder toutes les données, virer l'étendue, et faire comme ceci :

-win

-boot

-nux

- partition étendue

--swap

--home

--echange (FAT32)

--docs pour win en NTFS

Je pense que si ca ne va pas comme ca, je sais pas comment je vais faire...

Link to comment
Share on other sites

C'est sûr que sans /proc ça va beaucoup moins bien fonctionner.

 mkdir /mnt/partoche/proc
mount -t proc none /mnt/partoche/proc

:transpi:

De plus, il n'y a pas besoin de chroot pour installer grub, du moment que la commande est présente, ça suffit.

en plus pour grub, il n'y a pas de dique sdxy (de mémoire), pour lui, c'est quand même du (hdx,y) :francais:

Tout à fait, toujours hd (sauf les disquettes avec fd)

Link to comment
Share on other sites

C'est bon a savoir tout ca...

Bon j'ai essayé sans passer par un chroot...

Mais je suis avec mon live cd donc je devrais pas quand meme chrooter?

Toute facon, ca marche pas... selected disk does not exist...

quand je fais un fdisk -l, je vois que c'est la premiere partoche qui a l'etoile (pour le boot) alors que ca devrait etre celle qui contient grub non?

Ca me gonfle :byebye:

Link to comment
Share on other sites

Grub est généralement écrit dans le MBR, et il n'apparaitera pas avec fdisk (en fait, c'est le tout premier secteur du disque dur). Ne t'occupe pas de l'étoile de boot.

Tu te trompes probablement dans les numéros de disque.

Dis nous ce que t'affiche "fdisk -l", et dis nous aussi ce que tu essaie de faire en détail avec grub.

Link to comment
Share on other sites

Ben voila... Mais vraiment, je comprends pas...

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot	  Start		 End	  Blocks   Id  System
/dev/sda1   *		   1		1828	14683378+   7  HPFS/NTFS
/dev/sda2			1829		7938	49078575	f  W95 Ext'd (LBA)
/dev/sda3			7939		9833	15221587+  83  Linux
/dev/sda4			9834		9964	 1052257+  82  Linux swap / Solaris
/dev/sda5			1829		7938	49078543+   7  HPFS/NTFS
ubuntu@ubuntu:~$ grub
Probing devices to guess BIOS drives. This may take a long time.
ubuntu@ubuntu:~$


GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

   [ Minimal BASH-like line editing is supported.   For
	 the   first   word,  TAB  lists  possible  command
	 completions.  Anywhere else TAB lists the possible
	 completions of a device/filename. ]

grub> root (hd0,2)

Error 21: Selected disk does not exist

grub> root (hd1,2)

Error 21: Selected disk does not exist

grub> root (hd3,2)

Error 21: Selected disk does not exist

grub> root (hd2,2)

Error 21: Selected disk does not exist

grub>

J'ai essayé aussi root(sd0,2) mais il me met unrecognized command... Donc je suppose que vos dires sont exacts sur le fait que le petit grub fonctionne uniquement avec des hd...

Link to comment
Share on other sites

C'est étrange la structure de ton disque !

Normalement, quand tu as une partition logique, elle apparait en tant que "Extended" dans la colonne Système.

par exemple chez moi ça donne ça :

Périphérique Amorce	Début		 Fin	  Blocs	Id  Système
/dev/hda1   *		   1		2550	20482843+   7  HPFS/NTFS
/dev/hda2			2551		9729	57665317+   5  Extended
/dev/hda5			6928		9729	22507033+   c  W95 FAT32 (LBA)
/dev/hda6			2551		2677	 1020064+  82  Linux swap / Solaris
/dev/hda7			2678		6927	34138093+  83  Linux

Link to comment
Share on other sites

La structure des partoches a été créée par window$...

A votre avis, je dois revenir sur ma premiere idée, qui est donc de sauvegarder les données (ce qui est deja fait) virer l'extended et ensuite rajouter des partoches primaires et une extended made in linux?

Link to comment
Share on other sites

c'est vrai que c'est super bizzare... tu as une partition qui est étendu qui contient directement des données... bref rien de bien standard :transpi:

et si (après avoir sauvegarder les données) tu faisait un fix de la table des partitions (une réécriture complete ?) avec un outils *nix ?

Link to comment
Share on other sites

Bon les enfants... C'est partiiiii

J'ai viré toutes les partoches sauf celle de window$, je rencontre quelques problemes quand meme du fait que l'installateur ubuntu me fait des erreurs quand il monte et formate les partoches...

On dirait qu'il s'est mélangé les pinceaux entre les différentes partoches... Lors de la création, je voyais des numéros, mais lors du choix des points de montages, ils étaient plus les memes!!!

Donc j'ai arreté l'install et recommencé, maintenant il copie les fichiers...

Tout ce que j'espere c'est que grub va booter, sinon ca va me faire iech :cartonrouge:

Link to comment
Share on other sites

Tyrann 1 - 0 grub 8):arrow:

Holalalalalala grub égalise au menu...

Tyrann 1 - 1 grub ;)

Pas moyen de faire un choix :(

Le clavier est branché en usb et donc on dirait que le bios en veut pas...

Quelqu'un a une idée ou je dois aller poster en hardware?

J'aimerais marquer un dernier point et montrer ma suprématie a ce petit grub :mad2::-D:arrow:

Vous pouvez le dire, j'ai des accès de folie :cartonrouge:

Link to comment
Share on other sites

Tyrann 1 - 0 grub 8):arrow:

Holalalalalala grub égalise au menu...

Tyrann 1 - 1 grub ;)

Pas moyen de faire un choix :(

Le clavier est branché en usb et donc on dirait que le bios en veut pas...

Quelqu'un a une idée ou je dois aller poster en hardware?

J'aimerais marquer un dernier point et montrer ma suprématie a ce petit grub :mad2::-D:arrow:

Vous pouvez le dire, j'ai des accès de folie :cartonrouge:

Je serai de toi, j'irai voir dans la configuration de ton BIOS...

Moi j'ai une option spéciale qui permet justement de faire fonctionner les clavier et souris USB au boot.

Link to comment
Share on other sites

Tyrann 1 - 0 grub 8);)

Holalalalalala grub égalise au menu...

Tyrann 1 - 1 grub ;)

Pas moyen de faire un choix :(

Le clavier est branché en usb et donc on dirait que le bios en veut pas...

Quelqu'un a une idée ou je dois aller poster en hardware?

J'aimerais marquer un dernier point et montrer ma suprématie a ce petit grub ;):p:p

Vous pouvez le dire, j'ai des accès de folie ;)

Je serai de toi, j'irai voir dans la configuration de ton BIOS...

Moi j'ai une option spéciale qui permet justement de faire fonctionner les clavier et souris USB au boot.

C'est exact, j'ai posté pour gagner du temps, mais sinon j'ai trouvé tout seul :p

Cette option s'appelle LEGACY USB (support ou device, ou autre suivant le type de CM)

Moi j'avais l'option disabled (selectionnée), no mice et al devices

J'ai choisi all device comme ca je suis tranquille :-D

Et voila 8)

Le problème est donc résolu, merci a tous pour votre aide ;)

Nénamoins, c'est un peu un probleme contourné il me semble... Puisque j'ai du virer mes partoches et recommencer...

Je mets résolu quand meme car je suis content :p

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...