Jump to content

[RESOLU] [Ubuntu] Problème écran noir


Recommended Posts

Salut à tous !

Bon, voulant me remettre dans le monde du libre (après un lâche abbandon par manque de temps), j'ai réinstallé une Ubuntu Breezy, puis fais la mise à jour vers Dapper Drake , suite à un problème (le même que celui je vais vous exposer ^^ ) à l'installation directe de la Dapper.

Donc, tout ce met à jour, toussa... il me dis qu'il va supprimer des paquets, ok... ca reboot ! Et bien après le reboot et le chargement , mon écran se met en veille et je ne peut RIEN faire, sauf reboot barbare sur ma centrale... Et pourtant apparement derrière tout marche, j'entend le tamtam de loogin, et si tu tape en aveugle mon pseudo/mdp il se connecte ! Mais je ne vois rien ... facheux non ?!

Pourriez vous m'aider à résoudre ce problème ? J'ai posté un message sur ubuntu-fr mais apparement pas grand monde peut me répondre.

Merci d'avance à tous !

Link to comment
Share on other sites

Si tout fonctionne derrière, c'est peut-être un problème de configuration de X.

Il se peut que l'écran se mette en veille par mesure de protection, par exemple à cause d'une fréquence d'affichage trop élevée.

Essaye un Ctrl-Alt-F1 pour voir si tu récupères une console.

Sinon faut voir si tu peux démarrer en init 3 pour pas lancer le serveur X.

Link to comment
Share on other sites

Bonjour.

Un CTRL-ALT-F1 est impossible, je me vois à chaque fois obligé de redémarrer de façon barbare...

J'ai pu démarrer en "safe mode" dans grub, j'ai ensuite essayé de modifier quelques éléments via

dkpg-reconfigure xserver-xorg

, mais ça n'a rien changé (j'avais mis en résolution max de 1024*768 en 75Hz , ce qui passait plus que largement sur Breezy).

Je ne sais donc pas quoi faire, à la limite essayer de mettre un max à 800*600 mais bon :/ ...

[EDIT] : J'ai essayé, ca ne change rien, j'ai également essayé en mettant tous les modules visuels actifs par défaut au démarrage, pas de changement ...

Link to comment
Share on other sites

:D !

Vous pensez que prendre un dérivée de cette distribution, du genre Xubuntu, pourrais changer quelque chose ? Je pense que non mais bon, là je ne sais vraiment pas quoi faire ...

Bon, même problème sous Xubuntu.

Ca m'énerve, à chaque fois que je veux passer sous linux ya un problème ... pourtant j'ai vraiment envie !

[EDIT(du désespoir ^^ )]: Bon ben, je sais toujours pas quoi faire, j'ai pourtant essayé tout ce qu'il m'était accessible au vu de mes compétences très limitées... je vous appelle à l'aide , sans quoi il ne me restera qu'a trouver une autre distrib, et je n'accroche vraiment qu'a ubuntu, soit laisser tomber, et j'ai vraiment pas envie (réunir toutes mes activitées informatiques sous un même système fiable, puissant, complet et libre m'attire énormément ! ). Help ^^

Link to comment
Share on other sites

J'ai eu un problème similaire lorsque que je me vulais redemarrer une sessio ou éteindre l'ordi ça devenait noir et l'ordi tournait, il ne me restait pls qu'à éteindre comme une brute et rallumer....

En fait j'ai le driver proprio Nvidia et une sortie DVI, si tu as une config similaire ça peut-être ça, pour corriger le problème j'ai fait la manip suivante (tirée de la documantation ubuntu-fr.org):

Dans le fichier /etc/X11/xorg.conf, il faut rajouter une option pour préciser que l"écran est branché sur le port DVI.

*

Editez (avec gedit sour Ubuntu ou kate sous Kubuntu) le fichier /etc/X11/xorg.conf avec les droits de super-utilisateur :

$ sudo <editeur> /etc/X11/xorg.conf

1.

Cherchez Section "Screen” dans le fichier

2.

Vous devriez avoir quelque chose qui ressemble à ça :

Section "Screen"

Identifier "Default Screen"

Device <Votre_carte_graphique>

Monitor "Écran générique"

DefaultDepth <votre_profondeur_de_couleur>

3.

Ajoutez alors la ligne suivante juste en dessous de la ligne contenant DefaultDepth <votre_profondeur_de_couleur> :

Option "ConnectedMonitor" "DFP"

4.

Enregistrez les modifications et quittez.

*

Fermez la session et redémarrez votre serveur X (avec CTRL + ALT + Retour Arrière).

Après si tu as une 5700 ou une 5900 il ya encore ça à faire (toujours tiré de ubuntu-fr.org):

En fait il y a un bug avec les derniers drivers Nvidia, cela conduit a ne plus pouvoir obtenir les tty lors des touches <ctrl>+<alt>+<F{1-6}> Cela est du à un problème lors du chargement du noyau avec l"option "splash” Il faut donc enlever cette option :

Editer le fichier de menu de grub :

sudo gedit /boot/grub/menu.lst

Puis chercher cette ligne :

# defoptions=quiet splash

Enlever splash de cette ligne puis enregistrer Puis mettre a jour grub

sudo update-grub

Maintenant redémarré votre machine

sudo reboot

Et voila, ca marche chez moi en tout cas !

En espérant avoir pu t'apporter quelques pistes....

Link to comment
Share on other sites

Merci de ta réponse.

Je suis sur une ATI X800XL en sortie VGA, donc le première solution est , je pense, à proscrire :) .

Pour la deuxième, je pens eque c'est pareil, je ne pas essayé car après une nouvelle réinstall de la Breezy et une mise à jour je me retrouve avec gdm qui refuse de se lancer ...

C'est dingue, depui la 5.04 j'ai pas pu avec une distro fonctionnelle , que ce soit avec Ubuntu ou Debian ... pourtant j'ai pas une config super originale et exotique ... (cf config dans profil)

Merci qaund même :transpi:

Link to comment
Share on other sites

Bon, je sais pas si cela viens de la nature de la carte graphique, vu que je sais que ATI est linux ne sont en génral pas copain ...

Donc, je sais pas si ca risque de changer grand chose, j'espère que oui, mais je commence à envisager l'achat d'un Nvidia (j'ai la 7900GT en tête), mais bon ca fais un sacré investissemen tpour une distrib linux ...

Link to comment
Share on other sites

Bon, je sais pas si cela viens de la nature de la carte graphique, vu que je sais que ATI est linux ne sont en génral pas copain ...

Donc, je sais pas si ca risque de changer grand chose, j'espère que oui, mais je commence à envisager l'achat d'un Nvidia (j'ai la 7900GT en tête), mais bon ca fais un sacré investissemen tpour une distrib linux ...

En même temps, t'est pas obligé de taper directement dans de la 7900GT...

Link to comment
Share on other sites

Oui oui c'est sur, mais quite à investir, en revendant la X800XL qui garde un prix correct, ca me laisserais tranquille un moment.

Après il est vrai que quand je dis "changer de carte" ca veux pas dire automatiquement cette dernière, qui vise au en terme de prix... je le concède.

Enfin quelle que soit cette carte, cela est quand même dommage de devoir en changer pour faire tourner (enfin peut être, croyez vous que cela va régler le problème ?La est la question) une distrib linux correctement, même si je n'hésiterais pas à le faire.

Link to comment
Share on other sites

Tiens, merci, je testerais dès que possible, en retentant donc une réinstall de Dapper.

Mais je pense que je vais garder dans l'optique de retourner chez Nvidia, surtout si les solutions que tu me donnes ne fonctionnent pas(j'espère qu'elles marcherons :p ! ), moins chiant pour installer et plus performant sous Linux (sur une machine plus ancienne j'ai pu mettre une Breezy et les drivers Nvidia sans aucun problème, c'est la seule fois ou j'ai pu pleinement profiter de Linux :pleure: ! )...

En tout cas merci pour les indications :) !!

Link to comment
Share on other sites

Up ! Merci beaucoup ! La première solution (l'édit de xorg.conf ) m'a permis d'installer la Dapper sans souci !

Mais je vais tout de même m'empresser de migrer chez Nvidia, bien plus performant et posant moins de problème sous platerforme Linux .

Merci pour les conseils !

[RESOLU]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...