Jump to content

PB a la fermeture de l'interface graphique


Recommended Posts

Bonjour

Je viens d'installer une distrib Mandrake 10.1 sous VMware.

Je démarre et j'obtiens correctement le prompt après connexion de l'utilisateur ROOT.

Je lance l'interface graphique correctement aussi. Tout se passe bien.

Mais lorsque je quitte l'interface graphque pour revenir en ligne de commande, l'affichage ne fonctionne plus.

On dirai que l'écran passe dans une résolution que l'écran ne supporte pas.

Je vous joins un fichier pour exemple...

Est ce que quelqu'un a une idée ?

Merci d'avance pour votre aide...

Link to comment
Share on other sites

je sais que ça ne résoud pas le problème, mais normalement, tu n'es pas sensé lancer X en root...

et si tu installais un gestionnaire de login (par défaut mdkkdm sur la mdk 10.1, il me semble), ça te faciliterait la vie.

après, comme pour tout problème de X, il nous faudrait le nom de ta carte graphique, ainsi que le résultat de "grep EE /var/log/Xorg.0.log -n5" et/ou "grep WW /var/log/Xorg.0.log -n5"

pour voir où se situent les problèmes :yes:

Link to comment
Share on other sites

Alors juste pour préciser que je débute sous Linux... LOL

Carte graphique : intégrée à la carte mère = Intel Mobile I915GM/I910GML

Comme j'ai installé sur un machine virtuelle VMware, j'ai mis le pilote de la carte vidéo VMware proposée par défaut.

"grep EE /var/log/Xorg.0.log -n5"

7- Before reporting problems, check http://wiki.X.Org

8- to make sure that you have the latest version.

9-Module Loader present

10-Markers: (--) probed, (**) from config file, (==) default setting,

11- (++) from command line, (!!) notice, (II) informational,

12: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

13-(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 23 14:28:41 2006

14-(==) Using config file: "/etc/X11/xorg.conf"

15-(==) ServerLayout "layout1"

16-(**) |-->Screen "screen1" (0)

17-(**) | |-->Monitor "monitor1"

--

159- ABI class: X.Org Server Extension, version 0.2

160-(II) Loading extension SHAPE

161-(II) Loading extension MIT-SUNDRY-NONSTANDARD

162-(II) Loading extension BIG-REQUESTS

163-(II) Loading extension SYNC

164:(II) Loading extension MIT-SCREEN-SAVER

165-(II) Loading extension XC-MISC

166-(II) Loading extension XFree86-VidModeExtension

167-(II) Loading extension XFree86-Misc

168-(II) Loading extension XFree86-DGA

169-(II) Loading extension DPMS

--

202-(II) Loading extension GLX

203-(II) LoadModule: "/usr/X11R6/lib/modules/extensions/libglx.a" (glx)

204-(WW) LoadModule: given non-canonical module name "/usr/X11R6/lib/modules/extensions/libglx.a"

205-(II) Reloading /usr/X11R6/lib/modules/extensions/libglx.a

206-(II) UnloadModule: "glx"

207:(EE) Failed to load module "/usr/X11R6/lib/modules/extensions/libglx.a" (once-only module, 135962511)

208-(II) LoadModule: "vmware"

209-(II) Loading /usr/X11R6/lib/modules/drivers/vmware_drv.o

210-(II) Module vmware: vendor="X.Org Foundation"

211- compiled for 6.7.0, module version = 10.10.2

212- Module class: X.Org Video Driver

et/ou "grep WW /var/log/Xorg.0.log -n5"

7- Before reporting problems, check http://wiki.X.Org

8- to make sure that you have the latest version.

9-Module Loader present

10-Markers: (--) probed, (**) from config file, (==) default setting,

11- (++) from command line, (!!) notice, (II) informational,

12: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

13-(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 23 14:28:41 2006

14-(==) Using config file: "/etc/X11/xorg.conf"

15-(==) ServerLayout "layout1"

16-(**) |-->Screen "screen1" (0)

17-(**) | |-->Monitor "monitor1"

--

19-(**) |-->Input Device "Keyboard1"

20-(**) Option "XkbModel" "pc105"

21-(**) XKB: model: "pc105"

22-(**) Option "XkbLayout" "fr"

23-(**) XKB: layout: "fr"

24:(WW) Option "XkbOptions" requires an string value

25-(==) Keyboard: CustomKeycode disabled

26-(**) |-->Input Device "Mouse1"

27-(**) FontPath set to "unix/:-1"

28-(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"

29-(==) ModulePath set to "/usr/X11R6/lib/modules"

--

199-(II) Module GLcore: vendor="X.Org Foundation"

200- compiled for 6.7.0, module version = 1.0.0

201- ABI class: X.Org Server Extension, version 0.2

202-(II) Loading extension GLX

203-(II) LoadModule: "/usr/X11R6/lib/modules/extensions/libglx.a" (glx)

204:(WW) LoadModule: given non-canonical module name "/usr/X11R6/lib/modules/extensions/libglx.a"

205-(II) Reloading /usr/X11R6/lib/modules/extensions/libglx.a

206-(II) UnloadModule: "glx"

207-(EE) Failed to load module "/usr/X11R6/lib/modules/extensions/libglx.a" (once-only module, 135962511)

208-(II) LoadModule: "vmware"

209-(II) Loading /usr/X11R6/lib/modules/drivers/vmware_drv.o

--

438- [18] -1 0 0x00001440 - 0x0000145f (0x20) IX

439- [19] -1 0 0x00001060 - 0x0000107f (0x20) IX

440- [20] -1 0 0x00001470 - 0x0000147f (0x10) IX

441- [21] -1 0 0x00001460 - 0x0000146f (0x10) IX(B)

442-(II) VMWARE(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000

443:(WW) VMWARE(0): Failed to set up write-combining range (0xf0000000,0x1000000)

444-(II) VMWARE(0): Using XFree86 Acceleration Architecture (XAA)

445- Screen to screen bit blits

446-(==) VMWARE(0): Backing store disabled

447-(==) VMWARE(0): Silken mouse enabled

448:(WW) VMWARE(0): Option "DPMS" is not used

449-(==) RandR enabled

450-(II) Setting vga for screen 0.

451-(II) Initializing built-in extension MIT-SHM

452-(II) Initializing built-in extension XInputExtension

453-(II) Initializing built-in extension XTEST

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...