Jump to content

[ debian ] probleme avec locales


Recommended Posts

bonjour à tous,

je suis sous debian 2.4.27

j'ai un souci avec les locales

à chaque fois que j'essaie d'installer un package, voici ce que ça donne :


pegase:/# apt-get install rsync
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
rsync
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 203kB of archives.
After unpacking 373kB of additional disk space will be used.
Get:1 [ftp.fr.debian.org] stable/main rsync 2.6.4-6 [203kB]
Fetched 203kB in 0s (3631kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "fr_FR:fr",
LC_ALL = (unset),
LANG = "fr_FR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package rsync.
(Reading database ... 15779 files and directories currently installed.)
Unpacking rsync (from .../rsync_2.6.4-6_i386.deb) ...
Setting up rsync (2.6.4-6) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "fr_FR:fr",
LC_ALL = (unset),
LANG = "fr_FR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
rsync daemon not enabled in /etc/default/rsync

comment faire ? y a-t-il une solution ?

merci d'avance

sunfun

Link to comment
Share on other sites

Bon je sais pas exactement quoi faire, mais c'est juste pour signaler que j'ai le même problème sur une Ubuntu Dapper...

j'avais essayé de configurer les locales, set-environnement..., dpkg-reconfigure locale...

...mais j'ai un peu tout niq... :transpi:

et j'ai le même mesage d'erreur que toi ;)

Link to comment
Share on other sites

bonjour à tous,

merci de vos réponses

quand je fais la commande apt-get install locales, voici l'erreur que j'obtiens :


pegase:~# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 locales: Depends: glibc-2.3.2.ds1-22sarge3
E: Broken packages

ça me semble bizarre, alors j'ai essayé d'install libc6, mais sans succès

je ne vois pas trop comment faire pour résoudre mon souci

merci de votre aide

sunfun

Link to comment
Share on other sites

bonjour,

j'ai tous les packages à jour

y a peut être une mise à jour du noyau à faire, mais ce n'est pas ça qui résoudra mon probleme je pense

c'est assez bizarre comme probleme

je ne vois pas comment le résoudre

merci encore de votre aide.

sunfun

Link to comment
Share on other sites

bonjour,

j'ai fait un update récemment

j'ai fait apt-get update

puis apt-get upgrade

mais à chaque fois que je fais ça, j'ai aussi ce message d'erreur

alors ça doit surement être bloquant mais je ne sais pas trop comment m'en sortir

merci de votre aide

sunfun

Link to comment
Share on other sites

Est ce que tu as une glibc ?

 dpkg -l *glib*

C'est quoi ton noyau ?

uname -a

Est ce que tu peux coller ce que tu as en console (même si c'est la même chose que plus haut, c'est pas grave). Met tout, ce que tu tapes, ce que tu vois, histoire d'y voir clair.

Tu as fait une manip délicate avant que ça fasse les warnings ?

Link to comment
Share on other sites

bonjour,

voici ce que j'obtiens avec la commande dpkg -l *glib*


pegase:~# dpkg -l *glib*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name		   Version		Description
+++-==============-==============-============================================
un  glibc-2.3.5-3  <none>		 (no description available)
un  glibc-doc	  <none>		 (no description available)
un  glibc2		 <none>		 (no description available)
un  libglib1.2	 <none>		 (no description available)

pour le noyau j'ai :


pegase:~# uname -a
Linux pegase 2.4.27-2-386 #1 Wed Nov 30 21:38:51 JST 2005 i686 GNU/Linux

merci de votre aide

sunfun

Link to comment
Share on other sites

Salut

As tu fait un apt-get dist-upgrade .

Ou apt-get dselect-upgrade.

As tu le paquet locales d'installé ?

J'ai installé une debian samedi, j'ai eu le meme soucis, avec l'installation du paquet locales, ça a disparu .

a+

Link to comment
Share on other sites

bonjour à tous,

voici ce que j'obtiens en faisant les différentes commandes suivantes :


pegase:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pegase:~# apt-get dselect-upgrade
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pegase:~# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 locales: Depends: glibc-2.3.2.ds1-22sarge3
E: Broken packages
pegase:~#

effectivement glib n'a pas l'air installé mais est-ce que c'est le package libc6 à installer ?

si oui, voici ce que me donne la commande apt-get install libc6 :


pegase:~# apt-get install libc6
Reading package lists... Done
Building dependency tree... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pegase:~#

merci d'avance de votre aide

sunfun

Link to comment
Share on other sites

  • 3 months later...

:up: :up: :up: :up:

quelqu'un peut m'aider s'il vous plait ?

j'ai toujours ce meme message d'erreur


pegase:~# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "fr_FR:fr",
	LC_ALL = (unset),
	LANG = "fr_FR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed
pegase:~#

la commande apt-get install locales ne fonctionne pas :yes:

idem pour la commande apt-get install base-config

c'est comme si tout avait sauté :chinois:

je ne vois pas d'où ça vient :zarb::non:

pensez-vous que je dois tenter une mise à jour du kernel de la debian ? :sucre:

passer en 2.6.8 ou plus récent encore

actuellement, voici sous quel noyau je suis :

pegase:~# uname -a
Linux pegase 2.4.27-2-386 #1 Wed Nov 30 21:38:51 JST 2005 i686 GNU/Linux
pegase:~#

merci de votre aide :yes:

sunfun :byebye:

Link to comment
Share on other sites

Supprime locales et réinstalle le.

bonjour theocrite,

merci d'avoir répondu :D

voici ce que j'ai fait juste après ton conseil


pegase:~# apt-get remove locales
Reading package lists... Done
Building dependency tree... Done
Package locales is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pegase:~# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 locales: Depends: glibc-2.3.2.ds1-22sarge3
E: Broken packages
pegase:~# apt-get install glibc
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package glibc
pegase:~# apt-get install libc6
Reading package lists... Done
Building dependency tree... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pegase:~#

visiblement ça ne fonctionne pas ;)

penses-tu que je dois mettre à jour mon kernel ???

car visiblement meme en faisant un apt-get install libc6, ça ne veut pas s'installer :fou:

merci de ton aide ;)

sunfun :inpactitude:

Link to comment
Share on other sites

libc6 doit être installé de base

dpkg -l | grep --color libc

bonjour theocrite,

merci d'avoir répondu

tout semble installé, c'est ça que je ne comprends pas :incline:


pegase:~# dpkg -l | grep --color libc
ii  libc6					 2.3.5-13				   GNU C Library: Shared libraries and Timezone
ii  libcap1				   1.10-14					support for getting/setting POSIX.1e capabil
ii  libcomerr2				1.38+1.39-WIP-2005.12.31-1 common error description library
ii  libconfig-inifiles-perl   2.38-3					 Read .ini-style configuration files
ii  libconsole				0.2.3dbs-60				Shared libraries for Linux console and font
ii  libcupsys2				1.1.23-12				  Common UNIX Printing System(tm) - libs
ii  libcupsys2-gnutls10	   1.1.23-12				  Common UNIX Printing System(tm) - dummy libs
ii  libdb1-compat			 2.1.3-8					The Berkeley database routines [glibc 2.0/2.
ii  liblocale-gettext-perl	1.05-1					 Using libc functions for internationalizatio

que dois-je faire ? :craint::yes:

merci de ton aide :pleure:

sunfun ;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...