Jump to content

Pb reseau avec Etch amd64


Recommended Posts

Slt a vous

Depuis 2/3 jours maintenant je me retrouve avec un pb réseau assez grave.

Eth0 est mon reseau local, Eth1 ma connexion FAI en DHCP.

Voici la config de /etc/network/interfaces:

auto lo eth0 eth1

iface eth0 inet static

address 192.168.1.250

netmask 255.255.255.0

broadcast 192.168.1.255

iface eth1 inet dhcp

Hors quand je fais un ifconfig je me retrouve avec ce resultat

eth0 Lien encap:Ethernet HWaddr 00:50:04:9D:CA:DD

inet adr:169.254.169.84 Bcast:0.0.0.0 Masque:255.255.0.0

adr inet6: fe80::250:4ff:fe9d:cadd/64 Scope:Lien

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1015 errors:0 dropped:0 overruns:0 frame:0

TX packets:1614 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:1000

RX bytes:251494 (245.5 KiB) TX bytes:1088094 (1.0 MiB)

Interruption:3 Adresse de base:0x8000

eth1 Lien encap:Ethernet HWaddr 00:11:09:BC:F0:5E

inet adr:169.254.226.194 Bcast:0.0.0.0 Masque:255.255.0.0

adr inet6: fe80::211:9ff:febc:f05e/64 Scope:Lien

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2313 errors:0 dropped:0 overruns:0 frame:0

TX packets:2808 errors:0 dropped:0 overruns:1 carrier:0

collisions:0 lg file transmission:1000

RX bytes:1047839 (1023.2 KiB) TX bytes:428437 (418.3 KiB)

Interruption:5 Adresse de base:0xa000

Lors d'un redemarrage du service reseau (etc/init.d/networking restart) je recupere bien l'adresse DHCP sur eth1 mais avec une erreur a la fin pour eth0!

* /etc/network/options is deprecated.

Setting up IP spoofing protection...done (rp_filter).

Enabling packet forwarding...done.

Reconfiguring network interfaces...ifup: interface lo already configured

Internet Software Consortium DHCP Client 2.0pl5

Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.

All rights reserved.

Please contribute if you find this software useful.

For info, please visit http://www.isc.org/dhcp-contrib.html

sit0: unknown hardware address type 776

eth2: unknown hardware address type 24

sit0: unknown hardware address type 776

eth2: unknown hardware address type 24

Listening on LPF/eth1/00:11:09:bc:f0:5e

Sending on LPF/eth1/00:11:09:bc:f0:5e

Sending on Socket/fallback/fallback-net

DHCPREQUEST on eth1 to 255.255.255.255 port 67

DHCPACK from 81.56.223.254

bound to 81.56.223.94 -- renewal in 60 seconds.

SIOCSIFADDR: File exists

Failed to bring up eth0.

Si je relance le service reseau je n'ai plus l'erreur sur eth0 !!

mais ifconfig est identique.

Le pire dans tout ça c que j'arrive bien a pinger les deux IP, et que je sors sur le net, mais aucun des mes serveurs (de nom de domaine, web ou smtp) ne repondent depuis l'exterieur (ce qui reste logique au vu des IP affectes sur les interfaces).

Pourriez vous m'aidez a resoudre ce probleme d'interface qui ont les mauvaise addresses !?

Merci beaucoup.

Link to comment
Share on other sites

les scripts Debian sont volontiers buggés même sur une Sarge, alors sur Etch :transpi:

Si c'est juste pour faire une passerelle autant prendre une stable, c'est plus sûr à tous points de vue (enfin du mien en tout cas).

Link to comment
Share on other sites

Tu peux paster le /etc/networking/interfaces complet stp ? J'ai pas l'impression que ce soit le cas.

Perso en etch chez moi le réseau fonctionne on ne peux mieux.

Tu peux aussi tenter

ifconfig eth0 down
ifconfig eth1 down
ifconfig eth0 up
ifconfig eth1 up

Link to comment
Share on other sites

Si c'est juste pour faire une passerelle autant prendre une stable, c'est plus sûr à tous points de vue (enfin du mien en tout cas).

Le probleme ce ke pour avoir une debian en full 64 bits sur AMD64, ben c une etch en testing !!

Et ca fonctionnait tres bien depuis le mois de septembre !!

La seule modif (ou les seules !!), c la mise a jour du system (bcp de paquets), l'installation d'une carte Nvidia avec modif des param BIOS ( mais g fait marche arriere sur les param BIOS et ça ne change rien), une monté de noyau (de 2.6.12 a 2.6.15), ça a l'air de concorder avec la monté de noyau et l'install des pilotes NVIDIA, mais bon je n'en suis pas sur, vu que je fonctionnait qd même (en dégraddé), je ne m'en suis pas rendu compte aussitot (3/4 jours).

Sinon, pour le /etc/network/interfaces, manque juste les commentaires et la conf du loopback !

Pour les comandes sur les interfaces, je ferai ça ce soir, mais g des doutes !

Merci...

Link to comment
Share on other sites

Tu peux paster le /etc/networking/interfaces complet stp ? J'ai pas l'impression que ce soit le cas.

Perso en etch chez moi le réseau fonctionne on ne peux mieux.

Tu peux aussi tenter

ifconfig eth0 down
ifconfig eth1 down
ifconfig eth0 up
ifconfig eth1 up

pour l'/etc/networking/interfaces il manque juste les commentaires et la conf du Loopback

Bon je suis rentrer chez moi entre 12 et 14 et g passé les commandes et... ca ne donne rien de mieux.

Je pense que je fais marche arriere sur la version de noyau ce soir (retour en 2.6.12) !!

Link to comment
Share on other sites

et si tu tapes 'ifconfig eth0 192.168.1.250 up' ça marche au moins ?

Ouai ca marche, mais pas du premier coup, la premiere fois il me fait "SIOCFIADDR File exist" puis il me prend bien mon IP 192.168.1.250.

Mais pour l'interface public elle reste tjrs en 169.xxx.xxx.xxx apres un ifconfig eth1 down /ifconfig eth1 up!!

C bien les adresses reseaux prive de Microsoft qui sont en 169.xxx.xxx.xxx !???

Sinon je suis passé en 2.6.12 et le pb subsiste ! Donc c pas le noyau (tant mieux car le 2.6.15 me règle d'autres petits soucis)

Ou est ce k'il va me chopper ces sal@pۤ!? d'adresse!!!????

G egalement installer les derniers patch debian pour le noyau 2.6.15 et Udev (qui corrige un bon nombre de messages d'erreur au boot).

Mais tjrs rien.

Mais dans l'immediat y a foucheball et ensuite jeux en reseau avec kelkes potes, donc je pense m'y remettre ke vers 00h30/01h00 !!

encore merci pour votre aide !! :transpi:

Link to comment
Share on other sites

une idée comme ça, ça marche avec un live cd, des fois qu'une partie des choses viendraient de ton FAI ?

un test pour voir : commente ta conf réseau (sauf lo) et monte les à la main ('dhclient eth1' a priori).

Link to comment
Share on other sites

une idée comme ça, ça marche avec un live cd, des fois qu'une partie des choses viendraient de ton FAI ?

un test pour voir : commente ta conf réseau (sauf lo) et monte les à la main ('dhclient eth1' a priori).

Pas fait le live CD.

Mais g commenter le fichier /etc/network/interfaces et apres deux "ifconfig eth0 192.168.250 up", mon eth0 recupere la bonne IP (mais g tjrs l'erreur "SIOCSIFADDR: Le fichier existe" apres la premier fois) , et apres un "dhclient eth1", mon eth1 recupere la bonne IP !!

Bon je ne sais pas apres un reboot ce ke cela peut donner ( je fais mes manip a distance ! :( )

Je verrais ce soir mais c une piste !! Mon fichier Interface n est pas carré !????

Merci de vos reponses .

Link to comment
Share on other sites

Slt, me revoilu ( parti pour un WE prolongé!! :byebye: )

Bon g fait le test avec le LiceCD et c OK !!

Donc g bien un soucis avec le montage des interfaces ! :(

Ca vient de la conf de mon fichier "Interfaces" ou d'ailleurs ???

Voici une copie de celui-ci, si quelqu'un peut me soumettre une idée !!?

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
#auto lo eth1 eth0
auto lo
iface lo inet loopback
# The primary network interface

#iface eth1 inet dhcp

# the secondary network interface
#
#iface eth0 inet static
#	   address 192.168.1.250
#	   netmask 255.255.255.0
#	   broadcast 192.168.1.255




G mis en commentaire la conf de mes interface pour les tests !! :)

Merci a vous.

Dydge

Link to comment
Share on other sites

Slt, me revoilu ( parti pour un WE prolongé!! :transpi: )

Bon g fait le test avec le LiceCD et c OK !!

Donc g bien un soucis avec le montage des interfaces ! :(

Ca vient de la conf de mon fichier "Interfaces" ou d'ailleurs ???

Voici une copie de celui-ci, si quelqu'un peut me soumettre une idée !!?

hello, je crois que c'est plutôt le script qui utilise ta conf qu'il faudrait voir (/etc/init.d/networking chez moi sur sarge).

Je viens de jeter un coup d'oeil sur man interfaces (5 avril 2004) :

«KNOWN BUGS/LIMITATIONS

The ifup and ifdown programs work with so-called "physical" interface names. These

names are assigned to hardware by the kernel. Unfortunately it can happen that the

kernel assigns different physical interface names to the same hardware at different

times; for example, what was called "eth0" last time you booted is now called "eth1"

and vice versa. This creates a problem if you want to configure the interfaces appro-

priately. A way to deal with this problem is to use mapping scripts that choose logi-

cal interface names according to the properties of the interface hardware. See the

get-mac-address.sh script in the examples directory for an example of such a mapping

script. See also Debian bug #101728.»

may be ?

Link to comment
Share on other sites

Tu n'as pas de gateway ?

Et en rajoutant

		network 192.168.1.0

?

Hello tout d'abord

Si g une gateway, mais je l'ai viré car je pensais ke ca venait de la !!( elle correspond a mon IP fixe que je chope en DHCP (par mon FAI) )

Sinon en rajoutant le network, ca ne change rien !! :(

Sinon NoFun, g jeter un oeil sur le script /etc/init.d/networking et je ne vois rien de zarbi, mais bon sachant que mes connaissances en script sont un peu limitées j'en fais une copie ici !! :francais:

#!/bin/sh -e
### BEGIN INIT INFO
# Provides:		  networking
# Required-Start:	mountvirtfs ifupdown $local_fs
# Default-Start:	 S
# Default-Stop:	  0 6
### END INIT INFO

PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"

[ -x /sbin/ifup ] || exit 0

. /lib/lsb/init-functions

spoofprotect_rp_filter() {
[ -e /proc/sys/net/ipv4/conf/all/rp_filter ] || return 1
RC=0
for f in /proc/sys/net/ipv4/conf/*/rp_filter; do
	echo 1 > $f || RC=1
done
return $RC
}

spoofprotect() {
log_action_begin_msg "Setting up IP spoofing protection"
if spoofprotect_rp_filter; then
	log_action_end_msg 0 "rp_filter"
else
	log_action_end_msg 1
fi
}

ip_forward() {
log_action_begin_msg "Enabling packet forwarding"
if echo 1 > /proc/sys/net/ipv4/ip_forward; then
	log_action_end_msg 0
else
	log_action_end_msg 1
fi
}

syncookies() {
log_action_begin_msg "Enabling TCP SYN cookies"
if echo 1 > /proc/sys/net/ipv4/tcp_syncookies; then
	log_action_end_msg 0
else
	log_action_end_msg 1
fi
}

doopt() {
optname=$1
default=$2
opt=`grep "^$optname=" /etc/network/options || true`
if [ -z "$opt" ]; then
	opt="$optname=$default"
fi
optval=${opt#$optname=}
if [ "$optval" = "yes" ]; then
	eval $optname
fi
}

process_options() {
[ -e /etc/network/options ] || return 0
log_warning_msg "/etc/network/options is deprecated."
doopt spoofprotect yes
doopt syncookies no
doopt ip_forward no
}

case "$1" in
start)
	process_options
	log_action_begin_msg "Configuring network interfaces"
	if ifup -a; then
		log_action_end_msg $?
	else
		log_action_end_msg $?
	fi
   ;;

stop)
	if sed -n 's/^[^ ]* \([^ ]*\) \([^ ]*\) .*$/\2/p' /proc/mounts |
			grep -qE '^(nfs[1234]?|smbfs|ncp|ncpfs|coda|cifs)$'; then
		log_warning_msg "not deconfiguring network interfaces: network shares still mounted."
		exit 0
	fi

	log_action_begin_msg "Deconfiguring network interfaces"
	if ifdown -a --exclude=lo; then
		log_action_end_msg $?
	else
		log_action_end_msg $?
	fi
   ;;

force-reload|restart)
	process_options
	log_action_begin_msg "Reconfiguring network interfaces"
	ifdown -a --exclude=lo || true
	if ifup -a --exclude=lo; then
		log_action_end_msg $?
	else
		log_action_end_msg $?
	fi
   ;;

*)
	echo "Usage: /etc/init.d/networking {start|stop|restart|force-reload}"
	exit 1
   ;;
esac

exit 0

Et zoop encore une page de code !! :)

Juste un truc, je m'absente de demain jusqu'a dimanche donc je ne pourrais pas faire grd chose avant dimanche soir ou lundi.

Encore merci.

Link to comment
Share on other sites

si ça marche à la main et en désespoir de cause tu peux toujours faire un petit script lancé au démarage qui te monte tes interfaces. Tu peux ajouter les adaptations des paramètres réseau du noyau (genre rp_filter ou ip_forward).

Est-ce qu'un débianiste avancé peut dire si cette solution peut poser problème à d'autres scripts ?

edit : utilise ifconfig parce que si j'ai bien compris ifup utilise /etc/network/interfaces

Link to comment
Share on other sites

  • 3 weeks later...

Hello, me revoilou !!

Bon et bien g enfin eu le temps de me re-pencher sur mon probleme !!

Et je l'ai resolu hier soir !!

Vous connaissez le paquet ZeroConf !???

Et bien ct lui qui était installé.

Je pense qu'il s'est collé qd g ajouté quelques outils réseau et il devait faire parti d'une dependance !!! C ça qd on regarde pas en detail ce que les dependances installent !! :(

Et la je comprends mieux mes messages d'erreurs " SIOCSIFADDR: File exists Failed to bring up eth0" apres le /etc/init.d/networking restart !!

Le script /etc/init.d/networking devait essayé de configurer les interfaces mais elles l'etaient dèja par ZeroConf !!

je vous remercie tous pour votre aide !!

A+... ;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...