Jump to content

[RESOLU] Un player qui fait "Video On Desktop"


Recommended Posts

Suite... mais pas fin !

J'ai suivi à la lettre ce tuto : http://fr.gentoo-wiki.com/TIP_Xorg_X11_et_transparence et ça marche très bien sur ma "debuntu" avec xorg 6.8.2 et gnome 2.10 avec ma geforce fx 5200. Ca marche très bien sauf avec une vidéo :p La transparence et les ombrages se changent en méchant truc bleu tout vilain. J'ai essayé avec xine "normal" et "on-desktop" c'est pareil. C'est un problème d'overlay, non ? Un truc comme ça ? Je vais continuer mes petits tests mais je tenais à vous faire partager ce tuto bien fait et tout simple ;)

EDIT :

MIRACLE ! En effet avec mplayer ça marche :D Bon, j'ai pas les menus DVD mais CA MARCHE

RE-EDIT :

:craint: J'ai pas un "vrai" mode fullscreen avec cette sortie ! Je l'ai avec xv par exemple mais pas x11 ! Argh !

Enfin, bon, ça avance :8

RE-RE-EDIT :

Problème définitivement réglé en lançant mplayer -zoom -fs -vo x11 video.avi (bien sur en modifiant en conséquence /etc/mplayer/mplayer.conf ca se fait tout seul)

Voilà voilà, je suis bien content :chinois: Maintenant je vais pouvoir me regarder une vidéo en permanence en fond d'écran pendant que je chatte :p

C'était pas si compliqué :p

FIN

Link to post
Share on other sites

Youpii ;) merci pour ce lien !

petite question: des applications lourdes en OpenGL tournent bien ? ( dans le tuto, ils disent que quake3 plante par exemple ).

Edit: et ca doit marcher avec la TV en plus :eeek2: j'aime pas la tv, mais au moins ca fait une vidéo qui tourne tout le temps & pas en boucle !

Link to post
Share on other sites
petite question: des applications lourdes en OpenGL tournent bien ? ( dans le tuto, ils disent que quake3 plante par exemple ).

magnet@magnetux:~$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

CQFD

Mais... en suivant ce lien http://gentoo-wiki.com/TIP_Xorg_X11_and_Tranparency qui est la meme chose en anglais, on peut trouver cette astuce :

Nvidia + Xorg

glxgears (and other applications that use GLX) won't run

Try adding the following to your device section (again, the second device section with the clock lines and driver selection):


File: /etc/X11/xorg.conf

Option "AllowGLXWithComposite" "true"

*

Sinon j'ai pas Quake3 et autre jenesaispluslenom :chinois:

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...