Jump to content

Archived

This topic is now archived and is closed to further replies.

eminem6

serveur ftp linux

Recommended Posts

Je viens de comprendre pourquoi je n'arrivais pas à me logger et autre problème divers: il ou le charger un module (ou recompiler le noyeau :-p ):

#make menu-config
Device drivers -> Networking Suport -> Networking Option -> Network packet filtering (replace ipchain) -> IP: Netfilter Configuration
[*] FTP protocol suport
[*] TFTP protocol suport
(noyeau 2.6.8)

Après l'avoir modifier, le log fonctionne bien :zarb:

Maintenant je cherche le scrip qui le fait se lancer au démarrage (enfin surtout l'endroit ou modifier les options de pure-ftpd sous une debian)...

Share this post


Link to post
Share on other sites

Je n'arrive pas à configurer pure-ftpd :-(

Je suis sous débian et voilà ce que je renre pour le lancer:

pure-ftpd -4 -A -b -B -E -l puredb:/etc/pure-ftpd/pureftpd.pdb -H -o -F /usr/share/games/fortune/fr/amusantes

pure-pw mkdb

- J'arrive à me logger au ftp en utilisant les utilisateurs locaux mais pas ceux créer par "pure-pw useradd"

- Je ne suis pas chrooté (donc je peux remonter jusqu'a la racine!)

- Et j'ai beau modifier cette ligne (par exemple: changer -E en -e) ben ça n'authorise pas pour autant la connection en anonyme!! (à croire qu'il se fout complètement des arguments que je lui donne!)

Voilà, si vous savez pourquoi j'ai ça, si j'oublit une commande, merci de me prévenir :transpi:

Share this post


Link to post
Share on other sites

Est ce que qqn connait le nom du paquet qui contient la commande db_load permettant de créer fichier de type berkley database ( apparament elle n'est pas sur l'arbre Portage).

Merci.

Share this post


Link to post
Share on other sites
Est ce que qqn connait le nom du paquet qui contient la commande db_load permettant de créer fichier de type berkley database ( apparament elle n'est pas sur l'arbre Portage).

Merci.

Si, c'est le paquet sys-libs/db tout simplement :ouioui:

#emerge -s db

A noter que la commande comporte le numéro de la version ainsi il ne faut pas taper db_load mais db4.1_load (pour moi)

Share this post


Link to post
Share on other sites
Si, c'est le paquet sys-libs/db tout simplement :yes:

#emerge -s db

A noter que la commande comporte le numéro de la version ainsi il ne faut pas taper db_load mais db4.1_load (pour moi)

Thx, j'ai fait pls esearch, j'ai du oublié celui là :ouioui:

Share this post


Link to post
Share on other sites

Là, je suis en train d'essayer la configration en mode anonyme de vsftpd, lorsque je fais un ftp <mon ip> depuis chez moi en simple user, j'accede bien au serveur et je peux lister les fichiers, par contre de l'extérieur c'est possible de se connecter mais pas de lister les fichiers. J'ai fait un chmod 777 -R /home/ftp marche tjs pas, est ce que qqn aurait une idée de ce qui va pas dans ma configuration du vsftpd.conf?

background=YES

listen=YES

# listen_address=

anonymous_enable=YES

local_enable=NO

ftp_username=ftp

# anon_root=[$ftp_username's home directory]

write_enable=YES

anon_upload_enable=YES

anon_mkdir_write_enable=YES

anon_other_write_enable=YES

anon_world_readable_only=YES

anon_max_rate=2

idle_session_timeout=400

ascii_upload_enable=NO

connect_from_port_20=NO

port_enable=YES

hide_ids=NO

log_ftp_protocol=NO

syslog_enable=NO

max_per_ip=1

# cmds_allowed=

local_root=/usr/share/empty

nopriv_user=nobody

Share this post


Link to post
Share on other sites
Moi j'utilise pure-ftpd... c'est super sympa :)

Est-ce que t'as fait qqchose de spécial pour que ça fonctionne?

Mon problème est, que depuis chez moi, j'arrive bien à me connecter à mon serveur ftp et à lister les fichiers. Par contre, de l'extérieur, j'arrive bien à me connecter à mon serveur mais je n'arrive pas à lister les fichiers. Là, je suis sur PURE-FTP, et hier, avec VSFTPD j'avais exactement le même problème.

Voilà ce que j'obtiens en essayant de me connecter depuis l'extérieur:

www $ ftp -pv 80.119.8.45

Connected to 80.119.8.45.

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

220-You are user number 1 of 30 allowed.

220-Local time is now 00:05. Server port: 21.

220 You will be disconnected after 15 minutes of inactivity.

Name (80.119.8.45:fred): guest

500 This security scheme is not implemented

SSL not available

331 User guest OK. Password required

Password:

230-User guest has group access to: 443

230 OK. Current directory is /

Remote system type is UNIX.

Using binary mode to transfer files.

ftp> ls

227 Entering Passive Mode (80,119,8,45,240,95)

Je vois pas trop d'où ça peut venir?

- D'une option à configurer dans le kernel? je ne pense pas vu que c'est un protocol très vieux;

- Ne pas pouvoir lister on dirait un problème de droit, mais là, je comprends pas pourquoi y aurait ce problème sur un répartoire spécialement dédié au partage de fichier et chrooté ...

Share this post


Link to post
Share on other sites

Un problème de firewall?

(genre il faudrait peut-être ip_conntrack_ftp et jouer des established/related)

Share this post


Link to post
Share on other sites

×
×
  • Create New...